XDG-EMAIL(1) xdg-email Manual XDG-EMAIL(1)

xdg-email - ابزار خط فرمان برای ارسال رایانامه با استفاده از ویرایشگر رایانامهٔ ترجیحی کاربر

xdg-email [--utf8] [--cc address] [--bcc address] [--subject text] [--body text] [--attach file] [mailto-uri | address(es)]

xdg-email {--help | --manual | --version}

دستور xdg-email ویرایشگر رایانامهٔ ترجیحی کاربر را به منظور ارسال یک نامه به address(es) یا mailto-uri باز می‌کند. سند RFC2368 شناسه‌های mailto: URI را تعریف می‌کند. دستور xdg-email پشتیبانی را به فیلدهای to،‏ cc،‏ subject و body در mailto-uri محدود می‌کند و سایر فیلدها بدون هشدار نادیده گرفته می‌شوند. address(es) باید از قواعد نگارشی RFC822 پیروی کند. نشانی‌های چندگانه را می‌توان به‌صورت آرگومان‌های جداگانه وارد کرد.

تمام اطلاعات ارائه‌شده در خط فرمان برای پر کردن فیلدهای متناظر در ویرایشگر رایانامهٔ کاربر استفاده می‌شود. کاربر این امکان را خواهد داشت که پیش از ارسال واقعی رایانامه، هر بخش از این اطلاعات را تغییر دهد.

دستور xdg-email فقط برای استفاده در یک نشست میزکار است. استفاده از xdg-email با دسترسی ریشه (root) توصیه نمی‌شود.

--utf8

مشخص می‌کند که تمام گزینه‌های خط فرمان که در ادامه می‌آیند با کدگذاری utf8 هستند. بدون این گزینه، انتظار می‌رود گزینه‌های خط فرمان بر اساس locale کدگذاری شده باشند. اگر locale از پیش utf8 را مشخص کرده باشد، این گزینه تأثیری ندارد. این گزینه بر URIهای mailto که در خط فرمان ارسال می‌شوند تأثیری نمی‌گذارد.

--cc address

گیرنده‌ای را برای رونوشت (cc) در رایانامه مشخص می‌کند.

--bcc address

گیرنده‌ای را برای رونوشت پنهان (bcc) در رایانامه مشخص می‌کند.

--subject text

موضوعی را برای رایانامه مشخص می‌کند.

--body text

متن بدنه‌ای را برای رایانامه مشخص می‌کند. از آنجا که کاربر قادر خواهد بود پیش از ارسال واقعی رایانامه تغییراتی اعمال کند، این گزینه می‌تواند برای ارائهٔ یک الگو به کاربر استفاده شود. text می‌تواند شامل شکستگی سطر باشد.

--attach file

یک پیوست را برای رایانامه مشخص می‌کند. file باید به یک فایل موجود اشاره کند.

برخی از برنامه‌های رایانامه نیاز دارند که فایل پس از بازگشت دستور xdg-email همچنان موجود باقی بماند.

--help

نمایش خلاصهٔ دستور.

--manual

نمایش این صفحهٔ راهنما.

--version

نمایش اطلاعات نسخهٔ xdg-utils.

دستور xdg-email از متغیرهای محیطی زیر پیروی می‌کند:

XDG_UTILS_DEBUG_LEVEL

تنظیم این متغیر محیطی روی یک مقدار عددی غیر صفر باعث می‌شود xdg-email گزارش‌های با جزئیات بیشتری روی stderr ارائه دهد. تنظیم یک مقدار بالاتر، میزان جزئیات گزارش را افزایش می‌دهد.

کد خروج 0 نشان‌دهندهٔ موفقیت و کد خروج غیر صفر نشان‌دهندهٔ شکست است. کدهای خطای زیر ممکن است بازگردانده شوند:

1

خطا در نحو (syntax) خط فرمان.

2

یکی از فایل‌های ارائه‌شده در خط فرمان وجود نداشت.

3

یک ابزار مورد نیاز پیدا نشد.

4

عملیات شکست خورد.

5

مجوز لازم برای خواندن یکی از فایل‌های داده‌شده در خط فرمان وجود ندارد.

xdg-open(1), xdg-mime(1), MIME applications associations specification[1], RFC 6068 - The 'mailto' URI Scheme[2]

xdg-email 'Jeremy White <jwhite@example.com>'
xdg-email --attach /tmp/logo.png \
          --subject 'Logo contest' \
          --body 'Attached you find the logo for the contest.' \
          'jwhite@example.com'
xdg-email --subject 'Your password is about to expire' \
          'jwhite@example.com' 'bastian@example.com' 'whipple@example.com'

Kevin Krammer

نویسنده.

Jeremy White

نویسنده.

حق نشر © 2006

1.
MIME applications associations specification
2.
RFC 6068 - The 'mailto' URI Scheme
12/06/2025 xdg-utils 1.0