'\" t .\" Title: xdg-email .\" Author: Kevin Krammer .\" Generator: DocBook XSL Stylesheets vsnapshot .\" Date: 12/06/2025 .\" Manual: xdg-email Manual .\" Source: xdg-utils 1.0 .\" Language: English .\" .TH "XDG\-EMAIL" "1" "12/06/2025" "xdg-utils 1.0" "xdg-email Manual" .\" ----------------------------------------------------------------- .\" * Define some portability stuff .\" ----------------------------------------------------------------- .\" ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ .\" http://bugs.debian.org/507673 .\" http://lists.gnu.org/archive/html/groff/2009-02/msg00013.html .\" ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ .ie \n(.g .ds Aq \(aq .el .ds Aq ' .\" ----------------------------------------------------------------- .\" * set default formatting .\" ----------------------------------------------------------------- .\" disable hyphenation .nh .\" disable justification (adjust text to left margin only) .ad l .\" ----------------------------------------------------------------- .\" * MAIN CONTENT STARTS HERE * .\" ----------------------------------------------------------------- .SH "نام (NAME)" xdg-email \- ابزار خط فرمان برای ارسال رایانامه با استفاده از ویرایشگر رایانامهٔ ترجیحی کاربر .SH "خلاصه دستور (SYNOPSIS)" .HP \w'\fBxdg\-email\fR\ 'u \fBxdg\-email\fR [\fB\-\-utf8\fR] [\fB\-\-cc\fR\ \fIaddress\fR] [\fB\-\-bcc\fR\ \fIaddress\fR] [\fB\-\-subject\fR\ \fItext\fR] [\fB\-\-body\fR\ \fItext\fR] [\fB\-\-attach\fR\ \fIfile\fR] [\fImailto\-uri\fR | \fIaddress(es)\fR] .HP \w'\fBxdg\-email\fR\ 'u \fBxdg\-email\fR {\fB\-\-help\fR | \fB\-\-manual\fR | \fB\-\-version\fR} .SH "توضیحات (DESCRIPTION)" .PP دستور \fBxdg\-email\fR ویرایشگر رایانامهٔ ترجیحی کاربر را به منظور ارسال یک نامه به \fIaddress(es)\fR یا \fImailto\-uri\fR باز می‌کند\&. سند RFC2368 شناسه‌های mailto: URI را تعریف می‌کند\&. دستور xdg\-email پشتیبانی را به فیلدهای to،‏ cc،‏ subject و body در \fImailto\-uri\fR محدود می‌کند و سایر فیلدها بدون هشدار نادیده گرفته می‌شوند\&. \fIaddress(es)\fR باید از قواعد نگارشی RFC822 پیروی کند\&. نشانی‌های چندگانه را می‌توان به‌صورت آرگومان‌های جداگانه وارد کرد\&. .PP تمام اطلاعات ارائه‌شده در خط فرمان برای پر کردن فیلدهای متناظر در ویرایشگر رایانامهٔ کاربر استفاده می‌شود\&. کاربر این امکان را خواهد داشت که پیش از ارسال واقعی رایانامه، هر بخش از این اطلاعات را تغییر دهد\&. .PP دستور xdg\-email فقط برای استفاده در یک نشست میزکار است\&. استفاده از xdg\-email با دسترسی ریشه (root) توصیه نمی‌شود\&. .SH "گزینه‌ها (OPTIONS)" .PP \fB\-\-utf8\fR .RS 4 مشخص می‌کند که تمام گزینه‌های خط فرمان که در ادامه می‌آیند با کدگذاری utf8 هستند\&. بدون این گزینه، انتظار می‌رود گزینه‌های خط فرمان بر اساس locale کدگذاری شده باشند\&. اگر locale از پیش utf8 را مشخص کرده باشد، این گزینه تأثیری ندارد\&. این گزینه بر URIهای mailto که در خط فرمان ارسال می‌شوند تأثیری نمی‌گذارد\&. .RE .PP \fB\-\-cc\fR \fIaddress\fR .RS 4 گیرنده‌ای را برای رونوشت (cc) در رایانامه مشخص می‌کند\&. .RE .PP \fB\-\-bcc\fR \fIaddress\fR .RS 4 گیرنده‌ای را برای رونوشت پنهان (bcc) در رایانامه مشخص می‌کند\&. .RE .PP \fB\-\-subject\fR \fItext\fR .RS 4 موضوعی را برای رایانامه مشخص می‌کند\&. .RE .PP \fB\-\-body\fR \fItext\fR .RS 4 متن بدنه‌ای را برای رایانامه مشخص می‌کند\&. از آنجا که کاربر قادر خواهد بود پیش از ارسال واقعی رایانامه تغییراتی اعمال کند، این گزینه می‌تواند برای ارائهٔ یک الگو به کاربر استفاده شود\&. \fItext\fR می‌تواند شامل شکستگی سطر باشد\&. .RE .PP \fB\-\-attach\fR \fIfile\fR .RS 4 یک پیوست را برای رایانامه مشخص می‌کند\&. \fIfile\fR باید به یک فایل موجود اشاره کند\&. .sp برخی از برنامه‌های رایانامه نیاز دارند که فایل پس از بازگشت دستور xdg\-email همچنان موجود باقی بماند\&. .RE .PP \fB\-\-help\fR .RS 4 نمایش خلاصهٔ دستور\&. .RE .PP \fB\-\-manual\fR .RS 4 نمایش این صفحهٔ راهنما\&. .RE .PP \fB\-\-version\fR .RS 4 نمایش اطلاعات نسخهٔ xdg\-utils\&. .RE .SH "محیط (ENVIRONMENT)" .PP دستور xdg\-email از متغیرهای محیطی زیر پیروی می‌کند: .PP XDG_UTILS_DEBUG_LEVEL .RS 4 تنظیم این متغیر محیطی روی یک مقدار عددی غیر صفر باعث می‌شود xdg\-email گزارش‌های با جزئیات بیشتری روی stderr ارائه دهد\&. تنظیم یک مقدار بالاتر، میزان جزئیات گزارش را افزایش می‌دهد\&. .RE .SH "وضعیت خروج (EXIT STATUS)" .PP کد خروج 0 نشان‌دهندهٔ موفقیت و کد خروج غیر صفر نشان‌دهندهٔ شکست است\&. کدهای خطای زیر ممکن است بازگردانده شوند: .PP \fB1\fR .RS 4 خطا در نحو (syntax) خط فرمان\&. .RE .PP \fB2\fR .RS 4 یکی از فایل‌های ارائه‌شده در خط فرمان وجود نداشت\&. .RE .PP \fB3\fR .RS 4 یک ابزار مورد نیاز پیدا نشد\&. .RE .PP \fB4\fR .RS 4 عملیات شکست خورد\&. .RE .PP \fB5\fR .RS 4 مجوز لازم برای خواندن یکی از فایل‌های داده‌شده در خط فرمان وجود ندارد\&. .RE .SH "همچنین ببینید (SEE ALSO)" .PP \fBxdg-open\fR(1), \fBxdg-mime\fR(1), \m[blue]\fBMIME applications associations specification\fR\m[]\&\s-2\u[1]\d\s+2, \m[blue]\fBRFC 6068 \- The \*(Aqmailto\*(Aq URI Scheme\fR\m[]\&\s-2\u[2]\d\s+2 .SH "مثال‌ها (EXAMPLES)" .PP .if n \{\ .RS 4 .\} .nf xdg\-email \*(AqJeremy White \*(Aq .fi .if n \{\ .RE .\} .PP .if n \{\ .RS 4 .\} .nf xdg\-email \-\-attach /tmp/logo\&.png \e \-\-subject \*(AqLogo contest\*(Aq \e \-\-body \*(AqAttached you find the logo for the contest\&.\*(Aq \e \*(Aqjwhite@example\&.com\*(Aq .fi .if n \{\ .RE .\} .PP .if n \{\ .RS 4 .\} .nf xdg\-email \-\-subject \*(AqYour password is about to expire\*(Aq \e \*(Aqjwhite@example\&.com\*(Aq \*(Aqbastian@example\&.com\*(Aq \*(Aqwhipple@example\&.com\*(Aq .fi .if n \{\ .RE .\} .sp .SH "نویسندگان (AUTHORS)" .PP \fBKevin Krammer\fR .RS 4 نویسنده\&. .RE .PP \fBJeremy White\fR .RS 4 نویسنده\&. .RE .SH "کپی‌رایت و تکثیر (COPYRIGHT)" .br حق نشر \(co 2006 .br .SH "نکات (NOTES)" .IP " 1." 4 MIME applications associations specification .RS 4 \%http://www.freedesktop.org/wiki/Specifications/mime-apps-spec .RE .IP " 2." 4 RFC 6068 - The 'mailto' URI Scheme .RS 4 \%https://tools.ietf.org/html/rfc6068 .RE