| XDG-EMAIL(1) | xdg-email Manual | XDG-EMAIL(1) |
نام (NAME)
xdg-email - ابزار خط فرمان برای ارسال رایانامه با استفاده از ویرایشگر رایانامهٔ ترجیحی کاربر
خلاصه دستور (SYNOPSIS)
xdg-email [--utf8] [--cc address] [--bcc address] [--subject text] [--body text] [--attach file] [mailto-uri | address(es)]
xdg-email {--help | --manual | --version}
توضیحات (DESCRIPTION)
دستور xdg-email ویرایشگر رایانامهٔ ترجیحی کاربر را به منظور ارسال یک نامه به address(es) یا mailto-uri باز میکند. سند RFC2368 شناسههای mailto: URI را تعریف میکند. دستور xdg-email پشتیبانی را به فیلدهای to، cc، subject و body در mailto-uri محدود میکند و سایر فیلدها بدون هشدار نادیده گرفته میشوند. address(es) باید از قواعد نگارشی RFC822 پیروی کند. نشانیهای چندگانه را میتوان بهصورت آرگومانهای جداگانه وارد کرد.
تمام اطلاعات ارائهشده در خط فرمان برای پر کردن فیلدهای متناظر در ویرایشگر رایانامهٔ کاربر استفاده میشود. کاربر این امکان را خواهد داشت که پیش از ارسال واقعی رایانامه، هر بخش از این اطلاعات را تغییر دهد.
دستور xdg-email فقط برای استفاده در یک نشست میزکار است. استفاده از xdg-email با دسترسی ریشه (root) توصیه نمیشود.
گزینهها (OPTIONS)
--utf8
--cc address
--bcc address
--subject text
--body text
--attach file
برخی از برنامههای رایانامه نیاز دارند که فایل پس از بازگشت دستور xdg-email همچنان موجود باقی بماند.
--help
--manual
--version
محیط (ENVIRONMENT)
دستور xdg-email از متغیرهای محیطی زیر پیروی میکند:
XDG_UTILS_DEBUG_LEVEL
وضعیت خروج (EXIT STATUS)
کد خروج 0 نشاندهندهٔ موفقیت و کد خروج غیر صفر نشاندهندهٔ شکست است. کدهای خطای زیر ممکن است بازگردانده شوند:
1
2
3
4
5
همچنین ببینید (SEE ALSO)
xdg-open(1), xdg-mime(1), MIME applications associations specification[1], RFC 6068 - The 'mailto' URI Scheme[2]
مثالها (EXAMPLES)
xdg-email 'Jeremy White <jwhite@example.com>'
xdg-email --attach /tmp/logo.png \
--subject 'Logo contest' \
--body 'Attached you find the logo for the contest.' \
'jwhite@example.com'
xdg-email --subject 'Your password is about to expire' \
'jwhite@example.com' 'bastian@example.com' 'whipple@example.com'
نویسندگان (AUTHORS)
Kevin Krammer
Jeremy White
کپیرایت و تکثیر (COPYRIGHT)
حق نشر © 2006
نکات (NOTES)
- 1.
- MIME applications associations specification
- 2.
- RFC 6068 - The 'mailto' URI Scheme
| 12/06/2025 | xdg-utils 1.0 |