imap(1) General Commands Manual imap(1)

himalaya-imap - رابط برنامه‌نویسی ویژه IMAP

imap [-h|--help] <subcommands>

رابط برنامه‌نویسی ویژه IMAP.

دسترسی به رابط برنامه‌نویسی خام IMAP را فراهم می‌کند. هر دستور با نام معادل خود در پروتکل IMAP (استاندارد RFC 3501 و افزونه‌های آن) مطابقت دارد و همانند خود این پروتکل، به صورت فهرستی مسطح از دستورات ارائه شده است.

نمایش راهنما (مشاهده خلاصه‌ای با '-h')

دریافت اطلاعات درباره سرور IMAP
انتخاب صندوق پستی مشخص‌شده (دستور SELECT، استاندارد RFC 3501)
ایجاد صندوق پستی مشخص‌شده (دستور CREATE، استاندارد RFC 3501)
حذف صندوق پستی مشخص‌شده (دستور DELETE، استاندارد RFC 3501)
تغییر نام صندوق پستی مشخص‌شده (دستور RENAME، استاندارد RFC 3501)
اشتراک در صندوق پستی مشخص‌شده (دستور SUBSCRIBE، استاندارد RFC 3501)
لغو اشتراک از صندوق پستی مشخص‌شده (دستور UNSUBSCRIBE، استاندارد RFC 3501)
فهرست کردن صندوق‌های پستی (دستورات LIST / LSUB، استاندارد RFC 3501)
دریافت وضعیت صندوق پستی مشخص‌شده (دستور STATUS، استاندارد RFC 3501)
بستن صندوق پستی انتخاب‌شده (دستور CLOSE، استاندارد RFC 3501)
لغو انتخاب صندوق پستی انتخاب‌شده (دستور UNSELECT، استاندارد RFC 3691)
پاکسازی دائمی پیام‌های حذف‌شده در صندوق پستی مشخص‌شده (دستور EXPUNGE، استاندارد RFC 3501)
جستجوی پیام‌های IMAP (دستور SEARCH، استاندارد RFC 3501)
مرتب‌سازی پیام‌های IMAP (دستور SORT، استاندارد RFC 5256)
دسته‌بندی رشته‌ای پیام‌های IMAP (دستور THREAD، استاندارد RFC 5256)
ذخیره پرچم‌های IMAP روی پیام(ها) (دستور STORE، استاندارد RFC 3501)
فهرست کردن پرچم‌های موجود در صندوق پستی مشخص‌شده (پاسخ دستور SELECT، استاندارد RFC 3501)
واکشی اقلام داده پیام IMAP (دستور FETCH، استاندارد RFC 3501)
الحاق یک پیام به یک صندوق پستی (دستور APPEND، استاندارد RFC 3501)
کپی پیام(های) IMAP به صندوق پستی مشخص‌شده (دستور COPY، استاندارد RFC 3501)
انتقال پیام(های) IMAP به صندوق پستی مشخص‌شده (دستور MOVE، استاندارد RFC 6851)
ارسال یک یا چند دستور خام IMAP و چاپ پاسخ دقیق سرور
نمایش این پیام یا راهنمای زیردستور(های) مشخص‌شده
imap