.ie \n(.g .ds Aq \(aq .el .ds Aq ' .TH imap 1 "imap " .SH "نام (NAME)" himalaya-imap \- رابط برنامه‌نویسی ویژه IMAP .SH "خلاصه دستور (SYNOPSIS)" \fBimap\fR [\fB\-h\fR|\fB\-\-help\fR] <\fIsubcommands\fR> .SH "توضیحات (DESCRIPTION)" رابط برنامه‌نویسی ویژه IMAP. .PP دسترسی به رابط برنامه‌نویسی خام IMAP را فراهم می‌کند. هر دستور با نام معادل خود در پروتکل IMAP (استاندارد RFC 3501 و افزونه‌های آن) مطابقت دارد و همانند خود این پروتکل، به صورت فهرستی مسطح از دستورات ارائه شده است. .SH "گزینه‌ها (OPTIONS)" .TP \fB\-h\fR, \fB\-\-help\fR نمایش راهنما (مشاهده خلاصه‌ای با \*(Aq\-h\*(Aq) .SH "زیردستورها (SUBCOMMANDS)" .TP imap\-id(1) دریافت اطلاعات درباره سرور IMAP .TP imap\-select(1) انتخاب صندوق پستی مشخص‌شده (دستور SELECT، استاندارد RFC 3501) .TP imap\-create(1) ایجاد صندوق پستی مشخص‌شده (دستور CREATE، استاندارد RFC 3501) .TP imap\-delete(1) حذف صندوق پستی مشخص‌شده (دستور DELETE، استاندارد RFC 3501) .TP imap\-rename(1) تغییر نام صندوق پستی مشخص‌شده (دستور RENAME، استاندارد RFC 3501) .TP imap\-subscribe(1) اشتراک در صندوق پستی مشخص‌شده (دستور SUBSCRIBE، استاندارد RFC 3501) .TP imap\-unsubscribe(1) لغو اشتراک از صندوق پستی مشخص‌شده (دستور UNSUBSCRIBE، استاندارد RFC 3501) .TP imap\-list(1) فهرست کردن صندوق‌های پستی (دستورات LIST / LSUB، استاندارد RFC 3501) .TP imap\-status(1) دریافت وضعیت صندوق پستی مشخص‌شده (دستور STATUS، استاندارد RFC 3501) .TP imap\-close(1) بستن صندوق پستی انتخاب‌شده (دستور CLOSE، استاندارد RFC 3501) .TP imap\-unselect(1) لغو انتخاب صندوق پستی انتخاب‌شده (دستور UNSELECT، استاندارد RFC 3691) .TP imap\-expunge(1) پاکسازی دائمی پیام‌های حذف‌شده در صندوق پستی مشخص‌شده (دستور EXPUNGE، استاندارد RFC 3501) .TP imap\-search(1) جستجوی پیام‌های IMAP (دستور SEARCH، استاندارد RFC 3501) .TP imap\-sort(1) مرتب‌سازی پیام‌های IMAP (دستور SORT، استاندارد RFC 5256) .TP imap\-thread(1) دسته‌بندی رشته‌ای پیام‌های IMAP (دستور THREAD، استاندارد RFC 5256) .TP imap\-store(1) ذخیره پرچم‌های IMAP روی پیام(ها) (دستور STORE، استاندارد RFC 3501) .TP imap\-flags(1) فهرست کردن پرچم‌های موجود در صندوق پستی مشخص‌شده (پاسخ دستور SELECT، استاندارد RFC 3501) .TP imap\-fetch(1) واکشی اقلام داده پیام IMAP (دستور FETCH، استاندارد RFC 3501) .TP imap\-append(1) الحاق یک پیام به یک صندوق پستی (دستور APPEND، استاندارد RFC 3501) .TP imap\-copy(1) کپی پیام(های) IMAP به صندوق پستی مشخص‌شده (دستور COPY، استاندارد RFC 3501) .TP imap\-move(1) انتقال پیام(های) IMAP به صندوق پستی مشخص‌شده (دستور MOVE، استاندارد RFC 6851) .TP imap\-raw(1) ارسال یک یا چند دستور خام IMAP و چاپ پاسخ دقیق سرور .TP imap\-help(1) نمایش این پیام یا راهنمای زیردستور(های) مشخص‌شده