| dhcp-options(5) | File Formats Manual | dhcp-options(5) |
نام (NAME)
dhcp-options - گزینههای پروتکل پیکربندی پویای میزبان (DHCP)
توضیحات (DESCRIPTION)
پروتکل پیکربندی پویای میزبان (DHCP) به کلاینت اجازه میدهد گزینهها را از سرور DHCP دریافت کند که پیکربندی شبکه و سرویسهای مختلف موجود در شبکه را توصیف میکنند. هنگام پیکربندی dhcpd(8) یا dhclient(8)، اغلب باید گزینهها اعلان شوند. نحو اعلان گزینهها، و نامها و قالبهای گزینههایی که میتوان اعلان کرد، در اینجا مستند شدهاند.
مرجع: دستورات گزینهها (REFERENCE: OPTION STATEMENTS)
دستورات option در DHCP همیشه با کلمه کلیدی option آغاز میشوند، که پس از آن نام گزینه و سپس دادههای گزینه میآید. نامهای گزینهها و قالبهای داده در ادامه شرح داده شدهاند. نیازی نیست که همه گزینههای DHCP به صورت جامع مشخص شوند - تنها گزینههایی که کلاینتها به آنها نیاز دارند باید تعیین شوند.
دادههای گزینه در قالبهای گوناگونی ارائه میشوند، همانطور که در ادامه تعریف شده است:
نوع داده ip-address میتواند هم به صورت یک آدرس IP صریح (مانند 239.254.197.10) یا به صورت یک نام دامنه (مانند haagen.isc.org) وارد شود. هنگام وارد کردن نام دامنه، مطمئن شوید که آن نام دامنه به یک آدرس IP واحد تحلیل میشود. علاوه بر این، لطفاً توجه داشته باشید که نرمافزار (dhcpd یا dhclient) تنها در نخستین باری که گزینه مورد نیاز باشد تلاش خواهد کرد تا نام دامنه را تحلیل کند. برای مثال، اگر گزینه next-server به عنوان یک نام دامنه تعریف شده باشد، dhcpd هنگام پاسخ دادن به نخستین پرسش کلاینت پس از راهاندازی، تلاش خواهد کرد تا آن را تحلیل کند. در صورتی که آدرس دامنه متعاقباً تغییر کند، نرمافزار باید مجدداً راهاندازی شود تا تغییر اعمال گردد.
داده ip6-address یک آدرس IPv6 را مشخص میکند، مانند ::1 یا 3ffe:bbbb:aaaa:aaaa::1.
نوع داده int32 یک عدد صحیح ۳۲ بیتی علامتدار را مشخص میکند. نوع داده uint32 یک عدد صحیح ۳۲ بیتی بدون علامت را مشخص میکند. انواع داده int16 و uint16 اعداد صحیح ۱۶ بیتی علامتدار و بدون علامت را مشخص میکنند. انواع داده int8 و uint8 اعداد صحیح ۸ بیتی علامتدار و بدون علامت را مشخص میکنند. به اعداد صحیح ۸ بیتی بدون علامت گاهی اوکتت (octet) نیز گفته میشود.
نوع داده text یک رشته NVT ASCII را مشخص میکند که باید درون گیومه مضاعف قرار گیرد - برای مثال، جهت مشخص کردن گزینه root-path، نحو به صورت زیر خواهد بود:
option root-path "10.0.1.4:/var/tmp/rootfs";
نوع داده domain-name یک نام دامنه را مشخص میکند که نباید درون گیومه مضاعف قرار گیرد. نام دامنه دقیقاً مانند یک گزینه text ذخیره میشود.
نوع داده domain-list فهرستی از نامهای دامنه را مشخص میکند که درون گیومه مضاعف قرار گرفته و با کاما از یکدیگر جدا شدهاند ("example.com", "foo.example.com").
نوع داده flag یک مقدار بولی (boolean) را مشخص میکند. مقادیر بولی میتوانند true یا false باشند (یا on یا off، در صورتی که برای شما مفهومتر است).
نوع داده string یا یک رشته NVT ASCII محصور در گیومه مضاعف، یا مجموعهای از اوکتتها به صورت هگزادسیمال که با دونقطه از هم جدا شدهاند را مشخص میکند. برای مثال:
option dhcp-client-identifier "CLIENT-FOO"; یا option dhcp-client-identifier 43:4c:49:45:54:2d:46:4f:4f;
تنظیم مقادیر گزینه با استفاده از عبارات (SETTING OPTION VALUES USING EXPRESSIONS)
گاهی اوقات مفید است که بتوان مقدار یک گزینه DHCP را بر اساس مقداری که کلاینت ارسال کرده است تنظیم کرد. برای این کار، میتوانید از ارزیابی عبارات استفاده کنید. صفحه راهنمای dhcp-eval(5) نحوه نوشتن عبارات را توصیف میکند. برای انتساب نتیجه ارزیابی به یک گزینه، آن گزینه را به صورت زیر تعریف کنید:
option my-option = expression ;
برای مثال:
option hostname = binary-to-ascii (16, 8, "-",
substring (hardware, 1, 6));
شامل کردن تعاریف گزینهها (INCLUDING OPTION DEFINITIONS)
با شروع از نسخه 4.3.0، هنگامی که ISC تعاریف جدید گزینهها را اضافه میکند، آن تعاریف بر اساس تعریف یک آرگومان برای RFC مشخصکننده گزینه در includes/site.h درون کد گنجانده میشوند. این امر روشی را برای بازنویسی تعاریف ISC در صورت لزوم در اختیارتان قرار میدهد - برای مثال در صورتی که قبلاً با استفاده از سازوکار بخش «DEFINING NEW OPTIONS» در ادامه، گزینه را با قالبی متفاوت تعریف کرده باشید.
بهطور پیشفرض تمامی گزینهها فعال هستند. برای غیرفعال کردن یک گزینه، فایل includes/site.h را ویرایش کرده و تعریف مربوط به RFC مورد نظر را کامنت کنید.
گزینههای استاندارد DHCPV4 (STANDARD DHCPV4 OPTIONS)
مستندات مربوط به گزینههای گوناگون ذکرشده در زیر از آخرین پیشنویس IETF دربارهٔ گزینههای DHCP برگرفته شده است. گزینههایی که در زیر فهرست نشدهاند ممکن است هنوز پیادهسازی نشده باشند، اما استفاده از چنین گزینههایی با تعریف آنها در فایل پیکربندی امکانپذیر است. لطفاً برای اطلاعات بیشتر، بخش «تعریف گزینههای جدید (DEFINING NEW OPTIONS)» را در ادامهٔ این سند ببینید.
برخی از گزینههای ارائهشده در این مستندات به طور خودکار توسط سرور DHCP یا کلاینتها تولید میشوند و توسط کاربر قابل پیکربندی نیستند. مقدار چنین گزینهای میتواند در فایل پیکربندی عامل پروتکل DHCP دریافتکننده (سرور یا کلاینت)، برای نمونه در عبارتهای شرطی، استفاده شود. با این حال، مقدار این گزینه را نمیتوان در فایل پیکربندی عامل فرستنده استفاده کرد، زیرا این مقدار تنها پس از پردازش فایل پیکربندی مشخص میشود. در مستندات پیشرو، چنین گزینههایی با عنوان «توسط کاربر قابل پیکربندی نیست» نشان داده میشوند.
گزینههای استاندارد عبارتند از:
option all-subnets-local flag;
این گزینه مشخص میکند که آیا کلاینت مجاز است فرض کند تمام زیرشبکههای شبکهٔ IP که کلاینت به آن متصل است از همان MTU زیرشبکهای استفاده میکنند که کلاینت مستقیماً به آن متصل است یا خیر. مقدار true نشان میدهد که همهٔ زیرشبکهها دارای MTU یکسانی هستند. مقدار false به این معنی است که کلاینت باید فرض کند برخی از زیرشبکههای شبکهٔ مستقیماً متصلشده ممکن است MTU کوچکتری داشته باشند.
option arp-cache-timeout uint32;
این گزینه زمان انقضا (timeout) را بر حسب ثانیه برای مدخلهای حافظهٔ موقت ARP (حافظهٔ ARP cache) مشخص میکند.
option associated-ip ip-address [, ip-address... ];
این گزینه بخشی از پرسوجوی اجاره (lease query) است. از این گزینه برای بازگرداندن تمام نشانیهای IP مرتبط با یک کلاینت DHCP مشخص استفاده میشود.
این گزینه توسط کاربر قابل پیکربندی نیست.
option bcms-controller-address ip-address [, ip-address... ];
این گزینه فهرستی از نشانیهای IPv4 را برای استفاده به عنوان سرورهای کنترلکنندهٔ پخشی و چندپخشی ("BCMS") پیکربندی میکند.
option bcms-controller-names domain-list;
این گزینه شامل نامهای دامنهای کنترلکنندههای محلی سرورهای کنترلکنندهٔ پخشی و چندپخشی ("BCMS") است که کلاینت ممکن است از آنها استفاده کند.
option bootfile-name text;
این گزینه برای شناسایی یک فایل راهاندازی (bootstrap file) استفاده میشود. در صورت پشتیبانی توسط کلاینت، باید اثری مشابه اعلان filename داشته باشد. بعید است که کلاینتهای BOOTP از این گزینه پشتیبانی کنند. برخی از کلاینتهای DHCP از آن پشتیبانی خواهند کرد و برخی دیگر در واقع به آن نیاز دارند.
option boot-size uint16;
این گزینه طول ایمیج بوت پیشفرض کلاینت را در قالب بلوکهای ۵۱۲ اکتی (۵۱۲ بایتی) مشخص میکند.
option broadcast-address ip-address;
این گزینه نشانی پخشی (broadcast address) مورد استفاده در زیرشبکهٔ کلاینت را مشخص میکند. مقادیر مجاز برای نشانیهای برودکست در بخش 3.2.1.3 از STD 3 (RFC1122) مشخص شدهاند.
option capwap-ac-v4 ip-address [, ip-address ... ] ;
فهرستی از نشانیهای IPv4 مربوط به CAPWAP ACها که WTP ممکن است استفاده کند. نشانیها به ترتیب اولویت فهرست شدهاند.
این گزینه بر اساس RFC 5417 گنجانده شده است.
option client-last-transaction-time uint32;
این گزینه بخشی از پرسوجوی اجاره (lease query) است. به گیرنده امکان میدهد زمان آخرین دسترسی توسط کلاینت را تعیین کند. مقدار آن مدتزمانی بر حسب ثانیه از آخرین باری است که کلاینت با سرور DHCP ارتباط برقرار کرده است.
این گزینه توسط کاربر قابل پیکربندی نیست.
option cookie-servers ip-address [, ip-address... ];
گزینهٔ cookie server فهرستی از سرورهای کوکی RFC 865 در دسترس کلاینت را مشخص میکند. سرورها باید به ترتیب اولویت فهرست شوند.
option default-ip-ttl uint8;
این گزینه طول عمر پیشفرض (time-to-live یا TTL) را مشخص میکند که کلاینت باید در دیتگرامهای خروجی استفاده کند.
option default-tcp-ttl uint8;
این گزینه TTL پیشفرضی را مشخص میکند که کلاینت هنگام ارسال سگمنتهای TCP باید استفاده کند. کمترین مقدار ۱ است.
option default-url string;
قالب و معنای این گزینه در هیچ سند استانداردی شرح داده نشده است، اما ادعا شده که توسط شرکت کامپیوتری اپل (Apple Computer) استفاده میشود. مشخص نیست کلاینتها در صورت دریافت این گزینه به طور معقول چه کاری انجام خواهند داد. مسئولیت استفاده بر عهدهٔ خود کاربر است.
option dhcp-client-identifier string;
از این گزینه میتوان برای مشخص کردن شناسهٔ کلاینت DHCP در اعلان میزبان (host declaration) استفاده کرد، تا dhcpd بتواند رکورد میزبان را با تطبیق دادن آن با شناسهٔ کلاینت پیدا کند.
لطفاً توجه داشته باشید که برخی از کلاینتهای DHCP هنگام پیکربندی با شناسههای کلاینت به صورت متن ASCII، یک صفر به ابتدای متن ASCII اضافه میکنند. بنابراین ممکن است لازم باشد بنویسید:
option dhcp-client-identifier "\0foo"; به جای: option dhcp-client-identifier "foo";
option dhcp-lease-time uint32;
این گزینه در درخواست کلاینت (DHCPDISCOVER یا DHCPREQUEST) استفاده میشود تا کلاینت بتواند مدتزمان اجاره را برای نشانی IP درخواست کند. در پاسخ سرور (DHCPOFFER)، سرور DHCP از این گزینه برای مشخص کردن مدتزمان اجارهای که مایل به ارائهٔ آن است استفاده میکند.
این گزینه مستقیماً در سرور توسط کاربر قابل پیکربندی نیست؛ به گزینههای سرور max-lease-time و default-lease-time در dhcpd.conf(5) مراجعه کنید.
option dhcp-max-message-size uint16;
این گزینه، هنگامی که توسط کلاینت ارسال میشود، حداکثر اندازهٔ هر پاسخی را که سرور برای کلاینت میفرستد مشخص میکند. هنگامی که در سرور مشخص شده باشد، اگر کلاینت گزینهٔ dhcp-max-message-size را ارسال نکرده باشد، اندازهٔ تعیینشده در سرور استفاده میشود. این قابلیت برای پاسخهای BOOTP و همچنین DHCP کار میکند.
option dhcp-message text;
این گزینه توسط سرور DHCP استفاده میشود تا در صورت وقوع خطا، پیام خطایی را در یک پیام DHCPNAK به کلاینت DHCP ارائه دهد. یک کلاینت ممکن است از این گزینه در پیام DHCPDECLINE استفاده کند تا دلیل رد کردن پارامترهای پیشنهادی توسط کلاینت را مشخص کند.
این گزینه توسط کاربر قابل پیکربندی نیست.
option dhcp-message-type uint8;
این گزینه که توسط کلاینت و سرور ارسال میشود، نوع پیام DHCP موجود در بستهٔ DHCP را مشخص میکند. مقادیر ممکن (برگرفته از RFC2132) عبارتند از:
1 DHCPDISCOVER 2 DHCPOFFER 3 DHCPREQUEST 4 DHCPDECLINE 5 DHCPACK 6 DHCPNAK 7 DHCPRELEASE 8 DHCPINFORM
این گزینه توسط کاربر قابل پیکربندی نیست.
option dhcp-option-overload uint8;
این گزینه نشان میدهد که فیلدهای ´sname´ یا ´file´ در DHCP با استفاده شدن برای حمل گزینههای DHCP، بیشبارگذاری (overload) شدهاند. اگر پارامترهای بازگرداندهشده از فضای معمول اختصاصیافته برای گزینهها فراتر برود، سرور DHCP این گزینه را درج میکند.
اگر این گزینه وجود داشته باشد، کلاینت فیلدهای اضافی مشخصشده را پس از پایان تفسیر فیلدهای گزینههای استاندارد تفسیر میکند.
مقادیر مجاز برای این گزینه عبارتند از:
1 the ´file´ field is used to hold options 2 the ´sname´ field is used to hold options 3 both fields are used to hold options
این گزینه توسط کاربر قابل پیکربندی نیست.
option dhcp-parameter-request-list uint8 [, uint8... ];
این گزینه، هنگامی که توسط کلاینت ارسال میشود، مشخص میکند که کلاینت مایل است سرور چه گزینههایی را بازگرداند. به طور معمول در کلاینت ISC DHCP، این کار با استفاده از دستور request انجام میشود. اگر این گزینه توسط کلاینت مشخص نشود، سرور DHCP به طور معمول هر گزینهای را که در حوزه معتبر باشد و در پاسخ جای گیرد بازمیگرداند. هنگامی که این گزینه در سرور مشخص شود، سرور گزینههای مشخصشده را بازمیگرداند. از این مورد میتوان برای وادار کردن کلاینت به دریافت گزینههایی که درخواست نکرده است استفاده کرد، و همچنین میتوان برای تنظیم پاسخ سرور DHCP برای کلاینتهایی که ممکن است به مجموعهای محدودتر از گزینههای پیشفرض سرور نیاز داشته باشند، بهره برد.
option dhcp-rebinding-time uint32;
این گزینه تعداد ثانیهها از زمانی که کلاینت یک نشانی را دریافت میکند تا زمانی که کلاینت به حالت REBINDING منتقل میشود را مشخص میکند.
این گزینه توسط کاربر قابل پیکربندی است، اما اگر مقدار آن بزرگتر یا مساوی مدتزمان اجاره (lease time) باشد نادیده گرفته خواهد شد.
برای تسهیل مهاجرت DHCPv4+DHCPv6 در آینده، هر مقداری که در این گزینه پیکربندی شود به عنوان زمان "T1" (تجدید/renew) در DHCPv6 نیز استفاده میشود.
option dhcp-renewal-time uint32;
این گزینه تعداد ثانیهها از زمانی که کلاینت یک نشانی را دریافت میکند تا زمانی که کلاینت به حالت RENEWING منتقل میشود را مشخص میکند.
این گزینه توسط کاربر قابل پیکربندی است، اما اگر مقدار آن بزرگتر یا مساوی زمان اتصال مجدد (rebinding time) یا مدتزمان اجاره باشد نادیده گرفته خواهد شد.
برای تسهیل مهاجرت DHCPv4+DHCPv6 در آینده، هر مقداری که در این گزینه پیکربندی شود به عنوان زمان "T2" (اتصال مجدد/rebind) در DHCPv6 نیز استفاده میشود.
option dhcp-requested-address ip-address;
این گزینه توسط کلاینت در یک پیام DHCPDISCOVER استفاده میشود تا درخواست کند یک نشانی IP مشخص به آن اختصاص یابد.
این گزینه توسط کاربر قابل پیکربندی نیست.
option dhcp-server-identifier ip-address;
این گزینه در پیامهای DHCPOFFER و DHCPREQUEST به کار میرود و ممکن است به صورت اختیاری در پیامهای DHCPACK و DHCPNAK نیز گنجانده شود. کارگزارهای DHCP این گزینه را در DHCPOFFER قرار میدهند تا کلاینت بتواند میان پیشنهادهای مختلف اجاره تمایز قائل شود. کلاینتهای DHCP از محتوای فیلد «شناسه کارگزار» به عنوان نشانی مقصد برای هر پیام DHCP که به صورت تکپخشی (unicast) به کارگزار DHCP ارسال میشود، استفاده میکنند. کلاینتهای DHCP همچنین با گنجاندن این گزینه در پیام DHCPREQUEST مشخص میکنند که کدامیک از چندین پیشنهاد اجاره پذیرفته شده است.
مقدار این گزینه نشانی IP کارگزار است.
این گزینه به صورت مستقیم توسط کاربر قابل پیکربندی نیست. گزینه کارگزار server-identifier را در dhcpd.conf(5) ببینید.
option domain-name text;
این گزینه نام دامنهای را مشخص میکند که کلاینت هنگام تحلیل نامهای میزبان از طریق سامانه نام دامنه (DNS) باید استفاده کند.
option domain-name-servers ip-address [, ip-address... ];
گزینه domain-name-servers فهرستی از کارگزارهای نام سامانه نام دامنه (STD 13, RFC 1035) در دسترس کلاینت را مشخص میکند. کارگزارها باید به ترتیب اولویت فهرست شوند.
option domain-search domain-list;
گزینه domain-search یک «فهرست جستجو» از نامهای دامنه را مشخص میکند که کلاینت برای مکانیابی نامهای دامنهای که به طور کامل واجد شرایط نیستند (غیر FQDN) از آن استفاده میکند. تفاوت این گزینه با کاربرد سنتی گزینه domain-name برای همین منظور در این است که این گزینه روی خط ارتباطی در برچسبهای فشردهشده RFC1035 کدگذاری میشود. برای نمونه:
option domain-search "example.com", "sales.example.com",
"eng.example.com";
option extensions-path text;
این گزینه نام فایلی را مشخص میکند که شامل گزینههای اضافی برای تفسیر مطابق با قالب گزینههای DHCP به شرح مشخصشده در RFC2132 است.
option finger-server ip-address [, ip-address... ];
گزینه Finger server فهرستی از کارگزارهای Finger در دسترس کلاینت را مشخص میکند. کارگزارها باید به ترتیب اولویت فهرست شوند.
option font-servers ip-address [, ip-address... ];
این گزینه فهرستی از کارگزارهای قلم سیستم پنجره X (X Window System) در دسترس کلاینت را مشخص میکند. کارگزارها باید به ترتیب اولویت فهرست شوند.
option geoconf-civic string;
رشتهای برای نگهداری ساختار مدنی geoconf (geoconf civic structure).
این گزینه بر اساس RFC 4776 گنجانده شده است.
option host-name string;
این گزینه نام کلاینت را مشخص میکند. نام ممکن است همراه با نام دامنه محلی واجد شرایط باشد یا نباشد (ترجیح بر این است که برای تعیین نام دامنه از گزینه domain-name استفاده شود). برای محدودیتهای مجموعه کاراکتر به RFC 1035 مراجعه کنید. این گزینه تنها در صورتی توسط dhclient-script(8) لحاظ میشود که نام میزبان برای ماشین کلاینت تنظیم نشده باشد.
option ieee802-3-encapsulation flag;
این گزینه مشخص میکند که اگر رابط از نوع اترنت باشد، کلاینت باید از کپسولهسازی اترنت نسخه ۲ (RFC 894) استفاده کند یا IEEE 802.3 (RFC 1042). مقدار false نشان میدهد که کلاینت باید از کپسولهسازی RFC 894 استفاده کند. مقدار true به این معناست که کلاینت باید از کپسولهسازی RFC 1042 استفاده کند.
option ien116-name-servers ip-address [, ip-address... ];
گزینه ien116-name-servers فهرستی از کارگزارهای نام IEN 116 در دسترس کلاینت را مشخص میکند. کارگزارها باید به ترتیب اولویت فهرست شوند.
option impress-servers ip-address [, ip-address... ];
گزینه impress-server فهرستی از کارگزارهای Imagen Impress در دسترس کلاینت را مشخص میکند. کارگزارها باید به ترتیب اولویت فهرست شوند.
option interface-mtu uint16;
این گزینه واحد بیشینه انتقال (MTU) قابل استفاده در این رابط را مشخص میکند. کمترین مقدار مجاز برای MTU برابر ۶۸ است.
option ip-forwarding flag;
این گزینه مشخص میکند که آیا کلاینت باید لایه IP خود را برای فوروارد بستهها پیکربندی کند یا خیر. مقدار false به معنای غیرفعال کردن فوروارد IP و مقدار true به معنای فعال کردن فوروارد IP است.
option irc-server ip-address [, ip-address... ];
گزینه IRC server فهرستی از کارگزارهای IRC در دسترس کلاینت را مشخص میکند. کارگزارها باید به ترتیب اولویت فهرست شوند.
option loader-configfile text
این گزینه برای تعیین فایل پیکربندی بارگذاری بوت که یک کلاینت PXE باید استفاده کند، به کار میرود.
این گزینه بر اساس RFC 5071 گنجانده شده است.
option loader-pathprefix text
این گزینه برای تعیین پیشوند مسیری که یک کلاینت PXE باید در ترکیب با فایل پیکربندی بارگذاری بوت استفاده کند، به کار میرود.
این گزینه بر اساس RFC 5071 گنجانده شده است.
option loader-reboottime uint32
این گزینه برای تعیین حداکثر مدت زمانی که یک کلاینت PXE مجاز است پیش از راهاندازی مجدد (reboot) برای دستیابی به منابع شبکه پیکربندیشده صرف کند، استفاده میشود.
این گزینه بر اساس RFC 5071 گنجانده شده است.
option log-servers ip-address [, ip-address... ];
گزینه log-server فهرستی از کارگزارهای لاگ UDP از نوع MIT-LCS در دسترس کلاینت را مشخص میکند. کارگزارها باید به ترتیب اولویت فهرست شوند.
option lpr-servers ip-address [, ip-address... ];
گزینه LPR server فهرستی از کارگزارهای چاپگر خطی (line printer) منطبق با RFC 1179 در دسترس کلاینت را مشخص میکند. کارگزارها باید به ترتیب اولویت فهرست شوند.
option mask-supplier flag;
این گزینه مشخص میکند که آیا کلاینت باید با استفاده از ICMP به درخواستهای ماسک زیرشبکه (subnet mask) پاسخ دهد یا خیر. مقدار false نشان میدهد که کلاینت نباید پاسخ دهد. مقدار true به این معناست که کلاینت باید پاسخ دهد.
option max-dgram-reassembly uint16;
این گزینه حداکثر اندازه دیتاگرامی را که کلاینت باید برای سرهمبندی مجدد آن آماده باشد، مشخص میکند. کمترین مقدار مجاز ۵۷۶ است.
option merit-dump text;
این گزینه نام مسیر فایلی را مشخص میکند که در صورت کرش کردن کلاینت، تصویر حافظه اصلی (core dump) کلاینت باید در آن ذخیره شود. مسیر به عنوان یک رشته کاراکتری متشکل از نویسههای مجموعه کاراکتر NVT ASCII قالببندی میشود.
option mobile-ip-home-agent ip-address [, ip-address... ];
این گزینه فهرستی از نشانیهای IP را مشخص میکند که نشاندهنده کارگزاران مبدأ IP همراه (mobile IP home agents) در دسترس کلاینت هستند. عاملها باید به ترتیب اولویت فهرست شوند، هرچند معمولاً تنها یک عامل از این نوع وجود خواهد داشت.
option name-service-search uint16 [, uint6... ];
این گزینه فهرستی از سرویسهای نام را به ترتیبی که کلاینت باید برای استفاده از آنها تلاش کند، مشخص میکند.
این گزینه بر اساس RFC 2937 گنجانده شده است.
option nds-context string;
گزینه nds-context نام سرویس دایرکتوری نتوور اولیه (Netware Directory Service) را برای یک کلاینت NDS مشخص میکند.
option nds-servers ip-address [, ip-address... ];
گزینه nds-servers فهرستی از نشانیهای IP کارگزارهای NDS را مشخص میکند.
option nds-tree-name string;
گزینه nds-tree-name نام درخت NDS را که کلاینت NDS باید استفاده کند، مشخص میکند.
option netbios-dd-server ip-address [, ip-address... ];
گزینه کارگزار توزیع دیتاگرام NetBIOS (NBDD) فهرستی از کارگزارهای NBDD منطبق بر RFC 1001/1002 را به ترتیب اولویت مشخص میکند.
option netbios-name-servers ip-address [, ip-address...];
گزینه کارگزار نام NetBIOS (NBNS) فهرستی از کارگزارهای نام NBNS منطبق بر RFC 1001/1002 را به ترتیب اولویت مشخص میکند. سرویس نام NetBIOS امروزه بیشتر با عنوان WINS شناخته میشود. کارگزارهای WINS را میتوان با استفاده از گزینه netbios-name-servers تعیین کرد.
option netbios-node-type uint8;
گزینه نوع گره NetBIOS به کلاینتهای NetBIOS بر روی TCP/IP که قابل پیکربندی هستند اجازه میدهد تا طبق شرح ارائهشده در RFC 1001/1002 پیکربندی شوند. مقدار به صورت یک بایت (اکتت) مشخص میشود که نوع کلاینت را مشخص میکند.
انواع ممکن گره عبارتند از:
- 1
- B-node: همگانی (Broadcast) - بدون WINS
- 2
- P-node: همتا (Peer) - فقط WINS
- 4
- M-node: ترکیبی (Mixed) - ابتدا Broadcast، سپس WINS
- 8
- H-node: پیوندی (Hybrid) - ابتدا WINS، سپس Broadcast
option netbios-scope string;
گزینه دامنه NetBIOS (NetBIOS scope) پارامتر دامنه NetBIOS بر روی TCP/IP را برای کلاینت طبق مشخصات RFC 1001/1002 مشخص میکند. برای محدودیتهای مجموعه کاراکتر به RFC1001، RFC1002 و RFC1035 مراجعه کنید.
option netinfo-server-address ip-address [, ip-address... ];
گزینه netinfo-server-address در هیچ RFCای توصیف نشده است، اما توسط شرکت اپل (Apple Computers) تخصیص یافته (و ادعا میشود که در حال استفاده است). دشوار بتوان گفت آیا قالب فوق صحیح است یا در صورت پیکربندی مقادیر، انتظار میرود کلاینتها چه رفتاری داشته باشند. مسئولیت استفاده بر عهده خود کاربر است.
option netinfo-server-tag text;
گزینه netinfo-server-tag در هیچ RFCای توصیف نشده است، اما توسط شرکت اپل (Apple Computers) تخصیص یافته (و ادعا میشود که در حال استفاده است). دشوار بتوان گفت آیا قالب فوق صحیح است یا در صورت پیکربندی مقادیر، انتظار میرود کلاینتها چه رفتاری داشته باشند. مسئولیت استفاده بر عهده خود کاربر است.
option nis-domain text;
این گزینه نام دامنه NIS (سرویسهای اطلاعات شبکه سان یا Sun Network Information Services) کلاینت را مشخص میکند. این دامنه در قالب یک رشته نویسهای متشکل از نویسههای مجموعه نویسه NVT ASCII فرمتبندی میشود.
option nis-servers ip-address [, ip-address... ];
این گزینه فهرستی از نشانیهای IP را مشخص میکند که سرورهای NIS در دسترس کلاینت را نشان میدهند. سرورها باید به ترتیب اولویت فهرست شوند.
option nisplus-domain text;
این گزینه نام دامنه +NIS کلاینت را مشخص میکند. این دامنه در قالب یک رشته نویسهای متشکل از نویسههای مجموعه نویسه NVT ASCII فرمتبندی میشود.
option nisplus-servers ip-address [, ip-address... ];
این گزینه فهرستی از نشانیهای IP را مشخص میکند که سرورهای +NIS در دسترس کلاینت را نشان میدهند. سرورها باید به ترتیب اولویت فهرست شوند.
option nntp-server ip-address [, ip-address... ];
گزینه سرور NNTP فهرستی از سرورهای NNTP در دسترس کلاینت را مشخص میکند. سرورها باید به ترتیب اولویت فهرست شوند.
option non-local-source-routing flag;
این گزینه مشخص میکند آیا کلاینت باید لایه IP خود را برای اجازه دادن به فوروارد دیتاگرامهای دارای مسیریابی مبدأ غیرمحلی (non-local source routes) پیکربندی کند یا خیر (برای بررسی این موضوع به بخش 3.3.5 از [4] مراجعه کنید). مقدار false به معنای مجاز نبودن فوروارد چنین دیتاگرامهایی است و مقدار true به معنای مجاز بودن آن است.
option ntp-servers ip-address [, ip-address... ];
این گزینه فهرستی از نشانیهای IP را مشخص میکند که سرورهای NTP (بر اساس RFC 5905) در دسترس کلاینت را نشان میدهند. سرورها باید به ترتیب اولویت فهرست شوند.
option nwip-domain string;
نام دامنه NetWare/IP که کلاینت NetWare/IP باید از آن استفاده کند.
option nwip-suboptions string;
توالیای از زیرگزینهها برای کلاینتهای NetWare/IP - برای جزئیات به RFC2242 مراجعه کنید. معمولاً این گزینه با تعیین زیرگزینههای خاص NetWare/IP تنظیم میشود - برای اطلاعات بیشتر بخش زیرگزینههای NETWARE/IP را ببینید.
option pxe-system-type uint16 [, uint16 ... ];
فهرستی از یک یا چند عدد صحیح ۱۶ بیتی که به کلاینت امکان میدهد نوع (یا انواع) معماری پیش از بوت (pre-boot) خود را مشخص کند.
این گزینه بر اساس RFC 4578 گنجانده شده است.
option pxe-interface-id uint8 uint8 uint8
مقداری سه اکتتی که به کلاینت امکان میدهد نوع رابط شبکه خود را مشخص کند.
این گزینه بر اساس RFC 4578 گنجانده شده است.
option pxe-client-id uint8 string
یک اکتت تکی نشاندهنده نوع، به همراه یک رشته که به کلاینت امکان میدهد هویت کلاینت PXE خود را مشخص کند.
این گزینه بر اساس RFC 4578 گنجانده شده است.
option option-6rd uint8 uint8 ip6-address ip-address [, ip-address ...];
این گزینه حاوی اطلاعاتی درباره گزینه استقرار سریع (rapid deployment) است. شامل ۸ بیت طول ماسک IPv4، ۸ بیت طول پیشوند 6rd، یک پیشوند IPv6 به صورت یک نشانی IPv6 و فهرستی از یک یا چند نشانی IPv4 است.
این گزینه بر اساس RFC 5969 گنجانده شده است.
option pana-agent ip-address [, ip-address ... ] ;
مجموعهای از نشانیهای IPv4 مربوط به یک PAA برای استفاده کلاینت. نشانیها به ترتیب اولویت فهرست شدهاند.
این گزینه بر اساس RFC 5192 گنجانده شده است.
option path-mtu-aging-timeout uint32;
این گزینه مدتزمان انقضا (به ثانیه) را برای کهنهسازی مقادیر MTU مسیر (Path MTU) کشفشده توسط سازوکار تعریفشده در RFC 1191 مشخص میکند.
option path-mtu-plateau-table uint16 [, uint16... ];
این گزینه جدولی از اندازههای MTU را جهت استفاده هنگام اجرای کشف MTU مسیر مطابق با RFC 1191 مشخص میکند. این جدول در قالب فهرستی از اعداد صحیح بدون علامت ۱۶ بیتی، مرتبشده از کوچکترین به بزرگترین فرمتبندی میشود. حداقل مقدار MTU نمیتواند کمتر از ۶۸ باشد.
option pcode text;
این گزینه رشتهای مناسب برای متغیر محیطی TZ را مشخص میکند.
این گزینه بر اساس RFC 4833 گنجانده شده است.
option perform-mask-discovery flag;
این گزینه مشخص میکند آیا کلاینت باید کشف ماسک زیرشبکه را با استفاده از ICMP انجام دهد یا خیر. مقدار false نشاندهنده آن است که کلاینت نباید کشف ماسک را انجام دهد. مقدار true به معنای آن است که کلاینت باید کشف ماسک را انجام دهد.
option policy-filter ip-address ip-address
[, ip-address ip-address...];
این گزینه فیلترهای خطمشی را برای مسیریابی مبدأ غیرمحلی مشخص میکند. این فیلترها از فهرستی از نشانیهای IP و ماسکها تشکیل شدهاند که جفتهای مقصد/ماسک را برای فیلتر کردن مسیرهای مبدأ ورودی تعیین میکنند.
هر دیتاگرام دارای مسیریابی مبدأ که نشانی گام بعدی (next-hop) آن با یکی از این فیلترها مطابقت نداشته باشد، باید توسط کلاینت دور ریخته شود.
برای اطلاعات بیشتر به STD 3 (RFC1122) مراجعه کنید.
option pop-server ip-address [, ip-address... ];
گزینه سرور POP3 فهرستی از سرورهای POP3 در دسترس کلاینت را مشخص میکند. سرورها باید به ترتیب اولویت فهرست شوند.
option rdnss-selection uint8 ip-address ip-address domain-name;
گزینه rdnss-selection یک فیلد پرچمهای ۸ بیتی، یک نشانی IP اصلی و ثانویه برای سرور نام و یک فهرست دامنه از دامنههایی که RDNSS دانش ویژهای درباره آنها دارد را مشخص میکند.
این گزینه بر اساس RFC 6731 گنجانده شده است.
option resource-location-servers ip-address
[, ip-address...];
این گزینه فهرستی از سرورهای مکانیابی منبع (Resource Location) بر اساس RFC 887 در دسترس کلاینت را مشخص میکند. سرورها باید به ترتیب اولویت فهرست شوند.
option root-path text;
این گزینه نام مسیری را که حاوی دیسک ریشه (root disk) کلاینت است مشخص میکند. این مسیر در قالب یک رشته نویسهای متشکل از نویسههای مجموعه نویسه NVT ASCII فرمتبندی میشود.
option router-discovery flag;
این گزینه مشخص میکند آیا کلاینت باید با استفاده از سازوکار کشف مسیریاب (Router Discovery) تعریفشده در RFC 1256، درخواست کشف مسیریابها را ارسال کند یا خیر. مقدار false نشان میدهد که کلاینت نباید کشف مسیریاب را انجام دهد. مقدار true به این معنی است که کلاینت باید کشف مسیریاب را انجام دهد.
option router-solicitation-address ip-address;
این گزینه نشانیای را مشخص میکند که کلاینت باید درخواستهای کشف مسیریاب (router solicitation) را به آن ارسال کند.
option routers ip-address [, ip-address... ];
گزینه routers فهرستی از نشانیهای IP برای مسیریابهای موجود در زیرشبکه کلاینت را مشخص میکند. مسیریابها باید به ترتیب اولویت فهرست شوند.
option slp-directory-agent boolean ip-address [, ip-address... ];
این گزینه دو مورد را مشخص میکند: نشانیهای IP یک یا چند مأمور دایرکتوری پروتکل مکانیابی سرویس (Service Location Protocol Directory Agents) و این که آیا استفاده از این نشانیها اجباری است یا خیر. اگر مقدار بولی اولیه true باشد، مأمور SLP فقط باید از نشانیهای IP ارائهشده استفاده کند. اگر مقدار false باشد، مأمور SLP علاوه بر این ممکن است کشف چندپخشی فعال یا غیرفعال مأموران SLP را انجام دهد (برای جزئیات به RFC2165 مراجعه کنید).
لطفاً توجه داشته باشید که در این گزینه و گزینه slp-service-scope، اصطلاح «مأمور SLP» برای اشاره به مأمور پروتکل مکانیابی سرویس در حال اجرا روی سیستمی استفاده میشود که با استفاده از پروتکل DHCP در حال پیکربندی است.
همچنین، در نظر داشته باشید که برخی شرکتها ممکن است از SLP با عنوان NDS یاد کنند. اگر مأمور دایرکتوری NDS دارید که باید نشانی آن را پیکربندی کنید، گزینه slp-directory-agent باید کار کند.
option slp-service-scope boolean text;
گزینه حوزه سرویس پروتکل مکانیابی سرویس (Service Location Protocol Service Scope Option) دو مورد را مشخص میکند: فهرستی از حوزههای سرویس برای SLP و این که آیا استفاده از این فهرست اجباری است یا خیر. اگر مقدار بولی اولیه true باشد، مأمور SLP فقط باید از فهرست حوزههای ارائهشده در این گزینه استفاده کند؛ در غیر این صورت، ممکن است پیکربندی ایستا (استاتیک) خود را به فهرست ارائهشده در این گزینه ترجیح دهد.
رشته متنی باید فهرستی از حوزهها با جداکننده کاما باشد که مأمور SLP باید استفاده کند. این رشته میتواند حذف شود که در این صورت، مأمور SLP از فهرست تجمیعشده حوزههای تمامی مأموران دایرکتوری شناختهشده برای مأمور SLP استفاده خواهد کرد.
option smtp-server ip-address [, ip-address... ];
گزینهٔ سرور SMTP فهرستی از سرورهای SMTP در دسترس کلاینت را مشخص میکند. سرورها باید به ترتیب اولویت فهرست شوند.
option static-routes ip-address ip-address
[, ip-address ip-address...];
این گزینه فهرستی از مسیرهای ایستا (static routes) را مشخص میکند که کلاینت باید در حافظهٔ موقت مسیریابی (routing cache) خود نصب کند. اگر چندین مسیر به یک مقصد یکسان مشخص شده باشند، به ترتیب نزولی اولویت فهرست میشوند.
مسیرها شامل فهرستی از جفتنشانیهای IP هستند. نشانی اول نشانی مقصد، و نشانی دوم روتر مقصد است.
مسیر پیشفرض (0.0.0.0) یک مقصد غیرمجاز برای مسیر ایستا است. برای مشخص کردن مسیر پیشفرض، از گزینهٔ routers استفاده کنید. همچنین لطفاً توجه داشته باشید که این گزینه برای مسیریابی IP بدون کلاس (classless IP routing) در نظر گرفته نشده است؛ این گزینه شامل ماسک زیرشبکه نیست. از آنجا که مسیریابی IP بدون کلاس امروزه گستردهترین استاندارد مسیریابی مستقر است، این گزینه عملاً بیاستفاده است و توسط هیچیک از کلاینتهای محبوب DHCP مانند کلاینت DHCP مایکروسافت پیادهسازی نشده است.
option streettalk-directory-assistance-server ip-address
[, ip-address...];
گزینهٔ سرور راهنمای دایرکتوری StreetTalk (STDA) فهرستی از سرورهای STDA در دسترس کلاینت را مشخص میکند. سرورها باید به ترتیب اولویت فهرست شوند.
option streettalk-server ip-address [, ip-address... ];
گزینهٔ سرور StreetTalk فهرستی از سرورهای StreetTalk در دسترس کلاینت را مشخص میکند. سرورها باید به ترتیب اولویت فهرست شوند.
option subnet-mask ip-address;
گزینهٔ ماسک زیرشبکه (subnet mask)، ماسک زیرشبکهٔ کلاینت را مطابق با RFC 950 مشخص میکند. اگر هیچ گزینهٔ subnet-mask در هیچکجای محدوده (scope) ارائه نشده باشد، به عنوان آخرین راهحل، dhcpd از ماسک زیرشبکهٔ موجود در اعلان subnet برای شبکهای که نشانی در آن اختصاص مییابد استفاده خواهد کرد. با این حال، هرگونه اعلان گزینهٔ subnet-mask که در محدودهٔ نشانی در حال تخصیص باشد، ماسک زیرشبکهٔ مشخصشده در اعلان subnet را بازنویسی (override) خواهد کرد.
option subnet-selection ip-address;
در صورتی توسط کلاینت ارسال میشود که به نشانیای در زیرشبکهای غیر از آن که معمولاً انتخاب میشود (بر اساس نشانی رلهکنندهٔ زیرشبکهٔ متصلی که درخواست از آن دریافت شده است) نیاز باشد. به RFC 3011 مراجعه کنید. توجه داشته باشید شماره گزینهای که توسط این سرور استفاده میشود 118 است؛ این شماره همیشه شمارهٔ تعریفشده نبوده است و برخی از کلاینتها ممکن است از مقدار متفاوتی استفاده کنند. استفاده از این گزینه باید تا حدی آزمایشی در نظر گرفته شود!
این گزینه در سرور توسط کاربر قابل پیکربندی نیست.
option swap-server ip-address;
این گزینه نشانی IP سرور swap کلاینت را مشخص میکند.
option tftp-server-address ip-address [, ip-address... ];
این گزینه فهرستی از یک یا چند نشانی IPv4 از سرورهای tftp را که کلاینت ممکن است استفاده کند پیکربندی میکند.
این گزینه بر اساس RFC 5859 گنجانده شده است.
option tcp-keepalive-garbage flag;
این گزینه مشخص میکند که آیا کلاینت باید پیامهای TCP keepalive را همراه با یک اکتت دادهٔ بیهوده (garbage octet) برای سازگاری با پیادهسازیهای قدیمیتر ارسال کند یا خیر. مقدار false نشان میدهد که اکتت بیهوده نباید ارسال شود. مقدار true نشان میدهد که اکتت بیهوده باید ارسال شود.
option tcp-keepalive-interval uint32;
این گزینه بازهٔ زمانی (بر حسب ثانیه) را مشخص میکند که TCP کلاینت باید پیش از ارسال یک پیام keepalive روی اتصال TCP صبر کند. این زمان به صورت یک عدد صحیح بدون علامت ۳۲ بیتی مشخص میشود. مقدار صفر نشان میدهد که کلاینت نباید روی اتصالات پیامهای keepalive تولید کند، مگر اینکه به طور خاص توسط یک برنامه درخواست شده باشد.
option tcode text;
این گزینه نام یک مدخل منطقه زمانی (zone entry) را در پایگاه دادهٔ TZ مشخص میکند.
این گزینه بر اساس RFC 4833 گنجانده شده است.
option tftp-server-name text;
این گزینه برای شناسایی یک سرور TFTP استفاده میشود و در صورت پشتیبانی توسط کلاینت، باید اثری مشابه اعلان server-name داشته باشد. بعید است که کلاینتهای BOOTP از این گزینه پشتیبانی کنند. برخی از کلاینتهای DHCP از آن پشتیبانی خواهند کرد و برخی دیگر در واقع به آن نیاز دارند.
option time-offset int32;
گزینهٔ time-offset انحراف زمانی (offset) زیرشبکهٔ کلاینت را بر حسب ثانیه نسبت به ساعت هماهنگ جهانی (UTC) مشخص میکند.
option time-servers ip-address [, ip-address... ];
گزینهٔ time-server فهرستی از سرورهای زمان RFC 868 در دسترس کلاینت را مشخص میکند. سرورها باید به ترتیب اولویت فهرست شوند.
option trailer-encapsulation flag;
این گزینه مشخص میکند که آیا کلاینت باید در زمان استفاده از پروتکل ARP، استفاده از تریلرها (RFC 893 [14]) را مذاکره (negotiate) کند یا خیر. مقدار false نشان میدهد که کلاینت نباید تلاش کند از تریلرها استفاده کند. مقدار true به این معنی است که کلاینت باید برای استفاده از تریلرها تلاش کند.
option uap-servers text;
این گزینه فهرستی از URLها را مشخص میکند که هر یک به یک سرویس احراز هویت کاربر اشاره دارند که قادر به پردازش درخواستهای احراز هویت کپسولهشده در پروتکل احراز هویت کاربر (UAP) است. سرورهای UAP میتوانند اتصالات HTTP 1.1 یا SSLv3 را بپذیرند. اگر این فهرست شامل URLای باشد که فاقد مؤلفهٔ پورت است، پورت پیشفرض عادی در نظر گرفته میشود (یعنی پورت ۸۰ برای http و پورت ۴۴۳ برای https). اگر این فهرست شامل URLای باشد که مؤلفهٔ مسیر را ندارد، مسیر /uap فرض میشود. اگر بیش از یک URL در این فهرست مشخص شده باشد، URLها با فاصله (space) از هم جدا میشوند.
option user-class string;
این گزینه توسط برخی کلاینتهای DHCP به عنوان روشی برای مشخص کردن اطلاعات شناسایی توسط کاربران به کلاینت استفاده میشود. این گزینه میتواند به روشی مشابه با گزینهٔ vendor-class-identifier استفاده شود، اما مقدار این گزینه توسط کاربر مشخص میشود، نه سازنده (vendor). اکثر کلاینتهای جدید DHCP روشی در رابط کاربری خود دارند تا مقدار این شناسه را مشخص کنند که معمولاً به صورت یک رشتهٔ متنی است.
option v4-access-domain domain-name;
نام دامنهٔ مرتبط با شبکهٔ دسترسی جهت استفاده در کشف LIS (LIS Discovery).
این گزینه بر اساس RFC 5986 گنجانده شده است.
option v4-lost domain-name;
نام دامنهٔ سرور LoST که کلاینت باید استفاده کند.
این گزینه بر اساس RFC 5223 گنجانده شده است.
option v6-only-preferred uint32;
تعداد ثانیههایی که کلاینت باید DHCPv4 را طی آن غیرفعال کند.
این گزینه و نحوهٔ استفاده از آن توسط کلاینت در RFC 8925 مشخص شده است.
option vendor-class-identifier string;
این گزینه توسط برخی کلاینتهای DHCP برای شناسایی نوع سازنده و احتمالاً پیکربندی کلاینت DHCP استفاده میشود. این اطلاعات رشتهای از بایتها است که محتوای آن مختص سازنده بوده و در یک استاندارد مشخص نشده است. برای مشاهدهٔ اینکه کلاینتها چه شناسهٔ کلاس سازندهای را ارسال میکنند، میتوانید عبارت زیر را در فایل پیکربندی سرور DHCP خود بنویسید:
set vendor-string = option vendor-class-identifier;
این کار باعث میشود تمام مدخلهای موجود در فایل پایگاه دادهٔ اجارهٔ سرور DHCP برای کلاینتهایی که گزینهٔ vendor-class-identifier را ارسال کردهاند، دارای دستور set مشابه زیر باشند:
set vendor-string = "SUNW.Ultra-5_10";
گزینهٔ vendor-class-identifier معمولاً توسط سرور DHCP استفاده میشود تا مشخص شود کدام گزینهها در گزینهٔ vendor-encapsulated-options بازگردانده شوند. لطفاً برای اطلاعات بیشتر، بخش «گزینههای کپسولهشدهٔ سازنده (VENDOR ENCAPSULATED OPTIONS)» را در ادامهٔ این صفحهٔ راهنما ببینید.
option vendor-encapsulated-options string;
گزینهٔ vendor-encapsulated-options میتواند شامل یک مقدار اختصاصی سازنده یا یک یا چند زیرگزینهٔ (suboptions) اختصاصی سازنده باشد. این گزینه معمولاً مستقیماً در فایل پیکربندی سرور DHCP مشخص نمیشود؛ بلکه برای هر سازنده یک کلاس سازنده تعریف میشود، زیرگزینههای کلاس سازنده تعریف میشوند، مقادیر آن زیرگزینهها مشخص میگردند و سرور DHCP بر همان اساس پاسخ را آماده میکند.
برخی از رفتارهای پیشفرض برای سازندگان شناختهشدهٔ کلاینت DHCP (در حال حاضر، کلاینت DHCP مایکروسافت ویندوز ۲۰۰۰) به صورت خودکار پیکربندی شدهاند، اما در غیر این صورت باید به صورت دستی پیکربندی شود؛ برای جزئیات بیشتر به بخش «گزینههای کپسولهشدهٔ سازنده (VENDOR ENCAPSULATED OPTIONS)» در ادامهٔ این صفحهٔ راهنما مراجعه کنید.
option vivso string;
گزینهٔ vivso میتواند شامل چندین گزینهٔ مجزا باشد؛ یک گزینه به ازای هر Enterprise ID ۳۲ بیتی. سپس هر گزینهٔ تفکیکشده بر اساس Enterprise-ID، شامل گزینههای بیشتری است که قالب آنها توسط سازندهٔ دارندهٔ آن شناسه تعریف میشود. این گزینه معمولاً به صورت دستی پیکربندی نمیشود، بلکه از طریق تعاریف گزینههای واسط پیکربندی میگردد. لطفاً برای جزئیات بیشتر، بخش «گزینههای کپسولهشدهٔ سازنده (VENDOR ENCAPSULATED OPTIONS)» را در ادامهٔ این صفحهٔ راهنما نیز ببینید.
option www-server ip-address [, ip-address... ];
گزینهٔ سرور WWW فهرستی از سرورهای WWW در دسترس کلاینت را مشخص میکند. سرورها باید به ترتیب اولویت فهرست شوند.
option x-display-manager ip-address [, ip-address... ];
این گزینه فهرستی از سیستمهایی را مشخص میکند که در حال اجرای مدیر نمایش سامانه پنجره اکس (X Window System Display Manager) بوده و در دسترس کلاینت هستند. نشانیها باید به ترتیب اولویت فهرست شوند.
گزینه اطلاعات رله ایجنت (RELAY AGENT INFORMATION OPTION)
پیشنویس IETF با عنوان draft-ietf-dhc-agent-options-11.txt، مجموعهای از گزینههای کپسولهشده را تعریف میکند که یک رله ایجنت (عامل رله) میتواند هنگام ارسال بسته DHCP به سرور، به آن بیفزاید. سپس سرور میتواند بر اساس این گزینهها، درباره تخصیص آدرس (یا هر تصمیم دیگری که نیاز دارد) تصمیمگیری کند. همچنین سرور این گزینهها را در هر پاسخی که از طریق رله ایجنت میفرستد بازمیگرداند تا رله ایجنت بتواند از اطلاعات موجود در این گزینهها برای اهداف تحویل بسته یا حسابرسی استفاده کند.
پیشنویس فعلی دو گزینه را تعریف میکند. برای ارجاع به این گزینهها در سرور DHCP، نام فضای گزینه یعنی agent و به دنبال آن یک نقطه و سپس نام گزینه را مشخص کنید. معمولاً تعریف مقادیر برای این گزینهها در سرور کاربردی ندارد، اگرچه مجاز است. این گزینهها در کلاینت پشتیبانی نمیشوند.
option agent.circuit-id string;
زیرگزینه circuit-id یک شناسه محلیِ ایجنت را برای مداری که بسته DHCP کلاینت-به-سرور از آن دریافت شده است، کدگذاری میکند. این گزینه برای استفاده توسط ایجنتها در رله کردن پاسخهای DHCP به مدار مربوطه در نظر گرفته شده است. قالب این گزینه در حال حاضر وابسته به تولیدکننده تعریف شده است و احتمالاً به همین شکل باقی خواهد ماند، اگرچه پیشنویس فعلی امکان استانداردسازی قالب را در آینده فراهم کرده است.
option agent.remote-id string;
زیرگزینه remote-id اطلاعات مربوط به انتهای میزبان دوردست یک مدار را کدگذاری میکند. نمونههایی از اطلاعاتی که ممکن است شامل شود عبارتند از اطلاعات شناسه تماسگیرنده (caller ID)، اطلاعات نام کاربری، آدرس ATM دوردست، شناسه مودم کابلی و موارد مشابه. از نظر اصولی، مفهوم آن بهطور دقیق مشخص نشده است و عموماً باید به عنوان یک شیء مبهم (opaque) در نظر گرفته شود که از نظر مدیریتی تضمین شده است برای یک انتهای دوردست مشخص از یک مدار، یکتا باشد.
option agent.DOCSIS-device-class uint32;
زیرگزینه DOCSIS-device-class به منظور انتقال اطلاعاتی درباره نقطه پایانی، سختافزار و نرمافزار میزبان است که در غیر این صورت ممکن است سیستمعامل میزبان یا سرور DHCP از آنها آگاه نباشند (اما رله قادر به تشخیص آنها است). این زیرگزینه به صورت یک فیلد ۳۲ بیتی (۴ اوکتت) پیادهسازی شده است که هر بیت نمایانگر یک پرچم است که میزبان را از یکی از این جنبهها توصیف میکند. تاکنون، تنها بیت صفر (کمارزشترین بیت) در RFC3256 تعریف شده است. اگر این بیت روی یک تنظیم شود، میزبان به عنوان یک مودم کابلی کنترلشده با CPE (CCCM) در نظر گرفته میشود. تمام بیتهای دیگر رزرو شدهاند.
option agent.link-selection ip-address;
زیرگزینه link-selection توسط رله ایجنتها ارائه میشود تا به سرورها اطلاع دهد که کلاینت در واقع به کدام زیرشبکه متصل است. این گزینه در مواردی مفید است که giaddr (جایی که پاسخها باید به رله ایجنت ارسال شوند) در همان زیرشبکه کلاینت قرار ندارد. هنگامی که این گزینه در بستهای از یک رله ایجنت وجود داشته باشد، سرور DHCP از محتویات آن برای یافتن یک زیرشبکه تعریفشده در پیکربندی استفاده میکند و از آنجا یک گام به عقبتر، به هر شبکه مشترکی (shared-network) که زیرشبکه در آن تعریف شده است میرود؛ کلاینت میتواند طبق روال معمول، هر آدرسی را در آن شبکه مشترک دریافت کند.
زیرگزینههای FQDN کلاینت (THE CLIENT FQDN SUBOPTIONS)
گزینه Client FQDN که در حال حاضر در پیشنویس اینترنتی draft-ietf-dhc-fqdn-option-00.txt تعریف شده است، هنوز یک استاندارد نیست، اما از قبل به اندازه کافی کاربرد گستردهای پیدا کرده که آن را پیادهسازی کردهایم. با توجه به پیچیدگی قالب گزینه، ما آن را به جای یک گزینه منفرد، به صورت یک فضای زیرگزینه پیادهسازی کردهایم. بهطور کلی این گزینه نباید توسط کاربر پیکربندی شود - در عوض باید به عنوان بخشی از یک سیستم بهروزرسانی خودکار DNS مورد استفاده قرار گیرد.
option fqdn.no-client-update flag;
هنگامی که کلاینت این گزینه را ارسال میکند، اگر مقدار آن true باشد، به این معنی است که کلاینت تلاشی برای بهروزرسانی رکورد A خود نخواهد کرد. هنگامی که توسط سرور به کلاینت ارسال میشود، به این معنی است که کلاینت نباید رکورد A خودش را بهروزرسانی کند.
option fqdn.server-update flag;
هنگامی که کلاینت این گزینه را به سرور میفرستد، از سرور درخواست میکند که رکورد A آن را بهروزرسانی کند. هنگامی که توسط سرور ارسال میشود، به این معنی است که سرور رکورد A کلاینت را بهروزرسانی کرده است (یا در شرف بهروزرسانی آن است).
option fqdn.encoded flag;
اگر مقدار آن true باشد، نشان میدهد که نام دامنه موجود در گزینه به جای متن اسکی (ASCII) ساده، با فرمت سیمیِ DNS (DNS wire format) کدگذاری شده است. کلاینت معمولاً اگر از فرمت سیمی DNS در گزینه FQDN پشتیبانی نکند، این مقدار را false تنظیم میکند. سرور همیشه باید همان مقداری را بازگرداند که کلاینت ارسال کرده است. هنگامی که این مقدار در سمت پیکربندی تنظیم شود، قالبی را که زیرگزینه fqdn.fqdn بر اساس آن کدگذاری میشود کنترل میکند.
option fqdn.rcode1 flag;
option fqdn.rcode2 flag;
این گزینهها به ترتیب نتیجه بهروزرسانی رکوردهای A و PTR را مشخص میکنند و تنها توسط سرور DHCP به کلاینت DHCP ارسال میشوند. مقادیر این فیلدها همان مقادیر تعریفشده در مشخصات پروتکل DNS هستند.
option fqdn.fqdn text;
نام دامنهای را که کلاینت مایل به استفاده از آن است مشخص میکند. این میتواند یک نام دامنه کاملاً واجد شرایط (FQDN) یا یک برچسب منفرد باشد. اگر در انتهای نام نویسه ´.´ وجود نداشته باشد، کاملاً واجد شرایط نیست و سرور عموماً آن نام را در یک دامنه تعریفشده محلی بهروزرسانی خواهد کرد.
option fqdn.hostname --never set--;
این گزینه هرگز نباید تنظیم شود، اما میتوان آن را با استفاده از عملگرهای option و config-option در یک عبارت بازخوانی کرد، که در این حالت اولین برچسب را در زیرگزینه fqdn.fqdn بازمیگرداند - برای مثال، اگر مقدار fqdn.fqdn برابر "foo.example.com." باشد، آنگاه fqdn.hostname برابر "foo" خواهد بود.
option fqdn.domainname --never set--;
این گزینه هرگز نباید تنظیم شود، اما میتوان آن را با استفاده از عملگرهای option و config-option در یک عبارت بازخوانی کرد، که در این حالت تمام برچسبهای بعد از اولین برچسب را در زیرگزینه fqdn.fqdn بازمیگرداند - برای مثال، اگر مقدار fqdn.fqdn برابر "foo.example.com." باشد، آنگاه fqdn.domainname برابر "example.com." خواهد بود. اگر مقدار این زیرگزینه تنظیم نشده باشد، به این معنی است که یک نام واجد شرایطنشده در گزینه fqdn ارسال شده، یا اصلاً هیچ گزینه fqdn ارسال نشده است.
اگر مایل به استفاده از هر یک از این زیرگزینهها هستید، اکیداً توصیه میکنیم به پیشنویس گزینه Client FQDN (یا استاندارد آن، زمانی که استاندارد شد) مراجعه کنید - مستندات ارائهشده در اینجا در مقایسه با آن، مختصر و ناکامل است و صرفاً برای ارجاع افرادی در نظر گرفته شده که از قبل مشخصات گزینه Client FQDN را درک کردهاند.
زیرگزینههای NETWARE/IP (THE NETWARE/IP SUBOPTIONS)
استاندارد RFC2242 مجموعهای از گزینههای کپسولهشده را برای کلاینتهای Novell NetWare/IP تعریف میکند. برای استفاده از این گزینهها در سرور DHCP، نام فضای گزینه یعنی nwip و به دنبال آن یک نقطه و سپس نام گزینه را مشخص کنید. گزینههای زیر قابل تعیین هستند:
option nwip.nsq-broadcast flag;
اگر مقدار آن true باشد، کلاینت باید از Nearest Server Query نِتور برای یافتن سرور NetWare/IP استفاده کند. رفتار کلاینت نوول در صورتی که این زیرگزینه false باشد یا وجود نداشته باشد، مشخص نشده است.
option nwip.preferred-dss ip-address [, ip-address... ];
این زیرگزینه فهرستی از حداکثر پنج آدرس IP را مشخص میکند که هر یک از آنها باید آدرس IP یک سرور Domain SAP/RIP نِتور (DSS) باشد.
option nwip.nearest-nwip-server
ip-address
[, ip-address...];
این زیرگزینه فهرستی از حداکثر پنج آدرس IP را مشخص میکند که هر یک از آنها باید آدرس IP یک سرور Nearest NetWare IP باشد.
option nwip.autoretries uint8;
تعداد دفعاتی را که یک کلاینت NetWare/IP باید در زمان راهاندازی برای برقراری ارتباط با یک سرور مشخص DSS تلاش کند، تعیین مینماید.
option nwip.autoretry-secs uint8;
مدت زمان به ثانیه را مشخص میکند که یک کلاینت NetWare/IP باید بین تلاشهای مجدد هنگام برقراری ارتباط با یک سرور DSS در زمان راهاندازی منتظر بماند.
option nwip.nwip-1-1 uint8;
اگر مقدار آن true باشد، کلاینت NetWare/IP باید از سازگاری با NetWare/IP نسخه ۱.۱ پشتیبانی کند. این گزینه تنها در صورتی مورد نیاز است که کلاینت با سرورهای NetWare/IP نسخه ۱.۱ ارتباط برقرار کند.
option nwip.primary-dss ip-address;
آدرس IP سرور سرویس اصلی Domain SAP/RIP (DSS) را برای این دامنه NetWare/IP مشخص میکند. ابزار مدیریتی NetWare/IP از این مقدار هنگام پیکربندی سرور ثانویه DSS، به عنوان سرور اصلی DSS استفاده میکند.
گزینههای استاندارد DHCPV6 (STANDARD DHCPV6 OPTIONS)
گزینههای DHCPv6 تا حدی به دلیل استفاده از برچسبهای کد و طول ۱۶ بیتی با گزینههای DHCPv4 تفاوت دارند، اما از نظر معنایی، گزینههای با طول صفر در DHCPv6 مجاز هستند و با گزینههای چندگانه نیز رفتار متفاوتی صورت میگیرد. در حالی که در DHCPv4 گزینههای چندگانه به هم الحاق میشوند تا یک گزینه واحد را تشکیل دهند، در DHCPv6 انتظار میرود که نمونههای جداگانهای باشند. طبیعتاً بسیاری از گزینهها «مجاز» نیستند که چندین نمونه در یک بسته داشته باشند - معمولاً اینها گزینههایی هستند که توسط نرمافزار پروتکل DHCP پردازش میشوند، نه توسط کاربران یا برنامهها.
option dhcp6.client-id string;
این گزینه شناسهٔ DUID کلاینت را مشخص میکند. DUIDها مشابه شناسههای کلاینت DHCPv4 هستند ولی با آنها تفاوت دارند - انواع مستند شده duid عبارتند از:
duid-llt
duid-en
duid-ll
این مقدار نباید پیکربندی شود، بلکه توسط کلاینتها ارائه شده و توسط سرورها به عنوان یک قطعهدادهٔ باینری مات (opaque) کلید شناسه تلقی میشود.
option dhcp6.server-id string;
این گزینه شناسهٔ DUID سرور را مشخص میکند. میتوان از این گزینه برای پیکربندی یک قطعهدادهٔ باینری مات (opaque) برای شناسهٔ سرور خود استفاده کرد.
option dhcp6.ia-na string;
گزینهٔ «انجمن هویت برای نشانیهای غیرموقت» (ia-na) نشانیهای اختصاصیافتهای را حمل میکند که موقت نبوده و برای استفاده توسط کلاینت DHCPv6 هستند. این گزینه توسط نرمافزار سرور DHCPv6 تولید میشود و نباید پیکربندی شود.
option dhcp6.ia-ta string;
گزینهٔ «انجمن هویت برای نشانیهای موقت» (ia-ta) نشانیهای موقتی را حمل میکند که ممکن است در هر بار تمدید تغییر کنند. در نرمافزار فعلی DHCPv6 هیچ پشتیبانی از این ویژگی وجود ندارد.
option dhcp6.ia-addr string;
گزینهٔ «نشانی انجمن هویت» در داخل گزینههای ia-na یا ia-ta کپسولهسازی میشود تا نشانیهای مرتبط با آن IAها را نمایش دهد. این گزینهها توسط نرمافزار تولید میشوند، بنابراین نباید پیکربندی شوند.
option dhcp6.oro uint16 [ , uint16, ... ];
گزینهٔ «درخواست گزینه» ("ORO") معادل DHCPv6 برای parameter-request-list است. کلاینتها این گزینه را ارسال میکنند تا از سرورها درخواست کنند با گزینههای مرتبط با نیازها و کاربرد آنها پاسخ دهند. این گزینه نباید مستقیماً پیکربندی شود، بلکه در عوض باید از نحو request در dhclient.conf(5) استفاده کرد.
option dhcp6.preference uint8;
گزینهٔ preference به کلاینت DHCPv6 اطلاع میدهد که کدام سرور برای استفاده در زیرشبکهٔ موردنظر «ارجح» است. این ترجیح فقط در مراحل اولیهٔ پیکربندی اعمال میشود - به محض اینکه کلاینت به یک IA متصل (bound) شد، تا زمانی که آن IA دیگر معتبر نباشد یا منقضی شود، متصل به آن باقی خواهد ماند. این مقدار ممکن است روی سرور پیکربندی شود و توسط نرمافزار کلاینت پردازش میگردد.
option dhcp6.elapsed-time uint16;
گزینهٔ elapsed-time توسط نرمافزار کلاینت DHCPv6 ساخته میشود و بهطور بالقوه توسط واسطهها مورد استفاده قرار میگیرد. این گزینه نباید پیکربندی شود.
option dhcp6.relay-msg string;
گزینهٔ relay-msg توسط نرمافزار عامل بازپخش (relay agent) مداخلهگر DHCPv6 ساخته میشود. این گزینه کاملاً توسط نرمافزار پروتکل استفاده میشود و برای پیکربندی کاربر در نظر گرفته نشده است.
option dhcp6.unicast ip6-address;
گزینهٔ unicast توسط سرورهای DHCPv6 ارائه میشود که مایل هستند (یا ترجیح میدهند) بستههای Request، Renew، Decline و Release را از طریق تکپخشی (unicast) از کلاینتهای خود دریافت کنند. معمولاً کلاینتهای DHCPv6 این پیامها را بهصورت چندپخشی (multicast) ارسال میکنند. طبق RFC 3315، سرور پیام تکپخشیِ دریافتشده از یک کلاینت را رد خواهد کرد مگر اینکه پیشتر گزینهٔ unicast را به آن کلاینت ارسال کرده باشد (یا میتوانسته ارسال کند). این گزینه ممکن است روی سرور در سطح سراسری و شبکهٔ اشتراکی پیکربندی شود. هنگامی که یک پیام تکپخشی دریافت میشود، سرور وجود تعریفی معتبر از گزینهٔ unicast را بررسی میکند. اگر چنین گزینهای یافت شود، پیام پذیرفته خواهد شد وگرنه رد میشود.
option dhcp6.status-code status-code [ string ] ;
گزینهٔ status-code توسط سرورهای DHCPv6 برای مطلع کردن کلاینتها از شرایط خطا در طول ارتباط پروتکل ارائه میشود. این گزینه توسط نرمافزار پروتکل ساخته و پردازش میشود و نباید پیکربندی گردد.
option dhcp6.rapid-commit ;
گزینهٔ rapid-commit یک گزینه با طول صفر است که کلاینتها برای اعلام تمایل خود جهت ورود به تعهد سریع (rapid-commit) با سرور از آن استفاده میکنند.
option dhcp6.vendor-opts string;
گزینهٔ vendor-opts در واقع یک فضای زیرگزینهٔ کپسولهشده است که در آن هر «گزینه اطلاعات اختصاصی سازنده» (VSIO) با یک عدد ۳۲ بیتی شناسه سازمانی (Enterprise-ID) شناسایی میشود. فضاهای گزینهٔ کپسولهشده درون این گزینهها توسط سازندگان تعریف میشوند.
برای استفاده از این گزینه، بهترین روش بررسی بخش «گزینههای کپسولهشدهٔ سازنده (VENDOR ENCAPSULATED OPTIONS)» در ادامه است، بهویژه نکات مربوط به فضای گزینهٔ "vsio".
option dhcp6.interface-id string;
گزینهٔ interface-id توسط عاملهای بازپخش ساخته میشود و ممکن است برای راهنمایی پیکربندی در جهت تفکیک کلاینتها بر اساس رابطی که از راه دور به آن متصل هستند به کار رود. تعیین مقداری برای این گزینه منطقی نیست، اما بررسی محتویات آن میتواند مفید باشد.
option dhcp6.reconf-msg dhcpv6-message;
گزینهٔ reconf-msg توسط سرورها ساخته میشود و در پیامهای Reconfigure برای کلاینتها ارسال میگردد تا به آنها اطلاع دهد کلاینت باید با استفاده از چه پیامی بازپیکربندی (Reconfigure) شود. هیچ پشتیبانی از افزونههای بازپیکربندی DHCPv6 وجود ندارد و این گزینه صرفاً جهت اطلاعرسانی مستند شده است.
option dhcp6.reconf-accept ;
گزینهٔ reconf-accept توسط کلاینتهای DHCPv6 که از افزونههای بازپیکربندی پشتیبانی میکنند گنجانده میشود و اعلان میدارد در صورتی که سرور از آنها بخواهد بازپیکربندی شوند، پاسخ خواهند داد. هیچ پشتیبانی از افزونههای بازپیکربندی DHCPv6 وجود ندارد و این گزینه صرفاً جهت اطلاعرسانی مستند شده است.
option dhcp6.sip-servers-names domain-list;
گزینهٔ sip-servers-names به کلاینتهای SIP امکان میدهد یک سرور محلی SIP را پیدا کنند که برای تمامی درخواستهای خروجی SIP استفاده میشود، اصطلاحاً یک «سرور پروکسی خروجی». اگر میخواهید در عوض از نشانیهای IPv6 که به صورت دستی وارد شدهاند استفاده کنید، لطفاً گزینهٔ sip-servers-addresses در زیر را ببینید.
option dhcp6.sip-servers-addresses ip6-address [, ip6-address ... ] ;
گزینهٔ sip-servers-addresses به کلاینتهای SIP امکان میدهد یک سرور محلی SIP را بیابند که برای تمامی درخواستهای خروجی SIP استفاده میشود، اصطلاحاً «سرورهای پروکسی خروجی». اگر مایل به استفاده از نامهای دامنه به جای نشانیهای IPv6 هستید، لطفاً به گزینهٔ sip-servers-names در بالا مراجعه کنید.
option dhcp6.name-servers ip6-address [, ip6-address ... ] ;
گزینهٔ name-servers کلاینتها را از سرورهای بازگشتی DNS محلی و در دسترس مطلع میسازد. سادهترین توصیف برای آن، خط "nameserver" در فایل /etc/resolv.conf است.
option dhcp6.domain-search domain-list;
گزینهٔ domain-search مسیر جستجوی دامنهٔ کلاینت را مشخص میکند که برای پرسوجوهای بازگشتی DNS اعمال میشود. سادهترین توصیف برای آن، خط "search" در فایل /etc/resolv.conf است.
option dhcp6.ia-pd string;
گزینهٔ ia-pd توسط کلاینتها و سرورها ساخته میشود تا یک اتصال واگذاری پیشوند (Prefix Delegation) ایجاد کند - تا یک پیشوند IPv6 را به کلاینت واگذار نماید. این گزینه مستقیماً در dhcpd.conf(5) یا dhclient.conf(5) ویرایش نمیشود، بلکه توسط نرمافزار ساخته شده و مصرف میگردد.
option dhcp6.ia-prefix string;
گزینهٔ ia-prefix در داخل گزینههای ia-pd قرار میگیرد تا پیشوند(های) تخصیصدادهشده به کلاینت را مشخص کند. این گزینه مستقیماً در dhcpd.conf(5) یا dhclient.conf(5) ویرایش نمیشود، بلکه توسط نرمافزار ساخته شده و مصرف میگردد.
option dhcp6.nis-servers ip6-address [, ip6-address ... ] ;
گزینهٔ nis-servers سرورهای NIS موجود برای کلاینت را به ترتیب مشخص میکند.
option dhcp6.nisp-servers ip6-address [, ip6-address ... ] ;
گزینهٔ nisp-servers سرورهای +NIS موجود برای کلاینت را به ترتیب مشخص میکند.
option nis-domain-name domain-list;
گزینهٔ nis-domain-name نام دامنهٔ NIS را که انتظار میرود کلاینت استفاده کند مشخص میسازد، و با گزینهٔ nis-servers مرتبط است.
option dhcp6.nis-domain-name domain-name;
گزینهٔ dhcp6.nis-domain-name نام دامنهٔ NIS را که انتظار میرود کلاینت استفاده کند مشخص میسازد، و با گزینهٔ dhcp6.nis-servers مرتبط است.
option nisp-domain-name domain-list;
گزینهٔ nisp-domain-name نام دامنهٔ +NIS را که انتظار میرود کلاینت استفاده کند مشخص میسازد، و با گزینهٔ nisp-servers مرتبط است.
option dhcp6.nisp-domain-name domain-name;
گزینهٔ dhcp6.nisp-domain-name نام دامنهٔ +NIS را که انتظار میرود کلاینت استفاده کند مشخص میسازد، و با گزینهٔ dhcp6.nisp-servers مرتبط است.
option dhcp6.sntp-servers ip6-address [, ip6-address ... ] ;
گزینهٔ sntp-servers فهرستی از سرورهای SNTP محلی و موجود را برای کلاینت مشخص میکند تا ساعتهای خود را با آنها همگامسازی نماید.
option dhcp6.info-refresh-time uint32;
گزینهٔ info-refresh-time به کلاینتهای DHCPv6 که از پیامهای Information-request استفاده میکنند، راهنمایی میدهد که چه مدت زمانی باید میان تازهسازی اطلاعات ارائهشده به آنها فاصله باشد. توجه داشته باشید که این گزینه تنها در صورتی به کلاینت تحویل داده میشود و به احتمال زیاد بر رفتار کلاینت اثر میگذارد که کلاینت خود این گزینه را درخواست کرده باشد.
option dhcp6.bcms-server-d domain-list;
گزینهٔ bcms-server-d شامل نامهای دامنهٔ کنترلکنندههای محلی BCMS (خدمات کنترل پخش همگانی و چندپخشی - Broadcast and Multicast Control Services) است که کلاینت میتواند از آنها استفاده کند.
option dhcp6.bcms-server-a ip6-address [, ip6-address ... ] ;
گزینهٔ bcms-server-a شامل نشانیهای IPv6 مربوط به کنترلکنندههای محلی BCMS (خدمات کنترل پخش همگانی و چندپخشی - Broadcast and Multicast Control Services) است که کلاینت میتواند از آنها استفاده کند.
option dhcp6.geoconf-civic string;
رشتهای برای نگهداری ساختار مدنی geoconf (geoconf civic structure).
این گزینه بر اساس RFC 4776 گنجانده شده است.
option dhcp6.remote-id string;
گزینهٔ remote-id توسط عوامل رله (عامل بازپخش) ساخته میشود تا جزئیات مربوط به اطلاعاتی که رله دربارهٔ کلاینت میداند (مانند اینکه به چه پورتی متصل است و موارد دیگر) را به اطلاع سرور برساند. محتوای این گزینه ساختاری وابسته به سازنده دارد (مشابه VSIO)، اما تصمیم گرفته شده است با این گزینه به عنوان یک فیلد دادهبسته و کدر (opaque field) رفتار شود.
option dhcp6.subscriber-id string;
گزینهٔ subscriber-id یک فیلد دادهبسته و کدر (opaque field) است که توسط عامل رله ارائه میشود و اطلاعات بیشتری را دربارهٔ مشترک مورد نظر فراهم میکند. محتوای دقیق این گزینه به سازنده و/یا پیکربندی اپراتور برای دستگاه راه دور بستگی دارد، و به همین دلیل یک فیلد دادهبسته محسوب میشود.
option dhcp6.fqdn string;
گزینهٔ fqdn معمولاً توسط کلاینت یا سرور ساخته میشود و برای مذاکره پیرامون نام دامنهٔ کاملاً واجد شرایط (FQDN) کلاینت، و نیز تعیین اینکه کدام طرف مسئول بهروزرسانیهای پویای DNS است، به کار میرود. برای مشاهدهٔ جزئیات کامل، بخش زیرگزینههای Client FQDN را ببینید (گزینههای FQDN در DHCPv4 و DHCPv6 از همان فضای کپسولهشدهٔ «fqdn.» استفاده میکنند، بنابراین از هر نظر یکسان هستند).
option dhcp6.pana-agent ip6-address [, ip6-address ... ] ;
مجموعهای از نشانیهای IPv6 مربوط به یک PAA برای استفادهٔ کلاینت. این نشانیها به ترتیب اولویت فهرست شدهاند.
این گزینه بر اساس RFC 5192 گنجانده شده است.
option dhcp6.new-posix-timezone text;
این گزینه رشتهای مناسب برای متغیر محیطی TZ را مشخص میکند.
این گزینه بر اساس RFC 4833 گنجانده شده است.
option dhcp6.new-tzdb-timezone text;
این گزینه نام یک مدخل منطقهٔ زمانی را در پایگاهدادهٔ TZ مشخص میکند.
این گزینه بر اساس RFC 4833 گنجانده شده است.
option dhcp6.ero uint16 [, uint16 ... ] ;
فهرستی از گزینههای درخواستشده توسط عامل رله.
این گزینه بر اساس RFC 4994 گنجانده شده است.
option dhcp6.lq-query string;
گزینهٔ lq-query به صورت داخلی برای پرسوجوی اجاره (lease query) استفاده میشود.
option dhcp6.client-data string;
گزینهٔ client-data به صورت داخلی برای پرسوجوی اجاره (lease query) استفاده میشود.
option dhcp6.clt-time uint32;
گزینهٔ clt-time به صورت داخلی برای پرسوجوی اجاره (lease query) استفاده میشود.
option dhcp6.lq-relay-data ip6-address string;
گزینهٔ lq-relay-data به صورت داخلی برای پرسوجوی اجاره (lease query) استفاده میشود.
option dhcp6.lq-client-link ip6-address [, ip6-address ... ] ;
گزینهٔ lq-client-link به صورت داخلی برای پرسوجوی اجاره (lease query) استفاده میشود.
option dhcp6.v6-lost domain-name;
نام دامنهٔ سرور LoST برای استفادهٔ کلاینت.
این گزینه بر اساس RFC 5223 گنجانده شده است.
option dhcp6.capwap-ac-v6 ip6-address [, ip6-address ... ] ;
فهرستی از نشانیهای IPv6 مربوط به CAPWAP ACها که WTP میتواند استفاده کند. این نشانیها به ترتیب اولویت فهرست شدهاند.
این گزینه بر اساس RFC 5417 گنجانده شده است.
option dhcp6.relay-id string;
شناسهٔ DUID برای عامل رله.
این گزینه بر اساس RFC 5460 گنجانده شده است.
option dhcp6.v6-access-domain domain-name;
نام دامنهٔ مرتبط با شبکهٔ دسترسی جهت استفاده در کشف LIS (LIS Discovery).
این گزینه بر اساس RFC 5986 گنجانده شده است.
option dhcp6.sip-ua-cs-list domain-list;
فهرست نامهای دامنه در دامنههای خدمات پیکربندی کاربر-عامل SIP (SIP User Agent Configuration Service Domains).
این گزینه بر اساس RFC 6011 گنجانده شده است.
option dhcp6.bootfile-url text;
نشانی اینترنتی (URL) برای یک فایل راهاندازی (بوت).
این گزینه بر اساس RFC 5970 گنجانده شده است.
option dhcp6.bootfile-param string;
رشتهای برای پارامترهای ارسالی به فایل بوت. برای توضیحات بیشتر دربارهٔ ساختار و چیدمان پارامترها درون این رشته به RFC 5970 مراجعه کنید.
این گزینه بر اساس RFC 5970 گنجانده شده است.
option dhcp6.client-arch-type uint16 [, uint16 ... ] ;
فهرستی از یک یا چند نوع معماری که به صورت مقادیر ۱۶ بیتی توصیف شدهاند.
این گزینه بر اساس RFC 5970 گنجانده شده است.
option dhcp6.nii uint8 uint8 uint8;
گزینهٔ شناسهٔ رابط شبکهٔ کلاینت (client network interface identifier) اطلاعاتی را دربارهٔ سطح پشتیبانی کلاینت از UNDI ارائه میدهد. این مقادیر به ترتیب عبارتند از: نوع (type)، مقدار اصلی (major) و مقدار فرعی (minor).
این گزینه بر اساس RFC 5970 گنجانده شده است.
option dhcp6.aftr-name domain-name;
نام دامنهٔ نقطهٔ پایانی تونل AFTR.
این گزینه بر اساس RFC 6334 گنجانده شده است.
option dhcp6.erp-local-domain-name domain-name;
نام دامنه برای دامنهٔ ERP.
این گزینه بر اساس RFC 6440 گنجانده شده است.
option dhcp6.rdnss-selection ip6-address uint8 domain-name;
اطلاعات RDNSS شامل یک نشانی IPv6 از RDNSS، یک فیلد فلگهای ۸ بیتی و فهرستی از دامنههایی است که RDNSS اطلاعات و آگاهی ویژهای دربارهٔ آنها دارد.
این گزینه بر اساس RFC 6731 گنجانده شده است.
option dhcp6.client-linklayer-addr string;
نشانی لایهٔ پیوند (link-layer) کلاینت. دو بایت اول باید نوع لایهٔ پیوند و به دنبال آن خود نشانی باشد.
این گزینه بر اساس RFC 6939 گنجانده شده است.
option dhcp6.link-address ip6-address;
نشانی IPv6 که توسط عامل رله استفاده میشود تا پیوندی را که کلاینت روی آن قرار دارد به سرور مشخص کند.
این گزینه بر اساس RFC 6977 گنجانده شده است.
option dhcp6.solmax-rt uint32;
مقداری برای بازنویسی مقدار پیشفرض SOL_MAX_RT. این یک مقدار ۳۲ بیتی است.
این گزینه بر اساس RFC 7083 گنجانده شده است.
option dhcp6.inf-max-rt uint32;
مقداری برای بازنویسی مقدار پیشفرض INF_MAX_RT. این یک مقدار ۳۲ بیتی است.
این گزینه بر اساس RFC 7083 گنجانده شده است.
دسترسی به گزینههای رله DHCPV6 (ACCESSING DHCPV6 RELAY OPTIONS)
v6relay (relay-number, option) این گزینه امکان دسترسی به گزینهای را فراهم میکند که توسط یک عامل رله به بسته اضافه شده است. مقدار relay-number رله مورد نظر برای بررسی را مشخص میکند و option گزینهای است که باید پیدا شود. در DHCPv6، هر رله کل پیام قبلی را درون یک گزینه کپسولهسازی میکند، گزینههای خودش را (در صورت وجود) میافزاید و نتیجه را به جلو ارسال میکند. استاندارد RFC حداکثر ۳۲ جهش (hop) را تعیین کرده است. مقدار relay-number برابر با 0 یک عملیات بیاثر (no-op) است و به این معنی است که رلهها بررسی نشوند. مقدار 1 رلهای است که به کلاینت نزدیکتر است، 2 رله بعدی پس از کلاینت است و به همین ترتیب. هر مقداری بزرگتر از حداکثر تعداد جهشها، بدون توجه به شماره، به رله نزدیکتر به سرور اشاره دارد. برای استفاده از این گزینه در یک دستور class، چیزی شبیه به این خواهید داشت:
match if v6relay(1, option dhcp6.subscriber-id) = "client_1";
تعریف گزینههای جدید (DEFINING NEW OPTIONS)
کلاینت و سرور DHCP متعلق به Internet Systems Consortium امکان تعریف گزینههای جدید را فراهم میکنند. هر گزینه DHCP دارای یک نام، یک کد و یک ساختار است. نام توسط شما برای ارجاع به گزینه استفاده میشود. کد یک عدد است که توسط سرور و کلاینت DHCP برای ارجاع به گزینه استفاده میشود. ساختار، قالب و شکل محتوای یک گزینه را توصیف میکند.
برای تعریف یک گزینه جدید، باید نامی را انتخاب کنید که برای گزینه دیگری استفاده نشده باشد - برای مثال، نمیتوانید از "host-name" استفاده کنید زیرا پروتکل DHCP از قبل گزینه host-name را تعریف کرده است که در بخشهای قبلی این صفحه راهنما مستند شده است. اگر نام گزینهای در این صفحه راهنما وجود ندارد، میتوانید از آن استفاده کنید، اما احتمالاً ایده خوبی است که رشتهای منحصربهفرد را در ابتدای آن قرار دهید تا مطمئن شوید گزینههای آینده نام شما را اشغال نخواهند کرد. برای نمونه، ممکن است گزینهای با نام "local-host-name" تعریف کنید با این اطمینان که هیچ نام گزینه رسمی در DHCP با "local" شروع نخواهد شد.
پس از انتخاب نام، باید یک کد را انتخاب کنید. تمام کدهای بین 224 و 254 به عنوان گزینههای DHCP محلی سایت (´site-local´) رزرو شدهاند، بنابراین میتوانید هر یک از آنها را برای سایت خود (نه برای محصول/برنامه کاربردی خود) برگزینید. در RFC3942، فضای site-local از شروع در 128 به شروع در 224 تغییر یافت. در عمل، برخی سازندگان پروتکل را تا حدی آزادانه تفسیر کردهاند و کدهای گزینهای بزرگتر از 128 را برای مقاصد خود استفاده نمودهاند. راه واقعی برای اجتناب از این مشکل وجود ندارد و تصور میشد بعید است در عمل دردسر چندانی ایجاد کند. اگر با یک کد گزینه مستندشده توسط سازنده در فضاهای site-local جدید یا قدیمی برخورد کردید، لطفاً با سازنده خود تماس بگیرید و آنها را از rfc3942 مطلع کنید.
ساختار یک گزینه در واقع همان قالبی است که دادههای گزینه در آن نمایش مییابند. سرور ISC DHCP در حال حاضر از چند نوع ساده مانند اعداد صحیح (integers)، بولیها (booleans)، رشتهها (strings) و آدرسهای IP پشتیبانی میکند و همچنین از قابلیت تعریف آرایههایی از یک نوع منفرد یا آرایههایی از توالیهای ثابت از انواع داده پشتیبانی مینماید.
گزینههای جدید به صورت زیر اعلان میشوند:
option new-name code new-code = definition ;
مقادیر new-name و new-code باید نامی باشد که برای گزینه جدید انتخاب کردهاید و کدی که برگزیدهاید. definition باید تعریف ساختار گزینه باشد.
تعریفهای نوع گزینه ساده زیر پشتیبانی میشوند:
BOOLEAN
option new-name code new-code = boolean ;
گزینهای از نوع boolean یک فلگ با مقدار on یا off (یا true یا false) است. بنابراین یک مثال از کاربرد نوع boolean به صورت زیر خواهد بود:
option use-zephyr code 180 = boolean; option use-zephyr on;INTEGER
option new-name code new-code = sign integer width ;
نشانه sign باید خالی، unsigned یا signed باشد. مقدار width میتواند 8، 16 یا 32 باشد و به تعداد بیتهای عدد صحیح اشاره دارد. بنابراین برای مثال، دو خط زیر تعریف گزینه sql-connection-max و نحوه استفاده از آن را نشان میدهند:
option sql-connection-max code 192 = unsigned integer 16; option sql-connection-max 1536;IP-ADDRESS
option new-name code new-code = ip-address ;
گزینهای که ساختار آن یک آدرس IP است میتواند به صورت یک نام دامنه یا به عنوان چهار بخش دهدهی نقطهدار (dotted quad) بیان شود. بنابراین نمونه زیر یک مثال از کاربرد نوع ip-address است:
option sql-server-address code 193 = ip-address; option sql-server-address sql.example.com;IP6-ADDRESS
option new-name code new-code = ip6-address ;
گزینهای که ساختار آن آدرس IPv6 است باید به صورت یک آدرس معتبر IPv6 بیان شود. نمونه زیر یک مثال از کاربرد نوع ip6-address است:
option dhcp6.some-server code 1234 = array of ip6-address; option dhcp6.some-server 3ffe:bbbb:aaaa:aaaa::1, 3ffe:bbbb:aaaa:aaaa::2;
TEXT
option new-name code new-code = text ;
گزینهای که نوع آن text است، یک رشته متنی ASCII را کدگذاری میکند. برای مثال:
option sql-default-connection-name code 194 = text; option sql-default-connection-name "PRODZA";
DATA STRING
option new-name code new-code = string ;
گزینهای که نوع آن یک رشته داده (data string) است اساساً مجموعهای از بایتها است و میتواند مانند نوع text به عنوان متن داخل نقلقول مشخص شود، یا به صورت فهرستی از مقادیر هگزادسیمال جداشده با دونقطه (:) که مقادیر آنها باید بین 0 و FF باشد بیان گردد. برای مثال:
option sql-identification-token code 195 = string; option sql-identification-token 17:23:19:a6:42:ea:99:7c:22;
DOMAIN-LIST
option new-name code new-code = domain-list [compressed] ;
گزینهای که نوع آن domain-list است، فهرستی از نامهای دامنه با قالببندی RFC1035 (روی سیم، "DNS Format") است که با برچسبهای ریشه (root labels) از یکدیگر جدا شدهاند. کلیدواژه اختیاری compressed مشخص میکند که آیا گزینه باید نسبت به ابتدای محتوای گزینه (نه محتوای بسته) فشردهسازی شود یا خیر.
در صورت تردید، کلیدواژه compressed را حذف کنید. هنگامی که نرمافزار گزینهای فشردهشده را دریافت کند و کلیدواژه compressed حذف شده باشد، باز هم گزینه را (نسبت به فیلد محتوای گزینه) از حالت فشرده خارج خواهد کرد. این کلیدواژه تنها مشخص میکند که آیا بستههای ارسالی فشرده شوند یا خیر.
توجه داشته باشید هنگامی که گزینههای با قالببندی domain-list به عنوان متغیرهای محیطی به dhclient-script(8) خروجی داده میشوند، سازوکار استاندارد گریز (escape) در DNS استفاده میشود: آنها دهدهی هستند. این مورد برای استفاده مستقیم برای نمونه در /etc/resolv.conf مناسب است.
ENCAPSULATION
option new-name code new-code = encapsulate identifier ;
گزینهای که نوع آن encapsulate است، محتوای فضای گزینه مشخصشده در identifier را کپسولهسازی خواهد کرد. نمونههایی از گزینههای کپسولهشده در پروتکل DHCP به شکل کنونی آن شامل گزینه vendor-encapsulated-options، گزینه netware-suboptions و گزینه relay-agent-information است.
option space local; option local.demo code 1 = text; option local-encapsulation code 197 = encapsulate local; option local.demo "demo";
ARRAYS
گزینهها میتوانند شامل آرایههایی از هر یک از انواع بالا به جز انواع text و data string باشند که در حال حاضر در آرایهها پشتیبانی نمیشوند. یک مثال از تعریف آرایه به صورت زیر است:
option kerberos-servers code 200 = array of ip-address; option kerberos-servers 10.20.10.1, 10.20.11.1;RECORDS
گزینهها همچنین میتوانند شامل ساختارهای دادهای متشکل از توالی انواع داده باشند که گاهی به آن نوع رکورد (record type) گفته میشود. برای مثال:
option contrived-001 code 201 = { boolean, integer 32, text };
option contrived-001 on 1772 "contrivance";
همچنین
داشتن
گزینههایی
که
آرایهای
از رکوردها
هستند
امکانپذیر
است، برای
مثال:
option new-static-routes code 201 = array of {
ip-address, ip-address, ip-address, integer 8 };
option static-routes
10.0.0.0 255.255.255.0 net-0-rtr.example.com 1,
10.0.1.0 255.255.255.0 net-1-rtr.example.com 1,
10.2.0.0 255.255.224.0 net-2-0-rtr.example.com 3;
گزینههای کپسولهشده سازنده (VENDOR ENCAPSULATED OPTIONS)
پروتکل DHCP گزینه vendor-encapsulated-options را تعریف میکند که به سازندگان امکان میدهد گزینههای اختصاصی خود را تعریف کنند تا بهصورت کپسولهشده درون یک گزینه استاندارد DHCP ارسال شوند. همچنین گزینه Vendor Identified Vendor Sub Options (موسوم به «VIVSO») را تعریف میکند، و پروتکل DHCPv6 گزینه Vendor-specific Information Option (موسوم به «VSIO») را تعریف مینماید. قالب همه این گزینهها معمولاً در ساختار داخلی بهصورت رشتهای از گزینهها است، مشابه سایر گزینههای عادی DHCP. تفاوت گزینههای VIVSO و VSIO در این است که آنها حاوی گزینههایی متناظر با شمارههای شناسه سازمانی سازنده (Enterprise-ID) اختصاصیافته توسط IANA هستند که متعاقباً شامل گزینههایی منطبق بر مشخصات فنی هر سازنده خواهند بود. برای قالببندی گزینهها مطابق با مشخصات فنی سازنده خود، باید به مستندات آن سازنده مراجعه کنید.
مقدار این گزینهها را میتوان به یکی از دو روش تنظیم کرد. روش نخست این است که دادهها مستقیماً با استفاده از یک رشته متنی یا فهرستی از مقادیر هگزادسیمال که با دونقطه (:) از هم جدا شدهاند، مشخص شوند. برای راهنمایی در تشکیل این رشتهها، لطفاً برای گزینه Vendor Specific Information Option در DHCPv4 به RFC2132، برای گزینه Vendor Identified Vendor Sub Options در DHCPv4 به RFC3925، یا برای گزینه Vendor-specific Information Option در DHCPv6 به RFC3315 مراجعه فرمایید. برای نمونه:
option vendor-encapsulated-options
2:4:
AC:11:41:1:
3:12:
73:75:6e:64:68:63:70:2d:73:65:72:76:65:72:31:37:2d:31:
4:12:
2f:65:78:70:6f:72:74:2f:72:6f:6f:74:2f:69:38:36:70:63;
option vivso
00:00:09:bf:0E:
01:0c:
48:65:6c:6c:6f:20:77:6f:72:6c:64:21;
option dhcp6.vendor-opts
00:00:09:bf:
00:01:00:0c:
48:65:6c:6c:6f:20:77:6f:72:6c:64:21;
روش دوم برای تنظیم مقدار این گزینهها این است که کارگزار DHCP یک بافر گزینه مختص سازنده تولید کند. برای این کار باید چهار اقدام انجام دهید: یک فضای گزینه تعریف کنید، چند گزینه را در آن فضای گزینه مشخص نمایید، برای آنها مقادیری تعیین کنید، و مشخص کنید که باید از آن فضای گزینه برای ایجاد گزینه مربوطه استفاده شود.
برای تعریف یک فضای گزینه جدید که گزینههای سازنده بتوانند در آن ذخیره شوند، از عبارت option space استفاده کنید:
option space name [ [ code width number ] [ length width number ] [ hash size number ] ] ;
که در آن اعداد پس از code width، length width و hash size بهترتیب نشاندهنده تعداد بایتهای مورد استفاده برای توصیف کدهای گزینه، طول گزینهها، و اندازه جدولهای درهمسازی (بر حسب سطل یا باکت) برای نگهداری گزینهها در این فضا هستند (بیشتر فضاهای گزینه DHCPv4 از کدها و طولهای ۱ بایتی استفاده میکنند که مقدار پیشفرض است، در حالی که اغلب فضاهای گزینه DHCPv6 از کدها و طولهای ۲ بایتی بهره میبرند).
عرض کد و طول در پروتکل DHCP به کار میروند؛ شما باید این اعداد را طوری پیکربندی کنید که با فضای گزینه قابل اعمالی که در حال تنظیم آن هستید مطابقت داشته باشند. مقدار پیشفرض هر دوی آنها ۱ است. مقادیر معتبر برای عرض کد ۱، ۲ یا ۴ هستند. مقادیر معتبر برای عرض طول ۰، ۱ یا ۲ میباشند. بیشتر فضاهای گزینه DHCPv4 از کدها و طولهای ۱ بایتی استفاده میکنند که حالت پیشفرض است، در حالی که بیشتر فضاهای گزینه DHCPv6 از کدها و طولهای ۲ بایتی استفاده مینمایند. طول صفر بایتی گزینههایی مشابه با گزینه اطلاعات مختص سازنده (Vendor-specific Information Option) در DHCPv6 ایجاد میکند، اما نه محتویات آنها را!
مقادیر پیشفرض اندازه درهمسازی به code width انتخابشده بستگی دارد و ممکن است ۲۵۴ یا ۱۰۰۹ باشد. مقادیر معتبر در محدوده بین ۱ تا ۶۵۵۳۵ قرار دارند. توجه داشته باشید که هرچه این مقدار را بزرگتر تنظیم کنید، حافظه بیشتری مصرف خواهد شد. شیوه مناسب این است که مقداری را پیکربندی کنید که کمی بزرگتر از تعداد تخمینی گزینههایی باشد که قصد دارید درون این فضا تعریف نمایید. در نسخههای پیشین ISC DHCP (تا نسخه 3.0.* و خود آن)، این مقدار روی ۹۹۷۳ ثابت بود.
سپس میتوان از نام، همانطور که پیشتر در این سند شرح داده شد، در تعاریف گزینه استفاده کرد. برای نمونه:
option space SUNW code width 1 length width 1 hash size 3; option SUNW.server-address code 2 = ip-address; option SUNW.server-name code 3 = text; option SUNW.root-path code 4 = text; option space ISC code width 1 length width 1 hash size 3; option ISC.sample code 1 = text; option vendor.ISC code 2495 = encapsulate vivso-sample; option vendor-class.ISC code 2495 = text; option ISC.sample "configuration text here"; option vendor-class.ISC "vendor class here"; option space docsis code width 2 length width 2 hash size 17; option docsis.tftp-servers code 32 = array of ip6-address; option docsis.cablelabs-configuration-file code 33 = text; option docsis.cablelabs-syslog-servers code 34 = array of ip6-address; option docsis.device-id code 36 = string; option docsis.time-servers code 37 = array of ip6-address; option docsis.time-offset code 38 = signed integer 32; option vsio.docsis code 4491 = encapsulate docsis;
پس از اینکه یک فضای گزینه و قالب برخی از گزینهها را تعریف کردید، میتوانید محدودههایی (Scopes) ایجاد کنید که مقادیر آن گزینهها را مشخص کنند، و تعیین کنید چه زمانی باید به کار گرفته شوند. برای مثال، فرض کنید میخواهید دو دسته (کلاس) متفاوت از کلاینتها را مدیریت کنید. با استفاده از تعریف فضای گزینه ارائهشده در مثال پیشین، میتوانید بر اساس گزینه vendor-class-identifier که کلاینتها ارسال میکنند، مقادیر گزینههای متفاوتی را مطابق زیر برای کلاینتهای گوناگون بفرستید:
class "vendor-classes" {
match option vendor-class-identifier;
}
subclass "vendor-classes" "SUNW.Ultra-5_10" {
vendor-option-space SUNW;
option SUNW.root-path "/export/root/sparc";
}
subclass "vendor-classes" "SUNW.i86pc" {
vendor-option-space SUNW;
option SUNW.root-path "/export/root/i86pc";
}
option SUNW.server-address 172.17.65.1;
option SUNW.server-name "sundhcp-server17-1";
option vivso-sample.sample "Hello world!";
option docsis.tftp-servers ::1;
همانطور که در مثال بالا مشاهده میکنید، قواعد معمول تعیین محدوده (Scoping) برقرار هستند، بنابراین میتوانید مقادیر سراسری را در محدوده سراسری تعریف کنید، و تنها مقادیری را که مختص به یک کلاس خاص هستند در محدوده محلی قرار دهید. اعلان vendor-option-space به کارگزار DHCP اعلام میکند که از گزینههای موجود در فضای گزینه SUNW برای ساخت گزینه vendor-encapsulated-options در DHCPv4 استفاده کند. این یکی از محدودیتهای آن گزینه است؛ گزینههای VIVSO در DHCPv4 و VSIO در DHCPv6 میتوانند چندین تعریف سازنده مختلف را همزمان داشته باشند (حتی به یک کلاینت یکسان ارسال شوند)، بنابراین نیازی به پیکربندی این مورد نیست.
همچنین ببینید (SEE ALSO)
dhcpd.conf(5), dhcpd.leases(5), dhclient.conf(5), dhcp-eval(5), dhcpd(8), dhclient(8), RFC2132, RFC2131, RFC3046, RFC3315.
نویسندگان (AUTHORS)
اطلاعات مربوط به Internet Systems Consortium را میتوان در نشانی https://www.isc.org یافت.