dhcp-options(5) File Formats Manual dhcp-options(5) (NAME) dhcp-options - (DHCP) (DESCRIPTION) (DHCP) DHCP . dhcpd(8) dhclient(8) . . : (REFERENCE: OPTION STATEMENTS) option DHCP option . . DHCP - . : ip-address IP ( 239.254.197.10) ( haagen.isc.org) . IP . (dhcpd dhclient) . next-server dhcpd . . ip6-address IPv6 ::1 3ffe:bbbb:aaaa:aaaa::1. int32 . uint32 . int16 uint16 . int8 uint8 . (octet) . text NVT ASCII - root-path : option root-path "10.0.1.4:/var/tmp/rootfs"; domain-name . text . domain-list ("example.com", "foo.example.com"). flag (boolean) . true false ( on off ). string NVT ASCII . : option dhcp-client-identifier "CLIENT-FOO"; option dhcp-client-identifier 43:4c:49:45:54:2d:46:4f:4f; (SETTING OPTION VALUES USING EXPRESSIONS) DHCP . . dhcp-eval(5) . : option my-option = expression ; : option hostname = binary-to-ascii (16, 8, "-", substring (hardware, 1, 6)); (INCLUDING OPTION DEFINITIONS) 4.3.0 ISC RFC includes/site.h . ISC - <> . . includes/site.h RFC . DHCPV4 (STANDARD DHCPV4 OPTIONS) IETF DHCP . . << (DEFINING NEW OPTIONS)>> . DHCP . DHCP ( ) . . << >> . : option all-subnets-local flag; IP MTU . true MTU . false MTU . option arp-cache-timeout uint32; (timeout) ARP ( ARP cache) . option associated-ip ip-address [, ip-address... ]; (lease query) . IP DHCP . . option bcms-controller-address ip-address [, ip-address... ]; IPv4 ("BCMS") . option bcms-controller-names domain-list; ("BCMS") . option bootfile-name text; (bootstrap file) . filename . BOOTP . DHCP . option boot-size uint16; ( ) . option broadcast-address ip-address; (broadcast address) . 3.2.1.3 STD 3 (RFC1122) . option capwap-ac-v4 ip-address [, ip-address ... ] ; IPv4 CAPWAP AC WTP . . RFC 5417 . option client-last-transaction-time uint32; (lease query) . . DHCP . . option cookie-servers ip-address [, ip-address... ]; cookie server RFC 865 . . option default-ip-ttl uint8; (time-to-live TTL) . option default-tcp-ttl uint8; TTL TCP . . option default-url string; (Apple Computer) . . . option dhcp-client-identifier string; DHCP (host declaration) dhcpd . DHCP ASCII ASCII . : option dhcp-client-identifier "\0foo"; : option dhcp-client-identifier "foo"; option dhcp-lease-time uint32; (DHCPDISCOVER DHCPREQUEST) IP . (DHCPOFFER) DHCP . max-lease-time default- lease-time dhcpd.conf(5) . option dhcp-max-message-size uint16; . dhcp- max-message-size . BOOTP DHCP . option dhcp-message text; DHCP DHCPNAK DHCP . DHCPDECLINE . . option dhcp-message-type uint8; DHCP DHCP . ( RFC2132) : 1 DHCPDISCOVER 2 DHCPOFFER 3 DHCPREQUEST 4 DHCPDECLINE 5 DHCPACK 6 DHCPNAK 7 DHCPRELEASE 8 DHCPINFORM . option dhcp-option-overload uint8; 'sname' 'file' DHCP DHCP (overload) . DHCP . . : 1 the 'file' field is used to hold options 2 the 'sname' field is used to hold options 3 both fields are used to hold options . option dhcp-parameter-request-list uint8 [, uint8... ]; . ISC DHCP request . DHCP . . DHCP . option dhcp-rebinding-time uint32; REBINDING . (lease time) . DHCPv4+DHCPv6 "T1" (/renew) DHCPv6 . option dhcp-renewal-time uint32; RENEWING . (rebinding time) . DHCPv4+DHCPv6 "T2" ( /rebind) DHCPv6 . option dhcp-requested-address ip-address; DHCPDISCOVER IP . . option dhcp-server-identifier ip-address; DHCPOFFER DHCPREQUEST DHCPACK DHCPNAK . DHCP DHCPOFFER . DHCP << >> DHCP (unicast) DHCP . DHCP DHCPREQUEST . IP . . server-identifier dhcpd.conf(5) . option domain-name text; (DNS) . option domain-name-servers ip-address [, ip-address... ]; domain-name-servers (STD 13, RFC 1035) . . option domain-search domain-list; domain-search << >> ( FQDN) . domain-name RFC1035 . : option domain-search "example.com", "sales.example.com", "eng.example.com"; option extensions-path text; DHCP RFC2132 . option finger-server ip-address [, ip-address... ]; Finger server Finger . . option font-servers ip-address [, ip-address... ]; X (X Window System) . . option geoconf-civic string; geoconf (geoconf civic structure). RFC 4776 . option host-name string; . ( domain-name ). RFC 1035 . dhclient-script(8) . option ieee802-3-encapsulation flag; (RFC 894) IEEE 802.3 (RFC 1042). false RFC 894 . true RFC 1042 . option ien116-name-servers ip-address [, ip-address... ]; ien116-name-servers IEN 116 . . option impress-servers ip-address [, ip-address... ]; impress-server Imagen Impress . . option interface-mtu uint16; (MTU) . MTU . option ip-forwarding flag; IP . false IP true IP . option irc-server ip-address [, ip-address... ]; IRC server IRC . . option loader-configfile text PXE . RFC 5071 . option loader-pathprefix text PXE . RFC 5071 . option loader-reboottime uint32 PXE (reboot) . RFC 5071 . option log-servers ip-address [, ip-address... ]; log-server UDP MIT-LCS . . option lpr-servers ip-address [, ip-address... ]; LPR server (line printer) RFC 1179 . . option mask-supplier flag; ICMP (subnet mask) . false . true . option max-dgram-reassembly uint16; . . option merit-dump text; (core dump) . NVT ASCII . option mobile-ip-home-agent ip-address [, ip-address... ]; IP IP (mobile IP home agents) . . option name-service-search uint16 [, uint6... ]; . RFC 2937 . option nds-context string; nds-context (Netware Directory Service) NDS . option nds-servers ip-address [, ip-address... ]; nds-servers IP NDS . option nds-tree-name string; nds-tree-name NDS NDS . option netbios-dd-server ip-address [, ip-address... ]; NetBIOS (NBDD) NBDD RFC 1001/1002 . option netbios-name-servers ip-address [, ip-address...]; NetBIOS (NBNS) NBNS RFC 1001/1002 . NetBIOS WINS . WINS netbios-name- servers . option netbios-node-type uint8; NetBIOS NetBIOS TCP/IP RFC 1001/1002 . () . : 1 B-node: (Broadcast) - WINS 2 P-node: (Peer) - WINS 4 M-node: (Mixed) - Broadcast WINS 8 H-node: (Hybrid) - WINS Broadcast option netbios-scope string; NetBIOS (NetBIOS scope) NetBIOS TCP/IP RFC 1001/1002 . RFC1001 RFC1002 RFC1035 . option netinfo-server-address ip-address [, ip-address... ]; netinfo-server-address RFC (Apple Computers) ( ). . . option netinfo-server-tag text; netinfo-server-tag RFC (Apple Computers) ( ). . . option nis-domain text; NIS ( Sun Network Information Services) . NVT ASCII . option nis-servers ip-address [, ip-address... ]; IP NIS . . option nisplus-domain text; +NIS . NVT ASCII . option nisplus-servers ip-address [, ip-address... ]; IP +NIS . . option nntp-server ip-address [, ip-address... ]; NNTP NNTP . . option non-local-source-routing flag; IP (non-local source routes) ( 3.3.5 [4] ). false true . option ntp-servers ip-address [, ip-address... ]; IP NTP ( RFC 5905) . . option nwip-domain string; NetWare/IP NetWare/IP . option nwip-suboptions string; NetWare/IP - RFC2242 . NetWare/IP - NETWARE/IP . option pxe-system-type uint16 [, uint16 ... ]; ( ) (pre-boot) . RFC 4578 . option pxe-interface-id uint8 uint8 uint8 . RFC 4578 . option pxe-client-id uint8 string PXE . RFC 4578 . option option-6rd uint8 uint8 ip6-address ip-address [, ip-address ...]; (rapid deployment) . IPv4 6rd IPv6 IPv6 IPv4 . RFC 5969 . option pana-agent ip-address [, ip-address ... ] ; IPv4 PAA . . RFC 5192 . option path-mtu-aging-timeout uint32; ( ) MTU (Path MTU) RFC 1191 . option path-mtu-plateau-table uint16 [, uint16... ]; MTU MTU RFC 1191 . . MTU . option pcode text; TZ . RFC 4833 . option perform-mask-discovery flag; ICMP . false . true . option policy-filter ip-address ip-address [, ip-address ip-address...]; . IP / . (next-hop) . STD 3 (RFC1122) . option pop-server ip-address [, ip-address... ]; POP3 POP3 . . option rdnss-selection uint8 ip-address ip-address domain-name; rdnss-selection IP RDNSS . RFC 6731 . option resource-location-servers ip-address [, ip-address...]; (Resource Location) RFC 887 . . option root-path text; (root disk) . NVT ASCII . option router-discovery flag; (Router Discovery) RFC 1256 . false . true . option router-solicitation-address ip-address; (router solicitation) . option routers ip-address [, ip-address... ]; routers IP . . option slp-directory-agent boolean ip-address [, ip-address... ]; : IP (Service Location Protocol Directory Agents) . true SLP IP . false SLP SLP ( RFC2165 ). slp-service- scope << SLP>> DHCP . SLP NDS . NDS slp-directory-agent . option slp-service-scope boolean text; (Service Location Protocol Service Scope Option) : SLP . true SLP () . SLP . SLP SLP . option smtp-server ip-address [, ip-address... ]; SMTP SMTP . . option static-routes ip-address ip-address [, ip-address ip-address...]; (static routes) (routing cache) . . IP . . (0.0.0.0) . routers . IP (classless IP routing) . IP DHCP DHCP . option streettalk-directory-assistance-server ip-address [, ip-address...]; StreetTalk (STDA) STDA . . option streettalk-server ip-address [, ip-address... ]; StreetTalk StreetTalk . . option subnet-mask ip-address; (subnet mask) RFC 950 . subnet- mask (scope) dhcpd subnet . subnet-mask subnet (override) . option subnet-selection ip-address; ( ) . RFC 3011 . 118 . ! . option swap-server ip-address; IP swap . option tftp-server-address ip-address [, ip-address... ]; IPv4 tftp . RFC 5859 . option tcp-keepalive-garbage flag; TCP keepalive (garbage octet) . false . true . option tcp-keepalive-interval uint32; ( ) TCP keepalive TCP . . keepalive . option tcode text; (zone entry) TZ . RFC 4833 . option tftp-server-name text; TFTP server-name . BOOTP . DHCP . option time-offset int32; time-offset (offset) (UTC) . option time-servers ip-address [, ip-address... ]; time-server RFC 868 . . option trailer-encapsulation flag; ARP (RFC 893 [14]) (negotiate) . false . true . option uap-servers text; URL (UAP) . UAP HTTP 1.1 SSLv3 . URL ( http https). URL /uap . URL URL (space) . option user-class string; DHCP . vendor-class-identifier (vendor). DHCP . option v4-access-domain domain-name; LIS (LIS Discovery). RFC 5986 . option v4-lost domain-name; LoST . RFC 5223 . option v6-only-preferred uint32; DHCPv4 . RFC 8925 . option vendor-class-identifier string; DHCP DHCP . . DHCP : set vendor-string = option vendor-class-identifier; DHCP vendor-class-identifier set : set vendor-string = "SUNW.Ultra-5_10"; vendor-class-identifier DHCP vendor-encapsulated-options . << (VENDOR ENCAPSULATED OPTIONS)>> . option vendor-encapsulated-options string; vendor-encapsulated-options (suboptions) . DHCP DHCP . DHCP ( DHCP ) << (VENDOR ENCAPSULATED OPTIONS)>> . option vivso string; vivso Enterprise ID . Enterprise-ID . . << (VENDOR ENCAPSULATED OPTIONS)>> . option www-server ip-address [, ip-address... ]; WWW WWW . . option x-display-manager ip-address [, ip-address... ]; (X Window System Display Manager) . . (RELAY AGENT INFORMATION OPTION) IETF draft-ietf-dhc- agent-options-11.txt ( ) DHCP . ( ) . . . DHCP agent . . . option agent.circuit-id string; circuit-id DHCP -- . DHCP . . option agent.remote-id string; remote-id . (caller ID) ATM . (opaque) . option agent.DOCSIS-device-class uint32; DOCSIS-device-class DHCP ( ). ( ) . ( ) RFC3256 . CPE (CCCM) . . option agent.link-selection ip-address; link-selection . giaddr ( ) . DHCP (shared-network) . FQDN (THE CLIENT FQDN SUBOPTIONS) Client FQDN draft-ietf-dhc-fqdn- option-00.txt . . - DNS . option fqdn.no-client-update flag; true A . A . option fqdn.server-update flag; A . A ( ). option fqdn.encoded flag; true (ASCII) DNS (DNS wire format) . DNS FQDN false . . fqdn.fqdn . option fqdn.rcode1 flag; option fqdn.rcode2 flag; A PTR DHCP DHCP . DNS . option fqdn.fqdn text; . (FQDN) . '.' . option fqdn.hostname --never set--; option config-option fqdn.fqdn - fqdn.fqdn "foo.example.com." fqdn.hostname "foo" . option fqdn.domainname --never set--; option config-option fqdn.fqdn - fqdn.fqdn "foo.example.com." fqdn.domainname "example.com." . fqdn fqdn . Client FQDN ( ) - Client FQDN . NETWARE/IP (THE NETWARE/IP SUBOPTIONS) RFC2242 Novell NetWare/IP . DHCP nwip . : option nwip.nsq-broadcast flag; true Nearest Server Query NetWare/IP . false . option nwip.preferred-dss ip-address [, ip-address... ]; IP IP Domain SAP/RIP (DSS) . option nwip.nearest-nwip-server ip-address [, ip-address...]; IP IP Nearest NetWare IP . option nwip.autoretries uint8; NetWare/IP DSS . option nwip.autoretry-secs uint8; NetWare/IP DSS . option nwip.nwip-1-1 uint8; true NetWare/IP NetWare/IP . . NetWare/IP . . option nwip.primary-dss ip-address; IP Domain SAP/RIP (DSS) NetWare/IP . NetWare/IP DSS DSS . DHCPV6 (STANDARD DHCPV6 OPTIONS) DHCPv6 DHCPv4 DHCPv6 . DHCPv4 DHCPv6 . <<>> - DHCP . option dhcp6.client-id string; DUID . DUID DHCPv4 - duid : duid-llt duid-en duid-ll (opaque) . option dhcp6.server-id string; DUID . (opaque) . option dhcp6.ia-na string; << >> (ia-na) DHCPv6 . DHCPv6 . option dhcp6.ia-ta string; << >> (ia-ta) . DHCPv6 . option dhcp6.ia-addr string; << >> ia-na ia-ta IA . . option dhcp6.oro uint16 [ , uint16, ... ]; << >> ("ORO") DHCPv6 parameter-request-list . . request dhclient.conf(5) . option dhcp6.preference uint8; preference DHCPv6 <<>> . - IA (bound) IA . . option dhcp6.elapsed-time uint16; elapsed-time DHCPv6 . . option dhcp6.relay-msg string; relay-msg (relay agent) DHCPv6 . . option dhcp6.unicast ip6-address; unicast DHCPv6 ( ) Request Renew Decline Release (unicast) . DHCPv6 (multicast) . RFC 3315 unicast ( ). . unicast . . option dhcp6.status-code status-code [ string ] ; status-code DHCPv6 . . option dhcp6.rapid-commit ; rapid-commit (rapid-commit) . option dhcp6.vendor-opts string; vendor-opts << >> (VSIO) (Enterprise-ID) . . << (VENDOR ENCAPSULATED OPTIONS)>> "vsio". option dhcp6.interface-id string; interface-id . . option dhcp6.reconf-msg dhcpv6-message; reconf-msg Reconfigure (Reconfigure) . DHCPv6 . option dhcp6.reconf-accept ; reconf-accept DHCPv6 . DHCPv6 . option dhcp6.sip-servers-names domain-list; sip-servers-names SIP SIP SIP << >>. IPv6 sip-servers-addresses . option dhcp6.sip-servers-addresses ip6-address [, ip6-address ... ] ; sip-servers-addresses SIP SIP SIP << >>. IPv6 sip-servers-names . option dhcp6.name-servers ip6-address [, ip6-address ... ] ; name-servers DNS . "nameserver" /etc/resolv.conf . option dhcp6.domain-search domain-list; domain-search DNS . "search" /etc/resolv.conf . option dhcp6.ia-pd string; ia-pd (Prefix Delegation) - IPv6 . dhcpd.conf(5) dhclient.conf(5) . option dhcp6.ia-prefix string; ia-prefix ia-pd () . dhcpd.conf(5) dhclient.conf(5) . option dhcp6.nis-servers ip6-address [, ip6-address ... ] ; nis-servers NIS . option dhcp6.nisp-servers ip6-address [, ip6-address ... ] ; nisp-servers +NIS . option nis-domain-name domain-list; nis-domain-name NIS nis-servers . option dhcp6.nis-domain-name domain-name; dhcp6.nis-domain-name NIS dhcp6.nis-servers . option nisp-domain-name domain-list; nisp-domain-name +NIS nisp-servers . option dhcp6.nisp-domain-name domain-name; dhcp6.nisp-domain-name +NIS dhcp6.nisp-servers . option dhcp6.sntp-servers ip6-address [, ip6-address ... ] ; sntp-servers SNTP . option dhcp6.info-refresh-time uint32; info-refresh-time DHCPv6 Information-request . . option dhcp6.bcms-server-d domain-list; bcms-server-d BCMS ( - Broadcast and Multicast Control Services) . option dhcp6.bcms-server-a ip6-address [, ip6-address ... ] ; bcms-server-a IPv6 BCMS ( - Broadcast and Multicast Control Services) . option dhcp6.geoconf-civic string; geoconf (geoconf civic structure). RFC 4776 . option dhcp6.remote-id string; remote-id ( ) ( ) . ( VSIO) (opaque field) . option dhcp6.subscriber-id string; subscriber-id (opaque field) . / . option dhcp6.fqdn string; fqdn (FQDN) DNS . Client FQDN ( FQDN DHCPv4 DHCPv6 <> ). option dhcp6.pana-agent ip6-address [, ip6-address ... ] ; IPv6 PAA . . RFC 5192 . option dhcp6.new-posix-timezone text; TZ . RFC 4833 . option dhcp6.new-tzdb-timezone text; TZ . RFC 4833 . option dhcp6.ero uint16 [, uint16 ... ] ; . RFC 4994 . option dhcp6.lq-query string; lq-query (lease query) . option dhcp6.client-data string; client-data (lease query) . option dhcp6.clt-time uint32; clt-time (lease query) . option dhcp6.lq-relay-data ip6-address string; lq-relay-data (lease query) . option dhcp6.lq-client-link ip6-address [, ip6-address ... ] ; lq-client-link (lease query) . option dhcp6.v6-lost domain-name; LoST . RFC 5223 . option dhcp6.capwap-ac-v6 ip6-address [, ip6-address ... ] ; IPv6 CAPWAP AC WTP . . RFC 5417 . option dhcp6.relay-id string; DUID . RFC 5460 . option dhcp6.v6-access-domain domain-name; LIS (LIS Discovery). RFC 5986 . option dhcp6.sip-ua-cs-list domain-list; - SIP (SIP User Agent Configuration Service Domains). RFC 6011 . option dhcp6.bootfile-url text; (URL) (). RFC 5970 . option dhcp6.bootfile-param string; . RFC 5970 . RFC 5970 . option dhcp6.client-arch-type uint16 [, uint16 ... ] ; . RFC 5970 . option dhcp6.nii uint8 uint8 uint8; (client network interface identifier) UNDI . : (type) (major) (minor). RFC 5970 . option dhcp6.aftr-name domain-name; AFTR. RFC 6334 . option dhcp6.erp-local-domain-name domain-name; ERP. RFC 6440 . option dhcp6.rdnss-selection ip6-address uint8 domain-name; RDNSS IPv6 RDNSS RDNSS . RFC 6731 . option dhcp6.client-linklayer-addr string; (link-layer) . . RFC 6939 . option dhcp6.link-address ip6-address; IPv6 . RFC 6977 . option dhcp6.solmax-rt uint32; SOL_MAX_RT. . RFC 7083 . option dhcp6.inf-max-rt uint32; INF_MAX_RT. . RFC 7083 . DHCPV6 (ACCESSING DHCPV6 RELAY OPTIONS) v6relay (relay-number, option) . relay-number option . DHCPv6 ( ) . RFC (hop) . relay-number 0 (no-op) . 1 2 . . class : match if v6relay(1, option dhcp6.subscriber-id) = "client_1"; (DEFINING NEW OPTIONS) DHCP Internet Systems Consortium . DHCP . . DHCP . . - "host-name" DHCP host-name . . "local-host-name" DHCP "local" . . 224 254 DHCP ('site- local') ( / ) . RFC3942 site-local 128 224 . 128 . . site-local rfc3942 . . ISC DHCP (integers) (booleans) (strings) IP . : option new-name code new-code = definition ; new-name new-code . definition . : BOOLEAN option new-name code new-code = boolean ; boolean on off ( true false) . boolean : option use-zephyr code 180 = boolean; option use-zephyr on; INTEGER option new-name code new-code = sign integer width ; sign unsigned signed . width 8 16 32 . sql-connection- max : option sql-connection-max code 192 = unsigned integer 16; option sql-connection-max 1536; IP-ADDRESS option new-name code new-code = ip-address ; IP (dotted quad) . ip-address : option sql-server-address code 193 = ip-address; option sql-server-address sql.example.com; IP6-ADDRESS option new-name code new-code = ip6-address ; IPv6 IPv6 . ip6-address : option dhcp6.some-server code 1234 = array of ip6-address; option dhcp6.some-server 3ffe:bbbb:aaaa:aaaa::1, 3ffe:bbbb:aaaa:aaaa::2; TEXT option new-name code new-code = text ; text ASCII . : option sql-default-connection-name code 194 = text; option sql-default-connection-name "PRODZA"; DATA STRING option new-name code new-code = string ; (data string) text (:) 0 FF . : option sql-identification-token code 195 = string; option sql-identification-token 17:23:19:a6:42:ea:99:7c:22; DOMAIN-LIST option new-name code new-code = domain-list [compressed] ; domain-list RFC1035 ( "DNS Format") (root labels) . compressed ( ) . compressed . compressed ( ) . . domain-list dhclient-script(8) (escape) DNS : . /etc/resolv.conf . ENCAPSULATION option new-name code new-code = encapsulate identifier ; encapsulate identifier . DHCP vendor- encapsulated-options netware-suboptions relay-agent-information . option space local; option local.demo code 1 = text; option local-encapsulation code 197 = encapsulate local; option local.demo "demo"; ARRAYS text data string . : option kerberos-servers code 200 = array of ip-address; option kerberos-servers 10.20.10.1, 10.20.11.1; RECORDS (record type) . : option contrived-001 code 201 = { boolean, integer 32, text }; option contrived-001 on 1772 "contrivance"; : option new-static-routes code 201 = array of { ip-address, ip-address, ip-address, integer 8 }; option static-routes 10.0.0.0 255.255.255.0 net-0-rtr.example.com 1, 10.0.1.0 255.255.255.0 net-1-rtr.example.com 1, 10.2.0.0 255.255.224.0 net-2-0-rtr.example.com 3; (VENDOR ENCAPSULATED OPTIONS) DHCP vendor-encapsulated-options DHCP . Vendor Identified Vendor Sub Options ( <>) DHCPv6 Vendor-specific Information Option ( <>) . DHCP. VIVSO VSIO (Enterprise-ID) IANA . . . (:) . Vendor Specific Information Option DHCPv4 RFC2132 Vendor Identified Vendor Sub Options DHCPv4 RFC3925 Vendor-specific Information Option DHCPv6 RFC3315 . : option vendor-encapsulated-options 2:4: AC:11:41:1: 3:12: 73:75:6e:64:68:63:70:2d:73:65:72:76:65:72:31:37:2d:31: 4:12: 2f:65:78:70:6f:72:74:2f:72:6f:6f:74:2f:69:38:36:70:63; option vivso 00:00:09:bf:0E: 01:0c: 48:65:6c:6c:6f:20:77:6f:72:6c:64:21; option dhcp6.vendor-opts 00:00:09:bf: 00:01:00:0c: 48:65:6c:6c:6f:20:77:6f:72:6c:64:21; DHCP . : . option space : option space name [ [ code width number ] [ length width number ] [ hash size number ] ] ; code width length width hash size ( ) ( DHCPv4 DHCPv6 ). DHCP . . . . DHCPv4 DHCPv6 . (Vendor-specific Information Option) DHCPv6 ! code width . . . . ISC DHCP ( 3.0.* ) . . : option space SUNW code width 1 length width 1 hash size 3; option SUNW.server-address code 2 = ip-address; option SUNW.server-name code 3 = text; option SUNW.root-path code 4 = text; option space ISC code width 1 length width 1 hash size 3; option ISC.sample code 1 = text; option vendor.ISC code 2495 = encapsulate vivso-sample; option vendor-class.ISC code 2495 = text; option ISC.sample "configuration text here"; option vendor-class.ISC "vendor class here"; option space docsis code width 2 length width 2 hash size 17; option docsis.tftp-servers code 32 = array of ip6-address; option docsis.cablelabs-configuration-file code 33 = text; option docsis.cablelabs-syslog-servers code 34 = array of ip6-address; option docsis.device-id code 36 = string; option docsis.time-servers code 37 = array of ip6-address; option docsis.time-offset code 38 = signed integer 32; option vsio.docsis code 4491 = encapsulate docsis; (Scopes) . () . vendor- class-identifier : class "vendor-classes" { match option vendor-class-identifier; } subclass "vendor-classes" "SUNW.Ultra-5_10" { vendor-option-space SUNW; option SUNW.root-path "/export/root/sparc"; } subclass "vendor-classes" "SUNW.i86pc" { vendor-option-space SUNW; option SUNW.root-path "/export/root/i86pc"; } option SUNW.server-address 172.17.65.1; option SUNW.server-name "sundhcp-server17-1"; option vivso-sample.sample "Hello world!"; option docsis.tftp-servers ::1; (Scoping) . vendor-option-space DHCP SUNW vendor-encapsulated-options DHCPv4 . VIVSO DHCPv4 VSIO DHCPv6 ( ) . (SEE ALSO) dhcpd.conf(5), dhcpd.leases(5), dhclient.conf(5), dhcp-eval(5), dhcpd(8), dhclient(8), RFC2132, RFC2131, RFC3046, RFC3315. (AUTHORS) Internet Systems Consortium https://www.isc.org . dhcp-options(5)