| OPENSSL-FORMAT-OPTIONS(1ssl) | OpenSSL | OPENSSL-FORMAT-OPTIONS(1ssl) |
نام (NAME)
openssl-format-options - گزینههای قالببندی OpenSSL
خلاصه دستور (SYNOPSIS)
openssl command [ options ... ] [ parameters ... ]
توضیحات (DESCRIPTION)
چندین دستور OpenSSL میتوانند ورودی را در انواع گوناگونی از قالبها دریافت کرده یا خروجی را در قالبهای متنوعی تولید کنند.
از OpenSSL 3.0 به بعد، کلیدها، تکگواهیها و CRLها میتوانند از فایلهایی با هر یک از قالبهای DER، PEM یا P12 خوانده شوند. دیگر نیازی به مشخص کردن قالب ورودی آنها نیست و دستورهای openssl به طور خودکار تمامی قالبهای ممکن را امتحان خواهند کرد. با این حال، اگر قالب ورودی DER یا PEM مشخص شود، اجبار شده و اعمال خواهد شد.
به منظور دسترسی به یک کلید از طریق موتور (engine)، میتوان از قالب ورودی ENGINE استفاده کرد؛ همچنین میتوان شناسه کلید را در آرگومان <uri> مربوط به گزینه کلید، با پیشوند "org.openssl.engine:" قرار داد. برای نمونهای از کاربرد مورد دوم، به بخش «Engine Options» در openssl(1) مراجعه کنید.
گزینهها (OPTIONS)
گزینههای قالب (Format Options)
گزینهها برای مشخص کردن قالب به شرح زیر هستند. برای مشاهده اینکه کدام گزینهها پذیرفته میشوند، به صفحه راهنمای هر دستور به صورت جداگانه مراجعه کنید.
- -inform format, -outform format
- قالب جریانهای ورودی یا خروجی.
- -keyform format
- قالب یک منبع ورودی کلید خصوصی.
- -CRLform format
- قالب یک منبع ورودی CRL.
آرگومانهای گزینههای قالب (Format Option Arguments)
آرگومانهای ممکن برای قالب در ادامه شرح داده شدهاند. هر دو حالت حروف بزرگ و کوچک پذیرفته میشوند.
فهرست آرگومانهای مجاز قالب و مقدار پیشفرض، در مستندات هر دستور شرح داده شده است.
- DER
- یک قالب باینری، که بر اساس قواعد کدگذاری متمایز (Distinguished Encoding Rules یا DER) از زبان داده ASN.1 کدگذاری یا تجزیه (parse) شده است.
- ENGINE
- برای مشخص کردن اینکه دادههای رمزنگاری در یک engine متعلق به OpenSSL قرار دارند استفاده میشود. یک موتور باید از قبل پیکربندی شده باشد یا با استفاده از گزینه -engine مشخص شود. یک گذرواژه یا PIN ممکن است با استفاده از گزینه -passin به موتور ارائه گردد.
- P12
- یک فایل با کدگذاری DER حاوی یک شیء PKCS#12. ممکن است برای بازیابی کلید خصوصی یا گواهی، نیاز به ارائه گذرواژه رمزگشایی باشد.
- PEM
- یک قالب
متنی که در IETF
RFC 1421 و IETF RFC 7468 تعریف
شده است. به
طور خلاصه،
این قالب
بلوکی از
کدگذاری Base64
(تعریفشده
در IETF RFC 4648) است که
خطوط مشخصی
برای نشان
دادن شروع و
پایان آن
استفاده
میشوند:
Text before the BEGIN line is ignored. -----BEGIN object-type----- OT43gQKBgQC/2OHZoko6iRlNOAQ/tMVFNq7fL81GivoQ9F1U0Qr+DH3ZfaH8eIkX xT0ToMPJUzWAn8pZv0snA0um6SIgvkCuxO84OkANCVbttzXImIsL7pFzfcwV/ERK UM6j0ZuSMFOCr/lGPAoOQU0fskidGEHi1/kW+suSr28TqsyYZpwBDQ== -----END object-type----- Text after the END line is also ignored
مقدار object-type باید با نوع شیء مورد انتظار همخوانی داشته باشد. به عنوان مثال، عبارت "BEGIN X509 CERTIFICATE" اگر دستور تلاش کند یک کلید خصوصی را بخواند تطابق نخواهد داشت. انواع پشتیبانیشده شامل موارد زیر هستند:
ANY PRIVATE KEY CERTIFICATE CERTIFICATE REQUEST CMS DH PARAMETERS DSA PARAMETERS DSA PUBLIC KEY EC PARAMETERS EC PRIVATE KEY ECDSA PUBLIC KEY ENCRYPTED PRIVATE KEY PARAMETERS PKCS #7 SIGNED DATA PKCS7 PRIVATE KEY PUBLIC KEY RSA PRIVATE KEY SSL SESSION PARAMETERS TRUSTED CERTIFICATE X509 CRL X9.42 DH PARAMETERS
انواع قدیمی object-type'ها نیز جهت سازگاری با نسخههای پیشین پشتیبانی میشوند:
DSA PRIVATE KEY NEW CERTIFICATE REQUEST RSA PUBLIC KEY X509 CERTIFICATE
- SMIME
- یک شیء S/MIME همانطور که در IETF RFC 8551 شرح داده شده است. نسخههای قبلی با نام CMS شناخته میشدند و سازگار هستند. توجه داشته باشید که فرآیند تجزیه ساده است و ممکن است در پردازش برخی دادههای معتبر ناموفق باشد.
همچنین ببینید (SEE ALSO)
حق نشر (COPYRIGHT)
حق نشر ۲۰۰۰-۲۰۲۶ نویسندگان پروژه OpenSSL. کلیه حقوق محفوظ است.
تحت مجوز آپاچی نسخه ۲.۰ (Apache License 2.0) منتشر شده است. شما نمیتوانید از این فایل استفاده کنید مگر با رعایت مجوز. میتوانید یک نسخه از مجوز را در فایل LICENSE در توزیع منبع یا در https://www.openssl.org/source/license.html دریافت کنید.
| 2026-08-25 | 3.6.4 |