OPENSSL-FORMAT-OPTIONS(1ssl) OpenSSL OPENSSL-FORMAT-OPTIONS(1ssl) (NAME) openssl-format-options - OpenSSL (SYNOPSIS) openssl command [ options ... ] [ parameters ... ] (DESCRIPTION) OpenSSL . OpenSSL 3.0 CRL DER PEM P12 . openssl . DER PEM . (engine) ENGINE "org.openssl.engine:" . <> openssl(1) . (OPTIONS) (Format Options) . . -inform format, -outform format . -keyform format . -CRLform format CRL. (Format Option Arguments) . . . DER (Distinguished Encoding Rules DER) ASN.1 (parse) . ENGINE engine OpenSSL . -engine . PIN -passin . P12 DER PKCS#12. . PEM IETF RFC 1421 IETF RFC 7468 . Base64 ( IETF RFC 4648) : Text before the BEGIN line is ignored. -----BEGIN object-type----- OT43gQKBgQC/2OHZoko6iRlNOAQ/tMVFNq7fL81GivoQ9F1U0Qr+DH3ZfaH8eIkX xT0ToMPJUzWAn8pZv0snA0um6SIgvkCuxO84OkANCVbttzXImIsL7pFzfcwV/ERK UM6j0ZuSMFOCr/lGPAoOQU0fskidGEHi1/kW+suSr28TqsyYZpwBDQ== -----END object-type----- Text after the END line is also ignored object-type . "BEGIN X509 CERTIFICATE" . : ANY PRIVATE KEY CERTIFICATE CERTIFICATE REQUEST CMS DH PARAMETERS DSA PARAMETERS DSA PUBLIC KEY EC PARAMETERS EC PRIVATE KEY ECDSA PUBLIC KEY ENCRYPTED PRIVATE KEY PARAMETERS PKCS #7 SIGNED DATA PKCS7 PRIVATE KEY PUBLIC KEY RSA PRIVATE KEY SSL SESSION PARAMETERS TRUSTED CERTIFICATE X509 CRL X9.42 DH PARAMETERS object-type' : DSA PRIVATE KEY NEW CERTIFICATE REQUEST RSA PUBLIC KEY X509 CERTIFICATE SMIME S/MIME IETF RFC 8551 . CMS . . (SEE ALSO) openssl(1) (COPYRIGHT) - OpenSSL. . . (Apache License 2.0) . . LICENSE . 3.6.4 2026-08-25 OPENSSL-FORMAT-OPTIONS(1ssl)