.\" -*- mode: troff; coding: utf-8 -*- .\" Automatically generated by Pod::Man v6.0.2 (Pod::Simple 3.45) .\" .\" Standard preamble: .\" ======================================================================== .de Sp \" Vertical space (when we can't use .PP) .if t .sp .5v .if n .sp .. .de Vb \" Begin verbatim text .ft CW .nf .ne \\$1 .. .de Ve \" End verbatim text .ft R .fi .. .\" \*(C` and \*(C' are quotes in nroff, nothing in troff, for use with C<>. .ie n \{\ . ds C` "" . ds C' "" 'br\} .el\{\ . ds C` . ds C' 'br\} .\" .\" Escape single quotes in literal strings from groff's Unicode transform. .ie \n(.g .ds Aq \(aq .el .ds Aq ' .\" .\" If the F register is >0, we'll generate index entries on stderr for .\" titles (.TH), headers (.SH), subsections (.SS), items (.Ip), and index .\" entries marked with X<> in POD. Of course, you'll have to process the .\" output yourself in some meaningful fashion. .\" .\" Avoid warning from groff about undefined register 'F'. .de IX .. .nr rF 0 .if \n(.g .if rF .nr rF 1 .if (\n(rF:(\n(.g==0)) \{\ . if \nF \{\ . de IX . tm Index:\\$1\t\\n%\t"\\$2" .. . if !\nF==2 \{\ . nr % 0 . nr F 2 . \} . \} .\} .rr rF .\" .\" Required to disable full justification in groff 1.23.0. .if n .ds AD l .\" ======================================================================== .\" .IX Title "OPENSSL-FORMAT-OPTIONS 1ssl" .TH OPENSSL-FORMAT-OPTIONS 1ssl 2026-08-25 3.6.4 OpenSSL .\" For nroff, turn off justification. Always turn off hyphenation; it makes .\" way too many mistakes in technical documents. .if n .ad l .nh .SH "نام (NAME)" openssl\-format\-options \- گزینه‌های قالب‌بندی OpenSSL .SH "خلاصه دستور (SYNOPSIS)" .IX Header "SYNOPSIS" \&\fBopenssl\fR \&\fIcommand\fR [ \fIoptions\fR ... ] [ \fIparameters\fR ... ] .SH "توضیحات (DESCRIPTION)" .IX Header "DESCRIPTION" چندین دستور OpenSSL می‌توانند ورودی را در انواع گوناگونی از قالب‌ها دریافت کرده یا خروجی را در قالب‌های متنوعی تولید کنند. .PP از OpenSSL 3.0 به بعد، کلیدها، تک‌گواهی‌ها و CRLها می‌توانند از فایل‌هایی با هر یک از قالب‌های \fBDER\fR، \fBPEM\fR یا \fBP12\fR خوانده شوند. دیگر نیازی به مشخص کردن قالب ورودی آن‌ها نیست و دستورهای openssl به طور خودکار تمامی قالب‌های ممکن را امتحان خواهند کرد. با این حال، اگر قالب ورودی \fBDER\fR یا \fBPEM\fR مشخص شود، اجبار شده و اعمال خواهد شد. .PP به منظور دسترسی به یک کلید از طریق موتور (engine)، می‌توان از قالب ورودی \fBENGINE\fR استفاده کرد؛ همچنین می‌توان شناسه کلید را در آرگومان مربوط به گزینه کلید، با پیشوند \f(CW\*(C`org.openssl.engine:\*(C'\fR قرار داد. برای نمونه‌ای از کاربرد مورد دوم، به بخش «Engine Options» در \fBopenssl\fR\|(1) مراجعه کنید. .SH "گزینه‌ها (OPTIONS)" .IX Header "OPTIONS" .SS "گزینه‌های قالب (Format Options)" .IX Subsection "Format Options" گزینه‌ها برای مشخص کردن قالب به شرح زیر هستند. برای مشاهده اینکه کدام گزینه‌ها پذیرفته می‌شوند، به صفحه راهنمای هر دستور به صورت جداگانه مراجعه کنید. .IP "\fB\-inform\fR \fIformat\fR, \fB\-outform\fR \fIformat\fR" 4 .IX Item "-inform format, -outform format" قالب جریان‌های ورودی یا خروجی. .IP "\fB\-keyform\fR \fIformat\fR" 4 .IX Item "-keyform format" قالب یک منبع ورودی کلید خصوصی. .IP "\fB\-CRLform\fR \fIformat\fR" 4 .IX Item "-CRLform format" قالب یک منبع ورودی CRL. .SS "آرگومان‌های گزینه‌های قالب (Format Option Arguments)" .IX Subsection "Format Option Arguments" آرگومان‌های ممکن برای قالب در ادامه شرح داده شده‌اند. هر دو حالت حروف بزرگ و کوچک پذیرفته می‌شوند. .PP فهرست آرگومان‌های مجاز قالب و مقدار پیش‌فرض، در مستندات هر دستور شرح داده شده است. .IP \fBDER\fR 4 .IX Item "DER" یک قالب باینری، که بر اساس قواعد کدگذاری متمایز (Distinguished Encoding Rules یا DER) از زبان داده ASN.1 کدگذاری یا تجزیه (parse) شده است. .IP \fBENGINE\fR 4 .IX Item "ENGINE" برای مشخص کردن اینکه داده‌های رمزنگاری در یک \fBengine\fR متعلق به OpenSSL قرار دارند استفاده می‌شود. یک موتور باید از قبل پیکربندی شده باشد یا با استفاده از گزینه \fB\-engine\fR مشخص شود. یک گذرواژه یا PIN ممکن است با استفاده از گزینه \fB\-passin\fR به موتور ارائه گردد. .IP \fBP12\fR 4 .IX Item "P12" یک فایل با کدگذاری DER حاوی یک شیء PKCS#12. ممکن است برای بازیابی کلید خصوصی یا گواهی، نیاز به ارائه گذرواژه رمزگشایی باشد. .IP \fBPEM\fR 4 .IX Item "PEM" یک قالب متنی که در IETF RFC 1421 و IETF RFC 7468 تعریف شده است. به طور خلاصه، این قالب بلوکی از کدگذاری Base64 (تعریف‌شده در IETF RFC 4648) است که خطوط مشخصی برای نشان دادن شروع و پایان آن استفاده می‌شوند: .Sp .Vb 7 \& Text before the BEGIN line is ignored. \& \-\-\-\-\-BEGIN object\-type\-\-\-\-\- \& OT43gQKBgQC/2OHZoko6iRlNOAQ/tMVFNq7fL81GivoQ9F1U0Qr+DH3ZfaH8eIkX \& xT0ToMPJUzWAn8pZv0snA0um6SIgvkCuxO84OkANCVbttzXImIsL7pFzfcwV/ERK \& UM6j0ZuSMFOCr/lGPAoOQU0fskidGEHi1/kW+suSr28TqsyYZpwBDQ== \& \-\-\-\-\-END object\-type\-\-\-\-\- \& Text after the END line is also ignored .Ve .Sp مقدار \fIobject\-type\fR باید با نوع شیء مورد انتظار همخوانی داشته باشد. به عنوان مثال، عبارت \f(CW\*(C`BEGIN X509 CERTIFICATE\*(C'\fR اگر دستور تلاش کند یک کلید خصوصی را بخواند تطابق نخواهد داشت. انواع پشتیبانی‌شده شامل موارد زیر هستند: .Sp .Vb 10 \& ANY PRIVATE KEY \& CERTIFICATE \& CERTIFICATE REQUEST \& CMS \& DH PARAMETERS \& DSA PARAMETERS \& DSA PUBLIC KEY \& EC PARAMETERS \& EC PRIVATE KEY \& ECDSA PUBLIC KEY \& ENCRYPTED PRIVATE KEY \& PARAMETERS \& PKCS #7 SIGNED DATA \& PKCS7 \& PRIVATE KEY \& PUBLIC KEY \& RSA PRIVATE KEY \& SSL SESSION PARAMETERS \& TRUSTED CERTIFICATE \& X509 CRL \& X9.42 DH PARAMETERS .Ve .Sp انواع قدیمی \fIobject\-type\fR\*(Aqها نیز جهت سازگاری با نسخه‌های پیشین پشتیبانی می‌شوند: .Sp .Vb 4 \& DSA PRIVATE KEY \& NEW CERTIFICATE REQUEST \& RSA PUBLIC KEY \& X509 CERTIFICATE .Ve .IP \fBSMIME\fR 4 .IX Item "SMIME" یک شیء S/MIME همان‌طور که در IETF RFC 8551 شرح داده شده است. نسخه‌های قبلی با نام CMS شناخته می‌شدند و سازگار هستند. توجه داشته باشید که فرآیند تجزیه ساده است و ممکن است در پردازش برخی داده‌های معتبر ناموفق باشد. .SH "همچنین ببینید (SEE ALSO)" .IX Header "SEE ALSO" \&\fBopenssl\fR\|(1) .SH "حق نشر (COPYRIGHT)" .IX Header "COPYRIGHT" حق نشر ۲۰۰۰-۲۰۲۶ نویسندگان پروژه OpenSSL. کلیه حقوق محفوظ است. .PP تحت مجوز آپاچی نسخه ۲.۰ (Apache License 2.0) منتشر شده است. شما نمی‌توانید از این فایل استفاده کنید مگر با رعایت مجوز. می‌توانید یک نسخه از مجوز را در فایل LICENSE در توزیع منبع یا در دریافت کنید.