| CLEANUP(8) | راهنمای Postfix | CLEANUP(8) |
نام (NAME)
cleanup - متعارفسازی و قرار دادن پیام Postfix در صف
خلاصه دستور (SYNOPSIS)
cleanup [گزینههای عمومی دیمن Postfix]
توضیحات (DESCRIPTION)
دیمن cleanup(8) نامههای ورودی را پردازش کرده، آنها را در صف نامه incoming درج میکند و مدیر صف را از ورودشان باخبر میسازد.
دیمن cleanup(8) تبدیلات زیر را انجام میدهد:
- درج
سرآیندهای
مفقود پیام:
(Resent-) From:، To:،
Message-Id: و Date:.
این قابلیت با تنظیمات پارامترهای local_header_rewrite_clients و always_add_missing_headers فعال میشود. - تبدیل
نشانیهای
پاکت و
سرآیند به
قالب
استاندارد
user@fully-qualified-domain که
مورد
انتظار
سایر
برنامههای
Postfix است. این
وظیفه به
دیمن trivial-rewrite(8)
وابسته است.
تبدیل سرآیند با تنظیم پارامتر local_header_rewrite_clients فعال میشود. - حذف
نشانیهای
تکراری
گیرنده در
پاکت نامه.
این قابلیت با تنظیم پارامتر duplicate_filter_limit فعال میگردد. - حذف
سرآیندهای
پیام: Bcc،
Content-Length، Resent-Bcc،
Return-Path.
این کار با تنظیم پارامتر message_drop_headers فعال میشود. - بهصورت
اختیاری،
بازنویسی
تمام
نشانیهای
پاکت و
سرآیند
مطابق با
نگاشتهای
مشخصشده
در
جدولهای
جستجوی canonical(5).
تبدیل سرآیند با تنظیم پارامتر local_header_rewrite_clients فعال میشود. - بهصورت
اختیاری،
نقابگذاری
نشانی
فرستنده در
پاکت و
نشانیهای
سرآیند
پیام (یعنی
حذف
اطلاعات
میزبان یا
دامنه ذیل
تمامی
دامنههای
فهرستشده
در پارامتر
masquerade_domains، به جز
نامهای
کاربری
فهرستشده
در masquerade_exceptions).
بهطور
پیشفرض،
نقابگذاری
نشانی بر
گیرندگان
پاکت
تأثیری
نمیگذارد.
تبدیل سرآیند با تنظیم پارامتر local_header_rewrite_clients فعال میشود. - بهصورت اختیاری، بسط گیرندگان پاکت بر اساس اطلاعات یافتشده در جدولهای جستجوی virtual_alias_maps.
دیمن cleanup(8) بررسیهای سلامت و صحت محتوای هر پیام را انجام میدهد. هنگامی که مشکلی بیابد، به طور پیشفرض وضعیت عیبیابی را به کلاینت سرویس cleanup بازمیگرداند و مدیریت مشکل را به خود کلاینت واگذار مینماید. همچنین کلاینت میتواند درخواست کند که دیمن cleanup(8) در صورت بروز مشکل، پیام را به فرستنده پس بزند (bounce کند).
استانداردها (STANDARDS)
RFC 822 (پیامهای متنی اینترنت ARPA) RFC 2045 (فرمت MIME برای بدنه پیامهای اینترنتی) RFC 2046 (انواع رسانه MIME) RFC 2822 (قالب پیام اینترنتی) RFC 3463 (کدهای وضعیت پیشرفته) RFC 3464 (اعلانهای وضعیت تحویل) RFC 5322 (قالب پیام اینترنتی) RFC 8689 (سرآیند پیام TLS-Required)
عیبیابی (DIAGNOSTICS)
مشکلات و تراکنشها در syslogd(8) یا postlogd(8) ثبت میشوند.
اشکالات (BUGS)
قوانین بازنویسی مبتنی بر جدول، بیان ساختارهای شرطی if then else و سایر روابط منطقی را دشوار میسازند.
پارامترهای پیکربندی (CONFIGURATION PARAMETERS)
تغییرات main.cf به صورت خودکار اعمال میشوند، زیرا فرآیندهای cleanup(8) تنها برای مدت محدودی اجرا میشوند. برای تسریع اعمال تغییرات از دستور "postfix reload" استفاده کنید.
متن زیر تنها خلاصهای از پارامترها را ارائه میدهد. برای جزئیات بیشتر شامل مثالها به postconf(5) مراجعه کنید.
کنترلهای سازگاری (COMPATIBILITY CONTROLS)
- undisclosed_recipients_header (خروجی 'postconf -d' را ببینید)
- سرآیند پیامی که سرور cleanup(8) در Postfix هنگام نبود سرآیند To: یا Cc: در پیام درج میکند.
تنها در Postfix نسخه 2.1 موجود است:
- enable_errors_to (no)
- گزارش خطاهای تحویل نامه به نشانی مشخصشده با سرآیند پیامی غیراستاندارد Errors-To:، به جای نشانی فرستنده در پاکت (این ویژگی در Postfix نسخه 2.2 حذف شده است، در نسخه 2.1 به صورت پیشفرض غیرفعال است، و در نسخههای قدیمیتر Postfix همیشه فعال بود).
موجود در Postfix نسخه 2.6 و بالاتر:
- always_add_missing_headers (no)
- افزودن همیشگی سرآیندهای (Resent-) From:، To:، Date: یا Message-ID: در صورت عدم وجود آنها.
موجود در Postfix نسخه 2.9 و بالاتر:
- enable_long_queue_ids (no)
- فعالسازی شناسههای صف طولانی و غیرتکراری (نام فایلهای صف).
کنترلهای قالببندی سرآیند (HEADER FORMATTING CONTROLS)
موجود در Postfix نسخه 3.0 و بالاتر:
- message_drop_headers (bcc, content-length, resent-bcc, return-path)
- نامهای سرآیندهای پیامی که دیمن cleanup(8) پس از اعمال header_checks(5) و پیش از فراخوانی برنامههای Milter حذف خواهد کرد.
موجود در Postfix نسخه 3.3 و بالاتر:
- header_from_format (standard)
- قالب سرآیند From: تولیدشده توسط Postfix.
موجود در Postfix نسخه 3.10 و بالاتر:
- full_name_encoding_charset (utf-8)
- نام مجموعه کاراکترها (که "charset" نیز نامیده میشود) که Postfix هنگام تولید خودکار نام کامل کدگذاریشده بر اساس RFC 2047 در خروجی قرار میدهد.
- non_empty_end_of_header_action (fix_quietly)
- نحوه پردازش پیام توسط دیمن cleanup(8) زمانی که سرآیند اصلی پیام با یک خط غیرخالی خاتمه مییابد.
کنترلهای فیلتر محتوای داخلی (BUILT-IN CONTENT FILTERING CONTROLS)
فیلتر محتوای داخلی Postfix با هدف متوقف ساختن هجوم کرمها یا ویروسها طراحی شده است. این یک فیلتر محتوای عمومی نیست.
- body_checks (empty)
- جدولهای جستجوی اختیاری برای بازرسی محتوا همانگونه که در صفحه راهنمای body_checks(5) مشخص شده است.
- header_checks (empty)
- جدولهای جستجوی اختیاری برای بازرسی محتوای سرآیندهای اصلی غیر MIME پیام، طبق صفحه راهنمای header_checks(5).
موجود در Postfix نسخه 2.0 و بالاتر:
- body_checks_size_limit (51200)
- میزان متنی از یک بخش بدنه پیام (یا پیوست، در صورتی که ترجیح میدهید از این اصطلاح استفاده کنید) که مشمول بازرسی body_checks قرار میگیرد.
- mime_header_checks ($header_checks)
- جدولهای جستجوی اختیاری برای بازرسی محتوای سرآیندهای مرتبط با MIME پیام، همانطور که در صفحه راهنمای header_checks(5) شرح داده شده است.
- nested_header_checks ($header_checks)
- جدولهای جستجوی اختیاری برای بازرسی محتوای سرآیندهای غیر MIME در پیامهای پیوستشده، طبق توضیحات صفحه راهنمای header_checks(5).
موجود در Postfix نسخه 2.3 و بالاتر:
- message_reject_characters (empty)
- مجموعه کاراکترهایی که Postfix در محتوای پیام رد خواهد کرد.
- message_strip_characters (empty)
- مجموعه کاراکترهایی که Postfix از محتوای پیام حذف خواهد کرد.
موجود در Postfix نسخههای 3.9، 3.8.5، 3.7.10، 3.6.14، 3.5.24 و بالاتر:
- cleanup_replace_stray_cr_lf (yes)
- جایگزینی هر کاراکتر تک و سرگردان <CR> یا <LF> در محتوای پیام با یک کاراکتر فاصله (space)، به منظور جلوگیری از قاچاق SMTP خروجی، و مستقلسازی ارزیابی امضاهای DKIM یا سایر امضاهای اضافهشده توسط Postfix از نحوه مدیریت چنین کاراکترهایی توسط سرور ایمیل راه دور.
کنترلهای میلتر قبل از صف (BEFORE QUEUE MILTER CONTROLS)
از نسخه 2.3، Postfix از پروتکل Milter (فیلتر ایمیل) Sendmail نسخه 8 پشتیبانی میکند. هنگامی که نامه از طریق سرور smtpd(8) دریافت نشود، سرور cleanup(8) تا حد امکان رویدادهای SMTP را شبیهسازی خواهد کرد. برای جزئیات به سند MILTER_README مراجعه کنید.
- non_smtpd_milters (empty)
- فهرستی از برنامههای Milter (فیلتر ایمیل) برای نامههای جدیدی که از طریق سرور smtpd(8) در Postfix دریافت نمیشوند.
- milter_protocol (6)
- نسخه پروتکل فیلتر ایمیل و افزونههای اختیاری پروتکل برای ارتباط با برنامه Milter؛ قبل از Postfix 2.6 پروتکل پیشفرض 2 بود.
- milter_default_action (Postfix >= 3.11: shutdown; Postfix < 3.11: tempfail)
- اقدام پیشفرض در زمانی که پاسخ Milter (فیلتر ایمیل) در دسترس نباشد (برای نمونه، پیکربندی نادرست Postfix یا خرابی Milter).
- milter_macro_daemon_name ($myhostname)
- مقدار ماکروی {daemon_name} برای برنامههای Milter (فیلتر ایمیل).
- milter_macro_v ($mail_name $mail_version)
- مقدار ماکروی {v} برای برنامههای Milter (فیلتر ایمیل).
- milter_connect_timeout (30s)
- مهلت زمانی برای اتصال به یک برنامه Milter (فیلتر ایمیل)، و برای مذاکره بر سر گزینههای پروتکل.
- milter_command_timeout (30s)
- مهلت زمانی برای ارسال یک دستور SMTP به برنامه Milter (فیلتر ایمیل)، و دریافت پاسخ.
- milter_content_timeout (300s)
- مهلت زمانی برای ارسال محتوای پیام به برنامه Milter (فیلتر ایمیل)، و دریافت پاسخ.
- milter_connect_macros (خروجی 'postconf -d' را ببینید)
- ماکروهایی که پس از تکمیل یک اتصال SMTP به برنامههای Milter (فیلتر ایمیل) ارسال میشوند.
- milter_helo_macros (خروجی 'postconf -d' را ببینید)
- ماکروهایی که پس از دستور SMTP HELO یا EHLO به برنامههای Milter (فیلتر ایمیل) ارسال میشوند.
- milter_mail_macros (خروجی 'postconf -d' را ببینید)
- ماکروهایی که پس از دستور SMTP MAIL FROM به برنامههای Milter (فیلتر ایمیل) ارسال میشوند.
- milter_rcpt_macros (خروجی 'postconf -d' را ببینید)
- ماکروهایی که پس از دستور SMTP RCPT TO به برنامههای Milter (فیلتر ایمیل) ارسال میشوند.
- milter_data_macros (خروجی 'postconf -d' را ببینید)
- ماکروهایی که پس از دستور SMTP DATA به برنامههای Milter (فیلتر ایمیل) نسخه 4 یا بالاتر ارسال میشوند.
- milter_unknown_command_macros (خروجی 'postconf -d' را ببینید)
- ماکروهایی که پس از یک دستور ناشناخته SMTP به برنامههای Milter (فیلتر ایمیل) نسخه 3 یا بالاتر ارسال میشوند.
- milter_end_of_data_macros (خروجی 'postconf -d' را ببینید)
- ماکروهایی که پس از پایان دادههای پیام به برنامههای Milter (فیلتر ایمیل) ارسال میشوند.
موجود در Postfix نسخه 2.5 و بالاتر:
- milter_end_of_header_macros (خروجی 'postconf -d' را ببینید)
- ماکروهایی که پس از پایان سرآیند پیام به برنامههای Milter (فیلتر ایمیل) ارسال میشوند.
موجود در Postfix نسخه 2.7 و بالاتر:
- milter_header_checks (empty)
- جدولهای جستجوی اختیاری برای بازرسی محتوای سرآیندهای پیامی که توسط برنامههای Milter تولید میشوند.
موجود در Postfix نسخه 3.1 و بالاتر:
- milter_macro_defaults (empty)
- فهرست اختیاری از جفتهای name=value که مقادیر پیشفرض ماکروهای دلخواهی را تعیین میکنند که ممکن است Postfix به برنامههای Milter ارسال کند.
کنترلهای پردازش مایم (MIME PROCESSING CONTROLS)
موجود در Postfix نسخه 2.0 و بالاتر:
- disable_mime_input_processing (no)
- غیرفعالسازی پردازش MIME هنگام دریافت نامه.
- mime_boundary_length_limit (2048)
- حداکثر طول رشتههای مرز (boundary) چندبخشی MIME.
- mime_nesting_limit (100)
- حداکثر سطح تودرتویی بازگشتی که پردازشگر MIME رسیدگی خواهد کرد.
- strict_8bitmime (no)
- فعالسازی همزمان هر دو پارامتر strict_7bit_headers و strict_8bitmime_body.
- strict_7bit_headers (no)
- رد کردن نامههای حاوی متن 8 بیتی در سرآیندهای پیام.
- strict_8bitmime_body (no)
- رد کردن متن 8 بیتی بدنه پیام فاقد اطلاعات کدگذاری محتوای 8 بیتی MIME.
- strict_mime_encoding_domain (no)
- رد کردن نامههای حاوی اطلاعات نامعتبر در Content-Transfer-Encoding: برای انواع محتوای MIME شامل message/* یا multipart/*.
موجود در Postfix نسخه 2.5 و بالاتر:
- detect_8bit_encoding_header (yes)
- تشخیص خودکار محتوای بدنه 8BITMIME با بررسی سرآیندهای پیام Content-Transfer-Encoding:؛ از نظر تاریخی، این رفتار به صورت سختکدشده "همیشه فعال" بود.
کنترلهای گیرنده رونوشت مخفی خودکار (AUTOMATIC BCC RECIPIENT CONTROLS)
سیستم Postfix میتواند به هنگام ورود نامه به سامانه پستی، به طور خودکار رونوشت پنهان (BCC) اضافه کند:
- always_bcc (empty)
- نشانی اختیاری که رونوشت پنهان (blind carbon copy) از هر پیامی را که توسط سامانه پستی Postfix دریافت میشود، دریافت میکند.
موجود در Postfix نسخه 2.1 و بالاتر:
- sender_bcc_maps (empty)
- جدولهای جستجوی اختیاری نشانی رونوشت پنهان (BCC)، ایندکسشده بر اساس نشانی فرستنده در پاکت.
- recipient_bcc_maps (empty)
- جدولهای جستجوی اختیاری نشانی رونوشت پنهان (BCC)، ایندکسشده بر اساس نشانی گیرنده در پاکت.
کنترلهای تبدیل نشانی (ADDRESS TRANSFORMATION CONTROLS)
بازنویسی نشانی به دیمن trivial-rewrite(8) واگذار شده است. سرور cleanup(8) نگاشت نشانی مبتنی بر جدول را پیادهسازی میکند.
- empty_address_recipient (MAILER-DAEMON)
- گیرنده نامههای ارسالشده به نشانی تهی (null address).
- canonical_maps (empty)
- جدولهای جستجوی اختیاری نگاشت نشانی برای سرآیندها و پاکتهای پیام.
- recipient_canonical_maps (empty)
- جدولهای جستجوی اختیاری نگاشت نشانی برای نشانیهای گیرنده در پاکت و سرآیند.
- sender_canonical_maps (empty)
- جدولهای جستجوی اختیاری نگاشت نشانی برای نشانیهای فرستنده در پاکت و سرآیند.
- masquerade_classes (envelope_sender, header_sender, header_recipient)
- تعیین اینکه کدام نشانیها مشمول نقابگذاری نشانی میشوند.
- masquerade_domains (empty)
- فهرست اختیاری از دامنههایی که ساختار زیردامنه آنها در نشانیهای ایمیل حذف خواهد شد.
- masquerade_exceptions (empty)
- فهرست اختیاری از نامهای کاربری که مشمول نقابگذاری نشانی نمیشوند، حتی زمانی که نشانیهای آنها با $masquerade_domains مطابقت دارد.
- propagate_unmatched_extensions (canonical, virtual)
- تعیین اینکه کدام جدولهای جستجوی نشانی، پسوند نشانی را از کلید جستجو به نتیجه جستجو کپی میکنند.
موجود در نسخههای پیش از Postfix 2.0:
- virtual_maps (empty)
- جدولهای جستجوی اختیاری با الف) نام دامنههایی که تمامی نشانیهای آنها به نشانیهایی در دامنههای محلی یا راه دور دیگر نگاشت میشوند، و ب) نشانیهایی که به نشانیهایی در سایر دامنههای محلی یا راه دور نگاشت میشوند.
موجود در Postfix نسخه 2.0 و بالاتر:
- virtual_alias_maps ($virtual_maps)
- جدولهای جستجوی اختیاری که اغلب با یک نشانی ایمیل کامل (شامل دامنه) جستجو میشوند و برای تمام گیرندگان اعمال میگردند: local(8)، مجازی و راه دور؛ این رفتار بر خلاف alias_maps است که تنها با بخش محلی نشانی ایمیل (بدون دامنه) جستجو شده و فقط برای گیرندگان local(8) اعمال میشود.
موجود در Postfix نسخه 2.2 و بالاتر:
- canonical_classes (envelope_sender, envelope_recipient, header_sender, header_recipient)
- تعیین اینکه چه نشانیهایی مشمول نگاشت نشانی canonical_maps هستند.
- recipient_canonical_classes (envelope_recipient, header_recipient)
- تعیین اینکه چه نشانیهایی مشمول نگاشت نشانی recipient_canonical_maps هستند.
- sender_canonical_classes (envelope_sender, header_sender)
- تعیین اینکه چه نشانیهایی مشمول نگاشت نشانی sender_canonical_maps هستند.
- remote_header_rewrite_domain (empty)
- بازنویسی یا افزودن سرآیندهای پیام در نامههای دریافتی از کلاینتهای راه دور در صورتی که مقدار پارامتر remote_header_rewrite_domain غیرخالی باشد؛ بهروزرسانی نشانیهای ناقص با دامنه مشخصشده در پارامتر remote_header_rewrite_domain و افزودن سرآیندهای مفقود.
کنترلهای منابع و نرخ مصرف (RESOURCE AND RATE CONTROLS)
- duplicate_filter_limit (1000)
- حداکثر تعداد نشانیهایی که توسط فیلتر تکرار نشانی برای بسط نام مستعار aliases(5) یا virtual(5)، یا برای نمایشهای صف showq(8) به خاطر سپرده میشود.
- header_size_limit (102400)
- حداکثر میزان حافظه بر حسب بایت برای ذخیرهسازی سرآیند یک پیام.
- hopcount_limit (50)
- حداکثر تعداد سرآیندهای پیام Received: مجاز در سرآیندهای اصلی پیام.
- in_flow_delay (1s)
- مدت زمان مکث پیش از پذیرش یک پیام جدید، زمانی که نرخ ورود پیام از نرخ تحویل پیام فراتر میرود.
- message_size_limit (10240000)
- حداکثر اندازه یک پیام بر حسب بایت، شامل اطلاعات پاکت نامه.
موجود در Postfix نسخه 2.0 و بالاتر:
- header_address_token_limit (10240)
- حداکثر تعداد نشانههای نشانی مجاز در یک سرآیند نشانی پیام.
- mime_boundary_length_limit (2048)
- حداکثر طول رشتههای مرز چندبخشی MIME.
- mime_nesting_limit (100)
- حداکثر سطح تودرتویی بازگشتی که پردازشگر MIME رسیدگی خواهد کرد.
- queue_file_attribute_count_limit (100)
- حداکثر تعداد مشخصههای (name=value) قابل ذخیرهسازی در یک فایل صف Postfix.
موجود در Postfix نسخه 2.1 و بالاتر:
- virtual_alias_expansion_limit (1000)
- حداکثر تعداد نشانیهایی که بسط نام مستعار مجازی از هر گیرنده اصلی تولید میکند.
- virtual_alias_recursion_limit (1000)
- حداکثر عمق تودرتویی بسط نام مستعار مجازی.
موجود در Postfix نسخه 3.0 و بالاتر:
- virtual_alias_address_length_limit (1000)
- حداکثر طول یک نشانی ایمیل پس از بسط نام مستعار مجازی.
کنترلهای SMTPUTF8 (SMTPUTF8 CONTROLS)
پشتیبانی مقدماتی از SMTPUTF8 در Postfix 3.0 معرفی شده است.
- smtputf8_enable (yes)
- فعالسازی پشتیبانی مقدماتی SMTPUTF8 برای پروتکلهای شرح دادهشده در RFC 6531، RFC 6532 و RFC 6533.
- smtputf8_autodetect_classes (sendmail, verify)
- تشخیص اینکه یک پیام برای کلاسهای مبدأ مشخصشده نامه به پشتیبانی SMTPUTF8 نیاز دارد.
موجود در Postfix نسخه 3.2 و بالاتر:
- enable_idna2003_compatibility (no)
- فعالسازی سازگاری 'گذرا' میان IDNA2003 و IDNA2008، هنگام تبدیل نامهای دامنه UTF-8 به/از فرمت ASCII مورد استفاده برای جستجوهای DNS.
پشتیبانی از TLS (TLS SUPPORT)
موجود در Postfix نسخه 3.10 و بالاتر:
- tls_required_enable (yes)
- فعالسازی پشتیبانی از سرآیند پیام "TLS-Required: no" که در RFC 8689 تعریف شده است.
- requiretls_esmtp_header (yes)
- ثبت درخواست ESMTP REQUIRETLS در یک سرآیند پیام "Require-TLS-ESMTP: yes".
کنترلهای متفرقه (MISCELLANEOUS CONTROLS)
- config_directory (خروجی 'postconf -d' را ببینید)
- مکان پیشفرض فایلهای پیکربندی main.cf و master.cf در Postfix.
- daemon_timeout (18000s)
- حداکثر زمانی که فرآیند دیمن Postfix میتواند صرف رسیدگی به یک درخواست کند پیش از آنکه توسط یک تایمر دیدهبان داخلی خاتمه یابد.
- delay_logging_resolution_limit (2)
- حداکثر تعداد ارقام پس از ممیز هنگام ثبت مقادیر تأخیر در لاگ.
- delay_warning_time (0h)
- مدت زمانی که پس از آن، فرستنده نسخهای از سرآیندهای پیامی را که هنوز در صف قرار دارد دریافت میکند.
- ipc_timeout (3600s)
- مهلت زمانی برای ارسال یا دریافت اطلاعات روی کانال ارتباطی داخلی.
- max_idle (100s)
- حداکثر مدت زمانی که فرآیند دیمن بیکار Postfix در انتظار اتصال ورودی میماند پیش از آنکه داوطلبانه خاتمه یابد.
- max_use (100)
- حداکثر تعداد اتصالات ورودی که فرآیند دیمن Postfix پیش از خروج داوطلبانه به آنها سرویسدهی میکند.
- myhostname (خروجی 'postconf -d' را ببینید)
- نام میزبان اینترنتی این سامانه پستی.
- myorigin ($myhostname)
- نام دامنهای که به نظر میرسد نامههای ارسالشده محلی از آن آمدهاند، و نامههای ارسالی محلی به آن تحویل داده میشوند.
- process_id (فقطخواندنی)
- شناسه فرآیند (PID) یک دستور یا فرآیند دیمن Postfix.
- process_name (فقطخواندنی)
- نام فرآیند یک دستور یا فرآیند دیمن Postfix.
- queue_directory (خروجی 'postconf -d' را ببینید)
- مکان دایرکتوری سطح بالای صف Postfix.
- soft_bounce (no)
- تور ایمنی برای نگه داشتن نامههایی در صف که در غیر این صورت به فرستنده پس زده میشدند.
- syslog_facility (mail)
- تسهیلات syslog برای ثبت لاگ Postfix.
- syslog_name (خروجی 'postconf -d' را ببینید)
- پیشوندی که به نام فرآیند در رکوردهای syslog اضافه میشود، به طوری که برای نمونه "smtpd" به صورت "prefix/smtpd" درمیآید.
موجود در Postfix نسخه 2.1 و بالاتر:
- enable_original_recipient (yes)
- فعالسازی پشتیبانی از نشانی گیرنده اصلی پس از بازنویسی یک نشانی به نشانی متفاوت (برای نمونه با نام مستعار یا با نگاشت متعارف).
موجود در Postfix نسخه 3.3 و بالاتر:
- service_name (فقطخواندنی)
- نام سرویس master.cf برای فرآیند دیمن Postfix.
موجود در Postfix نسخه 3.5 و بالاتر:
- info_log_address_format (external)
- قالب نشانی ایمیلی که در لاگهای غیردیباگ (info، warning و غیره) به کار خواهد رفت.
موجود در Postfix نسخه 3.9 و بالاتر:
- force_mime_input_conversion (no)
- تبدیل محتوای بدنهای که ادعا میکند 8 بیتی است به quoted-printable، پیش از header_checks، body_checks، Milters و قبل از فیلترهای محتوای پس از صف (after-queue).
فایلها (FILES)
/etc/postfix/canonical*, جدول نگاشت متعارف /etc/postfix/virtual*, جدول نگاشت مجازی
همچنین ببینید (SEE ALSO)
trivial-rewrite(8), بازنویسی نشانی qmgr(8), مدیریت صف header_checks(5), بازرسی محتوای سرآیند پیام body_checks(5), بازرسی محتوای بخشهای بدنه canonical(5), قالب جدول جستجوی نشانی متعارف virtual(5), قالب جدول جستجوی نام مستعار مجازی postconf(5), پارامترهای پیکربندی master(5), گزینههای عمومی دیمن master(8), مدیر فرآیندها postlogd(8), ثبت لاگ Postfix syslogd(8), ثبت لاگ سیستم
فایلهای راهنما (README FILES)
برای یافتن این اطلاعات از "postconf readme_directory" یا "postconf html_directory" استفاده کنید.
ADDRESS_REWRITING_README, دستکاری نشانی در Postfix CONTENT_INSPECTION_README, بازرسی محتوا
مجوز (LICENSE)
مجوز نرمافزار پستی امن (Secure Mailer) باید همراه با این نرمافزار توزیع شود.
نویسندگان (AUTHORS)
Wietse Venema IBM T.J. Watson Research P.O. Box 704 Yorktown Heights, NY 10598, USA Wietse Venema Google, Inc. 111 8th Avenue New York, NY 10011, USA Wietse Venema porcupine.org