CLEANUP(8) Postfix CLEANUP(8) (NAME) cleanup - Postfix (SYNOPSIS) cleanup [ Postfix] (DESCRIPTION) cleanup(8) incoming . cleanup(8) : o : (Resent-) From: To: Message-Id: Date:. local_header_rewrite_clients always_add_missing_headers . o user@fully-qualified-domain Postfix . trivial-rewrite(8) . local_header_rewrite_clients . o . duplicate_filter_limit . o : Bcc Content-Length Resent-Bcc Return-Path. message_drop_headers . o canonical(5). local_header_rewrite_clients . o ( masquerade_domains masquerade_exceptions). . local_header_rewrite_clients . o virtual_alias_maps. cleanup(8) . cleanup . cleanup(8) (bounce ). (STANDARDS) RFC 822 ( ARPA) RFC 2045 ( MIME ) RFC 2046 ( MIME) RFC 2822 ( ) RFC 3463 ( ) RFC 3464 ( ) RFC 5322 ( ) RFC 8689 ( TLS-Required) (DIAGNOSTICS) syslogd(8) postlogd(8) . (BUGS) if then else . (CONFIGURATION PARAMETERS) main.cf cleanup(8) . "postfix reload" . . postconf(5) . (COMPATIBILITY CONTROLS) undisclosed_recipients_header ( 'postconf -d' ) cleanup(8) Postfix To: Cc: . Postfix 2.1 : enable_errors_to (no) Errors-To: ( Postfix 2.2 2.1 Postfix ). Postfix 2.6 : always_add_missing_headers (no) (Resent-) From: To: Date: Message-ID: . Postfix 2.9 : enable_long_queue_ids (no) ( ). (HEADER FORMATTING CONTROLS) Postfix 3.0 : message_drop_headers (bcc, content-length, resent-bcc, return-path) cleanup(8) header_checks(5) Milter . Postfix 3.3 : header_from_format (standard) From: Postfix. Postfix 3.10 : full_name_encoding_charset (utf-8) ( "charset" ) Postfix RFC 2047 . non_empty_end_of_header_action (fix_quietly) cleanup(8) . (BUILT-IN CONTENT FILTERING CONTROLS) Postfix . . body_checks (empty) body_checks(5) . header_checks (empty) MIME header_checks(5). Postfix 2.0 : body_checks_size_limit (51200) ( ) body_checks . mime_header_checks ($header_checks) MIME header_checks(5) . nested_header_checks ($header_checks) MIME header_checks(5). Postfix 2.3 : message_reject_characters (empty) Postfix . message_strip_characters (empty) Postfix . Postfix 3.9 3.8.5 3.7.10 3.6.14 3.5.24 : cleanup_replace_stray_cr_lf (yes) (space) SMTP DKIM Postfix . (BEFORE QUEUE MILTER CONTROLS) 2.3 Postfix Milter ( ) Sendmail 8 . smtpd(8) cleanup(8) SMTP . MILTER_README . non_smtpd_milters (empty) Milter ( ) smtpd(8) Postfix . milter_protocol (6) Milter Postfix 2.6 2 . milter_default_action (Postfix >= 3.11: shutdown; Postfix < 3.11: tempfail) Milter ( ) ( Postfix Milter). milter_macro_daemon_name ($myhostname) {daemon_name} Milter ( ). milter_macro_v ($mail_name $mail_version) {v} Milter ( ). milter_connect_timeout (30s) Milter ( ) . milter_command_timeout (30s) SMTP Milter ( ) . milter_content_timeout (300s) Milter ( ) . milter_connect_macros ( 'postconf -d' ) SMTP Milter ( ) . milter_helo_macros ( 'postconf -d' ) SMTP HELO EHLO Milter ( ) . milter_mail_macros ( 'postconf -d' ) SMTP MAIL FROM Milter ( ) . milter_rcpt_macros ( 'postconf -d' ) SMTP RCPT TO Milter ( ) . milter_data_macros ( 'postconf -d' ) SMTP DATA Milter ( ) 4 . milter_unknown_command_macros ( 'postconf -d' ) SMTP Milter ( ) 3 . milter_end_of_data_macros ( 'postconf -d' ) Milter ( ) . Postfix 2.5 : milter_end_of_header_macros ( 'postconf -d' ) Milter ( ) . Postfix 2.7 : milter_header_checks (empty) Milter . Postfix 3.1 : milter_macro_defaults (empty) name=value Postfix Milter . (MIME PROCESSING CONTROLS) Postfix 2.0 : disable_mime_input_processing (no) MIME . mime_boundary_length_limit (2048) (boundary) MIME. mime_nesting_limit (100) MIME . strict_8bitmime (no) strict_7bit_headers strict_8bitmime_body. strict_7bit_headers (no) 8 . strict_8bitmime_body (no) 8 8 MIME. strict_mime_encoding_domain (no) Content-Transfer-Encoding: MIME message/* multipart/*. Postfix 2.5 : detect_8bit_encoding_header (yes) 8BITMIME Content-Transfer-Encoding: " " . (AUTOMATIC BCC RECIPIENT CONTROLS) Postfix (BCC) : always_bcc (empty) (blind carbon copy) Postfix . Postfix 2.1 : sender_bcc_maps (empty) (BCC) . recipient_bcc_maps (empty) (BCC) . (ADDRESS TRANSFORMATION CONTROLS) trivial-rewrite(8) . cleanup(8) . empty_address_recipient (MAILER-DAEMON) (null address). canonical_maps (empty) . recipient_canonical_maps (empty) . sender_canonical_maps (empty) . masquerade_classes (envelope_sender, header_sender, header_recipient) . masquerade_domains (empty) . masquerade_exceptions (empty) $masquerade_domains . propagate_unmatched_extensions (canonical, virtual) . Postfix 2.0: virtual_maps (empty) ) ) . Postfix 2.0 : virtual_alias_maps ($virtual_maps) ( ) : local(8) alias_maps ( ) local(8) . Postfix 2.2 : canonical_classes (envelope_sender, envelope_recipient, header_sender, header_recipient) canonical_maps . recipient_canonical_classes (envelope_recipient, header_recipient) recipient_canonical_maps . sender_canonical_classes (envelope_sender, header_sender) sender_canonical_maps . remote_header_rewrite_domain (empty) remote_header_rewrite_domain remote_header_rewrite_domain . (RESOURCE AND RATE CONTROLS) duplicate_filter_limit (1000) aliases(5) virtual(5) showq(8) . header_size_limit (102400) . hopcount_limit (50) Received: . in_flow_delay (1s) . message_size_limit (10240000) . Postfix 2.0 : header_address_token_limit (10240) . mime_boundary_length_limit (2048) MIME. mime_nesting_limit (100) MIME . queue_file_attribute_count_limit (100) (name=value) Postfix. Postfix 2.1 : virtual_alias_expansion_limit (1000) . virtual_alias_recursion_limit (1000) . Postfix 3.0 : virtual_alias_address_length_limit (1000) . SMTPUTF8 (SMTPUTF8 CONTROLS) SMTPUTF8 Postfix 3.0 . smtputf8_enable (yes) SMTPUTF8 RFC 6531 RFC 6532 RFC 6533. smtputf8_autodetect_classes (sendmail, verify) SMTPUTF8 . Postfix 3.2 : enable_idna2003_compatibility (no) '' IDNA2003 IDNA2008 UTF-8 / ASCII DNS. TLS (TLS SUPPORT) Postfix 3.10 : tls_required_enable (yes) "TLS-Required: no" RFC 8689 . requiretls_esmtp_header (yes) ESMTP REQUIRETLS "Require-TLS-ESMTP: yes". (MISCELLANEOUS CONTROLS) config_directory ( 'postconf -d' ) main.cf master.cf Postfix. daemon_timeout (18000s) Postfix . delay_logging_resolution_limit (2) . delay_warning_time (0h) . ipc_timeout (3600s) . max_idle (100s) Postfix . max_use (100) Postfix . myhostname ( 'postconf -d' ) . myorigin ($myhostname) . process_id () (PID) Postfix. process_name () Postfix. queue_directory ( 'postconf -d' ) Postfix. soft_bounce (no) . syslog_facility (mail) syslog Postfix. syslog_name ( 'postconf -d' ) syslog "smtpd" "prefix/smtpd" . Postfix 2.1 : enable_original_recipient (yes) ( ). Postfix 3.3 : service_name () master.cf Postfix. Postfix 3.5 : info_log_address_format (external) (info warning ) . Postfix 3.9 : force_mime_input_conversion (no) 8 quoted-printable header_checks body_checks Milters (after-queue). (FILES) /etc/postfix/canonical*, /etc/postfix/virtual*, (SEE ALSO) trivial-rewrite(8), qmgr(8), header_checks(5), body_checks(5), canonical(5), virtual(5), postconf(5), master(5), master(8), postlogd(8), Postfix syslogd(8), (README FILES) "postconf readme_directory" "postconf html_directory" . ADDRESS_REWRITING_README, Postfix CONTENT_INSPECTION_README, (LICENSE) (Secure Mailer) . (AUTHORS) Wietse Venema IBM T.J. Watson Research P.O. Box 704 Yorktown Heights, NY 10598, USA Wietse Venema Google, Inc. 111 8th Avenue New York, NY 10011, USA Wietse Venema porcupine.org CLEANUP(8)