| POSTALIAS(1) | General Commands Manual | POSTALIAS(1) |
نام (NAME)
postalias - مدیریت پایگاهدادههای نام مستعار Postfix
خلاصه دستور (SYNOPSIS)
postalias [-Nfijnoprsuvw] [-c
config_dir] [-d key] [-q key]
[file_type:]file_name ...
توضیحات (DESCRIPTION)
دستور postalias(1) یک یا چند پایگاهداده نام مستعار (alias) در Postfix را ایجاد یا پرسوجو کرده، یا نمونههای موجود را بهروزرسانی میکند. انتظار میرود قالبهای فایل ورودی و خروجی با Sendmail نگارش ۸ سازگار باشند و برای استفاده بهعنوان نگاشتهای نام مستعار NIS مناسب باشند.
اگر فایلهای نتیجه وجود نداشته باشند، با همان مجوزهای خواندن گروهی و دیگران (other) که فایل منبع آنها دارد ایجاد خواهند شد.
در زمان انجام بهروزرسانی پایگاهداده، تحویل سیگنال به تعویق میافتد و یک قفل مشورتی (advisory) انحصاری بر روی کل پایگاهداده قرار میگیرد تا از رفتارهای غیرمنتظره در فرآیندهای ناظر جلوگیری شود.
قالب فایلهای ورودی نام مستعار Postfix در aliases(5) شرح داده شده است.
بهطور پیشفرض، کلید جستجو برای حساس نبودن به بزرگی و کوچکی حروف به حروف کوچک نگاشت میشود؛ از Postfix 2.3 به بعد، این تبدیل اندازه حروف تنها برای جدولهایی انجام میشود که کلیدهای جستجوی آنها رشتههایی با حروف ثابت هستند، مانند btree:، dbm: یا hash:. در نگارشهای پیشین، کلید جستجو حتی در جدولهایی که فیلد جستجو میتوانست با هر دو نوع حروف کوچک و بزرگ مطابقت داشته باشد (مانند regexp: و pcre:) نیز تبدیل میشد. این امر منجر به از دست رفتن اطلاعات در جایگزینیهای $number میگردید.
گزینهها:
- -c config_dir
- خواندن فایل پیکربندی main.cf در دایرکتوری مشخصشده، بهجای دایرکتوری پیکربندی پیشفرض.
- -d key
- جستجوی
نگاشتهای
مشخصشده
برای یافتن
key و حذف یک
مدخل از هر
نگاشت. در
صورتی که
اطلاعات
درخواستی
پیدا شود،
وضعیت خروج
صفر خواهد
بود.
اگر مقدار کلید بهصورت - مشخص شود، برنامه مقادیر کلید را از جریان ورودی استاندارد میخواند. اگر دستکم یکی از کلیدهای درخواستی پیدا شود، وضعیت خروج صفر خواهد بود.
- -f
- هنگام
ایجاد یا
پرسوجوی
یک جدول،
کلید جستجو
را به حروف
کوچک تبدیل
نکن.
در نگارش 2.3 و بالاتر Postfix، این گزینه برای جدولهای عبارت باقاعده (regular expression) تاثیری ندارد؛ در آنجا تبدیل حروف با افزودن پرچم به الگو کنترل میشود.
- -i
- حالت افزایشی (Incremental). مدخلها را از ورودی استاندارد بخوان و پایگاهداده موجود را کوتاه (truncate) نکن. بهطور پیشفرض، postalias(1) یک پایگاهداده جدید از مدخلهای موجود در file_name ایجاد میکند.
- -j
- خروجی JSON.
قالببندی
خروجی
دستورهای -q
و -s
بهصورت یک
شیء {"key":
"value"} در هر
خط.
این ویژگی در نگارش 3.11 و بالاتر Postfix در دسترس است.
- -N
- شامل کردن نویسه تهی پایانی (null character) که کلیدها و مقادیر جستجو را خاتمه میدهد. بهطور پیشفرض، postalias(1) مطابق با رفتار پیشفرض سیستمعامل میزبان عمل میکند.
- -n
- نویسه تهی پایانی (null character) که کلیدها و مقادیر جستجو را خاتمه میدهد لحاظ نشود. بهطور پیشفرض، postalias(1) مطابق با رفتار پیشفرض سیستمعامل میزبان عمل میکند.
- -o
- هنگام پردازش یک فایل ورودی غیر ریشه (non-root)، دسترسیهای root را رها نکن. بهطور پیشفرض، postalias(1) دسترسیهای root را کنار میگذارد و با هویت مالک فایل مبدأ اجرا میشود.
- -p
- هنگام ایجاد فایل جدید، مجوزهای دسترسی فایل از فایل ورودی به ارث برده نشود؛ در عوض، فایل جدید با مجوزهای دسترسی پیشفرض (حالت 0644) ایجاد شود.
- -q key
- جستجوی
نگاشتهای
مشخصشده
برای یافتن
key و نوشتن
نخستین
مقدار
یافتشده
در جریان
خروجی
استاندارد.
در صورتی که
اطلاعات
درخواستی
پیدا شود،
وضعیت خروج
صفر خواهد
بود.
نکته: این عمل یک پرسوجوی منفرد با کلید مشخصشده انجام میدهد و مانند آنچه در صفحه راهنمای aliases(5) شرح داده شده است، پرسوجوهای تکرارشونده با زیررشتههای کلید انجام نمیدهد.
اگر مقدار کلید بهصورت - مشخص شود، برنامه مقادیر کلید را از جریان ورودی استاندارد میخواند و به ازای هر کلید یافتشده، یک خط خروجی بهصورت key: value مینویسد. اگر دستکم یکی از کلیدهای درخواستی پیدا شود، وضعیت خروج صفر خواهد بود.
- -r
- هنگام بهروزرسانی جدول، در صورت تلاش برای بهروزرسانی مدخلهای موجود هشداری نده و آن بهروزرسانیها را به هر حال اعمال کن.
- -s
- بازیابی تمامی عنصرهای پایگاهداده و نوشتن یک خط خروجی key: value برای هر عنصر. عنصرها به ترتیب ذخیره در پایگاهداده چاپ میشوند که لزوماً با ترتیب ورودی اصلی یکسان نیست. این ویژگی در نگارش 2.2 و بالاتر Postfix در دسترس است، اما برای همه انواع پایگاهداده پشتیبانی نمیشود.
- -u
- غیرفعال کردن پشتیبانی از UTF-8. پشتیبانی از UTF-8 در صورت فعال بودن «smtputf8_enable = yes» بهطور پیشفرض فعال است. این گزینه نیازمند معتبر بودن رشتههای UTF-8 برای کلیدها و مقادیر است.
- -v
- فعال کردن گزارشگیری با جزئیات (verbose) برای مقاصد اشکالزدایی. استفاده مکرر از گزینه -v میزان جزئیات خروجی نرمافزار را افزایش میدهد.
- -w
- هنگام بهروزرسانی جدول، در صورت تلاش برای بهروزرسانی مدخلهای موجود هشداری نده و آن تلاشها را نادیده بگیر.
آرگومانها:
- file_type
- نوع
پایگاهداده.
برای اطلاع
از اینکه چه
نوعهایی
پشتیبانی
میشوند،
از دستور
«postconf -m»
استفاده
کنید.
هنگامی که هیچ file_type مشخص نشده باشد، نرمافزار از نوع پایگاهداده تعیینشده در پارامتر پیکربندی default_database_type استفاده میکند. مقدار پیشفرض این پارامتر به محیط میزبان بستگی دارد.
دستور postalias(1) میتواند هر نوع فایل پشتیبانیشده را پرسوجو کند، اما تنها قادر به ایجاد انواع فایل زیر است:
- btree
- خروجی یک فایل btree به نام file_name.db است. این نوع در سیستمهای دارای پشتیبانی از پایگاهدادههای db موجود است.
- cdb
- خروجی یک فایل به نام file_name.cdb است. این نوع در سیستمهای دارای پشتیبانی از پایگاهدادههای cdb موجود است.
- dbm
- خروجی شامل دو فایل به نامهای file_name.pag و file_name.dir است. این نوع در سیستمهای دارای پشتیبانی از پایگاهدادههای dbm موجود است.
- fail
- جدولی که بهطور قطعی تمام درخواستها را با شکست مواجه میکند. نام جدول جستجو تنها برای ثبت در گزارش استفاده میشود. این جدول جهت تسهیل آزمونهای خطای Postfix وجود دارد.
- hash
- خروجی یک فایل درهمسازیشده (hashed) به نام file_name.db است. این نوع در سیستمهای دارای پشتیبانی از پایگاهدادههای db موجود است.
- lmdb
- خروجی یک فایل مبتنی بر btree به نام file_name.lmdb است. برخلاف سایر جدولهای مبتنی بر فایل پشتیبانیشده، lmdb از خواندن و نوشتن همزمان فرآیندهای مختلف پشتیبانی میکند. این نوع در سیستمهای دارای پشتیبانی از پایگاهدادههای lmdb موجود است.
- sdbm
- خروجی شامل دو فایل به نامهای file_name.pag و file_name.dir است. این نوع در سیستمهای دارای پشتیبانی از پایگاهدادههای sdbm موجود است.
- file_name
- نام فایل مبدأ پایگاهداده نام مستعار هنگام ایجاد یک پایگاهداده.
عیبیابی (DIAGNOSTICS)
مشکلات در جریان خطای استاندارد و در syslogd(8) یا postlogd(8) ثبت میشوند. نداشتن هیچ خروجی به این معنی است که مشکلی شناسایی نشده است. مدخلهای تکراری نادیده گرفته شده و با یک هشدار مشخص میشوند.
دستور postalias(1) در صورت موفقیت (از جمله موفقیت در جستجوی «postalias -q») با وضعیت خروج صفر خاتمه مییابد و در صورت بروز خطا با وضعیت خروج غیرصفر به پایان میرسد.
محیط (ENVIRONMENT)
- MAIL_CONFIG
- دایرکتوری حاوی فایلهای پیکربندی Postfix.
- MAIL_VERBOSE
- فعال کردن گزارشگیری با جزئیات برای مقاصد اشکالزدایی.
پارامترهای پیکربندی (CONFIGURATION PARAMETERS)
پارامترهای main.cf زیر بهطور خاص به این برنامه مربوط میشوند.
متن زیر تنها خلاصهای از پارامترها را ارائه میدهد. برای جزئیات بیشتر شامل مثالها، به postconf(5) مراجعه کنید.
- alias_database (see 'postconf -d' output)
- پایگاهدادههای نام مستعار برای تحویل local(8) که با «newaliases» یا «sendmail -bi» بهروزرسانی میشوند.
- config_directory (see 'postconf -d' output)
- مکان پیشفرض فایلهای پیکربندی main.cf و master.cf در Postfix.
- berkeley_db_create_buffer_size (16777216)
- اندازه بافر ورودی/خروجی (I/O) به ازای هر جدول برای برنامههایی که جدولهای Berkeley DB از نوع hash یا btree ایجاد میکنند.
- berkeley_db_read_buffer_size (131072)
- اندازه بافر ورودی/خروجی (I/O) به ازای هر جدول برای برنامههایی که جدولهای Berkeley DB از نوع hash یا btree را میخوانند.
- default_database_type (see 'postconf -d' output)
- نوع پیشفرض پایگاهداده برای استفاده در دستورهای newaliases(1)، postalias(1) و postmap(1).
- import_environment (see 'postconf -d' output)
- فهرست متغیرهای محیطی که یک فرآیند مجاز Postfix از یک فرآیند والد غیر Postfix وارد میکند، یا مقادیر بازنویسی محیط بهصورت name=value.
- smtputf8_enable (yes)
- فعال کردن پشتیبانی مقدماتی SMTPUTF8 برای پروتکلهای شرح دادهشده در RFC 6531، RFC 6532 و RFC 6533.
- syslog_facility (mail)
- تسهیلات syslog برای ثبت گزارشهای Postfix.
- syslog_name (see 'postconf -d' output)
- پیشوندی که در رکوردهای syslog به نام فرآیند اضافه میشود؛ بنابراین، برای مثال «smtpd» تبدیل به «prefix/smtpd» میشود.
موجود در Postfix 2.11 و بالاتر:
- lmdb_map_size (16777216)
- محدودیت اولیه اندازه پایگاهداده OpenLDAP LMDB بر حسب بایت.
استانداردها (STANDARDS)
RFC 822 (ARPA Internet Text Messages)
همچنین ببینید (SEE ALSO)
aliases(5)، قالب فایل ورودی پایگاهداده نام مستعار. local(8)، عامل تحویل محلی Postfix. postconf(1)، نوعهای پایگاهداده پشتیبانیشده postconf(5)، پارامترهای پیکربندی postmap(1)، ایجاد/بهروزرسانی/پرسوجوی جدولهای جستجو newaliases(1)، رابط سازگاری Sendmail. postlogd(8)، ثبت وقایع Postfix syslogd(8)، ثبت وقایع سیستم
فایلهای راهنما (README FILES)
از «postconf readme_directory» یا «postconf html_directory» برای یافتن محل این اطلاعات استفاده کنید.
DATABASE_README، نمای کلی جدول جستجوی Postfix
مجوز (LICENSE)
مجوز نرمافزاری Secure Mailer باید همراه با این نرمافزار توزیع شود.
نویسندگان (AUTHORS)
Wietse Venema IBM T.J. Watson Research P.O. Box 704 Yorktown Heights, NY 10598, USA Wietse Venema Google, Inc. 111 8th Avenue New York, NY 10011, USA