POSTALIAS(1) General Commands Manual POSTALIAS(1) (NAME) postalias - Postfix (SYNOPSIS) postalias [-Nfijnoprsuvw] [-c config_dir] [-d key] [-q key] [file_type:]file_name ... (DESCRIPTION) postalias(1) (alias) Postfix . Sendmail NIS . (other) . (advisory) . Postfix aliases(5) . Postfix 2.3 btree: dbm: hash:. ( regexp: pcre:) . $number . : -c config_dir main.cf . -d key key . . - . . -f . 2.3 Postfix (regular expression) . -i (Incremental). (truncate) . postalias(1) file_name . -j JSON. -q -s {"key": "value"} . 3.11 Postfix . -N (null character) . postalias(1) . -n (null character) . postalias(1) . -o (non-root) root . postalias(1) root . -p ( 0644) . -q key key . . : aliases(5) . - key: value . . -r . -s key: value . . 2.2 Postfix . -u UTF-8. UTF-8 <> . UTF-8 . -v (verbose) . -v . -w . : file_type . <> . file_type default_database_type . . postalias(1) : btree btree file_name.db . db . cdb file_name.cdb . cdb . dbm file_name.pag file_name.dir . dbm . fail . . Postfix . hash (hashed) file_name.db . db . lmdb btree file_name.lmdb . lmdb . lmdb . sdbm file_name.pag file_name.dir . sdbm . file_name . (DIAGNOSTICS) syslogd(8) postlogd(8) . . . postalias(1) ( <>) . (ENVIRONMENT) MAIL_CONFIG Postfix. MAIL_VERBOSE . (CONFIGURATION PARAMETERS) main.cf . . postconf(5) . alias_database (see 'postconf -d' output) local(8) <> <> . config_directory (see 'postconf -d' output) main.cf master.cf Postfix. berkeley_db_create_buffer_size (16777216) / (I/O) Berkeley DB hash btree . berkeley_db_read_buffer_size (131072) / (I/O) Berkeley DB hash btree . default_database_type (see 'postconf -d' output) newaliases(1) postalias(1) postmap(1). import_environment (see 'postconf -d' output) Postfix Postfix name=value. smtputf8_enable (yes) SMTPUTF8 RFC 6531 RFC 6532 RFC 6533. syslog_facility (mail) syslog Postfix. syslog_name (see 'postconf -d' output) syslog <> <> . Postfix 2.11 : lmdb_map_size (16777216) OpenLDAP LMDB . (STANDARDS) RFC 822 (ARPA Internet Text Messages) (SEE ALSO) aliases(5) . local(8) Postfix. postconf(1) postconf(5) postmap(1) // newaliases(1) Sendmail. postlogd(8) Postfix syslogd(8) (README FILES) <> <> . DATABASE_README Postfix (LICENSE) Secure Mailer . (AUTHORS) Wietse Venema IBM T.J. Watson Research P.O. Box 704 Yorktown Heights, NY 10598, USA Wietse Venema Google, Inc. 111 8th Avenue New York, NY 10011, USA POSTALIAS(1)