TNFTP(1) General Commands Manual TNFTP(1) (NAME) tnftp - (SYNOPSIS) tnftp [-46AadefginpRtVv] [-b bufsize] [-H header] [-N netrc] [-o output] [-P port] [-q quittime] [-r retry] [-s srcaddr] [-T dir,max[,inc]] [-x xfersize] [[user@]host [port]] [[user@]host:[path][/]] [file:///path] [ftp://[user[:password]@]host[:port]/path[/][;type=type]] [http://[user[:password]@]host[:port]/path] [https://[user[:password]@]host[:port]/path] ... tnftp -u url file ... tnftp -?.Sh - (DESCRIPTION) tnftp (File Transfer Protocol) . . FTP HTTP . . AUTO-FETCHING FILES . . -4 tnftp IPv4 . -6 tnftp IPv6 . -A (active mode) FTP . tnftp (passive mode) FTP . tnftp . . -a tnftp (anonymous) . -b bufsize HTTP bufsize . bufsize 16384 (16 KiB) . -d . -e . ange-ftp Emacs . -f (cache) FTP HTTP . -g (globbing) . -H header header HTTP HTTP . -H . -i . -N netrc ~/.netrc netrc . THE .netrc FILE . -n tnftp "auto-login" . tnftp .netrc ( ) . tnftp ( ), . ( ) . -o output output . output FILE NAMING CONVENTIONS . output `-' `|' output (basename) . -P port port . -p . tnftp . -q quittime quittime . -R . -r retry retry . -s srcaddr srcaddr IP . -t (packet tracing) . -T direction,maximum[,increment] direction maximum increment . rate . -u url file ... url url `ftp://' (auto-fetch) ( ), file . -V verbose progress . -v verbose progress . .Po progress, tnftp . tnftp . -x xfersize xfersize . xferbuf . -? . tnftp . tnftp FTP tnftp . tnftp `ftp>' . tnftp : ! [command [args]] . . $ macro-name [args] macro-name macdef . (unglobbed) . account [passwd] . . append local-file [remote-file] . remote-file ntrans nmap . type form mode struct . ascii type ascii. bell . binary type binary. bye FTP tnftp . (EOF) . case get mget mput . case ( ) . cd remote-directory remote-directory . cdup . chmod mode remote-file remote-file mode . close FTP . . connect host [port] open. cr (carriage return) type ascii . type ascii carriage return/linefeed . cr ( ) linefeed UNIX . non-UNIX linefeed type ascii linefeed cr . debug [debug-value] . debug-value . tnftp `-->' . delete remote-file remote-file . dir [remote-path [local-file]] . UNIX `ls -l' . remote-path . tnftp dir . local-file `-' . disconnect close. edit . . epsv, epsv4, epsv6 EPSV EPRT IP IPv4 IPv6 . EPSV/EPRT PASV/PORT . . epsv epsv4 epsv6 . exit bye. features .Pq Dv FEAT . fget localfile localfile . form format format. ( ) format `non-print' . ftp host [port] open. gate [host [port]] gate-ftp FTP TIS FWTK Gauntlet . gate-ftp ( FTPSERVER) . host gate-ftp gate-ftp host . port gate-ftp . get remote-file [local-file] remote-file . case, ntrans nmap . type, form, mode struct . glob mdelete, mget, mput mreget. (globbing) glob . mput csh(1) . mdelete, mget mreget, . : FTP `mls remote-files -' . : mget, mput mreget . tar(1) type binary . hash [size] (`#') . . size . hash progress . help [command] command. tnftp . idle [seconds] seconds . seconds . image type binary. lcd [directory] . directory . less file page. lpage local-file local-file set pager . lpwd . ls [remote-path [local-file]] dir. macdef macro-name . macro-name ( ) . . . ( open ) close . $ ( ). `$' `\' . `$' ( ) . `$' `i' ( ). `$i' . `\' . `\' `$' . mdelete [remote-files] remote-files . mdir remote-files local-file dir . tnftp mdir . mget remote-files remote-files get . glob . case, ntrans nmap . lcd directory ! mkdir directory . mkdir directory-name . mls remote-files local-file ls local-file . tnftp mls ..It Ic mlsd Op Ar remote-path remote-path ( ) MLSD. `remopts mlst ...' . mlst [remote-path] remote-path ( ) MLST. `remopts mlst ...' . mode mode-name mode-name. ( ) mode-name `stream' . modtime remote-file RFC 2822. more file page. mput local-files (wildcards) put . glob . ntrans nmap . mreget remote-files mget get reget . msend local-files mput. newer remote-file [local-file] . newer () . get . nlist [remote-path [local-file]] ls. nmap [inpattern outpattern] . . mput put . mget get . non-UNIX . inpattern outpattern . inpattern ( ntrans case ). `$1', `$2', ..., `$9' inpattern . `\' `$' . nmap [inpattern] . inpattern `$1.$2' `mydata.data ' `$1' `mydata' `$2' `data' . outpattern . `$1', `$2', ..., `$9' inpattern . `$0' . [seq1,seq2] seq1 seq1 seq2 . nmap $1.$2.$3 [$1,$2].[$2,file] `myfile.data' `myfile.data' `myfile.data.old ' `myfile.file' `myfile ' `myfile.myfile' `.myfile' . outpattern : nmap $1 sed s/ *$// > $1 `\' `$', `[', `]', `,' . ntrans [inchars [outchars]] . . mput put . mget get . non-UNIX . inchars outchars . inchars outchars . open host [port] FTP host. tnftp FTP . set auto-login () tnftp FTP ( ). page file file set pager . passive [auto] (passive) ( ). auto FTPMODE `auto' . () tnftp PASV PORT. PASV . . PORT . (Passive mode) tnftp (gateway router) . ( RFC 1123 FTP PASV .) pdir [remote-path] dir [remote-path] set pager . pls [remote-path] ls [remote-path] set pager . pmlsd [remote-path] mlsd [remote-path] set pager . preserve . progress . local-file `-' `|' . FILE NAMING CONVENTIONS . progress hash . prompt . . ( ) mget mput mdelete . : a `yes' `yes' . n `no ' . p `yes' ( prompt off ). q . y `yes ' . ? . `yes' . proxy ftp-command FTP . FTP . proxy open . `proxy ?' FTP . proxy : open close get mget put mput append . PASV FTP . put local-file [remote-file] . remote-file ntrans nmap . type form mode struct . pwd . quit bye. quote [arg ...] FTP . rate direction [maximum [increment]] maximum . maximum 0 ..Pp direction : all . get . put . maximum increment (: ) : SIGUSR1 maximum increment . SIGUSR2 maximum increment . . maximum . : rate type ascii . rcvbuf size size. recv remote-file [local-file] get. reget remote-file [local-file] reget get local-file remote-file local-file remote-file . . remopts command [command-options] FTP command command-options ( ). FTP : MLST ( MLSD MLST). rename [from [to]] from to. reset . / FTP . FTP . restart marker get put marker . UNIX . rhelp [command-name] FTP. command-name . rmdir directory-name . rstatus [remote-file] . remote-file remote-file . runique . get mget `.1' . `.2' . `.99' . . runique ( ). (off) . send local-file [remote-file] put. sendport PORT. tnftp PORT . PORT . PORT tnftp . PORT PORT . FTP PORT . set [option value] option value. option value . option : anonpass $FTPANONPASS ftp_proxy $ftp_proxy. http_proxy $http_proxy. https_proxy $https_proxy. no_proxy $no_proxy. pager $PAGER. prompt $FTPPROMPT. rprompt $FTPRPROMPT. sslnoverify $FTPSSLNOVERIFY. site [arg ...] SITE FTP . size remote-file remote-file . sndbuf size size. status tnftp. struct struct-name struct-name. struct-name ( ) `file' . sunique . FTP STOU FTP . . off . system . tenex type tenex. throttle rate. trace . type [type-name] type-name. . type-name : ascii (Network ASCII). . binary - . ebcdic EBCDIC. tnftp . image type binary. tenex TENEX . umask [newmask] umask newmask. newmask umask . unset option option. set . usage command command. user user-name [password [account]] FTP . password tnftp ( ). account FTP . account account . tnftp "auto-login" FTP . verbose (verbose). FTP . . . xferbuf size size. size 0 . ? [command] help. `"' . on off . ( hash rate xferbuf) . : b . () k 1024 m 1048576 g 1073741824 tnftp SIGINFO ( status stty(1) ) SIGQUIT ..Sh " (AUTO-FETCHING FILES)" tnftp (auto-fetch) . / . : [user@]host:[path][/] "" FTP. path (glob) globbing ( glob), mget path . path basename ( basename(1)) path, . . ftp://[user[:password]@]host[:port]/path[/][;type=type] FTP URL set ftp_proxy FTP . URL HTTP set ftp_proxy . set ftp_proxy user user . password . `;type=A' `;type=I' ( ) type ascii type binary . type binary . RFC 3986, tnftp path URL `ftp://' : o `/' host[:port] path path. o path `/' . tnftp cd . tnftp get . o `//' path `/' path cd . . o `%XX' ( RFC 3986) XX () . path cd get . `%2F' ( `/' ) `%7E' ( `~' ). : o `anonymous' . / `%2F' . ( ) `%7Euser/' . /etc/motd `localhost' `myname' `mypass ' `ftp://myname:mypass@localhost/%2fetc/motd' . o cd get `/' `%2F' ( `%2f') . URL : ftp://host/dir1/dir2/file cd dir1, cd dir2, get file. ftp://host/%2Fdir1/dir2/file cd /dir1, cd dir2, get file. ftp://host/dir1%2Fdir2/file cd dir1/dir2, get file. o cd . http://[user[:password]@]host[:port]/path HTTP (URL) HTTP . set http_proxy URL HTTP . path HTTP user ( password) URL .. https://[user[:password]@]host[:port]/path HTTPS HTTPS . set https_proxy HTTPS . path HTTPS user ( password) . file:///path /path . about:topic topic . : about:ftp tnftp. about:version tnftp. . -o output basename(1) path . HTTP path . -o output . FTP `/' path tnftp cd . set ftp_proxy . HTTP HTTP 1.1 . FTP HTTP HTTP 1.0 . -R FTP HTTP . FTP reget get . HTTP `Range: bytes=' HTTP/1.1 . WWW WWW . IPv6 . : `ftp://[::1]:21/'. IPv6 ..Sh " (ABORTING A FILE TRANSFER)" ( Ctrl-C) . . ABOR FTP . ABOR . ABOR . tnftp ABOR . ( ) . (FILE NAMING CONVENTIONS) tnftp . 1. `-' stdin ( ) stdout ( ) . 2. `|', (shell) . tnftp popen(3) (fork) stdout ( stdin ). `"| ls -lt"'. : `dir "" |more'. 3. globbing csh(1); glob . tnftp ( put), globbing . 4. mget get case, ntrans, nmap . runique, . 5. mput put ntrans nmap . sunique . FTP RFC 959 . " ASCII", " EBCDIC", " image" ( binary ) " local" ( PDP-10 PDP-20) . tnftp type ascii, type binary, type image type tenex . tnftp : mode, form struct. .netrc (THE .netrc FILE) .netrc . -N netrc NETRC . : machine name name . .netrc machine tnftp open . .netrc machine default . default machine name default . default machine . : default login anonymous password user@site FTP .netrc . -n . login name . name . password string . . .netrc anonymous .netrc tnftp . account string . ACCT . macdef name . macdef tnftp . .netrc ( ) . .netrc, macdef machine . macdef machine machine . init . : default macdef init epsv4 off . tnftp editline(3) . edit tty . GNU Emacs . editline(3) .editrc -- editrc(5) . tnftp ( ) . ftp-complete editline(3) . TAB . (COMMAND LINE PROMPT) tnftp `ftp> ' . set prompt . set rprompt ( ) . : %/ . %c[[0]n], %.[[0]n] n n . n `0' "/trailing" ( `%c') "...trailing" ( `%.') () . %M . %m `.'. %n . %% `%'. tnftp : FTPANONPASS FTP. "`whoami`@" . FTPMODE . : active FTP auto ( ) gate gate-ftp passive FTP FTPPROMPT . `ftp> ' . COMMAND LINE PROMPT . FTPRPROMPT . . COMMAND LINE PROMPT . FTPSERVER gate gate-ftp . FTPSERVERPORT gate-ftp gate . getservbyname(3) "ftpgate/tcp" . FTPUSERAGENT User-Agent HTTP . FTPSSLNOVERIFY SSL 1 . HOME .netrc . NETRC .netrc. PAGER . more(1) . SHELL . ftp_proxy (URL) FTP URL FTP ( FTP ). http_proxy . http_proxy (URL) HTTP URL HTTP. URL . <<>> URL ( `@' `/') `%XX' RFC 3986 . ftp_proxy http_proxy ( lynx(1)) . : . https_proxy (URL) HTTPS URL HTTPS. http_proxy . no_proxy ( ) . `:port' . tnftp . ls : 229 Entering Extended Passive Mode (|||58551|) epsv4 off . The .netrc File . (SEE ALSO) getservbyname(3), editrc(5), services(5), ftpd(8) (STANDARDS) tnftp : RFC 959 File Transfer Protocol RFC 1123 Requirements for Internet Hosts - Application and Support RFC 1635 How to Use Anonymous FTP RFC 2389 Feature negotiation mechanism for the File Transfer Protocol RFC 2428 FTP Extensions for IPv6 and NATs RFC 2616 Hypertext Transfer Protocol -- HTTP/1.1 RFC 2822 Internet Message Format RFC 3659 Extensions to FTP RFC 3986 Uniform Resource Identifier (URI) (HISTORY) tnftp 4.2BSD . URL tnftp BSD Luke Mewburn NetBSD 1.3 . IPv6 WIDE/KAME ( IPv6 KAME NetBSD ). (BUGS) . (carriage return) type ascii 4.2BSD . 4.2BSD type ascii . type binary . tnftp IPv4 ( IPv6 ::ffff:10.1.1.1) IPv4 AF_INET . IPv6 . IPv4 AF_INET6 . SIIT IPv6 IPv4 tnftp . Linux 6.12.113+deb13-amd64 February 7, 2026 Linux 6.12.113+deb13-amd64