TLSPROXY(8) System Manager's Manual TLSPROXY(8) (NAME) tlsproxy - TLS Postfix (SYNOPSIS) ?Btlsproxy?R [ Postfix] (DESCRIPTION) ?Btlsproxy?R(8) TLS . ?Bpostscreen?R(8) SMTP-over-TLS SMTP ( ) ?Bsmtp?R(8) TLS SMTP . ?Btlsproxy?R(8) . (PROTOCOL EXAMPLE) ?Bpostscreen?R(8) . ?Btlsproxy?R(8) . STARTTLS SMTP ?Bpostscreen?R(8) SMTP (server) ?Btlsproxy?R(8) . ?Bpostscreen?R(8) " TLS" ?Btlsproxy?R(8) . TLS ?Bpostscreen?R(8) (file descriptor) SMTP ?Btlsproxy?R(8) 220 SMTP . TLS SMTP ?Btlsproxy?R(8) . TLS ?Btlsproxy?R(8) / ?Bpostscreen?R(8) / SMTP . (SECURITY) ?Btlsproxy?R(8) . . chroot . (DIAGNOSTICS) ?Bsyslogd?R(8) ?Bpostlogd?R(8) . (CONFIGURATION PARAMETERS) ?Bmain.cf?R ?Btlsproxy?R(8) . <> . . ?Bpostconf?R(5) . STARTTLS (STARTTLS GLOBAL CONTROLS) ?Btlsproxy?R(8) . ?Btls_append_default_CA (no)?R (CA) *_tls_CApath *_tls_CAfile. ?Btls_daemon_random_bytes (32)?R ?Bsmtp?R(8) ?Bsmtpd?R(8) ?Btlsmgr?R(8) (PRNG) . ?Btls_high_cipherlist ( 'postconf -d' )?R OpenSSL "" (high). ?Btls_medium_cipherlist ( 'postconf -d' )?R OpenSSL "" (medium) . ?Btls_null_cipherlist (eNULL:!aNULL)?R OpenSSL "NULL" . ?Btls_eecdh_strong_curve (prime256v1)?R SMTP ECDH . ?Btls_eecdh_ultra_curve (secp384r1)?R SMTP ECDH . ?Btls_disable_workarounds ( 'postconf -d' )?R OpenSSL . ?Btls_preempt_cipherlist (no)?R SSLv3 SMTP . 2.8 3.7 : ?Btls_low_cipherlist ( 'postconf -d' )?R OpenSSL "" (low) . ?Btls_export_cipherlist ( 'postconf -d' )?R OpenSSL ("export") . 2.9 : ?Btls_legacy_public_key_fingerprints (no)?R 2.9.0 2.9.5 . 2.11 3.1 : ?Btls_dane_digest_agility (on)?R RFC7671 DANE TLSA. ?Btls_dane_trust_anchor_digest_enable (yes)?R DNS RFC 6698 (DANE TLSA) (trust-anchors) "2" . 2.11 : ?Btlsmgr_service_name (tlsmgr)?R ?Btlsmgr?R(8) master.cf. 3.0 : ?Btls_session_ticket_cipher (Postfix >= 3.0: aes-256-cbc, Postfix < 3.0: aes-128-cbc)?R TLS RFC5077. ?Bopenssl_path (openssl)?R OpenSSL ?Bopenssl?R(1). 3.2 : ?Btls_eecdh_auto_curves ( 'postconf -d' )?R SMTP . 3.4 : ?Btls_server_sni_maps (empty)?R SMTP SNI . 3.5 3.4.6 3.3.5 3.2.10 3.1.13 : ?Btls_fast_shutdown_enable (yes)?R TLS . 3.8 : ?Btls_ffdhe_auto_groups ( 'postconf -d' )?R FFDHE SMTP . 3.9 3.8.1 3.7.6 3.6.10 3.5.20 : ?Btls_config_file (default)?R OpenSSL. ?Btls_config_name (empty)?R OpenSSL . STARTTLS (STARTTLS SERVER CONTROLS) SMTP . ?Btlsproxy?R(8) SMTP root . ?Btlsproxy?R(8) . ?Btlsproxy_tls_CAfile ()?R CA ( PEM) SMTP CA . ?Btlsproxy_tls_CApath ()?R CA ( PEM). ?Btlsproxy_tls_always_issue_session_ids ()?R ?Btlsproxy?R(8) TLS TLS . ?Btlsproxy_tls_ask_ccert ()?R SMTP . ?Btlsproxy_tls_ccert_verifydepth ()?R SMTP . ?Btlsproxy_tls_cert_file ()?R RSA ?Btlsproxy?R(8) PEM. ?Btlsproxy_tls_ciphers ()?R TLS ?Btlsproxy?R(8) TLS (opportunistic) . ?Btlsproxy_tls_dcert_file ()?R DSA ?Btlsproxy?R(8) PEM. ?Btlsproxy_tls_dh1024_param_file ()?R DH ?Btlsproxy?R(8) EDH . ?Btlsproxy_tls_dh512_param_file ()?R DH ?Btlsproxy?R(8) EDH . ?Btlsproxy_tls_dkey_file ()?R DSA ?Btlsproxy?R(8) PEM. ?Btlsproxy_tls_eccert_file ()?R ECDSA ?Btlsproxy?R(8) PEM. ?Btlsproxy_tls_eckey_file ()?R ECDSA ?Btlsproxy?R(8) PEM. ?Btlsproxy_tls_eecdh_grade ()?R ?Btlsproxy?R(8) EECDH. ?Btlsproxy_tls_exclude_ciphers ()?R ?Btlsproxy?R(8) . ?Btlsproxy_tls_fingerprint_digest ()?R SMTP . ?Btlsproxy_tls_key_file ()?R RSA ?Btlsproxy?R(8) PEM. ?Btlsproxy_tls_loglevel ()?R ?Btlsproxy?R(8) TLS. ?Btlsproxy_tls_mandatory_ciphers ()?R TLS ?Btlsproxy?R(8) TLS . ?Btlsproxy_tls_mandatory_exclude_ciphers ()?R TLS. ?Btlsproxy_tls_mandatory_protocols ()?R SSL/TLS ?Btlsproxy?R(8) TLS. ?Btlsproxy_tls_protocols ()?R TLS ?Btlsproxy?R(8) . ?Btlsproxy_tls_req_ccert ()?R TLS SMTP . ?Btlsproxy_tls_security_level ()?R SMTP TLS ?Btlsproxy?R(8) smtpd_use_tls smtpd_enforce_tls . ?Btlsproxy_tls_chain_files ()?R ?Btlsproxy?R(8) PEM. 3.9 : ?Btlsproxy_tls_enable_rpk ()?R SMTP RFC7250 X.509 . STARTTLS (STARTTLS CLIENT CONTROLS) SMTP . ?Btlsproxy?R(8) SMTP root . 3.4 : ?Btlsproxy_client_CAfile ()?R CA TLS CA . ?Btlsproxy_client_CApath ()?R PEM TLS . ?Btlsproxy_client_chain_files ()?R ?Btlsproxy?R(8) PEM. ?Btlsproxy_client_cert_file ()?R RSA ?Btlsproxy?R(8) PEM. ?Btlsproxy_client_key_file ()?R RSA ?Btlsproxy?R(8) PEM. ?Btlsproxy_client_dcert_file ()?R DSA ?Btlsproxy?R(8) PEM. ?Btlsproxy_client_dkey_file ()?R DSA ?Btlsproxy?R(8) PEM. ?Btlsproxy_client_eccert_file ()?R ECDSA ?Btlsproxy?R(8) PEM. ?Btlsproxy_client_eckey_file ()?R ECDSA ?Btlsproxy?R(8) PEM. ?Btlsproxy_client_fingerprint_digest ()?R TLS . ?Btlsproxy_client_loglevel ()?R TLS ?Btlsproxy?R(8). ?Btlsproxy_client_loglevel_parameter (smtp_tls_loglevel)?R tlsproxy_client_loglevel . ?Btlsproxy_client_scert_verifydepth ()?R TLS . ?Btlsproxy_client_use_tls ()?R : TLS TLS . ?Btlsproxy_client_enforce_tls ()?R : SMTP TLS . ?Btlsproxy_client_per_site ()?R TLS TLS . 3.4 3.6 : ?Btlsproxy_client_level ()?R TLS ?Btlsproxy?R(8). ?Btlsproxy_client_policy ()?R TLS . 3.7 : ?Btlsproxy_client_security_level ()?R TLS ?Btlsproxy?R(8). ?Btlsproxy_client_policy_maps ()?R TLS . STARTTLS (OBSOLETE STARTTLS SUPPORT CONTROLS) ?Bsmtpd?R(8) . ?Btlsproxy_use_tls ()?R TLS : STARTTLS . ?Btlsproxy_enforce_tls ()?R TLS : STARTTLS TLS. ?Btlsproxy_client_use_tls ()?R : TLS TLS . ?Btlsproxy_client_enforce_tls ()?R : SMTP TLS . (RESOURCE CONTROLS) ?Btlsproxy_watchdog_timeout (10s)?R ?Btlsproxy?R(8) / (watchdog) . (MISCELLANEOUS CONTROLS) ?Bconfig_directory ( 'postconf -d' )?R main.cf master.cf . ?Bprocess_id ()?R (PID) . ?Bprocess_name ()?R . ?Bsyslog_facility (mail)?R syslog . ?Bsyslog_name ( 'postconf -d' )?R syslog . 3.3 : ?Bservice_name ()?R master.cf . (SEE ALSO) postscreen(8), smtpd(8), SMTP postconf(5), postlogd(8), syslogd(8), (LICENSE) Secure Mailer . (HISTORY) . . (AUTHORS) Wietse Venema IBM T.J. Watson Research P.O. Box 704 Yorktown Heights, NY 10598, USA Wietse Venema Google, Inc. 111 8th Avenue New York, NY 10011, USA TLSPROXY(8)