SSSD-LDAP(5) File Formats and Conventions SSSD-LDAP(5) (NAME) sssd-ldap - LDAP SSSD (DESCRIPTION) LDAP sssd(8) . "FILE FORMAT" sssd.conf(5) . SSSD LDAP . LDAP id auth access chpass . LDAP TLS/SSL LDAPS . sssd . LDAP . LDAP "ldap_access_filter" . (CONFIGURATION OPTIONS) SSSD LDAP . "DOMAIN SECTIONS" sssd.conf(5) . LDAP SSSD sssd-ldap-attributes(5) . ldap_uri, ldap_backup_uri (string) URI LDAP SSSD . " (FAILOVER)" . . " (SERVICE DISCOVERY)" . URI RFC 2732 : ldap[s]://[:port] IPv6 [] : ldap://[fc00::126:25]:389 ldap_chpass_uri, ldap_chpass_backup_uri (string) URI LDAP SSSD . " (FAILOVER)" . ldap_chpass_dns_service_name . : ldap_uri . ldap_search_base (string) (base DN) LDAP. SSSD 1.7.0 SSSD : search_base[?scope?[filter][?search_base?scope?[filter]]*] (scope) "base" "onelevel" "subtree" . LDAP http://www.ietf.org/rfc/rfc2254.txt : ldap_search_base = dc=example,dc=com ( ) ldap_search_base = dc=example,dc=com?subtree? ldap_search_base = cn=host_specific,dc=example,dc=com?subtree?(host=thishost)?dc=example.com?subtree? : ( ) . . : defaultNamingContext namingContexts RootDSE LDAP . defaultNamingContext namingContexts . namingContexts DN LDAP . . ldap_read_rootdse (string) SSSD LDAP RootDSE . . LDAP . SSSD . : o anonymous o authenticated o never "anonymous" SSSD RootDSE . . : anonymous ldap_schema (string) (Schema Type) LDAP . . . : o rfc2307 o rfc2307bis o IPA o AD . rfc2307 memberUid . rfc2307bis IPA DN member . AD Active Directory 2008r2 . : rfc2307 ldap_pwmodify_mode (string) . : o exop - (RFC 3062) o ldap_modify - userPassword ( ). o exop_force - (RFC 3062) (grace login). LDAP (authenticated bind) . : (bind) . userPassword . : exop ldap_default_bind_dn (string) bind DN LDAP. ldap_default_authtok_type (string) bind DN . : password obfuscated_password : password sss_obfuscate(8) . ldap_default_authtok (string) bind DN . ldap_force_upper_case_realm (boolean) Active Directory realm UPN . realm . : false ldap_enumeration_refresh_timeout (integer) SSSD (enumerated) . : 300 ldap_purge_cache_timeout (integer) ( ) . . (enumeration) . enumeration . subdomain_inherit . : 0 () ldap_group_nesting_level (integer) ldap_schema (schema) ( RFC2307bis) SSSD . RFC2307 . : . . . ldap_group_nesting_level 0 . Active Directory 2008 "id_provider=ad" ldap_use_tokengroups false Token-Groups . : 2 ldap_use_tokengroups Token-Groups initgroup Active Directory Server 2008 . subdomain_inherit . : AD IPA True False. ldap_host_search_base (string) . (search base) (host). "ldap_search_base" . : ldap_search_base ldap_subid_ranges_search_base (string) . (subordinate ranges). : IPA cn=subids,%basedn ldap_search_base. ldap_service_search_base (string) base DN (scope) LDAP LDAP . : search_base[?scope?[filter][?search_base?scope?[filter]]*] (scope) "base" "onelevel" "subtree" . 4.5.1.2 http://tools.ietf.org/html/rfc4511 . LDAP http://www.ietf.org/rfc/rfc2254.txt . "ldap_search_base" . : ldap_search_base scope filter Active Directory Range Retrieval . ldap_iphost_search_base (string) base DN (scope) LDAP LDAP . : search_base[?scope?[filter][?search_base?scope?[filter]]*] (scope) "base" "onelevel" "subtree" . 4.5.1.2 http://tools.ietf.org/html/rfc4511 . LDAP http://www.ietf.org/rfc/rfc2254.txt . "ldap_search_base" . : ldap_search_base scope filter Active Directory Range Retrieval . ldap_ipnetwork_search_base (string) base DN (scope) LDAP LDAP . : search_base[?scope?[filter][?search_base?scope?[filter]]*] (scope) "base" "onelevel" "subtree" . 4.5.1.2 http://tools.ietf.org/html/rfc4511 . LDAP http://www.ietf.org/rfc/rfc2254.txt . "ldap_search_base" . : ldap_search_base scope filter Active Directory Range Retrieval . ldap_search_timeout (integer) ( ) LDAP ( ) . : SSSD . . subdomain_inherit . : 6 ldap_enumeration_search_timeout (integer) ( ) LDAP ( ) . : 60 ldap_network_timeout (integer) ( ) poll(2)/select(2) connect(2) . subdomain_inherit . : 6 ldap_opt_timeout (integer) ( ) API LDAP . KDC SASL LDAP StartTLS . subdomain_inherit . : 8 ldap_connection_expire_timeout (integer) ( ) LDAP . . SASL/GSSAPI ( TGT) . ldap_opt_timeout ( ) . ldap_connection_expire_timeout <= ldap_opt_timout . ldap_connection_expire_offset . subdomain_inherit . : 900 (15 ) ldap_connection_expire_offset (integer) 0 ldap_connection_expire_timeout . subdomain_inherit . : 0 ldap_connection_idle_timeout (integer) ( ) LDAP . . 0 . subdomain_inherit . : 900 (15 ) ldap_page_size (integer) LDAP . LDAP . : 1000 ldap_disable_paging (boolean) LDAP . LDAP LDAP RootDSE . : OpenLDAP RootDSE . : 389 DS . . : False ldap_disable_range_retrieval (boolean) Active Directory . Active Directory MaxValRange 1500 . 1500 AD . SSSD . . SSSD . MaxValRange Active Directory . : False ldap_sasl_minssf (integer) LDAP SASL . OpenLDAP . : ( ldap.conf ) ldap_sasl_maxssf (integer) LDAP SASL . OpenLDAP . : ( ldap.conf ) ldap_deref_threshold (integer) (cache) (dereference) . . dereference 0 . SSSD IPA HBAC dereference dereference dereference rootDSE dereference . dereference LDAP . LDAP dereference . 389/RHDS OpenLDAP Active Directory. : (search bases) dereference . : 10 ldap_ignore_unreadable_references (bool) LDAP member . false . AD sssd AD LDAP . : False ldap_tls_reqcert (string) TLS . : never = . allow = . . . try = . . . demand = . . hard = "demand" : hard ldap_tls_cacert (string) (CA) sssd . : OpenLDAP /etc/openldap/ldap.conf ldap_tls_cacertdir (string) (CA) . '.0' . openssl rehash c_rehash . : OpenLDAP /etc/openldap/ldap.conf ldap_tls_cert (string) . : ldap_tls_key (string) . : ldap_tls_cipher_suite (string) (cipher suites) . . ldap.conf(5) . : OpenLDAP /etc/openldap/ldap.conf ldap_id_use_start_tls (boolean) id_provider tls . true . : true ldap_id_mapping (boolean) SSSD ldap_user_objectsid ldap_group_objectsid ldap_user_uid_number ldap_group_gid_number . objectSID ActiveDirectory . : false ldap_min_id, ldap_max_id (integer) SID ldap_id_mapping true ldap_user_uid_number ldap_group_gid_number . / . ldap_min_id ldap_max_id . . : ( 0 ) ldap_sasl_mech (string) SASL . GSSAPI GSS-SPNEGO . ldap_sasl_mech . ldap_sasl_mech . TRUSTED DOMAIN SECTION sssd.conf(5) . : ldap_sasl_authid (string) SASL . GSSAPI/GSS-SPNEGO Kerberos . ( host/myhost@EXAMPLE.COM) ( host/myhost) . : hostname@REALM netbiosname$@REALM host/hostname@REALM *$@REALM host/*@REALM netbiosname$@* host/* keytab . : host/hostname@REALM ldap_sasl_realm (string) (realm) SASL . krb5_realm . ldap_sasl_authid realm . : krb5_realm. ldap_sasl_canonicalize (boolean) true LDAP (canonicalize) (bind) SASL . : false; ldap_krb5_keytab (string) keytab SASL/GSSAPI/GSS-SPNEGO . subdomain_inherit . : keytab /etc/krb5.keytab ldap_krb5_init_creds (boolean) id_provider Kerberos (TGT) . SASL GSSAPI GSS-SPNEGO . : true ldap_krb5_ticket_lifetime (integer) TGT GSSAPI GSS-SPNEGO . subdomain_inherit . : 86400 (24 ) krb5_server, krb5_backup_server (string) IP Kerberos SSSD . "FAILOVER" . ( ) . - "SERVICE DISCOVERY" . KDC kpasswd SSSD DNS _udp _tcp . SSSD "krb5_kdcip" . "krb5_server" . krb5_realm (string) (REALM) ( SASL/GSSAPI/GSS-SPNEGO) . : /etc/krb5.conf krb5_canonicalize (boolean) principal LDAP (canonicalize) . MIT Kerberos >= 1.7 . : false krb5_use_kdcinfo (boolean) SSSD Kerberos realm KDC . Kerberos krb5.conf(5) . (locator plugin) sssd_krb5_locator_plugin(8) . : true ldap_pwd_policy (string) . : none - . . shadow - shadow(5) . <> . mit_kerberos - MIT Kerberos . chpass_provider=krb5 . : none : . ldap_referrals (boolean) (referral chasing) . sssd OpenLDAP 2.4.13 . Microsoft Active Directory . false . LDAP SSSD Microsoft Active Directory false . SSSD AD DC . : true ldap_dns_service_name (string) . : ldap ldap_chpass_dns_service_name (string) LDAP . : ldap_chpass_update_last_change (bool) ldap_user_shadow_last_change (Epoch) . <> SSSD LDAP shadowLastChange SSSD . : False ldap_access_filter (string) access_provider = ldap ldap_access_order = filter () . LDAP . access_provider = ldap ldap_access_order = filter . access_provider = permit . LDAP ( memberOf AD ). sssd- simple(5) . : access_provider = ldap ldap_access_filter = (employeeType=admin) employeeType "admin" . (online) . . : ldap_account_expire_policy (string) . LDAP bind . : shadow: ldap_user_shadow_expire . ad: ldap_user_ad_user_account_control . . . rhds ipa 389ds: ldap_ns_account_lock . nds: ldap_user_nds_login_allowed_time_map ldap_user_nds_login_disabled ldap_user_nds_login_expiration_time . . ldap_access_order "expire" ldap_account_expire_policy . : ldap_access_order (string) . : filter: ldap_access_filter lockout: . ldap 'pwdAccountLockedTime' '000001010000Z' . ldap_pwdlockout_dn . 'access_provider = ldap' . "ppolicy" . ppolicy: . ldap 'pwdAccountLockedTime' '000001010000Z' . 'pwdAccountLockedTime' 'Z' UTC . "access-denied" . ldap_pwdlockout_dn . 'access_provider = ldap' . expire: ldap_account_expire_policy pwd_expire_policy_reject, pwd_expire_policy_warn, pwd_expire_policy_renew: - SSH. : o pwd_expire_policy_reject - o pwd_expire_policy_warn - o pwd_expire_policy_renew - . 'access_provider = ldap' . 'ldap_pwd_policy' shadow mit_kerberos . authorized_service: authorizedService host: host rhost: rhost rhost pam pam : filter . ldap_pwdlockout_dn (string) DN LDAP . sssd.conf ppolicy LDAP . : cn=ppolicy,ou=policies,dc=example,dc=com : cn=ppolicy,ou=policies,$ldap_search_base ldap_deref (string) (alias dereferencing) . : never: . searching: . finding: . always: . : ( LDAP never ) ldap_rfc2307_fallback_to_local_users (boolean) LDAP RFC2307 . RFC2307 memberUid LDAP . SSSD nsswitch getpw*() initgroups() <<>> . initgroups() LDAP . : false wildcard_limit (integer) (wildcard lookup) . InfoPipe . : 1000 ( ) ldap_library_debug_level (integer) libldap . libldap debug_level . OpenLDAP -1 . : 0 ( libldap ) ldap_use_ppolicy (boolean) . ppolicy . : true ldap_ppolicy_pwd_change_threshold (integer) (grace logins) . : . : 0 SUDO (SUDO OPTIONS) sudo_provider sssd-sudo(5) . ldap_sudo_full_refresh_interval (integer) SSSD sudo ( ) . ldap_sudo_smart_refresh_interval . 0 . . : 21600 ( ) ldap_sudo_smart_refresh_interval (integer) SSSD sudo ( USN USN SSSD ) . USN modifyTimestamp . : USN : ) sudo ( ) ) ( ) ) ( ldap_connection_expire_timeout ). 0 . . : 900 ( ) ldap_sudo_random_offset (integer) 0 . . SSSD sudo . sudo . 0 . : 0 () ldap_sudo_use_host_filter (boolean) true SSSD ( / IPv4 IPv6 ). : true ldap_sudo_hostnames (string) (FQDN) . SSSD . ldap_sudo_use_host_filter false . : ldap_sudo_ip (string) / IPv4 IPv6 . SSSD . ldap_sudo_use_host_filter false . : ldap_sudo_include_netgroups (boolean) true SSSD netgroup sudoHost . ldap_sudo_use_host_filter false . : true ldap_sudo_include_regexp (boolean) true SSSD (wildcard) sudoHost . ldap_sudo_use_host_filter false . (wildcard) LDAP ! : false . sudo sudoers.ldap(5) . AUTOFS (AUTOFS OPTIONS) LDAP . ldap_autofs_map_master_name (string) automount LDAP. : auto.master ldap_autofs_map_object_class (string) automount LDAP. : nisMap (rfc2307, autofs_provider=ad) automountMap ldap_autofs_map_name (string) automount LDAP. : nisMapName (rfc2307, autofs_provider=ad) automountMapName ldap_autofs_entry_object_class (string) automount LDAP. (mount point) . : nisObject (rfc2307, autofs_provider=ad) automount ldap_autofs_entry_key (string) automount LDAP. . : cn (rfc2307, autofs_provider=ad) automountKey ldap_autofs_entry_value (string) automount LDAP. . : nisMapEntry (rfc2307, autofs_provider=ad) automountInformation automounter autofs sssd.conf SSSD automounter . (ADVANCED OPTIONS) LDAP . . ldap_netgroup_search_base (string) DN (scope) LDAP LDAP . : search_base[?scope?[filter][?search_base?scope?[filter]]*] "base" "onelevel" "subtree" . 4.5.1.2 http://tools.ietf.org/html/rfc4511 . LDAP http://www.ietf.org/rfc/rfc2254.txt . "ldap_search_base" . : ldap_search_base Active Directory Range Retrieval . ldap_user_search_base (string) DN (scope) LDAP LDAP . : search_base[?scope?[filter][?search_base?scope?[filter]]*] "base" "onelevel" "subtree" . 4.5.1.2 http://tools.ietf.org/html/rfc4511 . LDAP http://www.ietf.org/rfc/rfc2254.txt . "ldap_search_base" . : ldap_search_base Active Directory Range Retrieval . ldap_group_search_base (string) DN (scope) LDAP LDAP . : search_base[?scope?[filter][?search_base?scope?[filter]]*] "base" "onelevel" "subtree" . 4.5.1.2 http://tools.ietf.org/html/rfc4511 . LDAP http://www.ietf.org/rfc/rfc2254.txt . "ldap_search_base" . : ldap_search_base Active Directory Range Retrieval . "ldap_use_tokengroups" Active Directory GID . . ldap_sudo_search_base (string) DN (scope) LDAP LDAP . : search_base[?scope?[filter][?search_base?scope?[filter]]*] "base" "onelevel" "subtree" . 4.5.1.2 http://tools.ietf.org/html/rfc4511 . LDAP http://www.ietf.org/rfc/rfc2254.txt . "ldap_search_base" . : ldap_search_base Active Directory Range Retrieval . ldap_autofs_search_base (string) DN (scope) LDAP LDAP . : search_base[?scope?[filter][?search_base?scope?[filter]]*] "base" "onelevel" "subtree" . 4.5.1.2 http://tools.ietf.org/html/rfc4511 . LDAP http://www.ietf.org/rfc/rfc2254.txt . "ldap_search_base" . : ldap_search_base Active Directory Range Retrieval . (FAILOVER) . . . . : primary backup. (primary) (backup) . . SSSD . () . . (resolve) . . . . . (hard-coded) . . DNS (site) . SSSD . SSSD . . sssd.conf(5) . dns_resolver_server_timeout SSSD DNS . : 1000 dns_resolver_op_timeout SSSD DNS ( SRV) . : 3 dns_resolver_timeout SSSD . DNS SRV . : 6 LDAP LDAP . "ldap_opt_timeout" "dns_resolver_timeout" "dns_resolver_op_timeout" "dns_resolver_server_timeout" . (SERVICE DISCOVERY) DNS . . . "_srv_" . . DNS . "dns_discovery_domain" sssd.conf(5) . _tcp . . RFC 2782 . (ID MAPPING) SSSD POSIX Active Directory . : ID-mapping uidNumber gidNumber . . . . SSSD SSSD . () . . sss_cache(8) : o o SSSD o o SSSD . Active Directory objectSID . objectSID Active Directory (RID) . ID-mapping SSSD UID - <<>> (slices) - . Active Directory . SSSD . : SID murmurhash3 . . : . ( ). POSIX Active Directory ( ID-mapping) . "" . ( "[domain/DOMAINNAME]": ldap_id_mapping = True ldap_schema = ad . . ldap_idmap_range_min ( ) ( ) POSIX SID Active Directory . POSIX . : "min_id" "min_id" . "min_id" "ldap_idmap_range_min" . : 200000 ldap_idmap_range_max ( ) ( ) POSIX SID Active Directory . POSIX . : "max_id" "max_id" . "max_id" "ldap_idmap_range_max" . : 2000200000 ldap_idmap_range_size ( ) . . : RID Active Directory . RID . Active Directory objectSid=S-1-5-21-2153326666-2176343378-3404031434-1107 "ldap_idmap_range_size" 1108 RID RID ( : 1108 = 1107 - 0 + 1). . : 200000 ldap_idmap_default_domain_sid () SID . murmurhash . : ldap_idmap_default_domain () . : ldap_idmap_autorid_compat () ID-mapping "idmap_autorid" winbind . . : (non-deterministic) ( ). winbind "ldap_idmap_default_domain_sid" . : False ldap_idmap_helper_table_size ( ) UNIX SID . : SID UNIX RID SID . ldap_idmap_helper_table_size 0 . : 10 SID (Well-Known SIDs) SSSD Well-Known SID ( SID ) . Well-Known SID Linux/UNIX POSIX ID . SID (authorities) . Well-Known SID : o Null Authority o World Authority o Local Authority o Creator Authority o Mandatory Label Authority o Authentication Authority o NT Authority o Built-in (capitalized) (fully qualified name) Well-Known SID . SID SID SSSD SID . Well-Known SID . "NULL AUTHORITY" "WORLD AUTHORITY" "LOCAL AUTHORITY" "CREATOR AUTHORITY" "MANDATORY LABEL AUTHORITY" "AUTHENTICATION AUTHORITY" "NT AUTHORITY" "BUILTIN" sssd.conf . (EXAMPLE) SSSD LDAP [domains] . [domain/LDAP] id_provider = ldap auth_provider = ldap ldap_uri = ldap://ldap.mydomain.org ldap_search_base = dc=mydomain,dc=org ldap_tls_reqcert = demand cache_credentials = true LDAP (LDAP ACCESS FILTER EXAMPLE) SSSD ldap_access_order=lockout . [domain/LDAP] id_provider = ldap auth_provider = ldap access_provider = ldap ldap_access_order = lockout ldap_pwdlockout_dn = cn=ppolicy,ou=policies,dc=mydomain,dc=org ldap_uri = ldap://ldap.mydomain.org ldap_search_base = dc=mydomain,dc=org ldap_tls_reqcert = demand cache_credentials = true (NOTES) ldap.conf(5) OpenLDAP 2.4 . (SEE ALSO) sssd(8), sssd.conf(5), sssd-ldap(5), sssd-ldap-attributes(5), sssd- krb5(5), sssd-simple(5), sssd-ipa(5), sssd-ad(5), sssd-idp(5), sssd- sudo(5), sssd-session-recording(5), sss_cache(8), sss_debuglevel(8), sss_obfuscate(8), sss_seed(8), sssd_krb5_locator_plugin(8), sss_ssh_authorizedkeys(1), sss_ssh_knownhosts(1), sssd-ifp(5), pam_sss(8). sss_rpcidmapd(5) (AUTHORS) SSSD - https://github.com/SSSD/sssd SSSD 06/09/2026 SSSD-LDAP(5)