SNMPCMD(1) Net-SNMP SNMPCMD(1) (NAME) snmpcmd - Net- SNMP (SYNOPSIS) snmpcmd [OPTIONS] AGENT [PARAMETERS] (DESCRIPTION) SNMP : snmpbulkget, snmpbulkwalk, snmpdelta, snmpget, snmpgetnext, snmpnetstat, snmpset, snmpstatus, snmptable, snmptest, snmptrap, snmpdf, snmpusm , snmpwalk . SNMP SNMP agent . ( ) agent . . (COMMAND-LINE CONFIG OPTIONS) snmp.conf .conf Net-SNMP <<-->> . --dontLoadHostConfig=true . snmp.conf (double-dash) (single-dash) . snmp.conf snmp.conf . (GENERIC OPTIONS) Net-SNMP SNMP . SNMP . -d SNMP ( ) (dump) . -D[TOKEN[,...]] TOKEN() . ALL . -h, --help . -H . -I [brRhu] . INPUT OPTIONS . -L [eEfFoOsS] (logging) . LOGGING OPTIONS . -m MIBLIST MIB ( ) . MIBS mibs snmp.conf MIB Net-SNMP ( ) . MIBLIST <<->> <<+>> MIB . MIB . ALL MIB MIB . <<.>> MIB . -M DIRLIST MIB . MIBDIRS mibdirs snmp.conf Net- SNMP (/usr/share/snmp/mibs) ( ) . DIRLIST <<->> <<+>> . . . MIB MIBDIRS ("") . MIB -m mibs -M ( ) . mibfile MIB MIB . -v 1 | 2c | 3 : 1 (RFC 1155-1157) 2c (RFC 1901-1908) 3 (RFC 2571-2574). 3 . defVersion snmp.conf . -O [abeEfnqQsStTuUvxX] . OUTPUT OPTIONS . -P [cdeRuwW] MIB . MIB PARSING OPTIONS . -r retries . 5 . -t timeout . 1 . . -V, --version . -Yname="value" --name="value" ("name") snmp.conf "value" . snmp.conf . snmp.conf(5) ..SH " SNMPv3 (SNMPv3 Options)" SNMPv3 SNMPv3 USM SNMPv3 (D)TLS. -l secLevel securityLevel SNMPv3 (noAuthNoPriv|authNoPriv|authPriv). noAuthNoPriv () . defSecurityLevel snmp.conf . -n contextName contextName SNMPv3. contextName "" . defContext snmp.conf . SNMPv3 TLS (SNMPv3 over TLS Options) (transport) TLS . SNMP TLS DTLS snmp.conf . : Net-SNMP X.509 SNMP "tls" . ~/.snmp/tls /usr/local/share/snmp/tls . ( ) . Net-SNMP net-snmp-cert . (fingerprint) ( net-snmp-cert ) . "snmpd.crt" "snmpd" . -T localCert= (D)TLS . ( snmpd snmptrapd perl python) "snmpapp" ( snmpget snmpwalk ) . localCert snmp.conf . -T peerCert= . ( ). peerCert snmp.conf . -T trust_cert= CA (trust anchor) . Net- SNMP . "trustCert" snmp.conf . -T their_hostname= ( goodhost.example.com badhost.example.com ). subjectAltName CommonName X.509 . SNMPv3 USM (SNMPv3 with USM Options) SNMPv3 (USM) . -3[MmKk] 0xHEXKEY SNMPv3 . ( -3m -3M) ( -3k -3K) . SNMPv3 -A -X ( ) . SNMPv3 Net-SNMP ( http://www.Net-SNMP.org/tutorial-5/commands ). defAuthMasterKey (-3m) defPrivMasterKey (-3M) defAuthLocalizedKey (-3k) defPrivLocalizedKey (-3K) snmp.conf : snmp.conf(5). -a authProtocol (MD5|SHA|SHA-512|SHA-384|SHA-256|SHA-224) SNMPv3. defAuthType snmp.conf . -A authPassword SNMPv3. defAuthPassphrase snmp.conf . : snmp.conf(5). -e engineID engineID (authoritative ) REQUEST SNMPv3 ( "0x") . engine ID . -E engineID context engineID scopedPdu REQUEST SNMPv3 . engineID . -u secName securityName SNMPv3. defSecurityName snmp.conf . -x privProtocol (DES AES) SNMPv3. defPrivType snmp.conf . Net-SNMP OpenSSL . -X privPassword SNMPv3. defPrivPassphrase snmp.conf . : snmp.conf(5). -Z boots,time engineBoots engineTime SNMPv3. boots/time LCD . ..SH " SNMPv1 SNMPv2c (SNMPv1 and SNMPv2c Options)" -c community community SNMPv1/v2c . defCommunity snmp.conf . (AGENT SPECIFICATION) AGENT (SYNOPSIS) SNMP . : [:] AGENT IPv4 << >> (dotted quad) . UDP/IPv4 161 . : udp hostname[:port] IPv4-address[:port] tcp hostname[:port] IPv4-address[:port] unix pathname ipx [network]:node[/port] aal5pvc pvc [interface.][VPI.]VCI udp6 udpv6 udpipv6 hostname[:port] IPv6-address:port '['IPv6-address']'[:port] tcp6 tcpv6 tcpipv6 hostname[:port] IPv6-address:port '['IPv6-address']'[:port] <> <> . : hostname:161 UDP/IPv4 hostname 161. <<:161>> SNMP . udp:hostname . <> UDP/IPv4 . TCP:hostname:1161 hostname 1161 TCP/IPv4 . udp6:hostname:10161 UDP/IPv6 10161 hostname ( AAAA ). UDP6:[fe80::2d0:b7ff:fe21:c6c0] UDP/IPv6 161 fe80::2d0:b7ff:fe21:c6c0. tcpipv6:[::1]:1611 1611 (::1 IPv6) TCP/IPv6 . tls:hostname:10161 dtls:hostname:10161 SNMP DTLS TLS ISMS ( RFC ). TSM ( ). ( ). ssh:hostname:22 SNMP SSH ISMS ( RFC ). TSM (--defSecurityModel=tsm). ipx::00D0B7AAE308 IPX 00D0B7AAE308 IPX 36879 (900F ) RFC 1906 . ipx:0AE43409:00D0B721C6C0/1161 IPX 1161 00D0B721C6C0 0AE43409. unix:/tmp/local-agent /tmp/local-agent . /tmp/local-agent <> . alias:myname myname snmp.conf alias myname udp:127.0.0.1:9161 . . . AAL5PVC:100 PDU AAL5 VPI=0 VCI=100 ( ) ATM . PVC:1.10.32 PDU AAL5 VPI=10 ( ) VCI=32 ( ) ATM . <> <> . IPv6 udp6 <> . AAL5 PVC Linux ..SH " MIB (MIB PARSING OPTIONS)" MIB Net-SNMP Structure of Management Information (SMI) . () MIB MIB . -Pc () ASN.1 MIB (/ ). <<-->> MIB . ( ) commentToEOL . -Pd DESCRIPTION MIB MIB . . -Pe MIB . IMPORT MIB MIB . showMibErrors . -PR MIB ( ) MIB . . mibReplaceWithLatest . MIB OID ( MIB ). -Pu (underline) MIB . SMI MIB . mibAllowUnderline . -Pw MIB OID . mibWarningLevel 1 . -PW MIB . mibWarningLevel 2 . (OUTPUT OPTIONS) SNMP -O . ( ): $ snmpget -c public -v 1 localhost sysUpTime.0 SNMPv2-MIB::sysUpTime.0 = Timeticks: (14096763) 1 day, 15:09:27.63 -Oa ASCII ( DISPLAY-HINT MIB ). . Display Hint . -Ob (instance) OID : $ snmpgetnext -c public -v 1 localhost vacmSecurityModel SNMP-VIEW-BASED-ACM-MIB::vacmSecurityModel.0."wes" = xxx $ snmpgetnext -c public -v 1 -Ob localhost vacmSecurityModel SNMP-VIEW-BASED-ACM-MIB::vacmSecurityModel.0.3.119.101.115 = xxx -Oe (enumeration) : $ snmpget -c public -v 1 localhost ipForwarding.0 IP-MIB::ipForwarding.0 = INTEGER: forwarding(1) $ snmpget -c public -v 1 -Oe localhost ipForwarding.0 IP-MIB::ipForwarding.0 = INTEGER: 1 -OE (escape) : $ snmpgetnext -c public -v 1 localhost vacmSecurityModel SNMP-VIEW-BASED-ACM-MIB::vacmSecurityModel.0."wes" = xxx $ snmpgetnext -c public -v 1 -OE localhost vacmSecurityModel SNMP-VIEW-BASED-ACM-MIB::vacmSecurityModel.0.\"wes\" = xxx . -Of OID MIB : .iso.org.dod.internet.mgmt.mib-2.system.sysUpTime.0 = Timeticks: (14096763) 1 day, 15:09:27.63 -On OID : .1.3.6.1.2.1.1.3.0 = Timeticks: (14096763) 1 day, 15:09:27.63 -Op PRECISION PRECISION . (float/double) OPAQUE . PRECISION flag/field width/precision printf(3) : $ snmpget localhost outputVoltage.1 WIENER-CRATE-MIB::outputVoltage.u0 = Opaque: Float: 0.000000 V $ snmpget -Op +020.12 localhost outputVoltage.1 WIENER-CRATE-MIB::outputVoltage.u0 = Opaque: Float: +000000.000000000000 V -Oq varbind : SNMPv2-MIB::sysUpTime.0 1:15:09:27.63 -OQ varbind : SNMPv2-MIB::sysUpTime.0 = 1:15:09:27.63 -Os MIB ( ) : sysUpTime.0 = Timeticks: (14096763) 1 day, 15:09:27.63 -OS MIB : SNMPv2-MIB::sysUpTime.0 = Timeticks: (14096763) 1 day, 15:09:27.63 OID . -Ot TimeTicks : SNMPv2-MIB::sysUpTime.0 = 14096763 -OT (Hex) . -Ou OID UCD ( CMU) . <<>> OID MIB ( ) : system.sysUpTime.0 = Timeticks: (14096763) 1 day, 15:09:27.63 -OU UNITS . -Ov varbind OID : $ snmpget -c public -v 1 -Ov localhost ipForwarding.0 INTEGER: forwarding(1) -Ox (Hex) ( DISPLAY-HINT MIB ). . Display Hint . -OX <<>> : $ snmpgetnext -c public -v 1 localhost ipv6RouteTable IPv6-MIB::ipv6RouteIfIndex.63.254.1.0.255.0.0.0.0.0.0.0.0.0.0.0.64.1 = INTEGER: 2 $ snmpgetnext -c public -v 1 -OX localhost ipv6RouteTable IPv6-MIB::ipv6RouteIfIndex[3ffe:100:ff00:0:0:0:0:0][64][1] = INTEGER: 2 . snmp.conf(5) . (LOGGING OPTIONS) -L . -Ln . -Le (standard error). -Lf FILE . -Lo (standard output). -Ls FACILITY syslog (facility) ('d' LOG_DAEMON 'u' LOG_USER '0' '7' LOG_LOCAL0 LOG_LOCAL7). << >> . : -LE pri 'pri' . 'pri' - -LE pri1-pri2 'pri1' 'pri2' ( ) . -LF -LS . : 0 ! LOG_EMERG 1 a LOG_ALERT 2 c LOG_CRIT 3 e LOG_ERR 4 w LOG_WARNING 5 n LOG_NOTICE 6 i LOG_INFO 7 d LOG_DEBUG. LOG_NOTICE ( !). (INPUT OPTIONS) -I . . -Ib (regular expression) ( ) MIB . <<>> - . MIB vacmSecurityModel vacmsecuritymodel ( / ) vacm.*model ( ) . '.' (instance subidentifiers) . << >> MIB . sys*ontact.0 sysContact.0 ( sys*ontact sysContact ). MIB ( SNMPv2-MIB::sys.*ontact ). -Ih DISPLAY-HINT . (raw) : snmpset ... HOST-RESOURCES-MIB::hrSystemDate.0 x "07 D2 0C 0A 02 04 06 08" : snmpset ... HOST-RESOURCES-MIB::hrSystemDate.0 = 2002-12-10,2:4:6.8 -Ir MIB . () (agent) ( ) . ( ) . -IR << >> (random access) MIB . OID MIB ( MIB) MIB . .iso.org.dod.internet.mib-2.system.sysDescr.0 ( SNMPv2-MIB::sysDescr.0) sysDescr.0 . : MIB MIB MIB . MIB-MODULE::objectName MIB ( MIB ). -Is SUFFIX OID . (index) . -IS PREFIX OID . MIB ( ). -Iu UCD OID . OID 'mib-2' ( '.' MIB ). sysDescr system.sysDescr.0 . '.' OID << >> (fully qualified) MIB MIB . MIB -Ib -IR -Iu . OID <<>> OID ( ) << >> (-IR) << >> (-Ib) ..SH " (ENVIRONMENT VARIABLES)" PREFIX ( UCD). .iso.org.dod.internet.mgmt.mib-2 . MIBS MIB . : SNMPv2-TC:SNMPv2-MIB:IF-MIB:IP-MIB:TCP-MIB:UDP-MIB: SNMP-VACM-MIB. -m . MIBDIRS MIB. /usr/share/snmp/mibs . -M . (FILES) /etc/snmp/snmpd.conf (Agent). : snmpd.conf(5). /etc/snmp/snmp.conf ~/.snmp/snmp.conf . : snmp.conf(5). (SEE ALSO) snmpget(1), snmpgetnext(1), snmpset(1), snmpbulkget(1), snmpbulkwalk(1), snmpwalk(1), snmptable(1), snmpnetstat(1), snmpdelta(1), snmptrap(1), snmpinform(1), snmpusm(1), snmpstatus(1), snmptest(1), snmp.conf(5). V5.9.5.2 20 Jul 2010 SNMPCMD(1)