SIEGE(1) Siege Load Tester SIEGE(1) siege - HTTP/FTP (SYNOPSIS) siege [options] siege [options] siege [options] -g siege [options] -f urls.txt (DESCRIPTION) siege (multi-threaded) (benchmarking) HTTP/FTP . RFC 2616 (HTTP) RFC 959 (FTP) . . . $HOME/.siege/siege.conf . $HOME/.siege siege.conf cookies.txt siege . siege.config . (OPTIONS) (Option Syntax) siege . : -c 25 -c25 : --concurrent=25 (Option Values) -V, --version siege . -h, --help siege . -C, --config $HOME/.siege/siege.conf . -v, --verbose siege (verbose) . 'verbose = false' (override) . siege : * HTTP 2xx * HTTP 3xx (cyan) * HTTP 4xx (magenta) * HTTP 5xx * HTTP : siege.conf : 'color = off' -q, --quiet siege . -g/--get . (exit code) . siege --quiet -g www.joedog.org if [ $? -eq 0 ] ; then echo "Success" else echo "Failure" fi -g URL, --get=URL URL (headers) . : gmethod = HEAD|GET $ siege -g "https://www.joedog.org" HEAD / HTTP/1.0 Host: www.joedog.org Accept: */* User-Agent: Mozilla/5.0 (unknown-x86_64-linux-gnu) Siege/4.0.0-beta5 Connection: close HTTP/1.1 200 OK Server: cloudflare-nginx Date: Tue, 09 Feb 2016 18:18:41 GMT Content-Type: text/html; charset=UTF-8 Connection: close Last-Modified: Wed, 25 Nov 2015 18:46:08 GMT Cache-Control: max-age=3, must-revalidate Expires: Tue, 09 Feb 2016 18:18:44 GMT Vary: Accept-Encoding,Cookie CF-RAY: 27219407eeff084a-IAD : URL siege . -p URL, --print=URL -g / --get . $ siege -p http://www.joedog.org GET / HTTP/1.0 Host: www.joedog.org Accept: */* User-Agent: Mozilla/5.0 (unknown-x86_64-linux-gnu) Siege/4.0.3rc1 Connection: close HTTP/1.1 301 Moved Permanently Date: Wed, 19 Oct 2016 16:58:13 GMT Content-Type: text/html; charset=iso-8859-1 Location: https://www.joedog.org Server: cloudflare-nginx Connection: close 301 Moved Permanently

Moved Permanently

The document has moved here.


Apache/2.2.31 (Amazon) Server at www.joedog.org Port 80
-c NUM, --concurrent=NUM . . . apache (thread) . siege -c 1024 siege apache . siege . siege.conf . -r NUM, --reps=NUM|once siege . 'once' . --reps=3 siege . --reps=once urls.txt . urls.txt -f --file= . -t NUMm, --time=NUMm --reps . "NUMm" "NUM" "m" S M H . siege : -t3600S -t60M -t1H. . -d NUM, --delay=NUM siege . NUM . . (--delay=0.5). (transaction time) . . (elapsed time) . : (parser) (: -p/--parser) . ..IP "-b, --benchmark" 4 siege . . -i, --internet siege (internet mode) . urls.txt (: -f / --file=) . -f FILE, --file=FILE siege URL . URL . URL URL () . urls.txt siege . siege ($) (escape) : https://$(HOST)/siege/jsoner.php POST {"price": "\$10 per mile"} -R FILE, --rc=FILE (resource file) . siegerc $HOME/.siege/siege.conf . . -L FILE, --log=FILE $prefix/var/log/siege.log . . -m "string", --mark="string" . . . -H "header: value", --header="Header: value" . . Cookie . -H "Cookie: value" siege . -A "string", --agent="string" user-agent . siege --agent="JoeDog Jr. in da hizzle" : User-agent: JoeDog Jr. in da hizzle User-agent -H/--header . -T "text", --content-type="text" . Content-type . --no-parser HTML . siege style- sheet javascript . . siege . --no-follow siege (redirects) 3xx . (URL FORMAT) siege RFC 1738 URL . RFC 1738 siege URL . RFC 1738 URL : ://:@:/;?# URL siege : ://:@:/ POST (POST) : ://:@:/ POST siege : http://www.joedog.org POST haha=papa&dada=mama ftp://ftp.armstrong.com/ PUT : URL () . URL urls.txt . siege . URL 1738 . : [scheme://] host.domain.xxx [:port] [/path/file] siege URL . www.joedog.org http://www.joedog.org:80.SH " URLS.txt (URLS.txt FILE)" <