POSTSCREEN(8) System Manager's Manual POSTSCREEN(8) (NAME) postscreen - Postfix (SYNOPSIS) postscreen [ Postfix] (DESCRIPTION) postscreen(8) Postfix . postscreen(8) SMTP Postfix SMTP . postscreen(8) SMTP . SMTP (MUA) . postscreen(8) MX TCP smtpd(8) MUA submission ( TCP) . << >> postscreen submission MX . postscreen(8) (allowlist) . IP SMTP postscreen(8) Postfix SMTP . . postscreen(8) Postfix SMTP mynetworks ( SMTP ). . postscreen(8) . postscreen(8) helo . postscreen(8) SMTP . Postfix SMTP . (SECURITY) postscreen(8) . . (chrooted) . (STANDARDS) RFC 821 ( SMTP) RFC 1123 ( ) RFC 1652 ( 8bit-MIME) RFC 1869 ( SMTP) RFC 1870 ( ) RFC 1985 ( ETRN) RFC 2034 ( SMTP) RFC 2821 ( SMTP) Not: RFC 2920 ( SMTP SMTP Pipelining) RFC 3030 ( CHUNKING BINARYMIME) RFC 3207 ( STARTTLS) RFC 3461 ( SMTP DSN) RFC 3463 ( ) RFC 5321 ( SMTP ) (DIAGNOSTICS) syslogd(8) postlogd(8) . (BUGS) SMTP postscreen(8) AUTH XCLIENT XFORWARD . << >> . << >> IP . : IP . <> POSTSCREEN_README . (CONFIGURATION PARAMETERS) main.cf postscreen(8) . <> . . postconf(5) . : postscreen(8) ( ) . ( ${stress?{X}:{Y}} $name smtpd ). stress . (COMPATIBILITY CONTROLS) postscreen_command_filter ($smtpd_command_filter) SMTP. postscreen_discard_ehlo_keyword_address_maps ($smtpd_discard_ehlo_keyword_address_maps) SMTP EHLO ( pipelining starttls auth ) postscreen(8) EHLO SMTP . postscreen_discard_ehlo_keywords ($smtpd_discard_ehlo_keywords) EHLO ( pipelining starttls auth ) postscreen(8) EHLO SMTP . Postfix . : dns_ncache_ttl_fix_enable (no) libc . Postfix . : postscreen_reject_footer_maps ($smtpd_reject_footer_maps) 4XX 5XX postscreen(8) . Postfix . : respectful_logging (see 'postconf -d' output) ( <> ). (TROUBLE SHOOTING CONTROLS) postscreen_expansion_filter (see 'postconf -d' output) postscreen_reject_footer ( <> ). postscreen_reject_footer ($smtpd_reject_footer) 4XX 5XX postscreen(8) . soft_bounce (no) . POSTSCREEN (BEFORE-POSTSCREEN PROXY AGENT) Postfix . : postscreen_upstream_proxy_protocol (empty) postscreen. postscreen_upstream_proxy_timeout (5s) postscreen_upstream_proxy_protocol. / (PERMANENT ALLOW/DENYLIST TEST) SMTP . Postfix SMTP . postscreen_access_list (permit_mynetworks) / IP SMTP. postscreen_blacklist_action (ignore) Postfix . postscreen_denylist_action . (MAIL EXCHANGER POLICY TESTS) postscreen(8) MX MX . MX MTA . postscreen(8) MTA . postscreen_allowlist_interfaces (static:all) IP postscreen(8) SMTP postscreen(8) . (BEFORE 220 GREETING TESTS) <<220 servername>> SMTP . Postfix SMTP . dnsblog_service_name (dnsblog) dnsblog(8) master.cf. postscreen_dnsbl_action (ignore) postscreen(8) DNSBL SMTP ( postscreen_dnsbl_sites postscreen_dnsbl_threshold ). postscreen_dnsbl_reply_map (empty) DNSBL DNSBL postscreen . postscreen_dnsbl_sites (empty) / DNS . postscreen_dnsbl_threshold (1) ( ) SMTP DNSBL postscreen_dnsbl_sites. postscreen_greet_action (ignore) postscreen(8) SMTP postscreen_greet_wait . postscreen_greet_banner ($smtpd_banner) <<220-text...>> postscreen(8) <<220 text...>> Postfix SMTP SMTP (pre-greet). postscreen_greet_wait (normal: 6s, overload: 2s) postscreen(8) SMTP DNSBL (: ). smtpd_service_name (smtpd) postscreen(8) . Postfix . : postscreen_dnsbl_whitelist_threshold (0) Postfix . postscreen_dnsbl_allowlist_threshold . Postfix . : postscreen_dnsbl_timeout (10s) DNSBL DNSWL. Postfix . : postscreen_denylist_action (ignore) postscreen(8) SMTP postscreen_access_list . postscreen_allowlist_interfaces (static:all) IP postscreen(8) SMTP postscreen(8) . postscreen_dnsbl_allowlist_threshold (0) SMTP << >> << >> DNSBL postscreen_dnsbl_sites. (AFTER 220 GREETING TESTS) <<220 servername>> SMTP . RCPT TO 4XX . Postfix SMTP . postscreen_bare_newline_action (ignore) postscreen(8) SMTP (bare newline) (carriage return) . postscreen_bare_newline_enable (no) SMTP << >> (bare newline) postscreen(8). postscreen_disable_vrfy_command ($disable_vrfy_command) SMTP VRFY postscreen(8). postscreen_forbidden_commands ($smtpd_forbidden_commands) postscreen(8) SMTP . postscreen_helo_required ($smtpd_helo_required) SMTP HELO EHLO MAIL. postscreen_non_smtp_command_action (drop) postscreen(8) SMTP SMTP postscreen_forbidden_commands . postscreen_non_smtp_command_enable (no) << SMTP>> postscreen(8). postscreen_pipelining_action (enforce) postscreen(8) SMTP . postscreen_pipelining_enable (no) SMTP (pipelining) postscreen(8). (CACHE CONTROLS) postscreen_cache_cleanup_interval (12h) () postscreen(8). postscreen_cache_map (btree:$data_directory/postscreen_cache) postscreen(8). postscreen_cache_retention_time (7d) postscreen(8) . postscreen_bare_newline_ttl (30d) postscreen(8) IP SMTP << >> . postscreen_dnsbl_max_ttl (${postscreen_dnsbl_ttl?{$postscreen_dnsbl_ttl}:{1}}h) postscreen(8) IP DNS . postscreen_dnsbl_min_ttl (60s) postscreen(8) IP DNS . postscreen_greet_ttl (1d) postscreen(8) IP PREGREET . postscreen_non_smtp_command_ttl (30d) postscreen(8) IP SMTP << SMTP>> . postscreen_pipelining_ttl (30d) postscreen(8) IP SMTP <> . (RESOURCE CONTROLS) line_length_limit (2048) . postscreen_client_connection_count_limit ($smtpd_client_connection_count_limit) SMTP postscreen(8) . postscreen_command_count_limit (20) SMTP SMTP postscreen(8). postscreen_command_time_limit (normal: 300s, overload: 10s) SMTP postscreen(8). postscreen_post_queue_limit ($default_process_limit) Postfix SMTP . postscreen_pre_queue_limit ($default_process_limit) Postfix SMTP . postscreen_watchdog_timeout (10s) postscreen(8) SMTP . STARTTLS (STARTTLS CONTROLS) postscreen_tls_security_level ($smtpd_tls_security_level) TLS SMTP postscreen(8) postscreen_use_tls postscreen_enforce_tls . tlsproxy_service_name (tlsproxy) tlsproxy(8) master.cf. STARTTLS (OBSOLETE STARTTLS SUPPORT CONTROLS) smtpd(8) . postscreen_use_tls ($smtpd_use_tls) TLS (Opportunistic TLS): STARTTLS SMTP TLS. postscreen_enforce_tls ($smtpd_enforce_tls) TLS (Mandatory TLS): STARTTLS SMTP TLS. (MISCELLANEOUS CONTROLS) config_directory (see 'postconf -d' output) main.cf master.cf Postfix ( <> ). delay_logging_resolution_limit (2) . command_directory (see 'postconf -d' output) postfix ( <> ). max_idle (100s) Postfix . process_id (read-only) (PID) Postfix. process_name (read-only) Postfix. syslog_facility (mail) syslog Postfix. syslog_name (see 'postconf -d' output) syslog <> <> ( <> ). Postfix . : service_name (read-only) Postfix master.cf. Postfix . : info_log_address_format (external) ( info warning ) . (SEE ALSO) smtpd(8) Postfix SMTP tlsproxy(8) TLS Postfix dnsblog(8) / DNS postlogd(8) Postfix syslogd(8) README (README FILES) <> <> . POSTSCREEN_README Postscreen Postfix (LICENSE) Secure Mailer . (HISTORY) . (Postfix) . postscreen(8) Michael Tokarev spamd OpenBSD Traffic Control MailChannels . (AUTHORS) Wietse Venema IBM T.J. Watson Research P.O. Box 704 Yorktown Heights, NY 10598, USA Wietse Venema Google, Inc. 111 8th Avenue New York, NY 10011, USA Wietse Venema porcupine.org POSTSCREEN(8)