POSTMAP(1) General Commands Manual POSTMAP(1) (NAME) postmap - Postfix (SYNOPSIS) postmap [-bfFhijmnNoprsuUvw] [-c config_dir] [-d key] [-q key] [file_type:]file_name ... (DESCRIPTION) postmap(1) Postfix . (other) . (advisory lock) . (INPUT FILE FORMAT) : o : key whitespace value o `#` . o . . key value . . Postfix `"` . `"` `` . -F value / postmap(1) ( ) base64 value . key RFC 5322 (localpart) localpart <<;>> <<.>> . . Postfix (fixed-case) btree: dbm: hash:. ( regexp: pcre:) . $number . (COMMAND-LINE ARGUMENTS) -b (body query mode). <<-q ->> RFC 5322 . . -b . body_checks(5) MIME -m . -b MIME message/* . : <> -b UTF-8 . UTF-8 -U . Postfix . . -c config_dir main.cf . -d key key . . - . . -f . . Postfix (regular expression) . -F base64 . base64 ( << >> ). Postfix . . -h (header query mode). <<-q ->> RFC 5322 . . . -h . header_checks(5) MIME -m . -h MIME message/* . : <> -h UTF-8 . UTF-8 -U . Postfix . . -i (Incremental mode). / (truncate) . postmap(1) file_name . -j JSON. -q -s {"key": "value"} . Postfix . . -m MIME <<-b>> <<-h>>. Postfix . . -N (null character) . postmap(1) . -n . postmap(1) . -o . postmap(1) . -p ( 0644) . -q key key . . : ( access(5) canonical(5) transport(5) virtual(5) Postfix ) . - key value . . -r . -s key value . . Postfix . . -u UTF-8. UTF-8 "smtputf8_enable = yes" UTF-8 . -U "smtputf8_enable = yes" UTF-8 -b -h . -v (verbose) . -v . -w . : file_type . <> . file_type default_database_type . . postmap(1) : btree btree file_name.db . db . cdb file_name.cdb . cdb . dbm file_name.pag file_name.dir . dbm . fail ( ). . Postfix . hash file_name.db . db . lmdb btree file_name.lmdb . lmdb . lmdb . sdbm file_name.pag file_name.dir . sdbm . file_name . (DIAGNOSTICS) syslogd(8) postlogd(8) . . . postmap(1) ( <>) . (ENVIRONMENT) MAIL_CONFIG Postfix. MAIL_VERBOSE . (CONFIGURATION PARAMETERS) main.cf . . postconf(5) . berkeley_db_create_buffer_size (16777216) I/O hash btree Berkeley DB . berkeley_db_read_buffer_size (131072) I/O hash btree Berkeley DB . config_directory (see 'postconf -d' output) main.cf master.cf Postfix. default_database_type (see 'postconf -d' output) newaliases(1) postalias(1) postmap(1). import_environment (see 'postconf -d' output) Postfix -Postfix name=value. smtputf8_enable (yes) SMTPUTF8 RFC 6531 RFC 6532 RFC 6533. syslog_facility (mail) (syslog facility) Postfix. syslog_name (see 'postconf -d' output) syslog "smtpd" "prefix/smtpd" . Postfix . : lmdb_map_size (16777216) OpenLDAP LMDB . (SEE ALSO) postalias(1), // (alias) postconf(1), postconf(5), postlogd(8), Postfix syslogd(8), README (README FILES) <> <> . DATABASE_README, Postfix (LICENSE) Secure Mailer . (AUTHORS) Wietse Venema IBM T.J. Watson Research P.O. Box 704 Yorktown Heights, NY 10598, USA Wietse Venema Google, Inc. 111 8th Avenue New York, NY 10011, USA POSTMAP(1)