podman-push(1) General Commands Manual podman-push(1) (NAME) podman-push - (SYNOPSIS) podman push [] [] podman image push [] [] (DESCRIPTION) (image index) (push) . (Image storage) . (DESTINATION) (DESTINATION) . containers-transports(5) . docker ( ) . ( WSL2) docker . # $ podman push quay.io/podman/stable # docker $ podman push docker://quay.io/podman/stable # $ podman push myimage quay.io/username/myimage # $ podman push myimage dir:/tmp/myimage # docker-archive $ podman push myimage docker-archive:/tmp/myimage # $ sudo podman push myimage docker-daemon:docker.io/library/myimage:33 # OCI $ podman push myimage oci-archive:/tmp/myimage (OPTIONS) --authfile= . ${XDG_RUNTIME_DIR}/containers/auth.json /macOS $HOME/.config/containers/auth.json . podman login . $HOME/.docker/config.json docker login . : REGISTRY_AUTH_FILE . export REGISTRY_AUTH_FILE= . --cert-dir= (*.crt *.cert *.key) . (: /etc/containers/certs.d) containers-certs.d(5) . ( ( WSL2) ). --compress 'dir'. ( ). : dir . --compression-format=gzip | zstd | zstd:chunked . : gzip zstd zstd:chunked. gzip containers.conf . zstd:chunked zstd . --compression-level= . zstd ( ) gzip ( ) . --creds=[[:]] [[:]] . . (echo) . . ( containers- registries.conf(5) ) containers-auth.json(5) . --digestfile= . --disable-content-trust . (NOOP) . --encrypt-layer=() () : (0-indexed) ( 0 -1 ). --encryption-key . --encryption-key= [protocol:keyfile] JWE (RFC7516) PGP (RFC4880) PKCS7 (RFC2315) jwe:/path/to/key.pem pgp:admin@example.com pkcs7:/path/to/x509-file. --force-compression . --compression-format true false . --format, -f= (oci v2s2 v2s1) . --quiet, -q ( ). . --remove-signatures . --retry=- . 3 . --retry-delay=- . . . --sign-by= << >> (simple signing) . ( ( WSL2) ). --sign-by-sigstore=- sigstore sigstore -. containers-sigstore-signing-params.yaml(5) . --sign-by-sigstore-private-key= sigstore . ( ( WSL2) ). --sign-by-sq-fingerprint= << >> Sequoia-PGP . ( ( WSL2) ). --sign-passphrase-file= ( --sign-by --sign-by-sq-fingerprint --sign-by-sigstore-private-key) . --tls-verify HTTPS (: true). true TLS . false TLS . TLS containers-registries.conf(5) . (EXAMPLES) : # podman push imageID dir:/path/to/image OCI: # podman push imageID oci-archive:/path/to/layout:image:tag : # podman push imageID docker://registry.example.com/repository:tag : # podman push --digestfile=/tmp/mydigest imageID docker://registry.example.com/repository:tag : # podman push imageID docker-daemon:image:tag : # podman push --authfile temp-auths/myauths.json alpine docker://docker.io/umohnani/alpine Getting image source signatures Copying blob sha256:5bef08742407efd622d243692b79ba0055383bbce12900324f75e56f589aedb0 4.03 MB / 4.03 MB [========================================================] 1s Copying config sha256:ad4686094d8f0186ec8249fc4917b71faa2c1030d7b5a025c29f26e19d95c156 1.41 KB / 1.41 KB [========================================================] 1s Writing manifest to image destination Storing signatures OCI: # podman push --format oci registry.access.redhat.com/rhel7 dir:rhel7-dir Getting image source signatures Copying blob sha256:9cadd93b16ff2a0c51ac967ea2abfadfac50cfa3af8b5bf983d89b8f8647f3e4 71.41 MB / 71.41 MB [======================================================] 9s Copying blob sha256:4aa565ad8b7a87248163ce7dba1dd3894821aac97e846b932ff6b8ef9a8a508a 1.21 KB / 1.21 KB [========================================================] 0s Copying config sha256:f1b09a81455c351eaa484b61aacd048ab613c08e4c5d1da80c4c46301b03cf3b 3.01 KB / 3.01 KB [========================================================] 0s Writing manifest to image destination Storing signatures (SEE ALSO) podman(1), podman-pull(1), podman-login(1), containers-certs.d(5), containers-registries.conf(5), containers-transports(5) (Troubleshooting) podman-troubleshooting(7) . podman-push(1)