PKI(1) strongSwan PKI(1) (NAME) pki - (PKI) (SYNOPSIS) pki command [option ...] pki -h | --help (DESCRIPTION) pki (PKI) . RSA ECDSA PKCS#10 subjectAltNames X.509 (end-entity) (root CA) (intermediate CA) CA subjectAltNames CRL URI OCSP . SHA-1 . pki Simple Certificate Enrollment Protocol (SCEP) RFC 8894 ipsec scepclient . Enrollment over Secure Transport (EST) RFC 7030 . Online Certificate Status Protocol (OCSP) RFC 6960 OpenXPKI . (COMMANDS) -h, --help . -g, --gen . -s, --self (self-signed). -i, --issue CA. -c, --signcrl CRL CA. -z, --acert (attribute certificate). -r, --req PKCS#10. -7, --pkcs7 / (wrap/unwrap) PKCS#7. -k, --keyid . -a, --print ( ) . -d, --dn DN (subject DN) X.509. -p, --pub . -V, --verify CA. -S, --scep X.509 SCEP. -C, --scepca [] CA [ RA] SCEP. -E, --est X.509 EST. -e, --estca [] CA EST. -o, --ocsp OCSP OCSP. (GENERAL OPTIONS) -v, --debug (debug) : 1 -+, --options (EXAMPLES) CA --gen . RSA . pki --gen > ca_key.der CA --self . (distinguished name) . pki --self --ca --in ca_key.der \ --dn "C=CH, O=strongSwan, CN=strongSwan CA" > ca_cert.der (End-Entity) CA . CA . . pki --gen > server_key.der . pki --pub --in server_key.der > server_pub.der CA . subjectAltName() ( pki --issue(8) ). pki --issue --in server_pub.der --cacert ca_cert.der \ --cakey ca_key.der --dn "C=CH, O=strongSwan, CN=VPN Server" \ --san vpn.strongswan.org --flag serverAuth > server_cert.der --pub (pipe) . (CRL) CRL --signcrl . pki --signcrl --cacert ca_cert.der --cakey ca_key.der \ --reason superseded --cert server_cert.der > crl.der cacert-- CA crlSign (flag crlSign--). URI CRL crl-- . (SEE ALSO) pki --gen(1), pki --self(1), pki --issue(1), pki --signcrl(1), pki --acert(1), pki --req(1), pki --pkcs7(1), pki --keyid(1), pki --print(1), pki --dn(1), pki --pub(1), pki --verify(1), pki --scep(1) pki --scepca(1) pki --est(1) pki --estca(1) pki --ocsp(1) 6.1.0 2023-10-20 PKI(1)