PIPE(8) System Manager's Manual PIPE(8) (NAME) pipe - Postfix (SYNOPSIS) pipe [generic Postfix daemon options] command_attributes... (DESCRIPTION) pipe(8) Postfix . master(8) . (next-hop) . pipe(8) . bounce(8) defer(8) trace(8) . (SINGLE-RECIPIENT DELIVERY) . . Delivered-To: X-Original-To: . Postfix : transport_destination_recipient_limit = 1 main.cf Postfix transport master.cf Postfix pipe . (COMMAND ATTRIBUTE SYNTAX) master.cf . : chroot=pathname () (root) . user directory=pathname . . Postfix 2.3 . directory=pathname () . user ( ). $queue_directory . . Postfix 2.2 . eol=string ( : \n) . \r\n \n . C (backslash) : \a \b \f \n \r \t \v \ddd ( ) \\. flags=BDFORXhqu.> () . . B . (MUA) "From " . D "Delivered-To: recipient" . : transport_destination_recipient_limit ( ). D (Postfix 2.5 ): Delivered-To: . . Postfix 2.0 . F "From sender time_stamp" . UUCP . O "X-Original-To: recipient" Postfix . : transport_destination_recipient_limit ( ). Postfix 2.0 . R Return-Path: . X . DSN ( ) "relayed" () "delivered" ( ) . Postfix 2.5 . h $original_recipient $recipient ( @) $domain $nexthop . UUCP . q (localpart) $sender $original_recipient $recipient ( @) RFC 822. UUCP BSMTP . sendmail(1) Postfix . q $user $extension $mailbox. u $original_recipient $recipient ( @) . UUCP . . "." "." . BSMTP . > ">" "From " . UUCP . null_sender=replacement (: MAILER-DAEMON) (null) ( ) $sender From_ Return-Path:. q . Postfix . q . : . pipe(8) : : command -f$sender -- $recipient -f . $sender : : command -f $sender -- $recipient : command $sender $recipient . Postfix 2.3 . size=size_limit () ( ) . user=username () user=username:groupname username. root . groupname username . argv=command... () . . . "{" "{" "}" ( Postfix 3.0 ). "{" "}" . Postfix . ${name} $name $(name) . $ $$ . ${client_address} . Postfix 2.2 . ${client_helo} HELO . Postfix 2.2 . ${client_hostname} . Postfix 2.2 . ${client_port} TCP . Postfix 2.5 . ${client_protocol} . Postfix 2.2 . ${domain} . user+foo@domain domain . h . Postfix 2.5 . ${envid} RFC 3461 . Postfix 3.9 . ${extension} . user+foo@domain foo . ${extension} . u . ${mailbox} . user+foo@domain user+foo . ${mailbox} . u . ${nexthop} (next-hop) . h . ${original_recipient} . ${original_recipient} . hqu . Postfix 2.5 . ${queue_id} . Postfix 2.11 . ${recipient} . ${recipient} . hqu . ${sasl_method} SASL AUTH Postfix SMTP . Postfix 2.2 . ${sasl_sender} SASL ( RFC 4954) MAIL FROM Postfix SMTP . Postfix 2.2 . ${sasl_username} SASL AUTH Postfix SMTP . Postfix 2.2 . ${sender} . MAILER-DAEMON null_sender . q . ${size} Postfix . ${user} . user+foo@domain user . ${user} . u . (STANDARDS) RFC 3463 ( ) (DIAGNOSTICS) . 0 . . 4.X.X 5.X.X ( 2.3 Postfix). ( ) "" (Postfix 3.0 ). . syslogd(8) postlogd(8) . corrupt . (SECURITY) : ) (IPC) Postfix ) . . (CONFIGURATION PARAMETERS) main.cf pipe(8) . "postfix reload" . . postconf(5) . (RESOURCE AND RATE CONTROLS) transport master.cf . transport_time_limit ($command_time_limit) command_time_limit transport master.cf . qmgr(8): transport_destination_concurrency_limit ($default_destination_concurrency_limit) default_destination_concurrency_limit transport master.cf . transport_destination_recipient_limit ($default_destination_recipient_limit) default_destination_recipient_limit transport master.cf . (MISCELLANEOUS CONTROLS) config_directory (see 'postconf -d' output) main.cf master.cf Postfix. daemon_timeout (18000s) Postfix (watchdog) . delay_logging_resolution_limit (2) . export_environment (see 'postconf -d' output) Postfix Postfix . ipc_timeout (3600s) . mail_owner (postfix) UNIX Postfix Postfix . max_idle (100s) Postfix . max_use (100) Postfix . process_id (read-only) (PID) Postfix. process_name (read-only) Postfix. queue_directory (see 'postconf -d' output) Postfix. recipient_delimiter (empty) (localpart) forward. . syslog_facility (mail) (syslog facility) Postfix. syslog_name (see 'postconf -d' output) syslog "smtpd" "prefix/smtpd" . 3.0 Postfix: pipe_delivery_status_filter ($default_delivery_status_filter) pipe(8) . 3.3 Postfix: enable_original_recipient (yes) ( ). service_name (read-only) master.cf Postfix. 3.5 Postfix: info_log_address_format (external) (info warning ) . (SEE ALSO) qmgr(8), queue manager bounce(8), delivery status reports postconf(5), configuration parameters master(5), generic daemon options master(8), process manager postlogd(8), Postfix logging syslogd(8), system logging (LICENSE) Secure Mailer . (AUTHOR(S)) Wietse Venema IBM T.J. Watson Research P.O. Box 704 Yorktown Heights, NY 10598, USA Wietse Venema Google, Inc. 111 8th Avenue New York, NY 10011, USA PIPE(8)