ovsdb-client(1) Open vSwitch ovsdb-client(1) ovsdb-client - ovsdb- server(1) (SYNOPSIS) : ovsdb-client [options] list-dbs [server] : ovsdb-client [options] get-schema [server] [database] ovsdb-client [options] list-tables [server] [database] ovsdb-client [options] list-columns [server] [database] [table] : ovsdb-client [options] convert [server] schema ovsdb-client [options] needs-conversion [server] schema ovsdb-client [options] get-schema-version [server] [database] : ovsdb-client [options] transact [server] transaction ovsdb-client [options] query [server] transaction ovsdb-client [options] dump [server] [database] [table [column...]] ovsdb-client [options] backup [server] [database] > snapshot ovsdb-client [options] [--force] restore [server] [database] < snapshot ovsdb-client [options] monitor [server] [database] table [column[,column]...]... ovsdb-client [options] monitor [server] [database] ALL ovsdb-client [options] monitor-cond [server] [database] conditions table [column[,column]...]... ovsdb-client [options] monitor-cond-since [server] [database] [last-id] conditions table [column[,column]...]... ovsdb-client [options] wait [server] database state : ovsdb-client [options] lock [server] lock ovsdb-client [options] steal [server] lock ovsdb-client [options] unlock [server] lock : ovsdb-client help : [--no-leader-only] : [--format=format] [--data=format] [--no-headings] [--pretty] [--bare] [--timestamp] : [--pidfile[=pidfile]] [--overwrite-pidfile] [--detach] [--no-chdir] [--no-self-confinement] : [-v[module[:destination[:level]]]]... [--verbose[=module[:destination[:level]]]]... [--log-file[=file]] : [--private-key=privkey.pem] [--certificate=cert.pem] [--ca-cert=cacert.pem] [--ssl-server-name=servername] [--bootstrap-ca-cert=cacert.pem] SSL/TLS: [--ssl-protocols=protocols] [--ssl-ciphers=ciphers] [--ssl-ciphersuites=ciphersuites] : [--record[=directory]] [--replay[=directory]] : [-h | --help] [-V | --version] ovsdb-client ovsdb-server . server OVSDB (active) (passive) OVSDB ovsdb(7) . unix:/run/openvswitch/db.sock database Open_vSwitch . ovsdb-client method1,method2,...,methodN ovsdb(7) . ovsdb-client (leader) . --no-leader-only . OVSDB Open vSwitch ovsdb(7) . ovsdb-client . (Server-Level Commands) ovsdb-client . list-dbs [server] server . database . (Database Schema Commands) (schema) . get-schema [server] [database] server database JSON . list-tables [server] [database] server database . list-columns [server] [database] table server database . table . (Database Version Management Commands) OVSDB OVSDB OVSDB . x.y.z 1.2.3. OVSDB Open vSwitch . ( ) x ( y z 0 ). ( ) y ( z 0 ). ( ) z . OVSDB . Open vSwitch . OVSDB . convert [server] schema OVSDB JSON OVSDB schema server schema schema . (ACID) . RPC set_db_change_aware ( Open vSwitch 2.9) (monitors) . . <<>> <<>> . schema : schema . schema . schema . . . . (clustered) (standalone) . (offline) convert ovsdb-tool . needs-conversion [server] schema schema server schema . no (stdout) yes . get-schema-version [server] [database] server database (stdout) . database . get-schema-cksum [server] [database] server database (checksum) (stdout) . database . . transact [server] transaction server transaction JSON params JSON-RPC transact stdout . query [server] transaction transact . server transaction JSON params JSON- RPC transact stdout . abort transaction abort ( ) . dump [server] [database] [table [column...]] server database stdout . table . column . backup [server] [database] > snapshot server (snapshot) (schema) database standalone active-backup OVSDB stdout . . ovsdb-server ovsdb-client restore . standalone active- backup cp. . (ephemeral) ovsdb-server . [--force] restore [server] [database] < snapshot snapshot standalone active-backup OVSDB ( ovsdb-client backup ). server database snapshot database snapshot . (atomically) . (UUID) snapshot OVSDB UUID . standalone active-backup UUID snapshot . ovsdb-server . snapshot restore . ovsdb-client convert. --force . monitor [server] [database] table [column[,column]...]... monitor-cond [server] [database] conditions table [column[,column]...]... monitor-cond-since [server] [database] [last-id] conditions table [column[,column]...]... server table database . table . . column . column : !initial . !insert . !delete . !modify . [column[,column]...] . . conditions JSON 5.1 RFC 7047 : JSON RFC (boolean) . --detach monitor monitor-cond monitor-cond-since ovsdb-client table ( ). monitor "monitor" RFC 7047 . monitor-cond monitor-cond-since RFC 7047 "monitor_cond" "monitor_cond_since" . ovsdb-server(1) . monitor [server] [database] ALL server database . . --detach ovsdb-client ( ). monitor "monitor" RFC 7047 . wait [server] database state database server state : added server . connected server . database (clustered) . removed database . ovsdb-server . database ovsdb-client . server ..SS " " OVSDB . lock [server] lock steal [server] lock unlock [server] lock server RFC 7047 lock . json . --detach ovsdb-client ( ). --detach lock steal unlock exit ovs-appctl . exit ovsdb-client ovsdb-server . lock steal unlock ovsdb-server . lock lock ovsdb-client . (OPTIONS) ovsdb-client . : -f format --format=format . format : table () . list . html HTML. csv RFC 4180 . json JSON RFC 4627 . JSON . JSON : caption . . headings . . data . . . OVSDB OVSDB . -d format --data=format json json . format : string () Database Values ovs-vsctl(8). bare : [] {} . . json JSON RFC 4627 . --no-headings . --pretty JSON . JSON . . JSON . --bare --format=list --data=bare --no-headings. --max-column-width=n n . . . --timestamp monitor monitor-cond monitor-cond-since . . JSON JSON time . -t --timeout=secs ovsdb-client secs . ovsdb-client SIGALRM . monitor monitor-cond monitor-cond-since . . POSIX . --pidfile[=pidfile] ( ovsdb-client.pid) PID . pidfile / /run/openvswitch . --pidfile pid . --overwrite-pidfile --pidfile pid ovsdb-client . --overwrite-pidfile pid . --pidfile . --detach ovsdb-client . (session) ( ) ( --no-chdir ). . --monitor ovsdb-client . (SIGABRT SIGALRM SIGBUS SIGFPE SIGILL SIGPIPE SIGSEGV SIGXCPU SIGXFSZ) . . --detach . --no-chdir --detach ovsdb-client (detach) . ovsdb-client unmount . --no-chdir ovsdb-client . core core dump . --detach . --no-self-confinement (self-confine) . (Access Control) . ( DAC MAC) . --user ovsdb-client "user:group" (root) . "user" ":group" . . CAP_IPC_LOCK CAP_NET_BIND_SERVICES . datapath ovs-vswitchd CAP_NET_ADMIN CAP_NET_BROADCAST CAP_NET_RAW . root ..SS " (Logging Options)" -v[spec] --verbose=[spec] . spec dbg . spec : o vlog/list ovs-appctl(8) . o syslog console file . ( --detach ovsdb-client .) o off emer err warn info dbg . . off . ovs-appctl(8) . spec . file --log-file ( ). OVS any . -v --verbose (verbosity) --verbose=dbg . -vPATTERN:destination:pattern --verbose=PATTERN:destination:pattern destination pattern . pattern ovs-appctl(8) . -vFACILITY:facility --verbose=FACILITY:facility (facility) RFC5424 . facility kern user mail daemon auth syslog lpr news uucp clock ftp ntp audit alert clock2 local0 local1 local2 local3 local4 local5 local6 local7 . daemon syslog local0 --syslog-target . --log-file[=file] . file . file /var/log/openvswitch/ovsdb-client.log . --syslog-target=host:port syslog syslog UDP port host . host IP (hostname). --syslog-method=method syslog (method) syslog . : o libc syslog() libc. libc syslog /dev/log . o unix:file . . rsyslogd 8.9 . rsyslogd UDP IP . o udp:ip:port UDP. rsyslogd . syslog UDP syslog UDP iptables syslog UDP . o null syslog . OVS_SYSLOG_METHOD libc ..SS " (Public Key Infrastructure Options)" -p privkey.pem --private-key=privkey.pem PEM ovsdb-client SSL/TLS . -c cert.pem --certificate=cert.pem PEM -p --private-key . (CA) SSL/TLS . -C cacert.pem --ca-cert=cacert.pem PEM CA ovsdb-client SSL/TLS . ( PKI SSL/TLS -c --certificate .) -C none --ca-cert=none SSL/TLS . . --ssl-server-name=servername (TLS Server Name Indication SNI) . SNI . SNI (service meshes) . --bootstrap-ca-cert=cacert.pem cacert.pem -C --ca-cert . ovsdb-client SSL/TLS CA SSL/TLS PEM . SSL/TLS CA . SSL/TLS CA (man-in-the-middle) (bootstrapping) . SSL/TLS CA SSL/TLS . SSL/TLS CA . -C --ca-cert () . SSL/TLS (SSL/TLS Connection Options) --ssl-protocols=protocols SSL/TLS ovsdb-client SSL/TLS . (protocols) TLSv1.2 TLSv1.3 . . TLSv1.2-TLSv1.3 TLSv1.2 TLSv1.3 . TLSv1.2+ TLSv1.2 . . TLSv1.X,TLSv1.(X+2) TLSv1.(X+1) . . TLSv1.2 . --ssl-ciphers=ciphers OpenSSL ovsdb-client SSL/TLS TLSv1.2 . DEFAULT:@SECLEVEL=2 . --ssl-ciphersuites=ciphersuites (ciphersuites) ciphersuite OpenSSL ovsdb-client SSL/TLS TLSv1.3 . OpenSSL ..SS " (Other Options)" --record[=directory] <<>> (recording) ( Unix ) . directory . directory / /run/openvswitch . directory /run/openvswitch . --replay[=directory] <<>> (replay) ( Unix ) . directory . directory / /run/openvswitch . directory /run/openvswitch . -h --help . -V --version . (SEE ALSO) ovsdb(7), ovsdb-server(1), ovsdb-client(1). Open vSwitch 4.0.0 ovsdb-client(1)