OPENSSL-VERIFICATION-OPTIONS(1ssl) OpenSSL OPENSSL-VERIFICATION-OPTIONS(1ssl) (NAME) openssl-verification-options - OpenSSL (SYNOPSIS) openssl command [ options ... ] [ parameters ... ] (DESCRIPTION) X.509 OpenSSL OpenSSL . X509_verify_cert(3) . . . ( ) . "sslserver" TLS ( ) . OpenSSL . DANE openssl-s_client(1) SSL_CTX_dane_enable(3) SSL_set1_host(3) X509_VERIFY_PARAM_set_flags(3) X509_check_host(3) . (Trust Anchors) RFC 4158 RFC 5280 (DN) . DN . RFC 5280 OpenSSL . . (CA) <<>> . . OpenSSL . PEM "TRUSTED CERTIFICATE" . ( ) / ( ) . (EKU) X.509 . << >> . : clientAuth ( SSL) serverAuth ( SSL) emailProtection ( S/MIME) codeSigning ( ) OCSPSigning ( OCSP) OCSP ( OCSP) timeStamping ( TSA) anyExtendedKeyUsage. OpenSSL 1.1.0 . CA : o . o . o ( ) : -partial_chain ( X509_V_FLAG_PARTIAL_CHAIN ). (Certification Path Building) . <<>> . . . . . : o . o . o . . (CA <<>>) . . X509_V_FLAG_PARTIAL_CHAIN . (Certification Path Validation) . (well-formed ) . -x509_strict . X.509v3 ( ) . -purpose CMS "smimesign" SSL/(D)TLS "sslserver" "sslclient" . X.509v3 <<>> (leaf) . CA . << >> . ( CA ) . . OpenSSL . . CA "notBefore" "notAfter" . -attime <<>> . ( CA -check_ss_sig ). keyUsage ( ) digitalSignature keyCertSign . . (OPTIONS) (Trusted Certificate Options) . . OpenSSL . OpenSSL . : : -CAfile file DER PEM . PEM . -no-CAfile . -CApath dir ( ). SubjectName X.509 . IssuerName . openssl-rehash(1) . -no-CApath . -CAstore uri uri CA. URI . URI "file:" URI -CAfile -CApath . "file:" ossl_store-file(7) . ( openssl-s_server(1)) ( openssl-s_time(1)) . -no-CAstore CA. (Verification Options) : -verbose . -attime timestamp timestamp . timestamp ( Unix Epoch) . -no_check_time CRL . -attime . -x509_strict . RFC 5280 . : o basicConstraints CA (critical) . o CA keyUsage . o pathlenConstraint keyCertSign . o pathlenConstraint CA . o . o CA keyUsage crlSign subjectAlternativeName . o subjectAlternativeName . o signatureAlgorithm . o authorityKeyIdentifier subjectKeyIdentifier . o authorityKeyIdentifier X.509v3 . o subjectKeyIdentifier CA X.509v3 . -ignore_critical OpenSSL ( RFC 5280). . -issuer_checks . -crl_check CRL . CRL . -crl_check_all CRL . -use_deltas CRL . -extended_crl CRL CRL CRL. -suiteB_128_only, -suiteB_128, -suiteB_192 Suite B . RFC 6460 . ECDSA SHA256 SHA384 P-256 P-384 . -auth_level level level. . (level) . . SSL_CTX_set_security_level(3) . -1 <<>> . 0 . 1 MD5 RSA . -partial_chain ( ) . CA . -check_ss_sig . CA keyCertSign . . -allow_proxy_certs . -trusted_first OpenSSL 1.1.0 . -CAfile -CApath -CAstore -trusted -untrusted . -no_alt_chains OpenSSL 1.1.0 -trusted_first . -trusted file file . -partial_chain . -no-CAfile -no-CApath -no-CAstore -CAfile -CApath -CAstore -trusted . . -untrusted file file . ( CA ) . . -policy arg arg user-initial-policy-set ( RFC 5280 ). arg OID . . -explicit_policy require-explicit-policy ( RFC 5280 ). -policy_check . -policy_print . -inhibit_any inhibit-any-policy ( RFC 5280 ). -inhibit_map inhibit-policy-mapping ( RFC 5280 ). -purpose purpose . : "sslclient" "sslserver" "nssslserver" "smimesign" "smimeencrypt" "crlsign" "ocsphelper" "timestampsign" "codesign" "any". TLS openssl-s_client(1) openssl-s_server(1) TLS ("sslserver") TLS ("sslclient") . CMS openssl-cms(1) S/MIME ("smimesign") . IETF RFC 5280 id-kp-serverAuth id-kp-clientAuth TLS OpenSSL . -verify_depth num num CA . num+2 -verify_depth . -verify_email email email Subject Alternative Name Distinguished Name . -verify_hostname hostname hostname DNS Subject Alternative Name Common Name . -verify_ip ip ip IP Subject Alternative Name . -verify_name name name . : "ssl_client" "ssl_server" "smime_sign" "pkcs7" "code_sign" "default". SSL/(D)TLS CMS/PKCS7 ( S/MIME) . . OID . -addtrust -addreject openssl-x509(1) . (Extended Verification Options) . CA CA . CA SHA-1 SHA-256. OpenSSL : -xkey infile, -xcert infile, -xchain . -cert -key -cert_chain . . -xchain_build -xkey -xcert -xchain . -xcertform DER|PEM|P12 . . -xkeyform DER|PEM|P12 . . (Certificate Extensions) -purpose -verify_name . (Basic Constraints) CA basicConstraints CA . CA true CA CA false CA . CA CA true . basicConstraints X.509v1 <>> . basicConstraints CA . (Key Usage) keyUsage . keyUsage CA keyCertSign . (Extended Key Usage) extKeyUsage ( EKU) . ( ) EKU anyExtendedKeyUsage . 4.2.1.12 RFC 5280 Extended Key Usage 6 EKU CA . CA/Browser TLS S/MIME EKU CA ( CA ) RFC 5280 . OpenSSL EKU CA . EKU CA "sslclient" "nssslserver" "sslserver" "smimesign" "smimeencrypt" EKU ( anyExtendedKeyUsage ) EKU . . (Checks Implied by Specific Predefined Policies) . basicConstraints keyUsage X.509v1 CA . (D)TLS Client ("sslclient") "clientAuth" (<< TLS WWW>>) . "digitalSignature" / "keyAgreement" . SSL . CA . CA SSL . basicConstraints . (D)TLS Server ("sslserver") "serverAuth" (<< TLS WWW>>) / OID SGC . "digitalSignature" "keyEncipherment" / "keyAgreement" . SSL . CA . CA SSL . basicConstraints . Netscape SSL Server ("nssslserver") sslserver Netscape SSL SSL keyUsage EE keyEncipherment . . SSL . Common S/MIME Checks "emailProtection" . S/MIME . S/MIME SSL . Verisign S/MIME . CA . CA S/MIME . basicConstraints . S/MIME Signing ("smimesign") S/MIME "digitalSignature" / nonRepudiation ( contentCommitment) . S/MIME Encryption ("smimeencrypt") S/MIME "keyEncipherment" . CRL Signing ("crlsign") "cRLSign" . CA basicConstraints . OCSP Helper ("ocsphelper") OCSP_basic_verify(3) . CA . Timestamp Signing ("timestampsign") "digitalSignature" / "nonRepudiation" ( "contentCommitment") . EKU "timeStamping" . . CA . Code Signing ("codesign") "digitalSignature" "keyCertSign" "cRLSign" . EKU "codeSign" "anyExtendedKeyUsage" "serverAuth" . CA . (BUGS) (API) X509_LOOKUP . ( -CAfile) ( -CApath) ( -CAstore) . ( ) . (SEE ALSO) X509_verify_cert(3), OCSP_basic_verify(3), openssl-verify(1), openssl-ocsp(1), openssl-ts(1), openssl-s_client(1), openssl-s_server(1), openssl-smime(1), openssl-cmp(1), openssl-cms(1) (HISTORY) -x509_strict OpenSSL 3.0 . (COPYRIGHT) - OpenSSL. . . (<<>>) . . LICENSE : 3.6.4 2026-08-25 OPENSSL-VERIFICATION-OPTIONS(1ssl)