OPENSSL-S_SERVER(1ssl) OpenSSL OPENSSL-S_SERVER(1ssl) (NAME) openssl-s_server - SSL/TLS (SYNOPSIS) openssl s_server [-help] [-port +int] [-accept val] [-unix val] [-4] [-6] [-unlink] [-context val] [-verify int] [-Verify int] [-cert infile] [-cert2 infile] [-certform DER|PEM|P12] [-cert_chain infile] [-build_chain] [-serverinfo val] [-key filename|uri] [-key2 filename|uri] [-keyform DER|PEM|P12|ENGINE] [-pass val] [-dcert infile] [-dcertform DER|PEM|P12] [-dcert_chain infile] [-dkey filename|uri] [-dkeyform DER|PEM|P12|ENGINE] [-dpass val] [-nbio_test] [-crlf] [-debug] [-msg] [-msgfile outfile] [-state] [-nocert] [-quiet] [-no_resume_ephemeral] [-www] [-WWW] [-http_server_binmode] [-no_ca_names] [-ignore_unexpected_eof] [-servername] [-servername_fatal] [-tlsextdebug] [-HTTP] [-id_prefix val] [-keymatexport val] [-keymatexportlen +int] [-CRL infile] [-CRLform DER|PEM] [-crl_download] [-chainCAfile infile] [-chainCApath dir] [-chainCAstore uri] [-verifyCAfile infile] [-verifyCApath dir] [-verifyCAstore uri] [-no_cache] [-ext_cache] [-verify_return_error] [-verify_quiet] [-ign_eof] [-no_ign_eof] [-no_ems] [-status] [-status_all] [-status_verbose] [-status_timeout int] [-proxy [http[s]://][userinfo@]host[:port][/path][?query][#fragment]] [-no_proxy addresses] [-status_url val] [-status_file infile] [-ssl_config val] [-trace] [-security_debug] [-security_debug_verbose] [-brief] [-rev] [-async] [-max_send_frag +int] [-split_send_frag +int] [-max_pipelines +int] [-naccept +int] [-read_buf +int] [-no_tx_cert_comp] [-no_rx_cert_comp] [-dhparam infile] [-nbio] [-psk_identity val] [-psk_hint val] [-psk val] [-psk_session file] [-srpvfile infile] [-srpuserseed val] [-timeout] [-mtu +int] [-listen] [-sctp] [-sctp_label_bug] [-use_srtp val] [-no_dhe] [-nextprotoneg val] [-alpn val] [-ktls] [-sendfile] [-zerocopy_sendfile] [-keylogfile outfile] [-recv_max_early_data int] [-max_early_data int] [-early_data] [-stateless] [-anti_replay] [-no_anti_replay] [-num_tickets] [-tfo] [-cert_comp] [-nameopt option] [-no_ssl3] [-no_tls1] [-no_tls1_1] [-no_tls1_2] [-no_tls1_3] [-ssl3] [-tls1] [-tls1_1] [-tls1_2] [-tls1_3] [-dtls] [-dtls1] [-dtls1_2] [-allow_proxy_certs] [-attime timestamp] [-no_check_time] [-check_ss_sig] [-crl_check] [-crl_check_all] [-explicit_policy] [-extended_crl] [-ignore_critical] [-inhibit_any] [-inhibit_map] [-partial_chain] [-policy arg] [-policy_check] [-policy_print] [-purpose purpose] [-suiteB_128] [-suiteB_128_only] [-suiteB_192] [-trusted_first] [-no_alt_chains] [-use_deltas] [-auth_level num] [-verify_depth num] [-verify_email email] [-verify_hostname hostname] [-verify_ip ip] [-verify_name name] [-x509_strict] [-issuer_checks] [-bugs] [-no_comp] [-comp] [-no_ticket] [-serverpref] [-client_renegotiation] [-legacy_renegotiation] [-no_renegotiation] [-no_resumption_on_reneg] [-legacy_server_connect] [-no_legacy_server_connect] [-no_etm] [-allow_no_dhe_kex] [-prefer_no_dhe_kex] [-prioritize_chacha] [-strict] [-sigalgs algs] [-client_sigalgs algs] [-groups groups] [-curves curves] [-named_curve curve] [-cipher ciphers] [-ciphersuites 1.3ciphers] [-min_protocol minprot] [-max_protocol maxprot] [-record_padding padding] [-debug_broken_protocol] [-no_middlebox] [-xkey infile] [-xcert file] [-xchain file] [-xchain_build file] [-xcertform DER|PEM]> [-xkeyform DER|PEM]> [-CAfile file] [-no-CAfile] [-CApath dir] [-no-CApath] [-CAstore uri] [-no-CAstore] [-rand files] [-writerand file] [-engine id] [-provider name] [-provider-path path] [-provparam [name:]key=value] [-propquery propq] [-enable_server_rpk] [-enable_client_rpk] (DESCRIPTION) SSL/TLS SSL/TLS . (OPTIONS) " " SSL_CONF_cmd(3) . -help . -port +int TCP . 4433 . -accept val TCP . *:4433 . -unix val . -4 IPv4. -6 IPv6. -unlink -unix (unlink) . -context val (context id) . . . -verify int, -Verify int . . -verify -Verify . ( PSK) . (D)TLS ("sslclient") . " " openssl-verification-options(1) . -cert infile : DSS DSS (DSA) . server.pem . -cert2 infile servername "server2.pem" . -certform DER|PEM|P12 . openssl-format-options(1) . -cert_chain (URI) -cert. ( OCSP stapling) . PEM DER PKCS#12 . -build_chain . -serverinfo val PEM. PEM TLS ServerHello ( <<>> ). TLS ClientHello ServerHello . -key filename|uri . . -key2 filename|uri servername -cert2 . -keyform DER|PEM|P12|ENGINE . openssl-format-options(1) . -pass val . val openssl-passphrase-options(1) . -dcert infile, -dkey filename|uri -cert -key ( ). . RSA DSS (DSA) . RSA DSS RSA DSS . -dcert_chain (URI) -dcert . PEM DER PKCS#12 . -dcertform DER|PEM|P12 . openssl-format-options(1) . -dkeyform DER|PEM|P12|ENGINE . openssl-format-options(1) . -dpass val . val openssl-passphrase-options(1) . -nbio_test / () . -crlf (line feed) CR+LF . -debug (hex dump) . -security_debug SSL/TLS . -security_debug_verbose SSL/TLS . -msg (hex dump) . -msgfile outfile -msg -trace . -state SSL . -CRL infile CRL . -CRLform DER|PEM CRL . openssl-format-options(1) . -crl_download (CRL) CDP . -verifyCAfile filename PEM CA ( / ) . -verifyCApath dir . << >> (hash format) openssl-verify(1) . -verifyCAstore uri (URI) . -verifyCAfile -verifyCApath -verifyCAstore ( SSL_CTX_set1_verify_cert_store(3)) -CAfile -CApath -CAstore . -CAfile (CA) Certificate Request -CApath -CAstore -verifyCA* . -chainCAfile file PEM . -chainCApath dir . << >> (hash format) openssl-verify(1) . -chainCAstore uri (URI) . URI . URI "file:" URI -chainCAfile -chainCApath . "file:" ossl_store-file(7) . -nocert . ( DH ) . -quiet . -no_resume_ephemeral (EC)DH (ephemeral) . -tlsextdebug (hex dump) TLS . -www . . HTML . "/renegcert" "/reneg" (renegotiation) . -WWW, -HTTP . "https://myhost/page.html" ./page.html . -HTTP HTTP ( ) . -WWW Content-Type . "html" "htm" "php" "text/html" "text/plain" . "/stats" -www . -http_server_binmode ( -WWW -HTTP) () . -no_ca_names CA Names TLS . TLS . -ignore_unexpected_eof TLS close_notify . close_notify . close_notify close_notify . SSL_shutdown(3) . -servername (Servername) TLS HostName. -servername_fatal (fatal alert) (: ). -id_prefix val SSL/TLS val . SSL/TLS ( ) ( ). -keymatexport . -keymatexportlen . -no_cache () . -ext_cache. . -verify_return_error . . -verify_quiet . -ign_eof EOF (: -quiet ). -no_ign_eof EOF . -no_ems (Extended Master Secret). -status ( OCSP OCSP stapling) : OCSP () . -status_all TLS v1.3 ( trust anchor) . -status_verbose ( OCSP stapling) OCSP . -cert_chain . -status_timeout int (timeout) OCSP int . -proxy [http[s]://][userinfo@]host[:port][/path][?query][#fragment] HTTP(S) OCSP -no_proxy . IPv6 "[" "]" . () "https" "http://" "https://" (userinfo) (path) (query) (fragment) . "http_proxy" TLS "HTTP_PROXY" "https_proxy" "HTTPS_PROXY" . -no_proxy addresses IP DNS HTTP(S) ( "..." ). "no_proxy" "NO_PROXY" . -status_url val (URL) (fallback) . . userinfo fragment . (query) (path) . -status_file infile OCSP OCSP . DER . OCSP . -ssl_config val SSL_CTX . -trace (trace) . -brief . -rev (echo) . -brief . -early_data . -async (asynchronous). . -engine . (dasync) ( ). -max_send_frag +int (fragment) . SSL_CTX_set_max_send_fragment(3) . -split_send_frag +int () . () max_pipelines. max_pipelines . SSL_CTX_set_split_send_fragment(3) . -max_pipelines +int () / . ( dasync) . . SSL_CTX_set_max_pipelines(3) . -naccept +int . -read_buf +int . () ( SSL_CTX_set_default_read_buffer_len(3) ). -no_tx_cert_comp TLSv1.3 . -no_rx_cert_comp TLSv1.3 . -no_comp TLS. TLS OpenSSL 1.1.0 . -num_tickets (tickets) TLSv1.3 . . . -dhparam infile DH . DH ( Ephemeral DH) DH . . . -nbio / (I/O) . -timeout . -mtu MTU (link-layer). -psk_identity val PSK PSK val . PSK "Client_identity" . -psk_hint val PSK val PSK. -psk val PSK val PSK. 0x -psk 1a2b3c4d. PSK . -psk_session file SSL_SESSION pem file PSK. TLSv1.3 . -srpvfile SRP. . -srpuserseed (seed) (salt) . . -listen DTLS . UDP () . ClientHello . HelloVerifyRequest . ClientHello () . -sctp SCTP UDP DTLS. -dtls -dtls1 -dtls1_2 . OpenSSL SCTP . -sctp_label_bug OpenSSL (endpoint-pair shared secrets) DTLS/SCTP. . -sctp . SCTP OpenSSL . -use_srtp SRTP (:) . -no_dhe DH DH (ephemeral DH) . -alpn val, -nextprotoneg val Application-Layer Protocol Negotiation (ALPN) Next Protocol Negotiation (NPN) . ALPN IETF NPN . val . . "http/1.1" "spdy/3". -tls1_3 -nextprotoneg . -ktls Kernel TLS . OpenSSL 3.2.0 . OpenSSL 3.2.0 Kernel TLS . -sendfile KTLS BIO_write() SSL_sendfile() HTTP . -ktls -WWW -HTTP . -zerocopy_sendfile SSL_sendfile() (zerocopy TX mode) (hardware offload) KTLS . TLS . -sendfile -sendfile . sendfile KTLS FreeBSD zerocopy . -keylogfile outfile TLS (keylog) ( Wireshark) TLS . -max_early_data int (early data) ( -early_data) . 16k . . -recv_max_early_data int . -early_data . -www -WWW -HTTP -rev . -stateless TLSv1.3 . -anti_replay, -no_anti_replay (Replay) . (Replay) . OpenSSL (session ticket) TLSv1.3 . () . . () . close_notify () . -tfo TCP Fast Open (RFC7413). -cert_comp (RFC8879) () . -nameopt option (subject) (issuer) . openssl-namedisplay-options(1) . -no_ssl3, -no_tls1, -no_tls1_1, -no_tls1_2, -no_tls1_3, -ssl3, -tls1, -tls1_1, -tls1_2, -tls1_3 << TLS>> (TLS Version Options) openssl(1) . -dtls, -dtls1, -dtls1_2 DTLS TLS . << TLS>> (TLS Version Options) openssl(1) . -bugs, -comp, -no_comp, -no_ticket, -serverpref, -client_renegotiation, -legacy_renegotiation, -no_renegotiation, -no_resumption_on_reneg, -legacy_server_connect, -no_legacy_server_connect, -no_etm -allow_no_dhe_kex, -prefer_no_dhe_kex, -prioritize_chacha, -strict, -sigalgs algs, -client_sigalgs algs, -groups groups, -curves curves, -named_curve curve, -cipher ciphers, -ciphersuites 1.3ciphers, -min_protocol minprot, -max_protocol maxprot, -record_padding padding, -debug_broken_protocol, -no_middlebox <> SSL_CONF_cmd(3) . -xkey infile, -xcert file, -xchain file, -xchain_build file, -xcertform DER|PEM, -xkeyform DER|PEM . << >> (Extended Verification Options) openssl-verification-options(1) . -CAfile file, -no-CAfile, -CApath dir, -no-CApath, -CAstore uri, -no-CAstore << >> (Trusted Certificate Options) openssl-verification-options(1) . -rand files, -writerand file << >> (Random State Options) openssl(1) . -engine id << >> (Engine Options) openssl(1) . . -provider name -provider-path path -provparam [name:]key=value -propquery propq << >> (Provider Options) openssl(1) provider(7) property(7) . -allow_proxy_certs, -attime, -no_check_time, -check_ss_sig, -crl_check, -crl_check_all, -explicit_policy, -extended_crl, -ignore_critical, -inhibit_any, -inhibit_map, -no_alt_chains, -partial_chain, -policy, -policy_check, -policy_print, -purpose, -suiteB_128, -suiteB_128_only, -suiteB_192, -trusted_first, -use_deltas, -auth_level, -verify_depth, -verify_email, -verify_hostname, -verify_ip, -verify_name, -x509_strict -issuer_checks . << >> (Verification Options) openssl-verification-options(1) . -verify_return_error . -enable_server_rpk (RPK) (RFC7250) . (RPK) . (RPK) X.509 X.509 . (RPK) / . -enable_client_rpk (RPK) (RFC7250) . X.509 (RPK) . (RPK) X.509 X.509 . (RPK) / . (CONNECTED COMMANDS) SSL -www -WWW . . . : q SSL . Q SSL . r SSL ( TLSv1.2 ). R SSL ( TLSv1.2 ). P TCP . S . k ( TLSv1.3). K ( TLSv1.3). c ( TLSv1.3). (NOTES) SSL . : openssl s_server -accept 443 -www . CA SSL (CA) . . openssl-sess_id(1) . (BUGS) C . SSL . : OpenSSL . . (SEE ALSO) openssl(1), openssl-sess_id(1), openssl-s_client(1), openssl-ciphers(1), SSL_CONF_cmd(3), SSL_CTX_set_max_send_fragment(3), SSL_CTX_set_split_send_fragment(3), SSL_CTX_set_max_pipelines(3), ossl_store-file(7) (HISTORY) -no_alt_chains OpenSSL 1.1.0 . -allow-no-dhe-kex -prioritize_chacha OpenSSL 1.1.1 . -srpvfile -srpuserseed -engine OpenSSL 3.0 . -enable_client_rpk -enable_server_rpk -no_rx_cert_comp -no_tx_cert_comp -tfo OpenSSL 3.2 . -status_all OpenSSL 3.6 . (COPYRIGHT) 2000-2026 OpenSSL . . 2.0 (<<>>) . . LICENSE . 3.6.4 2026-08-25 OPENSSL-S_SERVER(1ssl)