ntpd(1) User Commands ntpd(1) (NAME) ntpd - (NTP) (SYNOPSIS) ntpd [-flags] [-flag [value]] [--option-name[[=| ]value]] [ ... ] (DESCRIPTION) ntpd . (NTP) RFC-5905 RFC-1305 RFC-1059 RFC-1119 . ntpd ( ) . . ntpd ntp.conf(5) . . / (broadcast/multicast) . NetInfo ntpd ntp.conf(5) -c ntpd NetInfo . ntpd ntpd ntpq(1) ntpdc(1) . ntpd umask(2) ntpd umask(2) 022 . (OPTIONS) -4, --ipv4 DNS IPv4. : ipv6. DNS IPv4. -6, --ipv6 DNS IPv6. : ipv4. DNS IPv6. -a, --authreq . : authnoreq. (broadcast) (multicast) (symmetric passive). . -A, --authnoreq . : authreq. . . -b, --bcastsync (broadcast). -c string, --configfile=string . /etc/ntp.conf . -d, --debug-level . . -D number, --set-debug-level=number . . . -f string, --driftfile=string (drift). /etc/ntp.drift . driftfile driftfile /etc/ntp.conf . -g, --panicgate . . (panic threshold) ntpd . . ntpd . -q -x . tinker . -G, --force-step-once (Step) . ntpd ( ) (slew). . (monotonic time) . tinker . -i string, --jaildir=string (Jail). (Chroot) jaildir (root) . -u . . NetBSD ( --enable-clockctl) ( --enable-linuxcaps) ( --enable- solarisprivs) . -I iface, --interface=iface . . . . (wildcard) localhost . . interface . -k string, --keyfile=string . . /etc/ntp.keys . keys keyfile . -l string, --logfile=string (). . . logfile logfile . -L, --novirtualips . . . interface . -M, --modifymmtimer ( ). (resolution). ntpd . -n, --nofork . : wait-sync. -N, --nice . ntpd . -p string, --pidfile=string (PID). ntpd pidfile pidfile . -P number, --priority=number . . ntpd sched_setscheduler(SCHED_FIFO) . -q, --quit . : saveconfigquit, wait-sync. ntpd . ntpdate . -g -x . : . -r string, --propagationdelay=string /. / . . --saveconfigquit=string . : quit, wait-sync. ntpd . . -s string, --statsdir=string . . statsdir statsdir . -t tkey, --trustedkey=tkey . . . -u string, --user=string ( userid:groupid). . . NetBSD ( --enable-clockctl) ( --enable-linuxcaps) ( --enable-solarisprivs) . -U number, --updateinterval=number . . . . 0 . . --var=nvar ARG ntp (/ RW). . --dvar=ndvar ARG ntp (/ RW|DEF). . -w number, --wait-sync=number . : nofork, quit, saveconfigquit. . ntpd . 0 . () ETIMEDOUT . ntpd . -x, --slew (Slew) . ( ) (step) . . : 0.5 . . -g -q . tinker . : . --usepcc ( ). QueryPerformanceCounter. QueryPerformanceCounter (RDTSC x86) . --pccfreq=string ( ). QueryPerformanceCounter. (RDTSC x86) ( ) . -m, --mdns mDNS NTP. NTP mDNS mDNS . -?, --help . -!, --more-help (pager). --version [{v|c|n}] . 'v' . 'c' 'n' . (OPTION PRESETS) not presettable : NTPD_ NTPD (USAGE) NTP ntpd (poll interval) . . (bursts) . . iburst server ntp.conf(5) . (TOY) . . NTP . ntpd ntpd . ( TOY .) ntpd (panic) . -g ( -- NTPv4 ). CMOS ntpd . ntpd . (jitter) ( ) . ntpd . . . . ntpd drift . . . -x (slew) . -x . NTP (PPM) . . . . ntpd ntp.drift . . ( time.ien.it ) / . burst . ntpdate(1) sntp(1) ntpd(1) . NTP ( ) ntpd ntpd sntp(1) . ntpd(1) . NTP ( ) iburst server . ntp.drift ntpd(1) " " (warm-start) . ntpd(1) -g -N . "" . ntpd(1) . dovecot (monotonically- increasing) ntp-wait(1) ( -v ) ntp-wait(1) . (Frequency Discipline) ntpd ( ntp.drift, ) . . ntpd ntpd . ntpd . . ntpd ntpd . . (Operating Modes) ntpd / (symmetric active/passive) / / (broadcast/multicast) (manycast) "Association Management" ( HTML /usr/share/doc/ntp) . . . / - . . ntpd . . . . . ntpd . ntpdate(1) sntp(1) cron(8) . ntpd . -q . ntpd . iburst server . . . ntpdate(1) . ( Tru64 FreeBSD ) . ntpd . . ntpd . . (Poll Interval Control) NTP . . . tinker minpoll . minpoll . manycast broadcast . dial up . . . (capture range) PPM . PPM . ntp.drift . . -- (The huff-n'-puff Filter) . . . huff-n'-puff . . . (shift register) . . (huff) (puff) . tinker huffpuff ntp.conf(5) . (ENVIRONMENT) (OPTION PRESETS) . (FILES) /etc/ntp.conf /etc/ntp.drift (drift) /etc/ntp.keys (EXIT STATUS) : 0 (EXIT_SUCCESS) . 1 (EXIT_FAILURE) . 70 (EX_SOFTWARE) libopts . autogen- users@lists.sourceforge.net . . (SEE ALSO) ntp.conf(5), ntpdate(1), ntpdc(1), ntpq(1), sntp(1) http://www.ntp.org . HTML /usr/share/doc/ntp . David L. Mills, Network Time Protocol (Version 1), RFC1059 David L. Mills, Network Time Protocol (Version 2), RFC1119 David L. Mills, Network Time Protocol (Version 3), RFC1305 David L. Mills and J. Martin, Ed. and J. Burbank and W. Kasch, Network Time Protocol Version 4: Protocol and Algorithms Specification, RFC5905 David L. Mills and B. Haberman, Ed., Network Time Protocol Version 4: Autokey Specification, RFC5906 H. Gerstung and C. Elliott and B. Haberman, Ed., Definitions of Managed Objects for Network Time Protocol Version 4: (NTPv4), RFC5907 R. Gayraud and B. Lourdelet, Network Time Protocol (NTP) Server Option for DHCPv6, RFC5908 (AUTHORS) (University of Delaware) (Network Time Foundation) (COPYRIGHT) (C) 1992-2024 Network Time Foundation . NTP . (BUGS) ntpd . ntpd (stratum) . : https://bugs.ntp.org, bugs@ntp.org (NOTES) FreeBSD . AutoGen ntpd . 4.2.8p18 25 May 2024 ntpd(1)