negotiate_kerberos_auth(8) System Manager's Manual negotiate_kerberos_auth(8) (NAME) negotiate_kerberos_auth - (Kerberos) (Squid) 3.0.4sq (SYNOPSIS) negotiate_kerberos_auth [-h] [-d] [-i] [-r] [-s Service-Principal-Name] [-k Keytab-Name] [-c Replay-Cache-Directory] [-t Replay-Cache-Type] (DESCRIPTION) negotiate_kerberos_auth (Squid) Negotiate (Kerberos) . (OPTIONS) -h (stderr). -d (debug) stderr. -i (informational) stderr. -r (realm) . -s Service-Principal-name (Service Principal Name). -k Keytab-Name Keytab (: /etc/krb5.keytab). -c Replay-Cache-Directory (Replay Cache Directory) (: /var/tmp). -t Replay-Cache-Type (Replay Cache Type) (: dfl). (CONFIGURATION) squid.conf . auth_param negotiate program /path/to/negotiate_kerberos_auth auth_param negotiate children 10 auth_param negotiate keep_alive on : : keytab HTTP/fqdn . keytab -k . fqdn . IP . KRB5_KTNAME=/etc/squid/HTTP.keytab export KRB5_KTNAME : KRB5_CONFIG=/etc/krb5-squid.conf export KRB5_CONFIG (replay cache) ( ) . Negotiate(Kerberos) CPU . MIT -t none : KRB5RCACHETYPE=none export KRB5RCACHETYPE negotiate_kerberos_auth -s HTTP/fqdn . HTTP/fqdn@REALM HTTP.keytab -s GSS_C_NO_NAME negotiate_kerberos_auth . (AUTHOR) : Markus Moeller : Markus Moeller (COPYRIGHT) * Copyright (C) 1996-2014 The Squid Software Foundation and contributors * * +GPLv2 * . * COPYING CONTRIBUTORS . . (GNU GPL) (+GPLv2). (QUESTIONS) : (REPORTING BUGS) . https://wiki.squid-cache.org/SquidFaq/BugReporting . http://bugs.squid-cache.org Squid Bugs (SEE ALSO) squid(8) ext_kerberos_ldap_group_acl(8) RFC4559 - HTTP NTLM SPNEGO , RFC2478 - GSS-API, RFC1964 - GSS-API , : https://wiki.squid-cache.org/SquidFaq : http://www.squid-cache.org/Doc/config https://wiki.squid-cache.org/ConfigExamples/Authenticate/Kerberos negotiate_kerberos_auth(8)