.if !'po4a'hide' .TH negotiate_kerberos_auth 8 . .SH "نام (NAME)" negotiate_kerberos_auth \- ابزار کمکی احراز هویت مبتنی بر کربروس (Kerberos) برای اسکوئید (Squid) .PP نگارش 3.0.4sq . .SH "خلاصه دستور (SYNOPSIS)" .if !'po4a'hide' .B negotiate_kerberos_auth .if !'po4a'hide' .B [\-h] [\-d] [\-i] [\-r] [\-s Service\-Principal\-Name] [\-k Keytab\-Name] [\-c Replay\-Cache\-Directory] [\-t Replay\-Cache\-Type] . .SH "توضیحات (DESCRIPTION)" برنامه .B negotiate_kerberos_auth یک باینری نصب‌شده است که به اسکوئید (Squid) اجازه می‌دهد تا کاربران را از طریق پروتکل Negotiate و کربروس (Kerberos) احراز هویت کند. .SH "گزینه‌ها (OPTIONS)" .if !'po4a'hide' .TP 12 .if !'po4a'hide' .B \-h نمایش راهنمای باینری و اطلاعات ساختار دستوری خط فرمان در خروجی خطای استاندارد (stderr). .if !'po4a'hide' .TP 12 .if !'po4a'hide' .B \-d نوشتن پیام‌های اشکال‌زدایی (debug) در stderr. .if !'po4a'hide' .TP 12 .if !'po4a'hide' .B \-i نوشتن پیام‌های اطلاعاتی (informational) در stderr. .if !'po4a'hide' .TP 12 .if !'po4a'hide' .B \-r حذف قلمرو (realm) از نام کاربری قبل از بازگرداندن نام کاربری به اسکوئید. .if !'po4a'hide' .TP 12 .if !'po4a'hide' .B \-s Service\-Principal\-name تعیین نام اصلی سرویس (Service Principal Name). .if !'po4a'hide' .TP 12 .if !'po4a'hide' .B \-k Keytab\-Name تعیین نام پرونده Keytab کربروس (پیش‌فرض: /etc/krb5.keytab). .if !'po4a'hide' .TP 12 .if !'po4a'hide' .B \-c Replay\-Cache\-Directory تعیین پوشه حافظه نهان بازپخش (Replay Cache Directory) (پیش‌فرض: /var/tmp). .if !'po4a'hide' .TP 12 .if !'po4a'hide' .B \-t Replay\-Cache\-Type تعیین نوع حافظه نهان بازپخش (Replay Cache Type) (پیش‌فرض: dfl). . .SH "پیکربندی (CONFIGURATION)" .PP این ابزار کمکی برای استفاده به عنوان یک ابزار کمکی .B احراز هویت در .B squid.conf در نظر گرفته شده است. .if !'po4a'hide' .P .if !'po4a'hide' .ft CR .if !'po4a'hide' .nf .if !'po4a'hide' auth_param negotiate program /path/to/negotiate_kerberos_auth .if !'po4a'hide' .br .if !'po4a'hide' auth_param negotiate children 10 .if !'po4a'hide' .br .if !'po4a'hide' auth_param negotiate keep_alive on .if !'po4a'hide' .fi .if !'po4a'hide' .ft .PP .B نکته: ممکن است تغییرات زیر در پرونده راه‌اندازی اسکوئید لازم باشد: خطوط زیر را به اسکریپت راه‌اندازی اسکوئید اضافه کنید تا اسکوئید را به یک پرونده keytab هدایت کند که شامل نام اصلی سرویس HTTP/fqdn برای دامنه پیش‌فرض کربروس است. نام keytab را می‌توان با گزینه \-k نیز مشخص کرد. مقدار fqdn باید نام پروکسی تنظیم‌شده در مرورگر باشد. نمی‌توانید از نشانی IP استفاده کنید. .nf KRB5_KTNAME=/etc/squid/HTTP.keytab export KRB5_KTNAME .fi اگر از دامنه کربروس متفاوتی نسبت به دامنه‌ای که خود ماشین در آن قرار دارد استفاده می‌کنید، می‌توانید با تنظیم متغیر محیطی زیر در اسکریپت راه‌اندازی، اسکوئید را به پرونده پیکربندی مجزای کربروس هدایت کنید: .nf KRB5_CONFIG=/etc/krb5\-squid.conf export KRB5_CONFIG .fi کربروس می‌تواند یک حافظه نهان بازپخش (replay cache) برای تشخیص استفاده مجدد از بلیت‌های کربروس (که معمولاً فقط در یک بازه ۵ دقیقه‌ای امکان‌پذیر است) نگهداری کند. اگر اسکوئید تحت بار کاری سنگین با درخواست‌های احراز هویت پروکسی Negotiate(Kerberos) باشد، بررسی‌های حافظه نهان بازپخش می‌تواند بار CPU بالایی ایجاد کند. اگر محیط به امنیت بسیار بالا نیاز ندارد، بررسی حافظه نهان بازپخش را می‌توان برای پیاده‌سازی‌های کربروس مبتنی بر MIT با افزودن خطوط زیر به اسکریپت راه‌اندازی یا استفاده از گزینه \-t none غیرفعال کرد: .nf KRB5RCACHETYPE=none export KRB5RCACHETYPE .fi اگر negotiate_kerberos_auth به هر دلیلی نام اصلی سرویس صحیح را تشخیص ندهد، می‌توانید آن را با \-s HTTP/fqdn ارائه دهید. اگر به چندین قلمرو کربروس سرویس می‌دهید، یک نام اصلی سرویس HTTP/fqdn@REALM به ازای هر قلمرو به پرونده HTTP.keytab اضافه کنید و از گزینه \-s GSS_C_NO_NAME در negotiate_kerberos_auth استفاده نمایید. . .SH "نویسنده (AUTHOR)" این برنامه توسط فرد زیر نوشته شده است: .if !'po4a'hide' .I Markus Moeller .PP این راهنما توسط فرد زیر نوشته شده است: .if !'po4a'hide' .I Markus Moeller . .SH "حق نشر (COPYRIGHT)" .PP * Copyright (C) 1996\-2014 The Squid Software Foundation and contributors * * نرم‌افزار اسکوئید تحت مجوز +GPLv2 توزیع می‌شود و شامل * مشارکت‌های افراد و سازمان‌های متعددی است. * لطفاً برای جزئیات پرونده‌های COPYING و CONTRIBUTORS را ببینید. .PP حق نشر این برنامه و مستندات متعلق به نویسندگان نام‌برده در بالاست. .PP توزیع‌شده تحت مجوز عمومی همگانی گنو (GNU GPL) نگارش ۲ یا بالاتر (+GPLv2). . .SH "پرسش‌ها (QUESTIONS)" پرسش‌ها درباره نحوه استفاده از این برنامه را می‌توانید به .I فهرست پستی کاربران اسکوئید ارسال کنید: .if !'po4a'hide' . .SH "گزارش باگ‌ها (REPORTING BUGS)" گزارش‌های باگ باید به زبان انگلیسی ارسال شوند. برای جزئیات مواردی که باید در گزارش باگ خود قرار دهید به https://wiki.squid\-cache.org/SquidFaq/BugReporting مراجعه کنید. .PP گزارش باگ‌ها یا اصلاحات باگ با استفاده از http://bugs.squid\-cache.org .PP گزارش باگ‌های امنیتی جدی به .I Squid Bugs .PP گزارش ایده‌ها برای بهبودهای جدید به .I فهرست پستی توسعه‌دهندگان اسکوئید .if !'po4a'hide' . .SH "همچنین ببینید (SEE ALSO)" .if !'po4a'hide' .BR squid "(8) " .if !'po4a'hide' .BR ext_kerberos_ldap_group_acl "(8) " .br .BR RFC4559 " \- احراز هویت HTTP با کربروس و NTLM بر پایه SPNEGO در مایکروسافت ویندوز," .br .BR RFC2478 " \- سازوکار مذاکره ساده و محافظت‌شده GSS\-API," .br .BR RFC1964 " \- سازوکار GSS\-API در نگارش ۵ کربروس," .br ویکی سؤالات متداول اسکوئید: .if !'po4a'hide' https://wiki.squid\-cache.org/SquidFaq .br راهنمای پیکربندی اسکوئید: .if !'po4a'hide' http://www.squid\-cache.org/Doc/config .if !'po4a'hide' https://wiki.squid\-cache.org/ConfigExamples/Authenticate/Kerberos