.\" -*-nroff-*- .\" .\" .\" Copyright (C) 1996-2026 Michael R. Elkins .\" .\" This program is free software; you can redistribute it and/or modify .\" it under the terms of the GNU General Public License as published by .\" the Free Software Foundation; either version 2 of the License, or .\" (at your option) any later version. .\" .\" This program is distributed in the hope that it will be useful, .\" but WITHOUT ANY WARRANTY; without even the implied warranty of .\" MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the .\" GNU General Public License for more details. .\" .\" You should have received a copy of the GNU General Public License .\" along with this program; if not, write to the Free Software .\" Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA. .\" .TH MUTT 1 "July 24, 2020" Unix "راهنمای کاربر" .SH "نام (NAME)" mutt \- کارگزار کاربری ایمیل مات (The Mutt Mail User Agent) .SH "خلاصه دستور (SYNOPSIS)" .TP 6 .B mutt [\fB\-nRyzZ\fR] [\fB\-e \fIcommand\fR] [\fB\-F \fIrcfile\fR] [\fB\-m \fItype\fR] [\fB\-f \fImailbox\fR] .TP 6 .B mutt [\fB\-Enx\fR] [\fB\-e \fIcommand\fR] [\fB\-F \fIrcfile\fR] [\fB\-H \fIdraft\fR] [\fB\-i \fIinclude\fR] .br [\fB\-b \fIbcc-addr\fR] [\fB\-c \fIcc-addr\fR] [\fB\-s \fIsubject\fR] .br [\fB\-a \fIfile ... \fB\-\-\fR] \fIto-addr ... .TP 6 .B mutt [\fB\-nx\fR] [\fB\-e \fIcommand\fR] [\fB\-F \fIrcfile\fR] [\fB\-b \fIbcc-addr\fR] [\fB\-c \fIcc-addr\fR] .br [\fB\-s \fIsubject\fR] [\fB\-a \fIfile ... \fB\-\-\fR] \fIto-addr ... \fR< message .TP 6 .B mutt [\fB\-n\fR] [\fB\-e \fIcommand\fR] [\fB\-F \fIrcfile\fR] \fB\-p .TP 6 .B mutt [\fB\-n\fR] [\fB\-e \fIcommand\fR] [\fB\-F \fIrcfile\fR] \fB\-A \fIalias .TP 6 .B mutt [\fB\-n\fR] [\fB\-e \fIcommand\fR] [\fB\-F \fIrcfile\fR] \fB\-Q \fIvariable .TP 6 .B mutt \fB\-v\fR[\fBv\fR] .TP 6 .B mutt \fB\-D .SH "توضیحات (DESCRIPTION)" .PP برنامهٔ Mutt یک ابزار کوچک اما بسیار قدرتمند مبتنی بر متن برای خواندن و ارسال رایانامه (ایمیل) در سیستم‌عامل‌های یونیکس است که از پایانه‌های رنگی، MIME، OpenPGP و حالت مرتب‌سازی موضوعی (threaded) پشتیبانی می‌کند. .PP .BR نکته : این صفحهٔ راهنما مرور مختصری از گزینه‌های خط فرمان برنامهٔ اجرایی \fBmutt\fP ارائه می‌دهد. نسخه‌ای از راهنمای کامل در مسیر \fI/usr/share/doc/mutt\fP در قالب متنی، HTML و/یا PDF قرار دارد. لطفاً برای یادگیری نحوهٔ استفاده و پیکربندی Mutt به راهنمای آن مراجعه کنید. .SH "گزینه‌ها (OPTIONS)" .TP .BI \-A " alias" چاپ نسخه گسترش‌یافته از \fIalias\fP مشخص‌شده و خروج. .TP .BI \-a " file ... " پیوست کردن یک \fIfile\fP با استفاده از MIME. جداسازی شناسه‌های \fIfile\fP و \fIto-addr\fP با \*(lq\fB\-\-\fP\*(rq الزامی است. برای مثال: .sp .in +4m .nf mutt \-a image.jpg \-\- to-addr mutt \-a img.jpg *.png \-\- to-addr-1 to-addr-2 .fi .in .sp گزینهٔ \fB\-a\fP باید در انتهای گزینه‌های خط فرمان قرار گیرد. .TP .BI \-b " bcc-addr" مشخص کردن یک نشانی رونوشت پنهان (BCC). .TP .BI \-c " cc-addr" مشخص کردن یک نشانی رونوشت (CC). .TP .BI \-d " level" اگر Mutt با \fB+DEBUG\fP کامپایل شده باشد، خروجی اشکال‌زدایی را در \fI~/.muttdebug0\fP ثبت می‌کند. \fIlevel\fP می‌تواند بین -5 تا 5 باشد و بر میزان جزئیات تأثیر می‌گذارد. مقدار صفر اشکال‌زدایی را غیرفعال می‌کند. مقدار کمتر از صفر چرخش خودکار فایل گزارش را غیرفعال می‌کند؛ در این حالت سطح گزارش برابر با مقدار مطلق آن خواهد بود. مقدار 2 (-2) برای اکثر موارد عیب‌یابی پیشنهاد می‌شود. .TP .B \-D چاپ مقدار تمام گزینه‌های پیکربندی در خروجی استاندارد (stdout). .TP .B \-E ویرایش فایل پیش‌نویس (\fIdraft\fP) مشخص‌شده با \fB\-H\fP یا فایل ضمیمه‌شده (\fIinclude\fP) مشخص‌شده با \fB\-i\fP در هنگام نوشتن پیام. .TP .BI \-e " command" مشخص کردن یک دستور پیکربندی (\fIcommand\fP) برای اجرا پس از پردازش فایل‌های مقداردهی اولیه. .TP .BI \-f " mailbox" مشخص کردن صندوق پستی (\fImailbox\fP) برای بارگذاری. .TP .BI \-F " rcfile" استفاده از \fIrcfile\fP به جای فایل پیکربندی کاربر. .TP .B \-h نمایش خلاصهٔ کوتاهی از گزینه‌ها و خروج. .TP .BI \-H " draft" مشخص کردن یک فایل پیش‌نویس (\fIdraft\fP) شامل سرایند و بدنه برای ارسال پیام. اگر \fIdraft\fP برابر با \*(lq\fB\-\fP\*(rq باشد، داده‌ها از ورودی استاندارد (stdin) خوانده می‌شوند. انتظار می‌رود فایل پیش‌نویس صرفاً شامل یک ایمیل مطابق با RFC822 \(em سرایندها و بدنه \(em باشد. اگرچه این یک فایل mbox نیست، اما اگر خط «\fBFrom\~\fP» قالب mbox وجود داشته باشد، بدون خطا نادیده گرفته می‌شود. فایل‌های پیش‌نویس در هر دو حالت تعاملی و دسته‌ای یکسان پردازش می‌شوند؛ آنها دست‌نخورده عبور داده نمی‌شوند. به عنوان مثال، فایل‌های پیش‌نویس رمزگذاری‌شده، رمزگشایی خواهند شد. .TP .BI \-i " include" مشخص کردن یک فایل الحاقی (\fIinclude\fP) برای درج در بدنهٔ پیام. در صورت تنظیم بودن \fB\-H\fP نادیده گرفته می‌شود. اگر \fIinclude\fP برابر با \*(lq\fB\-\fP\*(rq باشد، داده‌ها از ورودی استاندارد خوانده می‌شوند. .TP .BI \-m " type" مشخص کردن نوع (\fItype\fP) پیش‌فرض صندوق پستی برای پوشه‌های تازه ایجادشده. می‌تواند یکی از موارد زیر باشد: mbox، MMDF، MH یا Maildir. همچنین بخش \fB$mbox_type\fP را در راهنما ببینید. .TP .B \-n فایل پیکربندی سراسری سیستم (Muttrc) خوانده نشود. .TP .B \-p ادامه دادن ویرایش یک پیام به تعویق افتاده (postponed). در صورت عدم وجود پیام به تعویق افتاده، فوراً خارج می‌شود. .TP .BI \-Q " variable" پرس‌وجوی یک متغیر پیکربندی (\fIvariable\fP). این پرس‌وجو پس از تجزیه تمام فایل‌های پیکربندی و اجرای هرگونه دستور (\fIcommands\fP) ارائه‌شده در خط فرمان انجام می‌شود. .TP .B \-R باز کردن صندوق پستی در حالت فقط‌خواندنی. .TP .BI \-s " subject" مشخص کردن موضوع (\fIsubject\fP) پیام. در صورت داشتن فاصله، باید درون نقل‌قول قرار گیرد. .TP .B \-v نمایش شماره نسخه Mutt و تعاریف زمان کامپایل. .TP .B \-vv نمایش اطلاعات مجوز و حق نشر. .TP .B \-x شبیه‌سازی حالت نگارش .BR mailx (1). .TP .B \-y اجرای Mutt همراه با فهرستی از تمام صندوق‌های پستی مشخص‌شده توسط دستور پیکربندی \fImailboxes\fP. .TP .B \-z خروج فوری با کد 1 در صورتی که صندوق پستی (\fImailbox\fP) مشخص‌شده با \fB\-f\fP هیچ پیامی نداشته باشد. .TP .B \-Z باز کردن نخستین صندوق پستی مشخص‌شده در دستور پیکربندی \fImailboxes\fP که شامل نامهٔ جدید باشد. در صورتی که در هیچ‌کدام نامه جدیدی نباشد، فوراً با کد 1 خارج می‌شود. .TP .B \-\- برخورد با شناسه‌های باقی‌مانده به عنوان \fIto-addr\fP حتی اگر با خط تیره آغاز شوند. همچنین گزینهٔ \fB\-a\fP در بالا را ببینید. نشانی \fIto-addr\fP می‌تواند یک نشانی ایمیل محلی یا شبکه‌ای و یا یک URL از نوع :mailto باشد. .SH "محیط (ENVIRONMENT)" .IP "EDITOR, VISUAL" ویرایشگر مورد استفاده هنگام نگارش پیام‌ها را مشخص می‌کند. اگر هر دو متغیر EDITOR و VISUAL تنظیم شده باشند، VISUAL اولویت دارد. اگر هیچ‌کدام تنظیم نشده باشند، پیش‌فرض .BR vi (1) است. .IP "EGDSOCKET, RANDFILE" مسیرهای مورد استفاده برای مقداردهی اولیه موتور تصادفی کتابخانهٔ SSL. .IP "EMAIL" نشانی ایمیل کاربر. .IP "HOME" مسیر کامل دایرکتوری خانگی کاربر. .IP "MAIL" مسیر کامل صندوق پستی مخزن (spool) کاربر. .IP "MAILDIR" مسیر کامل صندوق پستی مخزن کاربر در صورت تنظیم نبودن MAIL. معمولاً زمانی استفاده می‌شود که صندوق پستی مخزن یک پوشهٔ .BR maildir (5) باشد. .IP "MAILCAPS" مسیر جستجوی فایل‌های mailcap. .IP "MM_NOASK" در صورت تنظیم بودن این متغیر، mailcap همیشه بدون درخواست تأیید اولیه استفاده می‌شود. .IP "PGPPATH" دایرکتوری حاوی دسته‌کلید عمومی PGP کاربر. هنگام استفاده با برنامهٔ اصلی PGP، برنامهٔ mutt و .BR mutt_pgpring (1) به تنظیم بودن این متغیر وابسته هستند. .IP "REPLYTO" نشانی پیش‌فرض پاسخ‌به (Reply-To). .IP "TMPDIR" دایرکتوری ایجاد فایل‌های موقت. در صورت تنظیم نبودن، \fI/tmp\fP برای tmpdir$ و \fI/var/tmp\fP برای tmpdraftdir$ استفاده می‌شود. متغیرهای پیکربندی tmpdir$ و tmpdraftdir$ را نیز در راهنما ببینید. .IP "LC_ALL, LC_CTYPE, LANG" برای تعیین مجموعه نویسه‌ها (charset) و محلی‌سازی (locale) مورد استفاده قرار می‌گیرند. .IP TEXTDOMAINDIR دایرکتوری حاوی فایل‌های ترجمه. در صورت تنظیم، این مسیر جایگزین دایرکتوری نصب Mutt می‌شود. برای آزمایش تغییرات ترجمه استفاده می‌شود. .SH "فایل‌ها (FILES)" .TP .I ~/.muttrc .TQ .I ~/.mutt/muttrc .TQ .I $XDG_CONFIG_HOME/mutt/muttrc فایل‌های پیکربندی کاربر. .TP .I /etc/mutt/Muttrc or /usr/share/mutt/Muttrc فایل پیکربندی سراسری سیستم. .TP .I /tmp/muttXXXXXX فایل‌های موقت ایجادشده توسط Mutt. .TP .I ~/.muttdebug0 فایل حاوی خروجی اشکال‌زدایی. فایل‌های گزارش به‌طور خودکار توسط \fBmutt\fP با تغییر شماره در انتهای نام چرخانده می‌شوند. گزینهٔ \fB\-d\fP در بالا را ببینید. .TP .I ~/.mailcap تعریف‌های کاربر برای مدیریت انواع غیر متنی MIME. .TP .I /etc/mutt/mailcap تعریف‌های سیستمی برای مدیریت انواع غیر متنی MIME. .TP .I ~/.mime.types نگاشت شخصی کاربر بین انواع MIME و پسوند فایل‌ها. .TP .I /etc/mutt/mime.types نگاشت سیستمی بین انواع MIME و پسوند فایل‌ها. .TP .I /usr/bin/mutt_dotlock برنامهٔ ممتاز قفل‌گذاری با نقطه (dotlocking). .TP .I /usr/share/doc/mutt/manual.txt راهنمای Mutt. .SH "اشکالات (BUGS)" .PP هیچ مشکلی وجود ندارد. سگ‌های دورگه (Mutts) کک دارند، نه حشره (bug)! .SH "کک‌ها (FLEAS)" .PP تعلیق/ازسرگیری (Suspend/resume) هنگام ویرایش یک فایل با یک ویرایشگر خارجی در SunOS 4.x در صورت استفاده از کتابخانه curses در /usr/5lib کار نمی‌کند. هرچند با کتابخانه S-Lang کار \fIمی‌کند\fP. .PP تغییر اندازه صفحه هنگام استفاده از یک صفحه‌بند (pager) خارجی در برخی سیستم‌ها باعث به هم ریختن رفتار Mutt می‌شود. .PP تعلیق/ازسرگیری در Ultrix کار نمی‌کند. .PP اگر کلیدهای میانبر یکی از توابع فهرست‌شده را هنگام اجرای Mutt تغییر دهید، خط راهنما برای منوی نمایه (index menu) به‌روزرسانی نمی‌شود. .PP برای دریافت فهرست به‌روزتری از اشکالات یا همان کک‌ها، لطفاً به سامانه ردیابی اشکالات پروژه mutt در آدرس https://gitlab.com/muttmua/mutt/issues مراجعه کنید. نکته: سامانه ردیابی اشکالات برای درخواست ویژگی‌های جدید نیست. این درخواست‌ها باید به فهرست پستی mutt-dev ارسال شوند؛ برای جزئیات بیشتر به بخش 1.2 راهنما با عنوان فهرست‌های پستی (Mailing Lists) مراجعه کنید. .SH "بدون ضمانت (NO WARRANTIES)" این برنامه با این امید توزیع شده است که مفید باشد، اما بدون هرگونه ضمانت؛ حتی بدون ضمانت ضمنی قابلیت فروش یا تناسب برای یک هدف خاص. برای جزئیات بیشتر مجوز عمومی همگانی گنو (GNU General Public License) را مطالعه کنید. .SH "همچنین ببینید (SEE ALSO)" .PP .BR mutt_dotlock (1), .BR mutt_pgpring (1), .BR pgpewrap (1), .BR sendmail (1), .BR smail (1), .BR smime_keys (1), .BR curses (3), .BR ncurses (3), .BR mailcap (5), .BR maildir (5), .BR mbox (5), .BR mmdf (5), .BR muttrc (5) .PP صفحه خانگی Mutt: http://www.mutt.org .PP راهنمای Mutt .PP RFC5322 \(em قالب پیام اینترنتی: https://tools.ietf.org/rfcmarkup/5322 (جایگزین RFC2822 و RFC822) .SH "نویسنده (AUTHOR)" .PP مایکل الکینز (Michael Elkins) و دیگران. برای برقراری ارتباط با توسعه‌دهندگان از استفاده کنید.