SMTP(8) System Manager's Manual SMTP(8) (NAME) smtp, lmtp - SMTP+LMTP Postfix (SYNOPSIS) smtp [ Postfix] [flags=DORX] lmtp [ Postfix] [flags=DORX] (DESCRIPTION) SMTP+LMTP Postfix SMTP LMTP . . . master(8) . smtp lmtp . SMTP+LMTP . bounce(8) defer(8) trace(8) . SMTP LMTP << SMTP>> << LMTP>> . scache(8) SMTP+LMTP . . . SMTP (SMTP SERVER LOOKUP) SMTP Postfix (Postfix 3.5 ). . SMTP : domainname domainname:service (: smtp). SRV MX service . [hostname] [hostname]:service () (: smtp). [address] [address]:service (: smtp). IPv6 [ipv6:address] . LMTP (LMTP SERVER LOOKUP) LMTP Postfix (Postfix 3.5 ). . LMTP : unix:pathname pathname (bind) . chroot Postfix . inet:domainname inet:domainname:service LMTP (: lmtp). SRV service . inet:hostname inet:hostname:service () (: lmtp). SRV [hostname] . inet:[address] inet:[address]:service (: lmtp). IPv6 [ipv6:address] . (SINGLE-RECIPIENT DELIVERY) SMTP+LMTP Postfix . Delivered-to: X-Original-To: . Postfix : transport_destination_recipient_limit = 1 main.cf Postfix transport master.cf Postfix . (COMMAND ATTRIBUTE SYNTAX) flags=DORX () . D "Delivered-To: recipient" . : transport_destination_recipient_limit ( << >> ). D : Delivered-To: . . Postfix 3.5 . O "X-Original-To: recipient" Postfix . : transport_destination_recipient_limit ( << >> ). Postfix 3.5 . R "Return-Path: " . Postfix 3.5 . X . DSN ( ) <<>> (success) "relayed" () "delivered" ( ) . Postfix 3.5 . (SECURITY) SMTP+LMTP . SMTP LMTP DNS . SMTP+LMTP chroot . (STANDARDS) RFC 821 ( SMTP) RFC 822 ( ARPA) RFC 1651 ( SMTP) RFC 1652 ( 8bit-MIME) RFC 1870 ( ) RFC 2033 ( LMTP) RFC 2034 ( SMTP) RFC 2045 (MIME: ) RFC 2046 (MIME: ) RFC 2554 ( AUTH) RFC 2821 ( SMTP) RFC 2782 ( SRV) RFC 2920 ( SMTP) RFC 3207 ( STARTTLS) RFC 3461 ( DSN SMTP) RFC 3463 ( ) RFC 4954 ( AUTH) RFC 5321 ( SMTP) RFC 6531 (SMTP ) RFC 6533 ( ) RFC 7672 ( SMTP DANE TLS ) RFC 8689 ( REQUIRETLS SMTP TLS-Required) (DIAGNOSTICS) syslogd(8) postlogd(8) . corrupt . notify_classes (postmaster) (bounces) . (BUGS) SMTP LMTP TLS ( SMTP LMTP) Postfix 3.4 . SMTP LMTP SASL IP TCP . (CONFIGURATION PARAMETERS) 2.3 Postfix SMTP LMTP smtp lmtp . smtp_xxx <<>> lmtp_xxx LMTP . LMTP <<>> . main.cf smtp(8) . "postfix reload" . . postconf(5) . (COMPATIBILITY CONTROLS) ignore_mx_lookup_error (no) DNS MX . smtp_always_send_ehlo (yes) EHLO SMTP. smtp_never_send_ehlo (no) EHLO SMTP. smtp_defer_if_no_mx_address_found (no) MX IP . smtp_line_length_limit (998) Postfix SMTP . smtp_pix_workaround_delay_time (10s) SMTP Postfix "." "." PIX . smtp_pix_workaround_threshold_time (500s) SMTP Postfix "." PIX "smtp fixup" . smtp_pix_workarounds (disable_esmtp, delay_dotcrlf) CISCO PIX . smtp_pix_workaround_maps (empty) SMTP CISCO PIX. smtp_quote_rfc821_envelope (yes) MAIL FROM RCPT TO SMTP Postfix RFC 5321 . smtp_reply_filter (empty) SMTP . smtp_skip_5xx_greeting (yes) SMTP 5XX . smtp_skip_quit_response (yes) QUIT SMTP. Postfix 2.0 : smtp_skip_4xx_greeting (yes) SMTP 4XX ( ). Postfix 2.2 : smtp_discard_ehlo_keyword_address_maps (empty) SMTP EHLO ( pipelining starttls auth ) SMTP Postfix EHLO SMTP . smtp_discard_ehlo_keywords (empty) EHLO ( pipelining starttls auth ) SMTP Postfix EHLO SMTP . smtp_generic_maps (empty) SMTP Postfix . Postfix 2.2.9 : smtp_cname_overrides_servername (version dependent) SMTP CNAME DNS CNAME SASL TLS TLS . Postfix 2.3 : lmtp_discard_lhlo_keyword_address_maps (empty) LMTP LHLO ( pipelining starttls auth ) LMTP Postfix LHLO LMTP . lmtp_discard_lhlo_keywords (empty) LHLO ( pipelining starttls auth ) LMTP Postfix LHLO LMTP . Postfix 2.4.4 : send_cyrus_sasl_authzid (no) SMTP LMTP "no" (authzid) SASL (authcid) SASL authcid . Postfix 2.5 : smtp_header_checks (empty) header_checks(5) SMTP Postfix. smtp_mime_header_checks (empty) mime_header_checks(5) SMTP Postfix. smtp_nested_header_checks (empty) nested_header_checks(5) SMTP Postfix. smtp_body_checks (empty) body_checks(5) SMTP Postfix. Postfix 2.6 : tcp_windowsize (0) TCP . Postfix 2.8 : smtp_dns_resolver_options (empty) DNS SMTP Postfix. Postfix 2.9 3.6: smtp_per_record_deadline (no) smtp_*_timeout ( SMTP SMTP SMTP TLS). Postfix 2.9 : smtp_send_dummy_mail_auth (no) "AUTH=<>" MAIL FROM SMTP SASL . Postfix 2.11 : smtp_dns_support_level (empty) DNS SMTP Postfix. Postfix 3.0 : smtp_delivery_status_filter ($default_delivery_status_filter) smtp(8) . smtp_dns_reply_filter (empty) DNS SMTP Postfix. Postfix 3.3 : smtp_balance_inet_protocols (yes) IPv4 IPv6 SMTP Postfix smtp_mx_address_limit . Postfix 3.5 : info_log_address_format (external) (info warning ) . Postfix 3.6 : dnssec_probe (ns:.) DNS (: "ns") DNS (: ".") Postfix DNSSEC . known_tcp_ports (lmtp=24, smtp=25, smtps=submissions=465, submission=587) services(5) . Postfix 3.7 : smtp_per_request_deadline (no) smtp_*_timeout TLS SMTP SMTP. smtp_min_data_rate (500) / DATA smtp_per_request_deadline . header_from_format (standard) From: Postfix. Postfix 3.8 : use_srv_lookup (empty) () SRV DNS. ignore_srv_lookup_error (no) SRV MX IP SRV . allow_srv_lookup_fallback (no) SRV SRV MX IP SRV . MIME (MIME PROCESSING CONTROLS) Postfix 2.0 : disable_mime_output_conversion (no) 8BITMIME 7BIT. mime_boundary_length_limit (2048) (boundary) MIME. mime_nesting_limit (100) MIME . (EXTERNAL CONTENT INSPECTION CONTROLS) Postfix 2.1 : smtp_send_xforward_command (no) XFORWARD EHLO SMTP Postfix XFORWARD . SASL (SASL AUTHENTICATION CONTROLS) smtp_sasl_auth_enable (no) SASL SMTP Postfix. smtp_sasl_password_maps (empty) SMTP Postfix username:password (next-hop). smtp_sasl_security_options (noplaintext, noanonymous) SASL SMTP Postfix Postfix 2.3 SASL smtp_sasl_type . Postfix 2.2 : smtp_sasl_mechanism_filter (empty) SMTP Postfix SASL SMTP . Postfix 2.3 : smtp_sender_dependent_authentication (no) SMTP Postfix SASL SMTP . smtp_sasl_path (empty) SMTP Postfix SASL smtp_sasl_type . smtp_sasl_type (cyrus) SASL SMTP Postfix . Postfix 2.5 : smtp_sasl_auth_cache_name (empty) SASL SMTP . smtp_sasl_auth_cache_time (90d) smtp_sasl_auth_cache_name . smtp_sasl_auth_soft_bounce (yes) SMTP SASL 535 . Postfix 2.9 : smtp_send_dummy_mail_auth (no) "AUTH=<>" MAIL FROM SMTP SASL . Postfix 3.9 : smtp_sasl_password_result_delimiter (:) sasl_passwd_maps. TLS (TLS SUPPORT CONTROLS) STARTTLS TLS_README . smtp_tls_security_level (Postfix >= 3.11: may; Postfix < 3.11: empty) SMTP TLS SMTP Postfix. smtp_sasl_tls_security_options ($smtp_sasl_security_options) SASL SMTP Postfix SMTP TLS . smtp_starttls_timeout (300s) SMTP Postfix TLS. smtp_tls_CAfile (empty) (CA) CA SMTP CA . smtp_tls_CApath (empty) PEM SMTP Postfix SMTP . smtp_tls_cert_file (empty) RSA SMTP Postfix PEM. smtp_tls_mandatory_ciphers (medium) TLS SMTP Postfix TLS . smtp_tls_exclude_ciphers (empty) SMTP Postfix TLS. smtp_tls_mandatory_exclude_ciphers (empty) SMTP Postfix TLS. smtp_tls_dcert_file (empty) DSA SMTP Postfix PEM. smtp_tls_dkey_file ($smtp_tls_dcert_file) DSA SMTP Postfix PEM. smtp_tls_key_file ($smtp_tls_cert_file) RSA SMTP Postfix PEM. smtp_tls_loglevel (0) TLS SMTP Postfix. smtp_tls_note_starttls_offer (no) SMTP STARTTLS TLS . smtp_tls_policy_maps (empty) TLS SMTP Postfix (next-hop) smtp_tls_per_site . smtp_tls_mandatory_protocols (see 'postconf -d' output) TLS SMTP Postfix TLS . smtp_tls_scert_verifydepth (9) SMTP . smtp_tls_secure_cert_match (nexthop, dot-nexthop) (peername) SMTP Postfix "secure" TLS. smtp_tls_session_cache_database (empty) TLS SMTP Postfix. smtp_tls_session_cache_timeout (3600s) TLS SMTP Postfix. smtp_tls_verify_cert_match (hostname) (peername) SMTP Postfix "verify" TLS. tls_daemon_random_bytes (32) smtp(8) smtpd(8) tlsmgr(8) (PRNG) (seed) . tls_high_cipherlist (see 'postconf -d' output) OpenSSL "high" (). tls_medium_cipherlist (see 'postconf -d' output) OpenSSL "medium" () . tls_null_cipherlist (eNULL:!aNULL) OpenSSL "NULL" . Postfix 2.3 3.7: tls_low_cipherlist (see 'postconf -d' output) OpenSSL "low" () . tls_export_cipherlist (see 'postconf -d' output) OpenSSL "export" . Postfix 2.4 : smtp_sasl_tls_verified_security_options ($smtp_sasl_tls_security_options) SASL SMTP Postfix SMTP TLS . Postfix 2.5 : smtp_tls_fingerprint_cert_match (empty) SMTP "fingerprint" TLS (smtp_tls_security_level = fingerprint). smtp_tls_fingerprint_digest (see 'postconf -d' output) SMTP . Postfix 2.6 : smtp_tls_protocols (see 'postconf -d' output) TLS SMTP Postfix TLS . smtp_tls_ciphers (medium) TLS SMTP Postfix TLS . smtp_tls_eccert_file (empty) ECDSA SMTP Postfix PEM. smtp_tls_eckey_file ($smtp_tls_eccert_file) ECDSA SMTP Postfix PEM. Postfix 2.7 : smtp_tls_block_early_mail_reply (no) TLS ( CVE-2009-3555) HELO MAIL RCPT DATA TLS SMTP Postfix . Postfix 2.8 : tls_disable_workarounds (see 'postconf -d' output) OpenSSL . Postfix 2.11 3.1: tls_dane_digest_agility (on) RFC7671 DANE TLSA. tls_dane_trust_anchor_digest_enable (yes) DNS RFC 6698 (DANE TLSA) "2" . Postfix 2.11 : smtp_tls_trust_anchor_file (empty) PEM / . smtp_tls_force_insecure_host_tlsa_lookup (no) DANE TLSA . tlsmgr_service_name (tlsmgr) tlsmgr(8) master.cf. Postfix 3.0 : smtp_tls_wrappermode (no) SMTP Postfix SUBMISSIONS ( SMTPS ) STARTTLS . Postfix 3.1 : smtp_tls_dane_insecure_mx_policy (dane) TLS MX TLSA "secure" dane MX MX . Postfix 3.2 : tls_eecdh_auto_curves (see 'postconf -d' output) SMTP Postfix . Postfix 3.4 : smtp_tls_connection_reuse (no) TLS. smtp_tls_chain_files (empty) PEM . smtp_tls_servername (empty) SMTP (SNI) TLS. Postfix 3.5 3.4.6 3.3.5 3.2.10 3.1.13 : tls_fast_shutdown_enable (yes) Postfix TLS Postfix . Postfix 3.8 : tls_ffdhe_auto_groups (see 'postconf -d' output) - (FFDHE) SMTP Postfix . Postfix 3.9 3.8.1 3.7.6 3.6.10 3.5.20 : tls_config_file (default) OpenSSL. tls_config_name (empty) Postfix OpenSSL . Postfix 3.9 : smtp_tls_enable_rpk (no) SMTP X.509 RFC7250 . Postfix 3.10 : smtp_tlsrpt_enable (no) TLSRPT RFC 8460. smtp_tlsrpt_socket_name (empty) TLSRPT . smtp_tlsrpt_skip_reused_handshakes (Postfix >= 3.11: no, Postfix 3.10: yes) "yes" TLSRPT TLS <<>> . tls_required_enable (yes) "TLS-Required: no" RFC 8689. Postfix 3.10.5 : smtp_tls_enforce_sts_mx_patterns (yes) TLS STS: MX MX STS MX. Postfix 3.11 : requiretls_enable (yes) ESMTP "REQUIRETLS" "MAIL FROM". smtp_requiretls_policy (see 'postconf -d smtp_requiretls_policy' output) REQUIRETLS SMTP LMTP Postfix REQUIRETLS. smtp_log_tls_feature_status (yes) TLS . TLS (OBSOLETE TLS CONTROLS) Postfix 2.3 . . smtp_use_tls (no) : TLS SMTP STARTTLS . smtp_enforce_tls (no) : SMTP TLS . smtp_tls_enforce_peername (yes) TLS SMTP SMTP . smtp_tls_per_site (empty) TLS SMTP Postfix SMTP . smtp_tls_cipherlist (empty) Postfix < 2.3 TLS SMTP Postfix. (RESOURCE AND RATE CONTROLS) smtp_connect_timeout (30s) SMTP Postfix TCP ( ). smtp_helo_timeout (300s) SMTP Postfix HELO EHLO SMTP . lmtp_lhlo_timeout (300s) LMTP Postfix LHLO LMTP . smtp_xforward_timeout (300s) SMTP Postfix XFORWARD SMTP . smtp_mail_timeout (300s) SMTP Postfix MAIL FROM SMTP . smtp_rcpt_timeout (300s) SMTP Postfix SMTP RCPT TO SMTP . smtp_data_init_timeout (120s) SMTP Postfix SMTP DATA SMTP . smtp_data_xfer_timeout (180s) SMTP Postfix SMTP. smtp_data_done_timeout (600s) SMTP Postfix "." SMTP SMTP . smtp_quit_timeout (300s) SMTP Postfix QUIT SMTP . Postfix 2.1 : smtp_mx_address_limit (5) IP MX ( ) SMTP Postfix ( ). smtp_mx_session_limit (2) SMTP SMTP Postfix ( ). smtp_rset_timeout (20s) SMTP Postfix RSET SMTP . Postfix 2.2 : lmtp_cache_connection (yes) LMTP Postfix max_idle$ . Postfix 2.2 : smtp_connection_cache_destinations (empty) SMTP . smtp_connection_cache_on_demand (yes) SMTP . smtp_connection_reuse_time_limit (300s) Postfix SMTP . smtp_connection_cache_time_limit (2s) SMTP SMTP . Postfix 2.3 : connection_cache_protocol_timeout (5s) . Postfix 2.9 3.6: smtp_per_record_deadline (no) smtp_*_timeout ( SMTP SMTP SMTP TLS). Postfix 2.11 : smtp_connection_reuse_count_limit (0) SMTP SMTP ( ). Postfix 3.4 : smtp_tls_connection_reuse (no) TLS. Postfix 3.7 : smtp_per_request_deadline (no) smtp_*_timeout TLS SMTP SMTP. smtp_min_data_rate (500) / DATA smtp_per_request_deadline . qmgr(8): transport_destination_concurrency_limit ($default_destination_concurrency_limit) default_destination_concurrency_limit transport master.cf . transport_destination_recipient_limit ($default_destination_recipient_limit) default_destination_recipient_limit transport master.cf . SMTPUTF8 (SMTPUTF8 CONTROLS) SMTPUTF8 Postfix 3.0 . smtputf8_enable (yes) SMTPUTF8 RFC 6531 RFC 6532 RFC 6533. smtputf8_autodetect_classes (sendmail, verify) SMTPUTF8 . Postfix 3.2 : enable_idna2003_compatibility (no) <<>> IDNA2003 IDNA2008 UTF-8 / ASCII DNS . (TROUBLE SHOOTING CONTROLS) debug_peer_level (2) debug_peer_list . debug_peer_list (empty) debug_peer_level$ . error_notice_recipient (postmaster) . internal_mail_filter_classes (empty) Postfix non_smtpd_milters header_checks body_checks . notify_classes (resource, software) . (MISCELLANEOUS CONTROLS) best_mx_transport (empty) SMTP Postfix << >> . config_directory (see 'postconf -d' output) main.cf master.cf Postfix. daemon_timeout (18000s) Postfix . delay_logging_resolution_limit (2) . disable_dns_lookups (no) DNS SMTP LMTP Postfix. inet_interfaces (all) . inet_protocols (see 'postconf -d' output) Postfix . ipc_timeout (3600s) . lmtp_assume_final (no) LMTP DSN "delivered" ( ) "relayed" () . lmtp_tcp_port (24) TCP LMTP Postfix . max_idle (100s) Postfix . max_use (100) Postfix . process_id (read-only) (PID) Postfix. process_name (read-only) Postfix. proxy_interfaces (empty) . smtp_address_preference (any) ("ipv6" "ipv4" "any") SMTP Postfix IPv6 IPv4 MX . smtp_bind_address (empty) SMTP Postfix IPv4 (bind) . smtp_bind_address6 (empty) SMTP Postfix IPv6 (bind) . smtp_helo_name ($myhostname) HELO EHLO SMTP . lmtp_lhlo_name ($myhostname) LHLO LMTP . smtp_host_lookup (dns) SMTP Postfix IP . smtp_randomize_addresses (yes) MX . syslog_facility (mail) (facility) syslog Postfix. syslog_name (see 'postconf -d' output) syslog "smtpd" "prefix/smtpd" . Postfix 2.2 : fallback_relay (empty) SMTP . Postfix 2.3 : smtp_fallback_relay ($fallback_relay) SMTP . Postfix 3.0 : smtp_address_verify_target (rcpt) SMTP . Postfix 3.1 : lmtp_fallback_relay (empty) LMTP . Postfix 3.2 : smtp_tcp_port (smtp) TCP SMTP Postfix . Postfix 3.3 : service_name (read-only) Postfix master.cf. Postfix 3.7 : smtp_bind_address_enforce (no) SMTP Postfix smtp_bind_address smtp_bind_address6 . (SEE ALSO) generic(5), header_checks(5), body_checks(5), qmgr(8), bounce(8), scache(8), postconf(5), master(5), master(8), tlsmgr(8), TLS PRNG postlogd(8), Postfix syslogd(8), README (README FILES) "postconf readme_directory" "postconf html_directory" . SASL_README, SASL Postfix TLS_README, STARTTLS Postfix (LICENSE) Secure Mailer . (AUTHOR(S)) Wietse Venema IBM T.J. Watson Research P.O. Box 704 Yorktown Heights, NY 10598, USA Wietse Venema Google, Inc. 111 8th Avenue New York, NY 10011, USA : Jon Ribbens Oaktree Internet Solutions Ltd., Internet House, Canal Basin, Coventry, CV1 4LY, United Kingdom. SASL : Till Franke SuSE Rhein/Main AG 65760 Eschborn, Germany TLS : Lutz Jaenicke BTU Cottbus Allgemeine Elektrotechnik Universitaetsplatz 3-4 D-03044 Cottbus, Germany TLS SMTP : Victor Duchovni Morgan Stanley SMTP(8)