lftp(1) General Commands Manual lftp(1) (NAME) lftp - (SYNOPSIS) lftp [-d] [-e cmd] [-p port] [-u user[,pass]] [site] lftp -f script_file lftp -c commands lftp --version lftp --help (VERSION) 4.8.1 lftp . (DESCRIPTION) lftp FTP HTTP . site lftp open . lftp - FTP FTPS HTTP HTTPS HFTP FISH SFTP file ( HTTPS FTPS lftp GNU TLS OpenSSL ). "open URL" "open http://www.us.kernel.org/pub/linux". HFTP ftp-over-http-proxy . ftp:proxy "http://proxy[:port]" FTP . Fish ssh unix . SFtp SSH2 SFTP . FTP lftp BitTorrent "torrent" . (Seeding) . lftp . . FTP REST lftp . lftp (&) . () . . ^Z (c-z) "wait" ( "fg" "wait" ) . "jobs" . (cat ls ...) (pipe) . (&& ||) . lftp lftp nohup . xterm . lftp (mirror) . (mirror -R) . Mirror FXP . "at" "queue" . lftp /etc/lftp.conf ~/.lftprc ~/.lftp/rc ( ~/.lftp ~/.config/lftp/rc) . "set" . "debug" . "debug 3" . lftp . "set -a" "set -d" . . lftp OpenSSL (configure --with-openssl) OpenSSL OpenSSL . (http://www.openssl.org).SS " (Commands)" ! shell command . !ls . alias [name [value]] name . value value . . alias dir ls -lF alias less zmore at time [ -- command ] () . : at(1). attach [PID] lftp . bookmark [subcommand] bookmark . open bm:site/path . add [] del edit import list () cache [subcommand] cache () . : stat () on|off / flush size lim -1 expire Nx N (x=s) (x=m) (x=h) (x=d) cat files cat () (stdout) . ( : more zcat zmore) cd rdir . `-' . `cd -' . lftp `open site; cd -' . chmod [OPTS] mode files... . (mode) () (chmod(1) ). -c, --changes verbose -f, --quiet -v, --verbose -R, --recursive close [-a] . -a . cls [OPTS] files... `cls' . `ls' `cls' `ls' `cls' . -1 -a, --all () -B, --basename (basename) --block-size=SIZ SIZ -d, --directory -F, --classify ( /@) -h, --human-readable ( 1K) --si -k, --kilobytes --block-size=1024 -l, --long -q, --quiet -s, --size --filesize -i, --nocase -I, --sortnocase -D, --dirsfirst --sort=OPT "name" "size" "date" -S --user, --group, --perms, --date, --linkcount, --links --time-style=STYLE command cmd args... . debug [OPTS] level|off level . : -T / (truncate) -o -c (context) -p PID -t du [OPTS] path... . : -a, --all --block-size=SIZ SIZ -b, --bytes -c, --total -d, --max-depth=N ( --all) N --max-depth=0 --summarize -F, --files -h, --human-readable ( 1K 234M 2G) -H, --si -k, --kilobytes --block-size=1024 -m, --megabytes --block-size=1048576 -S, --separate-dirs -s, --summarize --exclude=PAT PAT echo [-n] string (echo) . edit [OPTS] file . : -k -o eval [-f format ] args... -f . -f . $0...$9 $@ . exit [bg] [top] [parent] [kill] [code] exit lftp . code lftp . code . "exit bg" cmd:move-background (false) . "exit top" "shell" ( lftp) . "exit parent" . "exit kill" (kill ). : "at 08:00 -- exit top kill &" lftp . fg "wait". find [OPTS] directory... ( ) . ls -R . . : -d MD, --max-depth=MD -l, --ls ftpcopy . : get ftp://... -o ftp://... get -O ftp://... file1 file2... put ftp://... mput ftp://.../* mget -O ftp://... ftp://.../* FXP ( FTP). FXP ftp:use-fxp lftp ( ) . get [-E] [-a] [-c] [-e] [-P N] [-O base] rfile [-o lfile] ... rfile lfile . -o rfile . rfile ( -o lfile) . (wildcards) mget . -c reget -E -e -a ascii ( ) -P N N -O URL : get README get README -o debian.README get README README.mirrors get README -o debian.README README.mirrors -o debian.mirrors get README -o ftp://some.host.org/debian.README get README -o ftp://some.host.org/debian-dir/ ( ) get1 [OPTS] rfile . : -o ( - rfile) -c reget -E -a ascii ( ) -d --source-region= --target-position= glob [OPTS] [command] patterns . -f () -d -a --exist --not-exist : glob echo * glob --exist *.csv && echo "There are *.csv files" help [cmd] cmd cmd . history [OPTS] [cnt] . cnt "all" . : -w . -r . -c . -l (). jobs [OPTS] [job_no...] . job_no . : -v -v -r kill all|job_no job_no . ( job_no jobs ) lcd ldir ldir. `-' . `lcd -' . ln [-s] existing-file new-link / . -s . local command file:// . : local pwd local ls local mirror /dir1 /dir2 lpwd . ls params . . ls rels cache flush. . mget [-c] [-d] [-a] [-E] [-e] [-P N] [-O base] files (wildcards). -c (reget). -d . -E -e -a ascii ( binary ) -P N N -O URL mirror [OPTS] [source [target]] . . -R . (base name) . . / URL . () ( ) . -c, --continue mirror -e, --delete --delete-excluded --delete-first --depth-first --scan-all-first -s, --allow-suid suid/sgid --allow-chown --ascii ascii ( --ignore-size) --ignore-time --ignore-size --only-missing --only-existing -n, --only-newer (-c ) --upload-older --transfer-all --no-empty-dirs ( --depth-first) -r, --no-recursion --recursion=MODE --no-symlinks -p, --no-perms --no-umask umask -R, --reverse (/ ) -L, --dereference --overwrite --no-overwrite -N, --newer-than=SPEC . --older-than=SPEC . --size-range=RANGE -P, --parallel[=N] N --use-pget[-n=N] pget --on-change=CMD --loop mirror -i RX, --include=RX -x RX, --exclude=RX -I GP, --include-glob=GP -X GP, --exclude-glob=GP --include-rx-from=FILE --exclude-rx-from=FILE --include-glob-from=FILE --exclude-glob-from=FILE / -f FILE, --file=FILE ( /path/to/*.txt) -F DIR, --directory=DIR ( /path/to/dir*) -O DIR, --target-directory=DIR URL -v, --verbose[=level] --log=FILE lftp FILE --script=FILE lftp FILE --just-print, --dry-run --script=- --max-errors=N --skip-noaccess . --use-cache --Remove-source-files ( ) --Remove-source-dirs ( ). . --Move --Remove-source-dirs -a --allow-chown --allow-suid --no-umask .TE RX (extended regular expression) egrep(1). GP (glob pattern) "*.zip". include exclude . (mirror) include exclude include exclude . . (symbolic links) FTP . "mirror -RL" ( ). --newer-than --older-than at(1) "now-7days" "week ago". . (verbosity) --verbose=level -v -vvv . : 0 - () 1 - 2 - + ( -e ) 3 - + --only-newer / . . --upload-older ( ). (timestamps) . (recursion mode) "always" "never" "missing" "newer" . "newer" mirror . mirror . --file --directory . URL . FXP FTP . FTP (dot-files .htaccess) LIST -a . "set ftp:list-options -a" . "newer" "missing" --scan-all-first --depth-first --no-empty-dirs mirror:no-empty-dirs=true . mkdir "[" -p "] " "[" -f "] " dir(s) . -p . -f mkdir . module "module " [ " args " ] dlopen(3). module:path . module_init . README.modules . more files "cat files | more". PAGER . ( cat zcat zmore) mput " [" -c "] [" -d "]" [ -a "] [" -E "]" [ -e ] [ -P " N]" [ -O " base] files" (wildcard expansion). . "-d" . l lx . -c reput -d T{ -E () -e -a ascii ( binary ) -P N N -O URL mrm file(s) "glob rm". () . mmv [-O directory] file(s) directory . -O . -O mv file1 file2 file1 file2. . mmv . nlist [args] open [OPTS] site URL (bookmark). URL URL . : -e cmd -u user[,pass] / . . -p port -s slot (slot) -d (debug) -B --user user --password pass --env-password LFTP_PASSWORD site URL ( ) -u --user URL %AB . pget [OPTS] rfile [-o lfile] . . (ASAP) . : -c . lfile.lftp-pget-status . -n maxconn ( pget:default-n ) put [-E] [-a] [-c] [-e] [-P N] [-O base] lfile [-o rfile] lfile rfile. -o (basename) lfile . (wildcards) mput . -o ( - lfile) -c reput. -E () -e -a ascii ( binary ) -P N N -O URL pwd [-p] URL . `-p' URL . queue [-n num ] cmd . . `-n' . `cd' `lcd' lftp . cd/lcd `queue' . `queue wait ' . `queue stop' . `queue stop' . `queue start' . lftp . `queue' . queue --delete|-d [index or wildcard expression] . . queue --move|-m [index] (index) . -q . -v (). -Q . --delete. : > get file & [1] get file > queue wait 1 > queue get another_file > cd a_directory > queue get yet_another_file queue -d 3 . queue -m 6 4 . queue -m "get*zip" 1 "get*zip" . ( .) queue -d "get*zip" "get*zip". quote cmd FTP - . - . (quoted) - . HTTP - HTTP. : ``quote []''. ``set- cookie'' ``post'' . open http://www.site.net quote set-cookie "variable=value; othervar=othervalue" set http:post-content-type application/x-www-form-urlencoded quote post /cgi-bin/script.cgi "var=value&othervar=othervalue" > local_file FISH - . . ### . . open fish://server quote find -name \*.zip reget rfile [-o lfile] `get -c'. rels [args] `ls' (cache) . renlist [args] `nlist' . repeat [OPTS] [[-d] delay] [command] . . -c -d --while-ok --until-ok --weak lftp . : repeat at tomorrow -- mirror repeat 1d mirror reput lfile [-o rfile] `put -c'. rm [-r] [-f] files.PP . (wildcards) mrm . -r . . -f . rmdir dir(s) . scache [session] . set [var [val]] . (unset) . "name/closure" closure . . set . : -a -d site site_cmd site site_cmd . . sleep interval . 'm' 'h' 'd' . at . slot [name] . . . slot:name URL . readline 0 9 Meta-0 Meta-9 ( Meta Alt ). source file source -e command file . source ~/.lftp/rc source -e echo help suspend lftp. fg bg . torrent [OPTS] torrent-files... BitTorrent torrent-files URL (magnet link) info_hash hex base32 . . --force-valid . . directory . (Seeding) torrent:stop-on-ratio torrent:seed-max-time . : -O --force-valid ( ). --only-new (metadata) . --only-incomplete . --dht-bootstrap= DHT node . . 6881 . : dht.transmissionbt.com router.utorrent.com router.bittorrent.com. --share BitTorrent. . user user [pass] user URL [pass] . URL URL . version lftp. wait [jobno] wait all (job) . jobno . "wait all" . zcat files cat zcat . ( cat more zmore ) zmore files more zcat . ( cat zcat more ).SS " (Settings)" lftp ~/.lftprc ~/.lftp/rc ( ~/.config/lftp/rc ~/.lftp ) . (alias) `set` . `debug` . /etc/lftp.conf . << (FILES)>> . lftp ( `set -a' ): bmk:save-passwords (boolean) ~/.local/share/lftp/bookmarks ~/.lftp/bookmarks `bookmark add`. . cache:cache-empty-listings (boolean) false . cache:enable (boolean) false . cache:expire (time interval) . cache:expire-negative (time interval) . cache:size (number) . . cmd:at-exit (string) lftp . cmd:at-exit-bg (string) lftp . cmd:at-exit-fg (string) lftp . cmd:at-background (string) lftp . cmd:at-terminate (string) lftp ( ) . cmd:at-finish (string) . cmd:at-queue-finish (string) . cmd:cls-completion-default (string) cls . cmd:cls-completion-default `-s' . cmd:cls-default (string) cls. . cmd:cls-exact-time (boolean) true cls . cmd:csh-history (boolean) csh . cmd:default-protocol (string) `open' . `ftp' . cmd:fail-exit (boolean) true ( || && ) . lftp . cmd:interactive (tri-boolean) true lftp . auto stdin . cmd:long-running (seconds) <<>> . 0 . cmd:ls-default (string) ls cmd:move-background (boolean) false lftp . `exit bg' . cmd:move-background-detach (boolean) true () lftp `attach' false lftp lftp fg lftp . cmd:prompt (string) (prompt). lftp (backslash) : \@ @ \a (07) \e (033) \h \n (newline) \s (lftp) \S \u \U (URL) ( ftp://g437.ub.gu.se/home/james/src/lftp) \v lftp ( 2.0.3) \w \W (basename) \l \L (basename) \nnn nnn \\ (backslash) \? . \[ \] cmd:parallel (number) . `get' . 1 . cmd:queue-parallel (number) . cmd:remote-completion (boolean) lftp . true Tab . Meta-Tab . Meta-Tab cmd:remote-completion false ..TP cmd:save-cwd-history (boolean) true lftp CWD ( ) ~/.local/share/lftp/cwd_history ~/.lftp/cwd_history <> lftp . true . cmd:save-rl-history (boolean) true lftp readline ~/.local/share/lftp/rl_history ~/.lftp/rl_history . true . cmd:show-status (boolean) false lftp . true . cmd:set-term-status (boolean) true lftp ( xterm) . (closure) TERM . cmd:status-interval (timeinterval) . cmd:stifle-rl-history (number) readline . cmd:term-status (string) . (closure) TERM . termcap <> <> . (escape) : \a (bell) \e (escape) \n (newline) \s "lftp" \v lftp \T cmd:time-style (string) cls --time-style . cmd:trace (boolean) true lftp ( sh -x). cmd:verify-host (boolean) true lftp <> (resolve) . <<&>> ^Z <> . cmd:verify-path (boolean) true lftp <> . <<&>> ^Z <> . : set cmd:verify-path/hftp://* false cd directory & cmd:verify-path-cached (boolean) false <> . cmd:verify-path . color:use-color (tri-boolean) true cls (completion) color:dir-colors . auto . color:dir-colors (string) . LS_COLORS . dircolors(1) . dns:SRV-query (boolean) SRV gethostbyname. SRV () . RFC2052 . dns:cache-enable (boolean) DNS. lftp . dns:cache-expire (time interval) (TTL) DNS. + 1d12h30m5s 36h. <> <> . dns:cache-size (number) DNS. dns:fatal-timeout (time interval) DNS. DNS lftp . <> . dns:order (list of protocol names) DNS . <> inet6 inet . inet6 (AAAA) <> . dns:use-fork (boolean) true lftp (fork) . true . dns:max-retries (number) lftp . > 0 lftp dns:order . dns:name (string) IP . (closure) IP . IP . file:charset (string) (local character set). . file:use-lock (boolean) true lftp (advisory locking) . file:use-fallocate (boolean) true lftp fallocate(2) posix_fallocate(3) (fragmentation) pget torrent . fish:auto-confirm (boolean) true lftp ssh <> . <> . fish:charset (string) fish . . fish:connect-program (string) . <<-l>> <<-p>> . <> . <> . <<-i>> . fish:shell (string) . /bin/sh . /bin/sh cd . lftp . bash /bin/bash . ftp:acct (string) ACCT . . (closure) user@host . ftp:anon-pass (string) FTP . "lftp@" . ftp:anon-user (string) FTP . "anonymous" . ftp:auto-sync-mode (regex) (regex) (sync mode) . ftp:catch-size (boolean) SIZE <<150 Opening data connection>> . ftp:charset (string) FTP . . UTF8 . ftp:client (string) FTP CLNT . CLNT . ftp:compressed-re (regex) <> . ftp:bind-data-socket (boolean) (bind) (interface) ( / passive mode). true loopback . ftp:fix-pasv-address (boolean) true PASV lftp PASV . lftp PASV . true ..TP ftp:fxp-passive-source (boolean) true lftp FTP passive . lftp . lftp . ftp:use-fxp . ftp:home (string) . (auto) . %2F (URL) FTP `/' . (closure) user@host . ftp:ignore-pasv-address (boolean) true lftp PASV . NAT . false . ftp:list-empty-ok (boolean) false LIST (NLST) . ftp:list-options (string) LIST . () `-a' . . ftp:mode-z-level (number) (0-9) MODE Z. ftp:nop-interval (seconds) NOOP . FTP "Transfer complete" (flush) . NOOP (timeout) . ftp:passive-mode (boolean) passive FTP . (dumb masquerading router) . passive lftp PASV PORT active . passive lftp active lftp . passive . ftp:port-ipv4 (ipv4 address) IPv4 PORT . . ftp:port-range (from-to) . min-max `full' `any' . `full' . ftp:prefer-epsv (boolean) EPSV passive . `false' . ftp:proxy (URL) FTP . . FTP FTP FTP HTTP. ftp_proxy ``ftp://'' . FTP URL . ftp:proxy http:// hftp ( FTP HTTP) FTP . ftp:proxy-auth-type (string) ``joined'' lftp ``user@proxy_user@ftp.example.org'' ``password@proxy_password'' . ``joined-acct'' lftp ``user@ftp.example.org proxy_user'' ( ) . ACCT . ``open'' lftp ``OPEN ftp.example.org'' ``USER user'' . . ``user'' () lftp ``user@ftp.example.org'' . . ``proxy-user@host'' lftp ``USER proxy_user@ftp.example.org'' . . ftp:rest-list (boolean) REST LIST . FTP REST LIST . ftp:rest-stor (boolean) false lftp REST STOR . REST STOR ( ). ftp:retry-530 (regex) 530 PASS . ( ) ( ) . ftp:retry-530-anonymous (regex) (anonymous) ftp:retry-530. ftp:site-group (string) SITE GROUP . . (closure) user@host . ftp:skey-allow (boolean) skey/opie . (on) . ftp:skey-force (boolean) (plain text) skey/opie . skey/opie . (off) . ftp:ssl-allow (boolean) true (non- anonymous) SSL FTP . true . SSL lftp ssl/tls . ftp:ssl-auth (string) AUTH SSL TLS TLS-P TLS-C . RFC4217 . FEAT TLS SSL . ftp:ssl-data-use-keys (boolean) true lftp ssl:key-file . false (session ID) . true . ftp:ssl-force (boolean) true SSL (clear) . false . ftp:ssl-protect-data (boolean) true SSL . . . true . ftp:ssl-protect-fxp (boolean) true FTP FXP SSL . CPSV SSCN . SSL lftp FXP ftp:ssl-force . true . ftp:ssl-protect-list (boolean) true SSL . true . ftp:ssl-use-ccc (boolean) true lftp CCC ssl . ftp:stat-interval (time interval) STAT. . ftp:strict-multiline (boolean) true lftp ( ). false . ftp:sync-mode (boolean) true lftp . FTP . off lftp (round trip time) . FTP on . ftp:timezone (string) LIST . GMT [+|-]HH[:MM[:SS]] TZ ( Europe/Moscow MSK-3MSD,M3.5.0,M10.5.0/3) . GMT . TZ . ftp:too-many-re (regexp) 421 . ftp:trust-feat (string) true FEAT SIZE MDTM REST . false . ftp:use-abor (boolean) false lftp ABOR . ftp:use-allo (boolean) true lftp ALLO ..TP ftp:use-feat (boolean) () lftp FEAT ftp . ftp:use-fxp (boolean) lftp ftp . ftp:use-hftp (boolean) ftp:proxy http hftp (GET HEAD) CONNECT . true . ftp:use-ip-tos (boolean) lftp IPTOS_LOWDELAY IPTOS_THROUGHPUT . ftp:lang (boolean) LANG FEAT. . ftp:use-mdtm (boolean) () lftp MDTM . ftp:use-mdtm-overloaded (boolean) lftp MDTM . false . ftp:use-mlsd (boolean) lftp MLSD . ftp:use-mode-z (boolean) lftp <> . ftp:use-pret (tri-boolean) auto PRET FEAT . . PRET PORT PASV . ftp:use-site-idle (boolean) lftp `SITE IDLE' net:idle . false . ftp:use-site-utime (boolean) lftp `SITE UTIME' . true . ftp:use-site-utime2 (boolean) lftp `SITE UTIME' . true . `SITE UTIME' . ftp:use-size (boolean) () lftp SIZE . ftp:use-stat (boolean) lftp FXP STAT . ftp:stat-interval . true . ftp:use-stat-for-list (boolean) lftp LIST STAT . `.' STAT . STAT lftp . STAT ftp:list-options ( -la). ftp:use-telnet-iac (boolean) () lftp TELNET IAC TELNET RFC959 . TELNET 255 (0xFF, 0377) ABOR STAT TELNET IP+SYNCH . ftp:use-tvfs (tri-boolean) auto TVFS FEAT . . TVFS . ftp:use-utf8 (boolean) lftp `OPTS UTF8 ON' UTF-8 ( ) . . ftp:use-quit (boolean) lftp ftp QUIT . true . ftp:verify-address (boolean) . . ftp . ftp:verify-port (boolean) 20 (ftp-data) . . . ftp:web-mode (boolean) . ftp . false . ftps:initial-prot (string) PROT FTPS . C S E P . lftp PROT . PROT Clear . hftp:cache (boolean) / ftp-over- http. hftp:cache-control (string) HTTP . hftp:decode (boolean) lftp hftp Content-Encoding deflate gzip compress x-gzip x-compress . hftp:proxy (URL) HTTP FTP-over-HTTP (hftp) . hftp HTTP . ftp_proxy <> http_proxy . FTP URL . hftp:use-allprop (boolean) lftp `' `PROPFIND' . hftp:use-authorization (boolean) off lftp URL . ( M-soft) . on lftp Authorization . hftp:use-head (boolean) off lftp hftp `HEAD' `GET' . lftp <> . hftp:use-mkcol (boolean) off lftp hftp `MKCOL' `PUT' . off . hftp:use-propfind (boolean) off lftp hftp `PROPFIND' `GET' . off . lftp PROPPATCH . hftp:use-range (boolean) lftp Range . hftp:use-type (boolean) off lftp `;type=' URL . . on . http:accept, http:accept-charset, http:accept-encoding, http:accept-language (string) HTTP . http:authorization (string) . <> . . http:cache (boolean) /. http:cache-control (string) HTTP . http:cookie (string) . (closure) : set cookie/www.somehost.com "param=value" http:decode (boolean) lftp Content-Encoding deflate gzip compress x-gzip x-compress . http:post-content-type (string) Content- Type HTTP POST . <> ..TP http:proxy (URL) HTTP . lftp HTTP . http_proxy . URL . http:put-method (PUT or POST) (put) HTTP . http:put-content-type (string) HTTP Content-Type PUT . http:referer (string) HTTP Referer . <<.>> URL . <<.>> . Referer . http:set-cookies (boolean) (true) lftp Set- Cookie http:cookie . http:use-allprop (boolean) lftp <<>> <> . http:use-mkcol (boolean) (off) lftp <> <> HTTP . (on) . http:use-propfind (boolean) lftp <> HTTP <> . off . lftp PROPPATCH <> . http:use-range (boolean) lftp Range . http:user-agent (string) lftp User-Agent HTTP . https:proxy (string) https . https_proxy . log:enabled (boolean) . (closure) <> <> <> . log:file (string) . stderr . log:level (number) . <> . log:max-size (number) . . log:prefix-error (string) log:prefix-note (string) log:prefix-recv (string) log:prefix-send (string) . log:show-ctx (boolean) log:show-pid (boolean) log:show-time (boolean) . mirror:dereference (boolean) mirror (dereference) . --no-dereference . (false) . mirror:exclude-regex (regex) . --include . mirror:include-regex (regex) . mirror:exclude-regex . mirror:exclude-regex . mirror:no-empty-dirs (boolean) mirror ( --no-empty-dirs). mirror:sort-by (string) . : name name-desc size size- desc date date-desc. name name-desc mirror:order . mirror:order (list of patterns) . <<*.sfv *.sum>> mirror *.sfv *.sum . <<*/>> . mirror:overwrite (boolean) mirror . mirror:parallel-directories (boolean) mirror . . mirror:parallel-transfer-count (number) mirror . --parallel . . mirror:require-source (boolean) mirror . mirror:set-permissions (boolean) mirror . --perms . (on) . mirror:skip-noaccess (boolean) mirror . (false) . mirror:use-pget-n (number) -n pget mirror . . pget . module:path (string) (:) . LFTP_MODULE_PATH . <> . net:connection-limit (number) . . net:connection-limit-timer (time interval) . net:connection-takeover (boolean) . net:idle (time interval) . . net:limit-rate (bytes per second) . . . 100K 102400 . net:limit-max (bytes) limit-rate . limit-rate . net:limit-total-rate (bytes per second) . . . . net:socket-buffer . . net:limit-total-max (bytes) limit-total-rate . limit-total-rate . net:max-retries (number) . . . net:no-proxy (string) . no_proxy . net:persist-retries (number) (hard errors). FTP 5xx . net:reconnect-interval-base (seconds) . net:reconnect- interval-multiplier ..TP net:reconnect-interval-max () . net:reconnect- interval-multiplier ( ) net:reconnect- interval-base . net:reconnect-interval-multiplier ( ) . . net:reconnect-interval- base net:reconnect-interval-max . net:socket-bind-ipv4 ( IPv4) IPv4 (bind) . . IPv4 . net:socket-bind-ipv6 ( IPv6) IPv6. net:socket-buffer () SO_SNDBUF SO_RCVBUF . 0 . net:socket-maxseg () TCP_MAXSEG . . net:timeout ( ) (timeout) . pget:default-n () pget. pget:min-chunk-size () . pget:save-status ( ) pget . "never" . .lftp-pget-status . sftp:auto-confirm () true lftp ssh "yes" . "no" . sftp:charset () SFTP . . SFTP 4 . 4 UTF-8 . sftp:connect-program () . "-l" "-p" . "ssh -a -x" . "-i" . sftp:max-packets-in-flight () (in-flight). (round trip time) size-read/size-write . 16 . sftp:protocol-version () (negotiate). 6 . . sftp:server-program () SFTP . "/" ssh2 connect-program -s . "sftp" . rsh : set sftp:connect-program rsh set sftp:server-program /usr/libexec/openssh/sftp-server SFTP SSH1 . sftp:size-read () . 0x8000 . sftp:size-write () . 0x8000 . ssl:ca-file ( ) (CA). ssl:ca-path ( ) ( OpenSSL). ssl:check-hostname () true lftp . ssl:crl-file ( ) (CRL). ssl:crl-path ( ) ( OpenSSL). ssl:key-file ( ) . ftps https . sftp fish sftp:connect-program fish:connect- program ( "-i" ssh ). ssl:cert-file ( ) . ssl:use-sni () true Server Name Indication (SNI) TLS . ssl:verify-certificate () yes (CA) (CRL) . (fingerprint) closure . ssl:priority () GnuTLS. TLS 1.2: set ssl:priority "NORMAL:-VERS-SSL3.0:-VERS-TLS1.0:-VERS-TLS1.1:+VERS-TLS1.2:-VERS-TLS1.3" OpenSSL - (+ ) SSL3.0 TLS1.0 TLS1.1 TLS1.2 : . TLS 1.3: set ssl:priority "NORMAL:-SSL3.0:-TLS1.0:-TLS1.1:-TLS1.2" torrent:ip ( IPv4) IP (tracker). HTTP . torrent:ipv6 ( IPv6) IPv6 . unicast . torrent:max-peers () (peers) . . torrent:port-range (-) . . torrent:retracker ( URL) (retracker) "http://retracker.local/announce". torrent:save-metadata () true lftp ~/.local/share/lftp/torrent/md ~/.lftp/torrent/md . torrent:seed-max-time ( ) (seed). (ratio) . (infinity) . torrent:seed-min-peers () . . torrent:stop-min-ppr ( ) (per- piece-ratio) (seeding). . torrent:stop-on-ratio ( ) (ratio) . torrent:timeout ( ) . . torrent:use-dht () true DHT . xfer:auto-rename() "on" . (off) . xfer:backup-suffix () ( strftime(3)) . xfer:clobber () (off) get . xfer:destination-directory ( URL ) -O get mget . ( -O)..TP xfer:disk-full-fatal (boolean) true lftp (quota) false lftp . xfer:eta-period (seconds) ETA . xfer:eta-terse (boolean) ETA ( ). true . xfer:keep-backup (boolean) true . xfer:make-backup (boolean) true lftp xfer:backup- suffix . xfer:max-redirections (number) . HTTP . 0 . xfer:parallel (number) get/put/mget/mput. xfer:rate-period (seconds) . xfer:temp-file-name (string) (*) . xfer:timeout (time interval) . . xfer:use-temp-file (boolean) true . xfer:verify (boolean) true verify-command . . xfer:verify-command (string) . . . <<:>> . (closures) . <> . `dns:` `net:` `ftp:` `http:` `hftp:` `open` ( dns:cache-size). `cmd:` (URL) . `log:` `debug` `xfer`. . lftp.conf . . Nx[Nx...] N ( ) x : d - h - m - s - . 5h30m 5.5h. `infinity` `inf` `never` `forever` `sleep forever` `set dns:cache-expire never`. (Boolean) True (true, on, yes, 1, +) False (false, off, no, 0, -) . (Tri-boolean) `auto` . (Integer) : k m g . : 0 (octal) 0x (hexadecimal). FTP (pipelining) Lftp FTP . ftp:sync-mode . (synchronous) . . (NAT) FTP . RFC959 : << FTP >>. RFC1123 : << READ EOL (CR LF) >> << READ FTP >>. ftp Unix VMS . ..SH " (OPTIONS)" -d . -e commands . -p port () . -u user[,pass] . (quote) . ~/.netrc LFTP_PASSWORD --env-password . ssh (authorized keys) . --norc rc (home). --rcfile file . . -f script_file . ( --norc) . -c commands . (semicolon) <<&&>> <<||>> . . ( --norc) . open lftp . (ENVIRONMENT VARIABLES) lftp : EDITOR edit . HOME (<<~>>) () . SHELL ! . PAGER (pager) . more zmore . http_proxy, https_proxy http:proxy hftp:proxy https:proxy . ftp_proxy URL ftp:proxy hftp:proxy . no_proxy net:no-proxy . LFTP_MODULE_PATH module:path . LFTP_HOME . ~/.lftp . XDG . LFTP_PASSWORD --env-password open . LS_COLORS color:dir-colors . XDG_CONFIG_HOME, XDG_DATA_HOME, XDG_CACHE_HOME ~/.lftp ( $LFTP_HOME) . ~/.config ~/.local/share ~/.cache . /lftp . (FILES) /etc/lftp.conf . --sysconfdir . /usr /etc /usr/local/etc . ~/.config/lftp/rc or ~/.lftp/rc, ~/.lftprc lftp /etc/lftp.conf . ~/.local/share/lftp/log or ~/.lftp/log lftp nohup . ~/.local/share/lftp/transfer_log or ~/.lftp/transfer_log log:enabled/xfer <> . log:file/xfer . ~/.local/share/lftp/bookmarks or ~/.lftp/bookmarks lftp . bookmark . ~/.local/share/lftp/cwd_history or ~/.lftp/cwd_history . ~/.local/share/lftp/bg/ or ~/.lftp/bg/ lftp . ~/.cache/lftp/DHT/ or ~/.lftp/DHT/" DHT IPv4 IPv6 . (host name) . ~/.cache/lftp/edit/ or ~/.lftp/edit/" edit . ~/.local/share/lftp/torrent/md/ or ~/.lftp/torrent/md/" (torrent metadata) . magnet . info_hash . ~/.netrc <> (login) . URL ..SH " (SEE ALSO)" ftpd(8), ftp(1) RFC854 (telnet) RFC959 (ftp) RFC1123 RFC1945 (http/1.0) RFC2052 (SRV RR) RFC2228 ( ftp) RFC2389 (ftp FEAT) RFC2428 (ftp/ipv6) RFC2518 (WebDAV) RFC2616 (http/1.1) RFC2617 ( http/1.1) RFC2640 ( ftp) RFC3659 ( ftp) RFC4217 (ftp ssl) BEP0003 ( BitTorrent) BEP0005 ( DHT) BEP0006 ( Fast) BEP0007 ( IPv6) BEP0009 ( ) BEP0010 ( ) BEP0012 ( ) BEP0023 ( ) BEP0032 ( DHT IPv6). https://tools.ietf.org/html/draft-preston-ftpext-deflate-04 ( deflate ftp) https://tools.ietf.org/html/draft-dd-pret-00 ( PRET) https://tools.ietf.org/html/draft-ietf-secsh-filexfer-13 (sftp). http://wiki.theory.org/BitTorrentSpecification http://www.bittornado.com/docs/multitracker-spec.txt http://www.rasterbar.com/products/libtorrent/dht_sec.html ( DHT) http://xbtt.sourceforge.net/udp_tracker_protocol.html ( UDP) (AUTHOR) Alexander V. Lukyanov lav@yars.free.net (ACKNOWLEDGMENTS) Christoph Lameter Debian GNU/Linux . Nicolas Lichtmaier James Troup Alexander V. Lukyanov . 11 June 2022 lftp(1)