LDAP_TABLE(5) File Formats Manual LDAP_TABLE(5) (NAME) ldap_table - LDAP Postfix (SYNOPSIS) postmap -q "string" ldap:/etc/postfix/filename postmap -q - ldap:/etc/postfix/filename (DESCRIPTION) Postfix . lmdb: cdb: hash: dbm: . (lookup tables) LDAP . Postfix <> . LDAP LDAP main.cf : alias_maps = ldap:/etc/postfix/ldap-aliases.cf /etc/postfix/ldap-aliases.cf main.cf Postfix . . Postfix . . Postfix << MAIN.CF>> . LDAP SSL STARTTLS SSL STARTTLS . (LIST MEMBERSHIP) LDAP $mynetworks $mydestination $relay_domains $local_recipient_maps . ** . <> DATABASE_README . $mydestination $relay_domains IP $mynetworks . . LDAP . $mydestination : query_filter = domain=* result_attribute = domain : query_filter = domain=%s result_attribute = domain LDAP (GENERAL LDAP PARAMETERS) . : () Postfix . server_host (: localhost) LDAP : server_host = ldap.example.com LDAP . ( server_port ) : server_host = ldap.example.com:1444 : . OpenLDAP ( ) (URL) LDAP () () : server_host = ldap://ldap.example.com:1444 ldap://ldap2.example.com:1444 URL LDAP OpenLDAP (UNIX domain sockets) LDAP SSL ( OpenLDAP SSL ): server_host = ldapi://%2Fsome%2Fpath ldaps://ldap.example.com:636 server_port (: 389) LDAP : server_port = 778 timeout (: 10 ) (timeout) : timeout = 5 search_base ( ) DN RFC2253 : search_base = dc=your, dc=com Postfix . '%' : %% '%' . %s . (metacharacters) RFC 2253 . %u user@domain %u (local part) (RFC 2253) . %u . . %d user@domain %d (RFC 2253) . . %[SUD] search_base . result_format ( result_filter << >> ) . %[1-9] %1 %2 ... %9 . user@mail.example.com %1 com %2 example %3 mail . (unqualified) . query_filter (: mailacceptinggeneralid=%s) RFC2254 %s Postfix (resolve) : query_filter = (&(mail=%s)(paid_up=true)) '%' : %% '%' (Postfix . ). %s . RFC 2254 . %u user@domain %u (RFC 2254) . %u . . %d user@domain %d (RFC 2254) . . %[SUD] query_filter . result_format ( result_filter << >> ) . %S %U %D Postfix . . %[1-9] %1 %2 ... %9 . user@mail.example.com %1 com %2 example %3 mail . . %1 ... %9 Postfix . . <> . <> LDAP . : query_filter () . result_format (: %s) Postfix . result_filter . . ( ) . '%' : %% '%' (Postfix . ). %s . . %u user@domain %u . . %d user@domain %d . . %[SUD1-9] . query_filter . %S %U %D %1 ... %9 Postfix . . <> mailHost transport(5) . . expansion_limit size_limit . %s . Postfix . result_filter . <> <> . . : ! domain (: ) <> . (FQDN) ** : 'user' "@domain" . LDAP . domain = postfix.org, hash:/etc/postfix/searchdomains LDAP LDAP . : local(8) . Postfix . . result_attribute (: maildrop) Postfix . result_attribute = mailbox, maildrop (<>) . result_attribute ldap . result_attribute leaf_result_attribute / terminal_result_attribute . <> . special_result_attribute (: ) () DN URL RFC 2255 LDAP . DN URL . special_result_attribute = memberdn DN result_attributes . URL URL ( ) Postfix . URL . URL (RFC 2255) URL Postfix . URL LDAP LDAP Postfix ( ) RFC 2255 ("attr;option") LDAP . URL . URL Postfix . LDAP LDAP . terminal_result_attribute (: ) (terminal) LDAP . <> (mailing-list manager) . result_attribute = terminal_result_attribute = maildrop / result_attribute <> . Postfix . . leaf_result_attribute (: ) LDAP ( ) . () DN URI . leaf_result_attribute result_attribute . <> <> DN . DN rfc822 <> . DN ( LDAP URI) <> . result_attribute = memberaddr special_result_attribute = memberdn terminal_result_attribute = maildrop leaf_result_attribute = mail / result_attribute <> . Postfix . . scope (: sub) LDAP: sub base one. LDAP_SCOPE_SUBTREE LDAP_SCOPE_BASE LDAP_SCOPE_ONELEVEL . bind (: yes) LDAP (bind) . LDAP bind . : # (Don't bind) bind = no # bind (SIMPLE bind) bind = yes # bind SASL bind = sasl Postfix . <> <> bind (SIMPLE) . Postfix . LDAP_README LDAP SASL <> <> <> <> <> . <> SASL . (bind) Postfix SSL LDAP . LDAP SSL ( ) . (cleartext) . bind_dn (: ) bind (distinguished name) . : bind_dn = uid=postfix, dc=your, dc=com <> ( ) DN SASL DN . bind_pw (: ) . Postfix . ldap:ldapsource main.cf bind . main.cf (world-readable) sendmail . : bind_pw = postfixpw <> ( ) SASL . cache ( ) cache_expiry ( ) cache_size ( ) Postfix . (Cache) .. OpenLDAP . recursion_limit (: 1000) DN URL. . expansion_limit (: 0) ( ) . . . . size_limit (: $expansion_limit) LDAP LDAP . . DN URL LDAP . : LDAP / . LDAP . <<-z>> <> . dereference (: 0) (dereference) LDAP. ( Postfix .) OpenLDAP/UM LDAP : 0 (never) 1 (when searching) 2 (when locating the base object for the search) 3 (always) ldap.h ldap_open(3) ldapsearch(1) . LDAP postfix-users@postfix.org . chase_referrals (: 0) LDAP_OPT_REFERRALS ( ) ( LDAP ). version (: 2) LDAP . debuglevel (: 0) (debugging) OpenLDAP . LDAP SASL (LDAP SASL PARAMETERS) OpenLDAP SASL Postfix . LDAP SASL LDAP_README SASL LDAP . LDAP . : (timeout) bind LDAP . SASL bind LDAP SASL . bind SASL proxymap(8) proxymap . import_environment proxymap(8) master.cf(5) . GSSAPI SASL . GSSAPI LDAP SMTP Postfix . SASL LDAP . <> <> . LDAP SASL : sasl_mechs (: ) () SASL . sasl_realm (: ) SASL (Realm) . sasl_authz_id (: ) SASL . sasl_minssf (: 0) SASL . LDAP SSL STARTTLS (LDAP SSL AND STARTTLS PARAMETERS) OpenLDAP SSL Postfix LDAP SSL STARTTLS . LDAP SSL URL LDAP SSL server_host : server_host = ldaps://ldap.example.com:636 STARTTLS start_tls : start_tls = yes LDAP : version = 3 Postfix master.cf chroot chroot . <> . LDAP SSL STARTTLS : start_tls (: no) STARTTLS . LDAP SSL ( SSL TCP ). tls_ca_cert_dir ( tls_ca_cert_file ) (CA) X509 PEM SSL/TLS . CA . (hash) CA . CA ( 9d66eef0.0 9d66eef0.1 ). . c_rehash ( OpenSSL) . tls_ca_cert_file ( tls_ca_cert_dir ) (CA) X509 PEM SSL/TLS . tls_ca_cert_dir . tls_cert ( ) X509 SSL/TLS . tls_key ( ) tls_cert . tls_require_cert (: no) SSL/TLS X509 . no yes . no OpenLDAP .. LDAP . OpenLDAP .. .. ( ) IP LDAP . OpenLDAP .. subjectAlternativeName LDAP : CommonName . no never TLS_REQCERT LDAP . OpenLDAP 2.0.x ( x <= 11) TLS . yes CA . LDAP () ( OpenLDAP ). yes demand TLS_REQCERT LDAP . <> <> TLS_REQCERT . OpenLDAP 2.0 . LDAP TLS . yes Postfix . OpenLDAP 2.0 . Postfix OpenLDAP . LDAP TLS (API) OpenLDAP 2.0 Postfix . tls_random_file ( ) dev/[u]random/ SSL/TLS. tls_cipher_suite ( ) (Cipher suite) SSL/TLS. (EXAMPLE) LDAP local(8) . main.cf : alias_maps = hash:/etc/aliases, ldap:/etc/postfix/ldap-aliases.cf ldap:/etc/postfix/ldap-aliases.cf : server_host = ldap.example.com search_base = dc=example, dc=com <> /etc/aliases Postfix LDAP ldap.example.com . (bind) mailacceptinggeneralid <> <> maildrop RFC822 . MAIN.CF (OBSOLETE MAIN.CF PARAMETERS) Postfix . LDAP main.cf . LDAP () . LDAP (underscore) . <> <> main.cf <> . : LDAP main.cf . Postfix . (OTHER OBSOLETE FEATURES) result_filter ( ) LDAP . result_filter result_format . . . (SEE ALSO) postmap(1) Postfix postconf(5) mysql_table(5) MySQL pgsql_table(5) PostgreSQL (README FILES) <> <> . DATABASE_README Postfix LDAP_README LDAP Postfix (LICENSE) Secure Mailer . (AUTHORS) Carsten Hoeger, Hery Rakotoarisoa, John Hensley, Keith Stevenson, LaMont Jones, Liviu Daia, Manuel Guesdon, Mike Mattice, Prabhat K Singh, Sami Haahtinen, Samuel Tardieu, Victor Duchovni, . LDAP_TABLE(5)