KDIG(1) Knot DNS KDIG(1) (NAME) kdig - DNS (SYNOPSIS) kdig [-] [ []]... kdig -h (DESCRIPTION) DNS . - . name | -q name | -x address | -G tapfile -, [query_class] [query_type] [@server]... [] name . server IPv4 IPv6 . address:port ( IPv6 [address]:port) address@port address#port . <> (UNIX socket) . /etc/resolv.conf . kdig NS (root zone) . query_class DNS ( IN CH) CLASSXXXXX XXXXX . IN . query_type DNS ( A AAAA NS SOA DNSKEY ANY ) : TYPEXXXXX XXXXX . AXFR (Full zone transfer). IXFR=serial (Incremental zone transfer) SOA ( ). NOTIFY=serial (Notify) SOA. NOTIFY (Notify) SOA. A . -4 IPv4 . -6 IPv6 . -b address IP address . :: 0.0.0.0 . server . -c class query_class. . -d (Debug). -dd ( Subject Alternative Name). -h, --help . -k keyfile TSIG keyfile . -y . -p port . 53 . -q name . name. name (question section) . -t type query_type. . -V, --version . -VV . -x address (PTR) IPv4 IPv6 address. . -y [alg:]name:key TSIG name . alg ( hmac-sha256 ) key Base64 . -E tapfile dnstap tapfile. -G tapfile dnstap tapfile. +[no]multiline . +[no]short . +[no]generic . +[no]crypto DNSSEC base64 . (*) +[no]aaflag AA. +[no]tcflag TC. +[no]rdflag RD. (*) +[no]recurse +[no]rdflag +[no]raflag RA. +[no]zflag . +[no]adflag AD. (*) +[no]cdflag CD. +[no]doflag DO. +[no]dnssec +[no]doflag +[no]all . +[no]qr . +[no]header . (*) +[no]comments . (*) +[no]opt EDNS. (*) +[no]opttext EDNS . +[no]optpresent EDNS draft-peltan-edns-presentation-format-01 . +[no]question (Question). (*) +[no]answer (Answer). (*) +[no]authority (Authority). (*) +[no]additional (Additional). (*) +[no]tsig TSIG. (*) +[no]stats . (*) +[no]class DNS. (*) +[no]ttl TTL. (*) +[no]tcp TCP ( UDP AXFR/IXFR TCP ). +[no]fastopen TCP Fast Open. +[no]ignore TCP (Truncated). +[no]keepopen TCP . +tcp +tls +https +quic . kdig . +[no]tls TLS (RFC 7858 Section 4.1 ). +[no]tls-ca[=FILE] TLS . (CA) PEM ( ). . +tls-hostname ( ) . +[no]tls-pin=BASE64 TLS (RFC 7858 Section 4.2 ). PIN SHA-256 Base64 X.509 SubjectPublicKeyInfo . . +[no]tls-hostname=STR TLS . +[no]tls-sni=STR TLS (Server Name Indication). +[no]tls-keyfile=FILE TLS . +[no]tls-certfile=FILE TLS . +[no]tls-ocsp-stapling[=H] TLS OCSP (%u ). OCSP . +[no]https[=URL] HTTPS (DNS-over-HTTPS) (RFC 1035 Section 4.2.1 ). URL=[authority][/path] . ( //) . server ( @) . path authority server path . libnghttp2 . +[no]https-get HTTPS HTTP/GET HTTP/POST. libnghttp2 . +[no]quic QUIC (DNS-over-QUIC). +[no]nsid (NSID). +[no]zoneversion EDNS (EDNS zone version). +[no]bufsize=B EDNS ( 1232 ). +[no]padding[=B] EDNS(0) . +tls TLS . ( +padding) TLS . +nopadding . +[no]alignment[=B] B- EDNS(0) ( no 128). +[no]subnet=SUBN EDNS(0) SUBN=addr/prefix. +[no]edns[=N] EDNS ( 0 ). +[no]msgdelay=T AXFR/IXFR. +[no]timeout=T ( 5 ). . notimeout . +[no]retry=N UDP (>=0) ( 2 ). AXFR/IXFR . +[no]expire EXPIRE EDNS. +[no]cookie[=HEX] EDNS(0) . +[no]badcookie . +[no]ednsopt[=CODE[:HEX]] EDNS. CODE EDNS HEX EDNS . . +noednsopt EDNS +ednsopt . +[no]proxy=SRC_ADDR[#SRC_PORT]-DST_ADDR[#DST_PORT] PROXYv2 . 0 53 . +[no]json JSON (RFC 8427). +noidn IDN ASCII . IDN libidn2 ! - IDN . ASCII . IDN . (NOTES) (*) . -k -y . Dnssec-keygen . keymgr(8) . (EXIT VALUES) 0 . . (EXAMPLES) 1. A example.com: $ kdig example.com A 2. AXFR example.com 192.0.2.1: $ kdig example.com -t AXFR @192.0.2.1 3. A example.com 192.0.2.1 2001:DB8::1 192.0.2.2. TCP: $ kdig +tcp example.com -t A @192.0.2.1 -x 2001:DB8::1 @192.0.2.2 4. SOA example.com TLS : $ kdig -d @185.49.141.38 +tls-ca +tls-host=getdnsapi.net \ +tls-pin=foxZRnIh9gZpWnl+zEiKa0EJ2rdCGroMWm02gaxSc9S= soa example.com 5. DNS HTTPS ( DoH): $ kdig @1.1.1.1 +https example.com. $ kdig @193.17.47.1 +https=/doh example.com. $ kdig @8.8.4.4 +https +https-get example.com. $ kdig @8.8.8.8 +https +tls-hostname=dns.google +fastopen example.com. 6. DoT: $ kdig @1.1.1.1 +tls +keepopen abc.example.com A mail.example.com AAAA 7. RFC 4892 : $ kdig @a.iana-servers.net. CH TXT id.server version.server (FILES) /etc/resolv.conf (SEE ALSO) khost(1), knsupdate(1), keymgr(8). (AUTHOR) CZ.NIC, z.s.p.o. (COPYRIGHT) Copyright (C) CZ.NIC, z.s.p.o. and contributors 3.5.5 2026-06-12 KDIG(1)