JOSE(1) JOSE(1) (NAME) jose - JSON (SYNOPSIS) jose alg [-k KIND] jose b64 dec -i B64 [-O BIN] jose b64 enc -I BIN [-o B64] jose jwe dec -i JWE [-I CT] -k JWK [-p] [-O PT] jose jwe enc [-i JWE] -I PT -k JWK [-p] [-r RCP] [-o JWE] [-O CT] [-c] jose jwe fmt -i JWE [-I CT] [-o JWE] [-O CT] [-c] jose jwk exc [-i JWK] -l JWK -r JWK [-o JWK] jose jwk gen -i JWK [-o JWK] jose jwk pub -i JWK [-o JWK] jose jwk thp -i JWK [-a ALG] [-o THP] jose jwk use -i JWK [-a] [-r] -u OP jose jws fmt -i JWS [-I PAY] [-o JWS] [-O PAY] [-c] jose jws sig [-i JWS] [-I PAY] [-s SIG] -k JWK [-o JWS] [-O PAY] [-c] jose jws ver -i JWS [-I PAY] -k JWK [-O PAY] [-a] (OVERVIEW) Jose C Javascript Object Signing and Encryption . Jose : o RFC 7515 - JSON (JWS) o RFC 7516 - JSON (JWE) o RFC 7517 - JSON (JWK) o RFC 7518 - JSON (JWA) o RFC 7519 - JSON (JWT) o RFC 7520 - JOSE o RFC 7638 - JSON (JWK) Jose : o Base64 (URL-safe) o o o (AUTHORS) Nathaniel McCallum (SEE ALSO) jose-alg(1), jose-b64-dec(1), jose-b64-enc(1), jose-jwe-dec(1), jose-jwe-enc(1), jose-jwe-fmt(1), jose-jwk-exc(1), jose-jwk-gen(1), jose-jwk-pub(1), jose-jwk-thp(1), jose-jwk-use(1), jose-jws-fmt(1), jose-jws-sig(1), jose-jws-ver(1) 06/09/2026 JOSE(1)