'\" t .\" Title: jose .\" Author: [see the "AUTHOR" section] .\" Generator: DocBook XSL Stylesheets vsnapshot .\" Date: 06/09/2026 .\" Manual: \ \& .\" Source: \ \& .\" Language: English .\" .TH "JOSE" "1" "06/09/2026" "\ \&" "\ \&" .\" ----------------------------------------------------------------- .\" * Define some portability stuff .\" ----------------------------------------------------------------- .\" ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ .\" http://bugs.debian.org/507673 .\" http://lists.gnu.org/archive/html/groff/2009-02/msg00013.html .\" ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ .ie \n(.g .ds Aq \(aq .el .ds Aq ' .\" ----------------------------------------------------------------- .\" * set default formatting .\" ----------------------------------------------------------------- .\" disable hyphenation .nh .\" disable justification (adjust text to left margin only) .ad l .\" ----------------------------------------------------------------- .\" * MAIN CONTENT STARTS HERE * .\" ----------------------------------------------------------------- .SH "نام (NAME)" jose \- مجموعه‌ابزار برای انجام امضا و رمزنگاری اشیاء JSON .SH "خلاصه دستور (SYNOPSIS)" .sp \fBjose alg\fR [\-k KIND] .sp \fBjose b64 dec\fR \-i B64 [\-O BIN] .sp \fBjose b64 enc\fR \-I BIN [\-o B64] .sp \fBjose jwe dec\fR \-i JWE [\-I CT] \-k JWK [\-p] [\-O PT] .sp \fBjose jwe enc\fR [\-i JWE] \-I PT \-k JWK [\-p] [\-r RCP] [\-o JWE] [\-O CT] [\-c] .sp \fBjose jwe fmt\fR \-i JWE [\-I CT] [\-o JWE] [\-O CT] [\-c] .sp \fBjose jwk exc\fR [\-i JWK] \-l JWK \-r JWK [\-o JWK] .sp \fBjose jwk gen\fR \-i JWK [\-o JWK] .sp \fBjose jwk pub\fR \-i JWK [\-o JWK] .sp \fBjose jwk thp\fR \-i JWK [\-a ALG] [\-o THP] .sp \fBjose jwk use\fR \-i JWK [\-a] [\-r] \-u OP .sp \fBjose jws fmt\fR \-i JWS [\-I PAY] [\-o JWS] [\-O PAY] [\-c] .sp \fBjose jws sig\fR [\-i JWS] [\-I PAY] [\-s SIG] \-k JWK [\-o JWS] [\-O PAY] [\-c] .sp \fBjose jws ver\fR \-i JWS [\-I PAY] \-k JWK [\-O PAY] [\-a] .SH "نمای کلی (OVERVIEW)" .sp ابزار José یک پیاده‌سازی به زبان C از استانداردهای Javascript Object Signing and Encryption است\&. به طور ویژه، José پیاده‌سازی استانداردهای زیر را هدف قرار می‌دهد: .sp .RS 4 .ie n \{\ \h'-04'\(bu\h'+03'\c .\} .el \{\ .sp -1 .IP \(bu 2.3 .\} RFC 7515 \- امضای وب JSON (JWS) .RE .sp .RS 4 .ie n \{\ \h'-04'\(bu\h'+03'\c .\} .el \{\ .sp -1 .IP \(bu 2.3 .\} RFC 7516 \- رمزنگاری وب JSON (JWE) .RE .sp .RS 4 .ie n \{\ \h'-04'\(bu\h'+03'\c .\} .el \{\ .sp -1 .IP \(bu 2.3 .\} RFC 7517 \- کلید وب JSON (JWK) .RE .sp .RS 4 .ie n \{\ \h'-04'\(bu\h'+03'\c .\} .el \{\ .sp -1 .IP \(bu 2.3 .\} RFC 7518 \- الگوریتم‌های وب JSON (JWA) .RE .sp .RS 4 .ie n \{\ \h'-04'\(bu\h'+03'\c .\} .el \{\ .sp -1 .IP \(bu 2.3 .\} RFC 7519 \- توکن وب JSON (JWT) .RE .sp .RS 4 .ie n \{\ \h'-04'\(bu\h'+03'\c .\} .el \{\ .sp -1 .IP \(bu 2.3 .\} RFC 7520 \- مثال‌های محافظت از محتوا با استفاده از JOSE .RE .sp .RS 4 .ie n \{\ \h'-04'\(bu\h'+03'\c .\} .el \{\ .sp -1 .IP \(bu 2.3 .\} RFC 7638 \- اثر انگشت کلید وب JSON (JWK) .RE .sp ابزار خط فرمان José امکاناتی برای موارد زیر فراهم می‌کند: .sp .RS 4 .ie n \{\ \h'-04'\(bu\h'+03'\c .\} .el \{\ .sp -1 .IP \(bu 2.3 .\} کدگذاری و کدگشایی Base64 امن برای نشانی وب (URL\-safe) .RE .sp .RS 4 .ie n \{\ \h'-04'\(bu\h'+03'\c .\} .el \{\ .sp -1 .IP \(bu 2.3 .\} تولید و مدیریت کلید .RE .sp .RS 4 .ie n \{\ \h'-04'\(bu\h'+03'\c .\} .el \{\ .sp -1 .IP \(bu 2.3 .\} رمزنگاری و رمزگشایی .RE .sp .RS 4 .ie n \{\ \h'-04'\(bu\h'+03'\c .\} .el \{\ .sp -1 .IP \(bu 2.3 .\} امضا و اعتبارسنجی .RE .SH "نویسندگان (AUTHORS)" .sp Nathaniel McCallum .SH "همچنین ببینید (SEE ALSO)" .sp \fBjose\-alg\fR(1), \fBjose\-b64\-dec\fR(1), \fBjose\-b64\-enc\fR(1), \fBjose\-jwe\-dec\fR(1), \fBjose\-jwe\-enc\fR(1), \fBjose\-jwe\-fmt\fR(1), \fBjose\-jwk\-exc\fR(1), \fBjose\-jwk\-gen\fR(1), \fBjose\-jwk\-pub\fR(1), \fBjose\-jwk\-thp\fR(1), \fBjose\-jwk\-use\fR(1), \fBjose\-jws\-fmt\fR(1), \fBjose\-jws\-sig\fR(1), \fBjose\-jws\-ver\fR(1)