ippfind(1) OpenPrinting ippfind(1) (NAME) ippfind - (SYNOPSIS) ippfind [ options ] regtype[,subtype][.domain.] ... [ expression ... ] ippfind [ options ] name[.regtype[.domain.]] ... [ expression ... ] ippfind --help ippfind --version (DESCRIPTION) ippfind DNS . IPP URI . (REGISTRATION TYPES) ippfind : _http._tcp (HTTP, RFC 2616) _https._tcp (HTTPS, RFC 2818) _ipp._tcp (IPP, RFC 2911) _ipps._tcp (IPPS, ) _printer._tcp (LPD, RFC 1179) (EXPRESSIONS) ippfind find(1) . find(1) ippfind POSIX . --exec -l --ls -p --print --print-name -q --quiet -s -x ippfind --print URI . : -d regex --domain regex . --false . -h regex --host regex . -l --ls Get-Printer-Attributes IPP "-ls" find HTTP . URI . --local . -N name --literal-name name . -n regex --name regex . --path regex URI . -P number[-number] --port number[-number] . -p --print URI . . -q --quiet - . -r --remote . -s --print-name . . --true . -t key --txt key TXT . --txt-key regex TXT . -u regex --uri regex URI . -x utility [ argument ... ] ; --exec utility [ argument ... ] ; . "{foo}" - <<>> . : ( expression ) . ! expression --not expression (NOT) . expression expression expression --and expression (AND) . expression --or expression (OR) . (SUBSTITUTIONS) "{foo}" -e --exec : {service_domain} "example.com." "local." . {service_hostname} "printer.example.com." "printer.local." . {service_name} "My Fine Printer". {service_port} IPP HTTP. {service_regtype} DNS-SD "_ipp._tcp" "_http._tcp" . {service_scheme} (scheme) URI DNS-SD "ipp" "http" . {} {service_uri} URI "ipp://printer.local./ipp/print" "http://printer.local./" . {txt_key} key TXT ( ). (OPTIONS) ippfind : --help . --version . -4 IPv4 . -6 IPv6 . -T seconds . ippfind . . -V version IPP . "1.1" "2.0" "2.1" "2.2". (EXIT STATUS) ippfind 0 1 2 3 4 . (ENVIRONMENT) ippfind : IPPFIND_SERVICE_DOMAIN "example.com." "local." . IPPFIND_SERVICE_HOSTNAME "printer.example.com." "printer.local." . IPPFIND_SERVICE_NAME "My Fine Printer". IPPFIND_SERVICE_PORT IPP HTTP. IPPFIND_SERVICE_REGTYPE DNS-SD "_ipp._tcp" "_http._tcp" . IPPFIND_SERVICE_SCHEME URI DNS- SD "ipp" "http" . IPPFIND_SERVICE_URI URI "ipp://printer.local./ipp/print" "http://printer.local./" . IPPFIND_TXT_KEY KEY TXT ( ). (EXAMPLES) IPP : ippfind --ls PostScript PostScript : ippfind --txt-pdl application/postscript --exec ipptool -f onepage-letter.ps '{}' print-job.test \; (SEE ALSO) ipptool(1) (COPYRIGHT) Copyright (C) 2020-2024 by OpenPrinting. 2021-02-28 ippsample ippfind(1)