.\" .\" ippfind man page. .\" .\" Copyright © 2020-2024 by OpenPrinting. .\" Copyright © 2013-2019 by Apple Inc. .\" .\" Licensed under Apache License v2.0. See the file "LICENSE" for more .\" information. .\" .TH ippfind 1 "ippsample" "2021-02-28" "OpenPrinting" .SH "نام (NAME)" ippfind \- یافتن چاپگرهای پروتکل چاپ اینترنتی .SH "خلاصه دستور (SYNOPSIS)" .B ippfind [ .I options ] \fIregtype\fR[\fB,\fIsubtype\fR][\fB.\fIdomain\fB.\fR] ... [ .I expression ... ] .br .B ippfind [ .I options ] \fIname\fR[\fB.\fIregtype\fR[\fB.\fIdomain\fB.\fR]] ... [ .I expression ... ] .br .B ippfind .B \-\-help .br .B ippfind .B \-\-version .SH "توضیحات (DESCRIPTION)" دستور \fBippfind\fR سرویس‌های ثبت‌شده در یک کارساز DNS یا موجود از طریق دستگاه‌های محلی را پیدا می‌کند. هدف اصلی آن یافتن چاپگرهای IPP و نمایش URIهای آن‌ها، نمایش وضعیت فعلی آن‌ها، یا اجرای دستورات است. .SS "انواع ثبت (REGISTRATION TYPES)" دستور \fBippfind\fR از انواع ثبت زیر پشتیبانی می‌کند: .TP 5 _http._tcp پروتکل انتقال ابرمتن (HTTP, RFC 2616) .TP 5 _https._tcp پروتکل امن انتقال ابرمتن (HTTPS, RFC 2818) .TP 5 _ipp._tcp پروتکل چاپ اینترنتی (IPP, RFC 2911) .TP 5 _ipps._tcp پروتکل امن چاپ اینترنتی (IPPS, پیش‌نویس) .TP 5 _printer._tcp دیمن چاپگر خطی (LPD, RFC 1179) .SS "عبارت‌ها (EXPRESSIONS)" دستور \fBippfind\fR از عبارت‌هایی بسیار شبیه به ابزار .BR find (1) پشتیبانی می‌کند. با این حال، برخلاف .BR find (1)، دستور \fBippfind\fR به جای الگوهای تطبیق نام فایل پوسته از عبارت‌های منظم POSIX استفاده می‌کند. اگر هیچ‌یک از موارد \fI\-\-exec\fR، \fI\-l\fR، \fI\-\-ls\fR، \fI\-p\fR، \fI\-\-print\fR، \fI\-\-print\-name\fR، \fI\-q\fR، \fI\-\-quiet\fR، \fI\-s\fR یا \fI\-x\fR مشخص نشده باشد، \fBippfind\fR گزینه \fI\-\-print\fR را برای چاپ URI سرویس هر آنچه پیدا می‌کند اضافه می‌کند. عبارت‌های زیر پشتیبانی می‌شوند: .TP 5 \fB\-d \fIregex\fR .TP 5 \fB\-\-domain \fIregex\fR درست است اگر دامنه با عبارت منظم مشخص‌شده مطابقت داشته باشد. .TP 5 .B \-\-false همیشه نادرست است. .TP 5 \fB\-h \fIregex\fR .TP 5 \fB\-\-host \fIregex\fR درست است اگر نام میزبان با عبارت منظم مشخص‌شده مطابقت داشته باشد. .TP 5 .B \-l .TP 5 .B \-\-ls صفات برگردانده‌شده توسط Get-Printer-Attributes را برای چاپگرهای IPP و خروجی سنتی "\-ls" ابزار \fIfind\fR را برای نشانی‌های اینترنتی HTTP فهرست می‌کند. در صورت در دسترس بودن URI، نتیجه درست است و در غیر این صورت نادرست خواهد بود. .TP 5 .B \-\-local درست است اگر سرویس برای این رایانه محلی باشد. .TP 5 \fB\-N \fIname\fR .TP 5 \fB\-\-literal\-name \fIname\fR درست است اگر نام نمونه سرویس با نام مشخص‌شده مطابقت داشته باشد. .TP 5 \fB\-n \fIregex\fR .TP 5 \fB\-\-name \fIregex\fR درست است اگر نام نمونه سرویس با عبارت منظم مشخص‌شده مطابقت داشته باشد. .TP 5 \fB\-\-path \fIregex\fR درست است اگر مسیر منبع URI با عبارت منظم مشخص‌شده مطابقت داشته باشد. .TP 5 \fB\-P \fInumber\fR[\fB-\fInumber\fR] .TP 5 \fB\-\-port \fInumber\fR[\fB-\fInumber\fR] درست است اگر درگاه با شماره یا محدوده داده‌شده مطابقت داشته باشد. .TP 5 .B \-p .TP 5 .B \-\-print اگر نتیجه عبارت‌های قبلی درست باشد، URI را چاپ می‌کند. نتیجه همیشه درست است. .TP 5 .B \-q .TP 5 .B \-\-quiet حالت بی‌صدا \- فقط کدهای خروج زیر را بازمی‌گرداند. .TP 5 .B \-r .TP 5 .B \-\-remote درست است اگر سرویس برای این رایانه محلی نباشد. .TP 5 .B \-s .TP 5 .B \-\-print\-name اگر نتیجه عبارت‌های قبلی درست باشد، نام نمونه سرویس را چاپ می‌کند. نتیجه همیشه درست است. .TP 5 .B \-\-true همیشه درست است. .TP 5 \fB\-t \fIkey\fR .TP 5 \fB\-\-txt \fIkey\fR درست است اگر رکورد TXT شامل کلید نام‌برده باشد. .TP 5 \fB\-\-txt\-\fIkey regex\fR درست است اگر رکورد TXT شامل کلید نام‌برده باشد و با عبارت منظم مشخص‌شده مطابقت داشته باشد. .TP 5 \fB\-u \fIregex\fR .TP 5 \fB\-\-uri \fIregex\fR درست است اگر URI با عبارت منظم مشخص‌شده مطابقت داشته باشد. .TP 5 \fB\-x \fIutility \fR[ \fIargument \fR... ] \fB;\fR .TP 5 \fB\-\-exec \fIutility \fR[ \fIargument \fR... ] \fB;\fR اگر نتیجه فعلی درست باشد، برنامه مشخص‌شده را اجرا می‌کند. آرگومان‌های "{foo}" با مقدار متناظر جایگزین می‌شوند \- بخش «جایگزینی‌ها» را در زیر ببینید. .PP عبارت‌ها همچنین می‌توانند شامل اصلاح‌کننده‌ها باشند: .TP 5 \fB( \fIexpression \fB)\fR گروه‌بندی نتیجه عبارت‌ها. .TP 5 \fB! \fIexpression\fR .TP 5 \fB\-\-not \fIexpression\fR نقیض (NOT) یکانی عبارت. .TP 5 \fIexpression expression\fR .TP 5 \fIexpression \fB\-\-and \fIexpression\fR عطف منطقی (AND) عبارت‌ها. .TP 5 \fIexpression \fB\-\-or \fIexpression\fR فصل منطقی (OR) عبارت‌ها. .SS "جایگزینی‌ها (SUBSTITUTIONS)" موارد جایگزین برای "{foo}" در \fI\-e\fR و \fI\-\-exec\fR عبارتند از: .TP 5 .B {service_domain} نام دامنه، برای مثال "example.com."، "local." و غیره. .TP 5 .B {service_hostname} نام دامنه کاملاً واجد شرایط، برای مثال "printer.example.com."، "printer.local." و غیره. .TP 5 .B {service_name} نام نمونه سرویس، برای مثال "My Fine Printer". .TP 5 .B {service_port} شماره درگاه برای کارساز، معمولاً ۶۳۱ برای IPP و ۸۰ برای HTTP. .TP 5 .B {service_regtype} نوع ثبت DNS-SD، برای مثال "_ipp._tcp"، "_http._tcp" و غیره. .TP 5 .B {service_scheme} طرحواره (scheme) URI برای نوع ثبت DNS-SD، برای مثال "ipp"، "http" و غیره. .TP 5 .B {} .TP 5 .B {service_uri} نشانی URI برای سرویس، برای مثال "ipp://printer.local./ipp/print"، "http://printer.local./" و غیره. .TP 5 \fB{txt_\fIkey\fB}\fR مقدار کلید \fIkey\fR در رکورد TXT (با حروف کوچک). .SH "گزینه‌ها (OPTIONS)" دستور \fBippfind\fR از گزینه‌های زیر پشتیبانی می‌کند: .TP 5 .B \-\-help نمایش راهنمای برنامه. .TP 5 .B \-\-version نمایش نسخه برنامه. .TP 5 .B \-4 استفاده از IPv4 هنگام فهرست‌کردن. .TP 5 .B \-6 استفاده از IPv6 هنگام فهرست‌کردن. .TP 5 \fB\-T \fIseconds\fR مشخص کردن زمان انتظار جستجو بر حسب ثانیه. اگر ۱ یا کمتر باشد، \fBippfind\fR به محض اینکه فرض کند همه چیز را پیدا کرده است متوقف می‌شود. زمان انتظار پیش‌فرض ۱ ثانیه است. .TP 5 \fB\-V \fIversion\fR نسخه IPP را هنگام فهرست کردن مشخص می‌کند. مقادیر پشتیبانی‌شده عبارتند از "1.1"، "2.0"، "2.1" و "2.2". .SH "وضعیت خروج (EXIT STATUS)" دستور \fBippfind\fR اگر نتیجه برای تمام عبارت‌های پردازش‌شده درست باشد مقدار 0، اگر نتیجه هر یک از عبارت‌های پردازش‌شده نادرست باشد مقدار 1، اگر مرور یا هر پرس‌وجو یا حل آدرس شکست بخورد مقدار 2، اگر یک گزینه تعریف‌نشده یا عبارت نامعتبر مشخص شده باشد مقدار 3، و اگر حافظه تمام شود مقدار 4 را برمی‌گرداند. .SH "محیط (ENVIRONMENT)" هنگام اجرای یک برنامه، \fBippfind\fR متغیرهای محیطی زیر را برای ثبت سرویس منطبق تنظیم می‌کند: .TP 5 .B IPPFIND_SERVICE_DOMAIN نام دامنه، برای مثال "example.com."، "local." و غیره. .TP 5 .B IPPFIND_SERVICE_HOSTNAME نام دامنه کاملاً واجد شرایط، برای مثال "printer.example.com."، "printer.local." و غیره. .TP 5 .B IPPFIND_SERVICE_NAME نام نمونه سرویس، برای مثال "My Fine Printer". .TP 5 .B IPPFIND_SERVICE_PORT شماره درگاه برای کارساز، معمولاً ۶۳۱ برای IPP و ۸۰ برای HTTP. .TP 5 .B IPPFIND_SERVICE_REGTYPE نوع ثبت DNS-SD، برای مثال "_ipp._tcp"، "_http._tcp" و غیره. .TP 5 .B IPPFIND_SERVICE_SCHEME طرحواره URI برای نوع ثبت DNS-SD، برای مثال "ipp"، "http" و غیره. .TP 5 .B IPPFIND_SERVICE_URI نشانی URI برای سرویس، برای مثال "ipp://printer.local./ipp/print"، "http://printer.local./" و غیره. .TP 5 .B IPPFIND_TXT_\fIKEY\fR مقادیر کلید \fIKEY\fR در رکورد TXT (با حروف بزرگ). .SH "مثال‌ها (EXAMPLES)" برای نمایش وضعیت تمام چاپگرهای IPP ثبت‌شده در شبکه خود، اجرا کنید: .nf ippfind \-\-ls .fi مشابهاً، برای ارسال یک صفحه آزمایشی PostScript به تمام چاپگرهای PostScript، اجرا کنید: .nf ippfind \-\-txt\-pdl application/postscript \-\-exec ipptool \-f onepage\-letter.ps '{}' print\-job.test \\; .fi .SH "همچنین ببینید (SEE ALSO)" .BR ipptool (1) .SH "حق نشر (COPYRIGHT)" Copyright \[co] 2020-2024 by OpenPrinting.