INND(8) InterNetNews Documentation INND(8) (NAME) innd - InterNetNews (SYNOPSIS) innd [-adfNrsSu] [-4 address] [-6 address] [-c days] [-H count] [-i count] [-l size] [-m mode] [-n flag] [-o count] [-P port] [-t timeout] [-T count] [-X seconds] (DESCRIPTION) innd InterNetNews NNTP (overview) active(5) history(5) . NNTP nnrpd(8) rnews(1) . innd . ctlinnd(8) . innd "ctlinnd mode" innstat(8) . innd : (running) (paused) (throttled). . innd . ctlinnd(8) ( ) innd ENOSPC / ( ) . innd nnrpd(8) nnrpd(8) ( ). innd NNTP innd nnrpd(8) nnrpd(8) ( ) innd . innd : incoming.conf innd newsfeeds inn.conf . inn.conf(5) . innd news news . . rc.news(8) . ( ) innbind(8) setuid root . (OPTIONS) inn.conf inn.conf inn.conf(5) . -4 address innd IP ( bindaddress inn.conf ). IP INN . IP . IP ("nnn.nnn.nnn.nnn") . bindaddress inn.conf INN IPv6 . inn.conf(5) -6 innd . systemd . -6 address INN IPv6 . innd IP ( bindaddress6 inn.conf ). IPv6 INN . IPv6 RFC 4291 ("n:n:n:n:n:n:n:n") . bindaddress6 inn.conf INN IPv4 . inn.conf(5) -4 innd . systemd . -a innd incoming.conf nnrpd ( noreader inn.conf ). -a incoming.conf . (Usenet) . -c days innd ( ) artcutoff inn.conf . . days 0 innd . "/remember/" expire.ctl(5) . (Message-ID) . "/remember/" expire.ctl "0" expire ( news.daily crontab "notdaily") expire.ctl . . -d, -f innd . -d . -f innd (forks) . -H count, -T count, -X seconds seconds . ( innd nnrpd ). . . . -H -X . "2" . -T -X . "128" "60" . -X "0" . -i count innd NNTP maxconnections inn.conf . . count "0" . -l size innd maxartsize inn.conf . size . size "0" . -m mode innd "running" . innd . mode "g" "p" "t" "running" "paused" "throttled" . ("g" "go" ). -N (Perl Python) innd ( ). innd ctlinnd(8) . -n flag innd ( nnrpd ) readerswhenstopped inn.conf . . flag "n" innd . flag "y" innd . -o count . ( innd ). innd count . newsfeeds ( innfeed(8) ). -P port innd port inn.conf . innd . -r innd active "ctlinnd renumber" . -s newsfeeds . innd syslog(3) . -S incoming.conf syslog(3) . ( .) -t seconds innd active (flush) . seconds . -u ( innd ) . . (CONTROL MESSAGES) Control << >> . (cancel) controlchan(8) newsfeeds . ( . .) . "control" . "control."command . newgroup "control.newgroup" "control" . . ( ) "control.cancel" . . "!control,!control.*" newsfeeds ( ). checkgroups newgroup rmgroup . ( checkgroups ) . newgroup "news.admin.meow" "news.admin.meow" ( "news.admin.*") . newgroup . newgroup (crosspost) << >> . newgroup "news.admin.meow" "news.admin.meow" ( Newsgroups) : *,@news.* news.* news.*,!control,!control.* control,control.* "control.newgroup" ( "control") "*" . : *,@news.*,!control,!control.* comp.*,@news.* ".ctl" . "news.admin.ctl" "control.cancel" ( "control") "news.admin" . ".ctl" INN . "to." . active mergetogroups inn.conf ( newsfeeds ) "to.uunet" . mergetogroups "to" ( active ) . mergetogroups "to.uunet" "to" "to.uunet" . (PROTOCOL DIFFERENCES) innd NNTP RFC 3977 (NNTP) RFC 4643 ( NNTP) RFC 4644 ( NNTP) RFC 6048 ( NNTP) : 1. XBATCH byte-count . byte-count rnews(1) ( cron ) . innxbatch(8) sendxbatches . 2. INN innd . nnrpd(8) . MODE READER innd nnrpd . 3. innd (wildmats) . 4. (IHAVE CHECK TAKETHIS) ( "435" "438" "439") ( "501" ). (HEADER MODIFICATIONS) innd . . ( pathhost inn.conf ) Path Path . pathalias pathcluster pathhost Path inn.conf(5) . Xref . innd . Lines linecountfuzz inn.conf . (CANCEL FEEDS) ( NoCeM ) INN ( ). (pathrun/nntpin) MODE CANCEL . "284" . (message-ID) . "289" "484" . ( . ). (LOGGING) innd (pathlog/news) . : mon dd hh:mm:ss.mmm + feed site ... mon dd hh:mm:ss.mmm j feed site ... mon dd hh:mm:ss.mmm c feed Cancelling mon dd hh:mm:ss.mmm - feed reason mon dd hh:mm:ss.mmm ? feed reason nntplinklog logartsize inn.conf / . . ( Path) (Message-ID) . . (+) . "j" active "j" ( active wanttrash inn.conf ) "junk" . "site ..." . "c" innd . (-) . innd : "%s" header too long Article exceeds local limit of %s bytes Article posted in the future -- "%s" Bad "%s" header field Can't write history Duplicate Duplicate "%s" header field EOF in headers Linecount %s != %s +- %s Missing %s header field No body No colon-space in "%s" header field No matching newsgroups in cancel <%s> No space Space before colon in "%s" header field Too old -- "%s" Unapproved for "%s" Unwanted newsgroup "%s" Unwanted distribution "%s" Whitespace in "Newsgroups" header field -- "%s" "%s" . ( Perl Python .) "?" CR LF LF CR. ( CRLF .) innd . wanttrash inn.conf true : "j" logtrash false ( "j" ). innd syslog(3) . ( "connected") . "SERVER" . "cant" . ( grep . "can't" .) . . . "internal" . (SIGNALS) innd SIGTERM SIGHUP . -d SIGINT . innd SIGUSR1 ctlinnd(8) . (HISTORY) Rich $alz InterNetNews. (SEE ALSO) active(5), ctlinnd(8), history(5), incoming.conf(5), inn.conf(5), innbind(8), innfeed(8), innstat(8), libinn_dbz(3), libinn_inndcomm(3), newsfeeds(5), nnrpd(8), rnews(1), syslog(3). INN 2.7.4 2025-03-29 INND(8)