HEADER_CHECKS(5) File Formats Manual HEADER_CHECKS(5) (NAME) header_checks - Postfix (SYNOPSIS) header_checks = pcre:/etc/postfix/header_checks mime_header_checks = pcre:/etc/postfix/mime_header_checks nested_header_checks = pcre:/etc/postfix/nested_header_checks body_checks = pcre:/etc/postfix/body_checks milter_header_checks = pcre:/etc/postfix/milter_header_checks smtp_header_checks = pcre:/etc/postfix/smtp_header_checks smtp_mime_header_checks = pcre:/etc/postfix/smtp_mime_header_checks smtp_nested_header_checks = pcre:/etc/postfix/smtp_nested_header_checks smtp_body_checks = pcre:/etc/postfix/smtp_body_checks postmap -q "string" pcre:/etc/postfix/filename postmap -q - pcre:/etc/postfix/filename (DESCRIPTION) cleanup(8) Postfix . SMTP access(5) . . . : . . << (EXAMPLES)>> . (header_checks body_checks) Postfix (unzip) . << (README FILES)>> . (FILTERS WHILE RECEIVING MAIL) Postfix : header_checks (: ) ( mime_header_checks ). mime_header_checks (: $header_checks) MIME . Postfix 2.0 . nested_header_checks (: $header_checks) ( mime_header_checks ). Postfix 2.0 . body_checks (multi-part) . 2.0 Postfix . (FILTERS AFTER RECEIVING MAIL) Postfix : milter_header_checks (: ) Milter . Postfix 2.7 . (FILTERS WHILE DELIVERING MAIL) Postfix SMTP . smtp_header_checks (: ) smtp_mime_header_checks (: ) smtp_nested_header_checks (: ) smtp_body_checks (: ) Postfix 2.5 . (COMPATIBILITY) Postfix 2.2 (case sensitive) "postmap -fq" . regexp: pcre: (case insensitive). (TABLE FORMAT) header_checks body_checks Postfix . pcre ( ) . regexp ( POSIX) . Postfix "postconf -m" . Postfix . pcre_table(5) regexp_table(5) . /pattern/flags action /pattern/ action . . !/pattern/flags action /pattern/ action . if /pattern/flags endif /pattern/ if endif . if..endif . : if..endif . if !/pattern/flags endif /pattern/ if endif . if..endif . `#' . / . . (TABLE SEARCH ORDER) . . (TEXT SUBSTITUTION) action ($1, $2 ) . ${n} $(n) . : ( ! ) . (ACTIONS) . Postfix . BCC user@domain (BCC) . (local part) (domain part) . BCC . : BCC NOTIFY=NONE . BCC RFC 3461 . : ( ) . Postfix 3.0 . / smtp . DISCARD optional text... . . . : header_checks body_checks . transport(5) discard(8) . Postfix 2.0 . / smtp . DUNNO . . Postfix OK DUNNO . Postfix 2.1 . FILTER transport:destination content_filter . . transport master.cf (destination) . FILTER_README Postfix . : $number transport destination . : content_filter main.cf . FILTER . : FILTER . transport (destination) destination (Postfix 2.7 ) transport:destination Postfix (Postfix 2.6 ). transport_maps sender_dependent_default_transport_maps . Postfix 2.0 . / smtp . HOLD optional text... hold . hold . . (hold) postcat(1) postsuper(1) . : $maximal_queue_lifetime $bounce_queue_lifetime "postsuper -r" . "postsuper -H" . : . Postfix 2.0 . / smtp . IGNORE . STRIP . INFO optional text... "info:" ... ( ) . . Postfix 2.8 . PASS optional text... "pass:" ... ( ) Milter . : . Postfix 3.2 . / smtp . PREPEND text... . : o PREPEND . o : / Postfix . o . o . Postfix 2.1 . milter_header_checks . REDIRECT user@domain . . : FILTER . REDIRECT . : REDIRECT ( ) canonical masquerade bcc (virtual alias) . Postfix 2.1 . / smtp . REPLACE text... . Postfix 2.2 . Postfix 2.2.2 . : o . o . PREPEND Postfix . REJECT optional text... . . ... . : header_checks body_checks . Postfix 2.3 (enhanced status codes) . ... Postfix "5.7.1" . / smtp . STRIP optional text... "strip:" ... ( ) . IGNORE . Postfix 3.2 . WARN optional text... "warning:" ... ( ) . . (BUGS) . . header_checks body_checks : o . . o (RFC 2045) . o (RFC 2047) . cleanup(8) . : From:, To:, Message-ID:, Date:. cleanup(8) . : Bcc:, Content-Length:, Return-Path:. (CONFIGURATION PARAMETERS) body_checks () body_checks(5) . body_checks_size_limit (51200) ( ) body_checks . header_checks () MIME header_checks(5) . mime_header_checks ($header_checks) MIME header_checks(5) . nested_header_checks ($header_checks) MIME header_checks(5) . disable_mime_input_processing (no) MIME . (EXAMPLES) . /x PCRE . [[:xdigit:]] CLSID . /etc/postfix/main.cf: header_checks = pcre:/etc/postfix/header_checks.pcre /etc/postfix/header_checks.pcre: /^Content-(Disposition|Type).*name\s*=\s*"?([^;]*(\.|=2E)( ade|adp|asp|bas|bat|chm|cmd|com|cpl|crt|dll|exe| hlp|ht[at]| inf|ins|isp|jse?|lnk|md[betw]|ms[cipt]|nws| \{[[:xdigit:]]{8}(?:-[[:xdigit:]]{4}){3}-[[:xdigit:]]{12}\}| ops|pcd|pif|prf|reg|sc[frt]|sh[bsm]|swf| vb[esx]?|vxd|ws[cfh]))(\?=)?"?\s*(;|$)/x REJECT Attachment name "$2" may not end with ".$4" HTML. /etc/postfix/main.cf: body_checks = regexp:/etc/postfix/body_checks /etc/postfix/body_checks: /^