FETCHMAIL(1) fetchmail reference manual FETCHMAIL(1) (NAME) fetchmail - POP IMAP ETRN ODMR (SYNOPSIS) fetchmail [...] [_...] fetchmailconf (DESCRIPTION) fetchmail () . mutt(1) elm(1) Mail(1) . fetchmail () . fetchmail : POP2 ( ) POP3 IMAP2bis IMAP4 IMAP4rev1. ESMTP ETRN ODMR . ( RFC .) fetchmail TCP/IP ( SLIP PPP) (MTA) SMTP (sender-initiated) sendmail . (DEPRECATION AND CRYPTOGRAPHIC SECURITY WARNINGS) MD4 MD5 SHA1 . . IETF RFC MD4 MD5 SHA1 fetchmail ODMR POP3 APOP . TLS 993 ( IMAP4) 995 ( POP3) STARTTLS . fetchmail NEWS fetchmail . (SUPPORT, TROUBLESHOOTING) fetchmail . : env LC_ALL=C fetchmail -V -v --nodetach --nosyslog ( fetchmail .) env LC_ALL=C fetchmail -vvv --nodetach --nosyslog ( fetchmail .) #G3 (FAQ) fetchmail . ( ) LC_ALL=C . . (QUICKSTART) . SMTP (MDA) maildrop dovecot-lda . . ! . .fetchmailrc POP3 : poll mailserver.example.org proto POP3 uidl user joe.sixpack keep ssl : mailserver.example.org . joe.sixpack . keep . ssl . POP3 IMAP "proto POP3 uidl" "proto IMAP" . mda : mda "/usr/bin/maildrop -d %T" . ~/.fetchmailrc : chmod 0600 ~/.fetchmailrc . fetchmail (verbose) . : fetchmail -v --fetchlimit 2 POP3 UIDL "keep" uidl keep fetchmail . TLS (SSL) (TLS (SSL) QUICKSTART) fetchmail README.SSL . --ssl --sslproto tls1.2+ fetchmail IETF RFC-8314 RFC-8996 RFC-8997 . Fetchmail 6.6.0 TLS STARTTLS SMTP --smtphost . (CONCEPTS) fetchmail POP IMAP ( ETRN ODMR) : singledrop () multidrop (). singledrop fetchmail ( ) . fetchmail . fetchmail singledrop fetchmailrc . multidrop fetchmail . fetchmail << >> (envelope recipient) . fetchmail (MTA) . POP IMAP . (ISP) . fetchmail () . Bcc . fetchmail multidrop / (wildcard) . ETRN ODMR SMTP . . fetchmail SMTP 25 (localhost) TCP/IP . fetchmail SMTP . MTA ( sendmail(8) exim(8) postfix(8) ). MDA ( ) MTA . ( .forward) MTA . fetchmail MDA ( --mda ) SMTP 25 . fetchmailconf fetchmailrc . X Tk ( ) . fetchmail (Novice mode) . (Expert mode) fetchmail (multidrop) . <> . (PREFACE ON THIS MANUAL) Fetchmail () . fetchmail (locale) : env LC_ALL=C fetchmail # env LANG=en fetchmail # . . (GENERAL OPERATION) fetchmail ~/.fetchmailrc ( fetchmailconf ). ~/.fetchmailrc . . 'poll' ~/.fetchmailrc idle ( ). fetchmail (pipelines) -- (EXIT CODES) . fetchmail . .fetchmailrc . .fetchmailrc . << >> (AUTHENTICATION) << >> (DAEMON MODE) . (General Options) -? | --help . -V | --version fetchmail . . fetchmail . C . . -c | --check ( ). ( ). ETRN ODMR . . IMAP POP2 POP3 . -s | --silent (). / ( ). --verbose . -v | --verbose . fetchmail (stdout) . --silent . (-v -v) . --nosoftbounce ( 6.3.10 : set no softbounce 6.3.10) (Hard bounce). "no softbounce" . --softbounce ( 6.3.10 : set softbounce 6.3.10) (Soft bounce). . fetchmail fetchmail hard bounce . (Disposal Options) -a | --all | ( 6.3.3) --fetchall ( : fetchall 3.0) () . . POP3 RETR TOP . POP2 --all ( ) ETRN ODMR . -a --all fetchall rc --fetchall 6.3.3 . -k | --keep ( : keep) . . keep . ETRN ODMR . POP3 --uidl uidl . -K | --nokeep ( : nokeep) . . .fetchmailrc keep . ETRN ODMR . --moveto ( : moveto) IMAP (flush) IMAP . [Gmail]/Trash . IMAP . --proto imap IMAP . --keep . -F | --flush ( : flush) POP3/IMAP. . () . : fetchmail fetchmail . ( IMAP2) . . POP3 'uidl' . : '-k' fetchmail . --limitflush POP3/IMAP 6.3.0. . --limit . ETRN ODMR . (Protocol and Query Options) -p | --proto | --protocol ( : proto[col]) . AUTO . proto : AUTO IMAP POP3 POP2 ( ). POP2 Post Office Protocol 2 ( ) POP3 Post Office Protocol 3 APOP POP3 MD5. (man-in-the-middle) . RPOP POP3 RPOP. KPOP POP3 Kerberos V4 1109. SDPS POP3 SDPS Demon Internet. IMAP IMAP2bis IMAP4 IMAP4rev1 ( fetchmail ). ETRN ESMTP ETRN. ODMR ESMTP On-Demand Mail Relay. ( ) ETRN ODMR. ETRN ESMTP ( BSD sendmail 8.8.0 ) SMTP . ODMR ODMR ETRN DNS . -U | --uidl ( : uidl) UIDL ( POP3 ). << >> (UIDL "unique ID listing" RFC1939 ). 'keep' . syslog . fetchmail . fetchmail . : --idfile. --idle ( 6.3.3) ( : idle 6.0.0) IDLE ( IMAP ). idle ! idle rc --idle 6.3.3 . IDLE fetchmail IMAP . Fetchmail IDLE 6.4.22 6.5.3 ( 616e8c70 f91923b5 ) Gitlab #69. --forceidle ( 6.5.0) ( : forceidle 6.5.0) IDLE . . --idletimeout ( 6.5.0) ( : idletimeout 6.5.0) ( ) IDLE ( ) . : 1680 (= ). -P | --service ( : service) 6.3.0. service . . R12 FAQ --ssl . --port . TLS STARTTLS TLS ( TLS ) --ssl ssl rc . --port ( : port) --service . : . --principal ( : principal) principal (principal) . POP3 IMAP Kerberos 4 . Kerberos 5 GSSAPI . fetchmail . -t | --timeout ( : timeout) timeout . fetchmail . fetchmail TCP . fetchmail . fetchmail -V . fetchmail . . 6.3.10 fetchmail SMTP SMTP/LMTP RFC-5321 . . fetchmail ( ) ( ) MTA "OK" fetchmail . --plugin ( : plugin) plugin TCP . ssh . $PATH "%h" "%p" ( ). Fetchmail (stdin) (stdout) . --plugout ( : plugout) plugin SMTP . -r | --folder ( : folder[s]) ( ) . . POP3 ETRN ODMR . --tracepolls ( : tracepolls) fetchmail 'polling account %s' 'folder %s' Received %s ( ) ( Received ). . 6.3.4 . --ssl ( : ssl) SSL SSL ( SSL-wrapped Implicit TLS RFC-8314 ). --sslproto ! README.SSL fetchmail . fetchmail STLS STARTTLS SSL POP3 IMAP . --sslproto . SSL . . IMAP 143 SSL 993 POP3 110 995 . /etc/services --service ( ISP ). --nossl ( : nossl) --nossl ssl defaults rc . --sslproto STARTTLS . --sslcert ( : sslcert) . SSL . . SSL . ( ). ( ) . --sslkey . : CommonName --user . --sslkey ( : sslkey) SSL . SSL . . SSL . ( ). ( ) . . . --sslcert . --sslproto ( : sslproto : 6.4.0) fetchmail . SSL/TLS --ssl STARTTLS ( SSL TLS) . TLS -- --sslcertck SSL . --sslproto . 'tls1.2+' 'auto' (+) . TLS ( OpenSSL AWS-LC wolfSSL) SSL TLS TLS . ! 'auto' ( TLS1.2+). 6.4.0 6.5.0. TLS. TLSv1.2 . ( fetchmail 6.5.0 6.4.x TLSv1.0 6.3.x SSLv3 ). '' STARTTLS. --ssl 'auto' . 'SSL23' 'auto' . . 'TLS' 'auto' . OpenSSL. 'TLS1' TLSv1. TLSv1.1 . TLS1+ . 'TLS1+' 6.4.0. TLSv1.0 . 'TLS1.1' 6.4.0. TLS v1.1. 'TLS1.1+' 6.4.0. TLS. TLSv1.1 . 'TLS1.2' 6.4.0. TLS v1.2. 'TLS1.2+' 6.4.0. TLS. TLSv1.2 . fetchmail 6.5.x . 'TLS1.3' 6.4.0. TLS v1.3. 'TLS1.3+' 6.4.0. TLS. TLSv1.3 . 'auto' . : '' ( ) 'auto' ( TLS) . --sslcertck ( : sslcertck 6.4.0) --sslcertck fetchmail SSL/TLS SSL TLS ( ) . ( sslcertfile sslcertpath ). ( ) sslfingerprint fetchmail . --nosslcertck ( : no sslcertck 6.4.X) --sslcertck . fetchmail . --sslfingerprint . --sslcertfile ( : sslcertfile 6.3.17) fetchmail . . --sslcertpath --sslcertfile --sslcertpath . --sslcertpath . . CA PEM . CA SSL FETCHMAIL_INCLUDE_DEFAULT_X509_CA_CERTS . --sslcertpath ( : sslcertpath) fetchmail . OpenSSL . OpenSSL - c_rehash ( OpenSSL tools/ ) . OpenSSL c_rehash . --sslcertfile . CA SSL FETCHMAIL_INCLUDE_DEFAULT_X509_CA_CERTS . --sslcommonname ( : sslcommonname 6.3.9) . SSL . (CommonName) fetchmail . fetchmail . CommonName "Server CommonName mismatch" . --sslfingerprint [{}] ( : sslfingerprint) (fingerprint) . fetchmail SSL . fetchmail sslcertck . fetchmail SSL . (MITM) fetchmail . EVP_MD : {MD5}00:01:...:0F. SSL . SHA256 . {algo} MD5 fetchmail 6.4 . --nosslcertck . --verbose --sslfingerprint '{algo}*' : --sslfingerprint '{SHA256}*' cert.pem : openssl x509 -in cert.pem -noout -sha256 -fingerprint x509(1ssl) . (Delivery Control Options) -S | --smtphost ( : smtp[host]) ( 6.6.0 fetchmail TLS STARTTLS SMTP ) ( 6.5.6 fetchmail IP RFC-5321 IPv4 IPv6 ) (hunt list) ( ). . 'localhost' . . "smtp" . ( / ) LMTP ( Cyrus IMAP ). : --smtphost server1,server2/2525,server3,/var/imap/socket/lmtp ODMR fetchmail (relay) ODMR SMTP LMTP . SMTP (/) : /25 or /587 or /smtp or /465 or /smtps smtp ( /etc/services ) fetchmail . : /notls STARTTLS (opportunistic) . localhost . /starttls STARTTLS Extended Hello (EHLO) --sslcertck . . /tls TLS --sslcertck . . /notls /tls /starttls: TLS ( localhost ). STARTTLS --nosslcertck . /tlsproto=PROTO --sslproto PROTO ( ). /notls . /servername=NAME X.509 NAME SMTP Server Name Indication (SNI) . /notls . : ()getaddrinfo : 'Servname not supported for ai_socktype'. : . : --smtphost dnsname.example.org/25/starttls/tlsproto=tls1.3/servername=commonname.example.com dnsname.example.org STARTTLS TLS v1.3 X.509 commonname.example.com . 6.5.5 : IP --smtpaddress --smtpname ( ) SMTP ! --esmtpname ( 6.5.7 : esmtpname 5.9.9) (authorization ID) SMTP AUTH SMTP . fetchmail FETCHMAILUSER LOGNAME USER . ( --help ) : "poll" smtphost ! : fetchmail loopback TLS - SMTP TLS STARTTLS . --esmtppassword ( 6.5.7 : esmtppassword 5.9.9) / SMTP AUTH SMTP . ( --help ) : rcfile fetchmail netrc. . (login) netrc. esmtpname ( ). : "poll" smtphost ! smtphost /servername= netrc. . : fetchmail loopback TLS - SMTP TLS STARTTLS . --fetchdomains ( : fetchdomains) ETRN ODMR . FQDN fetchmail . -D | --smtpaddress ( : smtpaddress) RCPT TO SMTP . SMTP ( --smtphost ) SMTP/LMTP 'localhost' /BSMTP . : fetchmail 6.5.5 SMTP SMTP --smtpaddress "[192.0.2.6]" --smtpaddress "[IPv6:2001:DB8::6]". --smtpname ( : smtpname) RCPT TO SMTP . . --smtpaddress . -Z | --antispam ( : antispam) SMTP . 1- . . antispam "MAIL FROM" SMTP/LMTP MTA ( Postfix qmail) RCPT TO . --antispam . --softbounce () . -m | --mda ( : mda) fetchmail (MDA LDA) SMTP LMTP . MDA maildrop MTA sendmail fetchmail . fetchmail (root) MDA : FETCHMAILUSER LOGNAME USER . ( !) . fetchmail . fetchmail . fetchmail ( ) FETCHMAILUSER MDA . MDA ( maildrop) setuid root setuid fetchmail . MDA . MDA "/usr/sbin/sendmail -i -f %F -- %T" (: sendmail -- ) "/usr/bin/deliver" "/usr/bin/maildrop -d %T". MDA %T (From) %F . %F %T (Single Quote) ! %T %F fetchmail (') MDA . MDA To/Cc/Bcc "sendmail -i -t" "qmail-inject" (mail loops) . ! multidrop MDA maildrop (envelope recipient) . procmail(1) ( ) << >> . procmail . maildrop(1) maildrop . qmail-inject . fetchmail qmail-inject . qmail-inject (broken threads) . --lmtp ( : lmtp) LMTP ( ) . smtphost ( ) ( RFC 2033) . --bsmtp ( : bsmtp) BSMTP . SMTP SMTP fetchmail . '-' BSMTP : fetchmail . . MAIL FROM RCPT TO fetchmail << >> (THE USE AND ABUSE OF MULTIDROP MAILBOXES) . --mda SMTP/LMTP . --bad-header {reject|accept} ( : bad-header 6.3.15) fetchmail ( ) . fetchmail fetchmail . fetchmail . (Resource Limit Control Options) -l | --limit ( : limit) (octet) << >> . ( "oversized" ). ( IMAP POP3 fetchall) . --limit . . --limitflush . ( --warnings ). ETRN ODMR . -w | --warnings ( : warnings) . fetchmail 'limit' ( 'postmaster') . (poll) . ( ). -b | --batchlimit ( : batchlimit) SMTP ( ). --batchlimit . sendmail(8) SMTP . MTA smail(8) . fetchmail . . ETRN ODMR . -B | --fetchlimit ( : fetchlimit) . . --fetchlimit . ETRN ODMR . --fetchsizelimit ( : fetchsizelimit) . . . . ETRN ODMR . POP3 . --fastuidl ( : fastuidl) UID . UID . ( ) UID . 'n' . 'n' 'n-1' 'n' 'n' . 'n' . 'n' . POP3 . -e | --expunge ( : expunge) . POP2 POP3 fetchmail QUIT -- fetchmail QUIT . POP3 . IMAP fetchmail EXPUNGE . . (re-indexing) expunge . fetchmail expunge -- "lock busy" . N fetchmail N expunge . expunge ( expunge ). ETRN ODMR . (Authentication Options) -u | --user | --username ( : user[name]) . . fetchmail . << >> (USER AUTHENTICATION) . -I | --interface ( : interface) (interface) ( ) IPv4 (IPv6 ). fetchmail TCP/IP SLIP PPP . . TCP/IP ( ISP ) ( ). --interface . IP . : interface/iii.iii.iii.iii[/mmm.mmm.mmm.mmm] ( sl0 ppp0 ). IP . IP . 255.255.255.255 ( ). FreeBSD . FreeBSD monitor . fetchmail . -M | --monitor ( : monitor) ( PPP) . TCP/IP . . fetchmail . FreeBSD . monitor interface FreeBSD fetchmail setgid kmem . fetchmail GID kmem . fetchmail . --auth ( : auth[enticate]) ( << >> (USER AUTHENTICATION) ). : any password kerberos_v5 kerberos ( kerberos_v4) gssapi cram-md5 otp ntlm msn ( POP3) external ( IMAP) implicit (ssh implicit ). any () fetchmail (EXTERNAL GSSAPI KERBEROS IV KERBEROS 5) (CRAM-MD5 NTLM X-OTP - MSN POP3 ) . : implicit IMAP PREAUTH ( --plugin ssh --sslproto '' rcfile sslproto '' STARTTLS fetchmail SSH ). external IMAP EXTERNAL . password cram-md5 ntlm msn otp fetchmail . ssh implicit ( --sslproto '' ) TLS external GSSAPI K4 gssapi kerberos_v4 . KPOP Kerberos . ETRN . GSSAPI RFC-2743 IANA : (GSSAPI) / / (SASL) . (Miscellaneous Options) -f | --fetchmailrc ~/.fetchmailrc . pathname "-" ( ) . --version 0700 (u=rwx,g=,o=) dev/null/ . -i | --idfile ( : idfile) fetchids. UID . : 6.3.0 fetchmail idfile fetchmail idfile . idfile . --pidfile ( : pidfile 6.3.4 fetchmail) PID (lock file) . : "ENVIRONMENT" . "lock file" . (Process ID) fetchmail . -n | --norewrite ( : no rewrite) fetchmail RFC-822 ( To From Cc Bcc Reply-To) (@ ). ( !). . ( MTA .) ETRN ODMR rewrite . -E | --envelope ( : envelope Multidrop) : envelope [] fetchmail (envelope address) . 'X-Envelope-To' . 'X-Original-To' 'Delivered-To'. . multidrop . 'envelope "Received"' Received sendmail . . fetchmail Received : "by host for address" host fetchmail . count ( ) . count : . : . -Q | --qvirtual ( : qvirtual Multidrop) envelope ( multidrop localdomain ). fetchmail ISP ( ) qmail . qmail Delivered-To: . qmail . . qmail ISP 'Virtualhosts' . 'username@userhost.userdom.dom.com' Delivered-To: : Delivered-To: mbox-userstr-username@userhost.example.com (ISP) 'mbox-userstr-' . 'envelope Delivered-To:' fetchmail 'mbox-userstr-' . . --configdump ~/.fetchmailrc . . ~/.fetchmailrc fetchmailconf . -y | --yydebug . (Removed Options) -T | --netsec 6.3.0 inet6_apps . (USER AUTHENTICATION AND ENCRYPTION) ETRN . fetchmail ftp(1) . (user-id) . fetchmail . -u -- . -u . 'jsmith' 'mailgrunt' fetchmail : fetchmail -u jsmith mailgrunt fetchmail . fetchmail . ~/.fetchmailrc . fetchmail . netrc (Using netrc files) fetchmail ~/.fetchmailrc ~/.netrc . fetchmail poll via . netrc. : machine hermes.example.org login joe password topsecret . . netrc ftp(1) fetchmail . ( ) . ( "quoted string") (\) . . : machine name . poll via fetchmail . login name fetchmail . Fetchmail login . password string fetchmail machine login poll/via . default machine . Fetchmail . machine . account string Fetchmail / . macdef macro_name Fetchmail ( ) . netrc. . . . (SSL) (TLS) (Secure Socket Layers (SSL) and Transport Layer Security (TLS)) SSL TLS . POP3 IMAP STARTTLS ( STLS) SSL/TLS . --ssl ( --ssl, --sslproto, --nosslcertck ) TLS . .fetchmailrc . POP3 IMAP SSL . SSL . --sslcertck sslcertck fetchmail - . TLS SSL fetchmail STARTTLS . TLS SSL --sslcertck STARTTLS . STARTTLS --sslproto auto --sslproto '' . STARTTLS TLS . --sslcertck sslcertck - . --sslcertck : SSL TLS . (common name) . . (CA) <<>> (self-signed) . --sslcertck sslcertck fetchmail (man-in-the-middle) fetchmail . sslcertck --sslcertck 6.4.0 fetchmail . SSL . SSL SSL . . . . SSL ( OpenSSL) . SSL: . ( dsniff ). SSH ( ) . POP3 (POP3 VARIANTS) POP3 ( RFC1081 RFC1225) .rhosts . RPOP RPOP PASS . RPOP fetchmail ( 'protocol RPOP' 'PASS' 'RPOP' ) fetchmail . (spoofing) RFC1460 . RFC1460 APOP . POP3 APOP ( popauth(8) ). ~/.fetchmailrc . fetchmail MD5 . APOP . RETR TOP (RETR or TOP) fetchmail TOP . TOP fetchmail . . RETR " " (seen) ( ) TOP . "fetchall" fetchmail RETR . "keep" "uidl" fetchmail RETR . fetchmail Maillennium POP3/PROXY ( Comcast) RETR TOP . fetchmail TOP . "keep" "TOP" "uidl" . fetchmail . fetchmail RETR TOP . (ALTERNATE AUTHENTICATION FORMS/METHODS) fetchmail Kerberos Kerberos ( --auth authenticate kerberos_v4 .fetchmailrc) Kerberos . : pollname via 'hesiod' fetchmail Hesiod . POP3 IMAP GSSAPI fetchmail GSSAPI RFC1731 RFC1734 . Kerberos 5 (TGT) . --user user .fetchmailrc (principal) . IMAP PREAUTH fetchmail . imapd ssh . 'implicit' .fetchmail . TLS1 IMAP AUTH=EXTERNAL fetchmail . 'external' fetchmail . POP3 RFC1938 fetchmail . . RPA Compuserve . fetchmail "@compuserve.com" RPA . IMAP NTLM ( Microsoft Exchange) . AUTH=NTLM fetchmail NTLM ( ) . 'user@domain' : @ NTLM . ESMTP (ESMTP AUTH) fetchmail ESMTP RFC 4952 . CRAM-MD5 PLAIN 6.5.X fetchmail LOGIN. / 'esmtpname' 'esmtppassword' . (DAEMON MODE) (Introducing the daemon mode) fetchmail . (Starting the daemon mode) fetchmail . --daemon -d fetchmail . ( ) . : fetchmail -d 900 ~/.fetchmailrc ( 'skip' ) (: + ) . 'set daemon ' ~/.fetchmailrc . fetchmail --daemon 0 -d0 . fetchmail . ( FETCHMAILHOME .) (Awakening the background daemon) fetchmail . . SIGUSR1 . 'wedged' . (Terminating the background daemon) -q --quit ( fetchmail ). --quit fetchmail . fetchmail . (Useful options for daemon mode) -L --logfile (: set logfile) fetchmail . (logfile) fetchmail touch(1) . ( ). (append) . . fetchmail (rotate) fetchmail . ( ) fetchmail . 6.5.0 "Jun 20 23:45:01 fetchmail: " . LC_TIME ( LC_ALL) TZ . --syslog (: set syslog) syslog(3) . fetchmail LOG_MAIL LOG_ERR LOG_ALERT LOG_INFO . () . .fetchmailrc stderr . --nosyslog syslog(3) ~/.fetchmailrc . --logfile ( ) . -N --nodetach . fetchmail init(8) runit(8) Gerrit Pape . logfile . POP2 IMAP2bis ( DNS sendmail) fetchall . ( ) . ( IMAP .) ~/.fetchmailrc fetchmail touch . ~/.fetchmailrc fetchmail ( exec(2) ). fetchmail ~/.fetchmailrc . (ADMINISTRATIVE OPTIONS) --postmaster (: set postmaster) multidrop . 'bouncemail' 'bouncemail' 'spambounce' . fetchmail . root 'postmaster' . postmaster - . 'FETCHMAILUSER' ENVIRONMENT . --nobounce "set no bouncemail" . --invisible (: set invisible) fetchmail . fetchmail MTA -- Received MTA fetchmail . invisible Received fetchmail MTA . --showdots (: set showdots) fetchmail fetchmail (verbose) . Fetchmail --verbose . --silent . --tracepolls fetchmail "polling {label} account {user}" Received {label} ( rcfile ~/.fetchmailrc) {user} . ( ). . .fetchmailrc 'tracepolls' . (RETRIEVAL FAILURE MODES) fetchmail . 25 ( ) SMTP fetchmail . MDA . MDA '' ( ) . maildrop(1) sendmail(1) ( sendmail Postfix) exim(1) . mda . MDA 0 . . fetchmail '' ( fetchmail --keep ) ( ) . --all ( ) . . POP2 . POP2 '' '' fetchmail . POP2 . POP3 ( VMS ). fetchmail . UIDL fastuidl 0 IMAP . POP3 POP3 fetchmail "No mail" . IMAP \Seen . fetchmail UIDVALIDITY UID . fetchmail IMAP Status BSD \Seen . IMAP RFC IMAP . . () fetchmail --keep . ETRN ODMR fetchmail SMTP SMTP . . (SPAM FILTERING) SMTP ' ' . MAIL FROM DATA SMTP () . sendmail 571 . RFC2821 550 "Requested action not taken: mailbox unavailable" ( "[E.g., mailbox not found, no access, or command rejected for policy reasons]." ). MTA exim 501 "Syntax error in parameters or arguments" . MTA postfix 554 . Zmailer 500 ( ). fetchmail 'antispam' . fetchmail ( 552 553 ). fetchmail IMAP . . . spambounce (bounce) RFC1892/RFC1894 . BUGS . SMTP/ESMTP (SMTP/ESMTP ERROR HANDLING) fetchmail SMTP/ESMTP -- --softbounce --: 452 ( ) . 552 ( ) . (bounce-mail) . 553 ( ) . . 500 --softbounce . BUGS . (THE RUN CONTROL FILE) fetchmail .fetchmailrc ( fetchmailconf ). . ~/.fetchmailrc 0700 (u=rwx,g=,o=) fetchmail ( --version ). .fetchmailrc fetchmail . (Run Control Syntax) '#' . . : ( ) . ( ). (line feed) ( ). ',' ';' ':' '=' . . (\n LF \t HT \b BS \r CR \nnn ( nnn 0 ) \0ooo \xhh ) . (LF NL) . . : C . fetchmail . C (\) 0 . : fetchmail \233 \xE9 ( e ) C \233 0233 = \x9B (CSI ) . 'poll' 'skip' ( ) . : . 'server' 'poll' . (noise keywords) 'and' 'with' 'has' 'wants' 'options' . . ':' ';' ',' . (Poll versus Skip) 'poll' fetchmail . 'skip' fetchmail . ( 'skip' .) (KEYWORD/OPTION SUMMARY) . . '-' . 's' 'm' (singledrop) (multidrop) . : ------------------------------------------------------------------------------------------------- set daemon -d . set postmaster (: fetchmail "postmaster" ) set bouncemail () set no bouncemail ( 'postmaster' ). set no spambounce ( ) (). set spambounce ( 'antispam') 'bouncemail'. : - . set no softbounce . . set softbounce (). set logfile -L . fetchmail . set syslog . set pidfile -p (PID). set idfile -i UID . set syslog syslog(3). set logfile . set no syslog syslog(3) (). set properties fetchmail ( ). : ----------------------------------------------------------------------------------------------- via DNS poll proto[col] -p ( ): POP2 POP3 IMAP APOP KPOP local[domains] m () port TCP/IP ( 'service' ). service -P ( TCP/IP ). auth[enticate] ( 'any') timeout -t ( ) envelope -E m (envelope-address) no envelope m qvirtual -Q m Qmail aka m DNS interface -I () IP poll monitor -M IP plugin . plugout . dns m DNS () no dns m DNS checkalias m IP no checkalias m () uidl -U POP3 UIDL () no uidl POP3 UIDL () interval N poll N . tracepolls poll Received principal (principal) ( IMAP kerberos ) esmtpname RFC2554 ESMTP. esmtppassword RFC2554 ESMTP. bad-header . reject () accept . idletimeout ( ) --idle . : ----------------------------------------------------------------------------------------------- user[name] -u . 'there' 'here' . is to pass[word] ssl SSL sslcert SSL sslcertck . fetchmail v6.4.0. no sslcertck . . sslfingerprint . sslcertfile CA sslcertpath c_rehash CA . sslcommonname (common name) . sslfingerprint MD5. Fetchmail . sslkey SSL sslproto ssl folder -r smtphost -S () smtp fetchdomains m smtpaddress -D RCPT TO smtpname RCPT TO antispam -Z SMTP mda -m MDA bsmtp BSMTP preconnect postconnect keep -k ( POP3 uidl ) flush -F () limitflush fetchall -a rewrite () stripcr carriage return forcecr carriage return pass8bits BODY=8BITMIME ESMTP dropstatus Status X-Mozilla-Status dropdelivered Delivered-To mimedecode quoted-printable MIME idle poll ( IMAP) forceidle poll ( IMAP ) no keep -K () no flush () no fetchall () no rewrite no stripcr carriage return () no forcecr carriage return () no pass8bits BODY=8BITMIME ESMTP () no dropstatus Status () no dropdelivered Delivered-To () no mimedecode quoted-printable MIME () no idle poll ( IMAP) limit -l warnings -w batchlimit -b fetchlimit -B fetchsizelimit fastuidl ( POP3) expunge -e (expunge) # ( IMAP POP3) properties fetchmail ( ) ( user username) . .fetchmailrc 'envelope' . ( ). ISP ( ) . (Keywords Not Corresponding To Option Switches) 'folder' 'smtphost' ( ) . : 'via' 'interval' 'aka' 'is' 'to' 'dns'/'no dns' 'checkalias'/'no checkalias' 'password' 'preconnect' 'postconnect' 'localdomains' 'stripcr'/'no stripcr' 'forcecr'/'no forcecr' 'pass8bits'/'no pass8bits' 'dropstatus/no dropstatus' 'dropdelivered/no dropdelivered' 'mimedecode/no mimedecode' 'no idle' 'no envelope'. 'via' . DNS . poll ( ). 'interval' ( ) poll . 'interval N' N poll . (Singledrop versus Multidrop options) THE USE AND ABUSE OF MULTIDROP MAILBOXES . 'is' 'to' () () ( = ) . is/to '*' . 6.3.4 fetchmail ( ) (fetchmail @ ). 6.3.5 fetchmail 'localdomains' 'aka' 'via' . . Received To Cc Bcc . fetchmail DNS . ( ) fetchmail ( ) Received To Cc Bcc ( << >> ). poll 'via' 'aka' 'localdomains' DNS . 'dns' 'checkalias' 'localdomains' 'aka' . fetchmail localdomain () . 'bouncemail' (postmaster) . ( 'postmaster' ). BUGS . 'dns' ( ) . 'aka' 'localdomains' DNS . . 'checkalias' ( ) 'dns' MTA (canonical name) poll . poll fetchmail To/Cc/Bcc ( << >> ). fetchmail IP poll MTA IP . rcfile . 'no dns' rcfile 'checkalias' . 'aka' . DNS . . fetchmail DNS . : 'aka' -- () 'aka netaxs.com' netaxs.com '.netaxs.com' pop3.netaxs.com mail.netaxs.com. 'localdomains' fetchmail . fetchmail MDA ( ). 'localdomains' 'no envelope' fetchmail Received X-Envelope-To 'envelope' . 'no envelope' 'envelope ' . 'envelope "Received"' Received . password . 'preconnect' fetchmail . POP ssh(1) . (poll) . 'postconnect' . 'forcecr' LF CRLF . RFC821 MTA ( MTA qmail ). 'stripcr' carriage return . MDA '' ( CR ) SMTP '' ( CR ) . 'stripcr' 'forcecr' 'stripcr' . 'pass8bits' "Content-Transfer-Encoding: 7bit" . () fetchmail BODY=7BIT ESMTP ISO KOI-8 . 'pass8bits' fetchmail BODY=8BITMIME ESMTP . ( ) . 'dropstatus' Status X-Mozilla- Status () . MUA ( ) . Status . (: Status POP .) 'dropdelivered' Delivered-To () . qmail Postfix "" . . 'mimedecode' MIME quoted-printable . ESMTP ( MTA sendmail ) quoted- printable . MIME . mimedecode RFC2047 . 'idle' IMAP IDLE RFC2177 . fetchmail IDLE poll IDLE . IMAP . IDLE fetchmail NOOP . IDLE TCP/IP LOGIN/LOGOUT . IDLE fetchmail poll IDLE . . 'properties' . fetchmail . . '--configdump' . (Miscellaneous Run Control Options) 'here' 'there' . 'user eric is esr' 'eric' 'esr' 'user eric there is esr here' 'user esr here is eric there' . 'protocol' : auto ( AUTO) ( ) pop2 ( POP2) ( ) pop3 ( POP3) sdps ( SDPS) imap ( IMAP) apop ( APOP) kpop ( KPOP) 'any' 'password' 'kerberos' 'kerberos_v4' 'kerberos_v5' 'gssapi' 'cram-md5' 'otp' 'msn' ( POP3) 'ntlm' 'implicit' 'external' ( IMAP). 'password' ( CRAM-MD5 ) 'kerberos' fetchmail Kerberos 'gssapi' fetchmail GSSAPI . 'auth' . 'kpop' POP3 1109 Kerberos V4 . . : 'set logfile' --logfile . --logfile . --logfile fetchmail fetchmail --syslog . 'set daemon' poll --daemon . --daemon --daemon 0 . 'set postmaster' . 'set syslog' syslogd(8) . FETCHMAIL (DEBUGGING FETCHMAIL) Fetchmail (Fetchmail crashing) fetchmail " " . "" . " " (segmentation fault) " " "SIGSEGV" "segfault" . . segfault segfault . segfault . Sig11 . segfault " " (stack backtrace) . fetchmail (Enabling fetchmail core dumps) fetchmail (core dumps) . fetchmail " " "backtrace" . . backtrace fetchmail (strip) . stripped . fetchmail . : file `which fetchmail` fetchmail . (unstripped) stripped . fetchmail . . fetchmail . " " "limit" "ulimit" . . bash "ulimit -Sc unlimited" . . fetchmail . fetchmail -d0 -v . --nosyslog -N . . fetchmail ./fetchmail ./fetchmail -Nvd0 --nosyslog . . GNU GDB ( ) gdb ./fetchmail fetchmail.core GDB backtrace full ( backtrace ) quit gdb . : "core" . RFC 822 (INTERACTION WITH RFC 822) fetchmail : Return-Path: Resent-Sender: ( @ ! ) Sender: ( @ ! ) Resent-From: From: Reply-To: Apparently-From: MAIL FROM SMTP . . (bounce) ( ). : fetchmail 'envelope' . Received . fetchmail :Resent-To :Resent-Cc :Resent-Bcc . To:/Cc:/Bcc: . Resent-* :To :Cc :Bcc :Apparently-To . ( :Resent-To :To .) (CONFIGURATION EXAMPLES) . / $HOME/.netrc fetchmail ftp(1) . : poll SERVERNAME protocol PROTOCOL username NAME password PASSWORD : poll pop.provider.net protocol pop3 username "jsmith" password "secret1" : poll pop.provider.net proto pop3 user "jsmith" password "secret1" : poll pop.provider.net proto pop3 user "jsmith" pass "secret1" poll other.provider.net proto pop2 user "John.Smith" pass "My^Hat" (noise words) : poll pop.provider.net proto pop3 user "jsmith", with password secret1, is "jsmith" here; poll other.provider.net proto pop2: user "John.Smith", with password "My^Hat", is "John.Smith" here; . : poll mail.provider.net with proto pop3: user "jsmith" there has password "4u but u cannot krak this" is jws here and wants mda "/bin/mail" 'poll' 'defaults' . . : defaults proto pop3 user "jsmith" poll pop.provider.net pass "secret1" poll mail.provider.net user "jjsmith" there has password "secret2" . 'user' . : poll pop.provider.net proto pop3 port 3111 user "jsmith" with pass "secret1" is "smith" here user jones with pass "secret2" is "jjones" here keep 'smith' 'jsmith' pop.provider.net 'jjones' 'jones' pop.provider.net . 'jones' . (multidrop) : poll pop.provider.net: user maildrop with pass secret1 to golux 'hurkle'='happy' snark here 'maildrop' 'golux' 'hurkle' 'snark' . 'golux' 'snark' 'hurkle' 'happy' . fetchmail .. user@domain . Fetchmail .. user@domain . : poll pop.provider.net localdomains loonytoons.org toons.org envelope X-Envelope-To user maildrop with pass secret1 to * here 'maildrop' . fetchmail loonytoons.org toons.org ( 'joe@daffy.loonytoons.org') SMTP . (mail loops) ! ssh plugin . stdin stdout imapd ssh . IMAP . poll mailhost.net with proto imap: plugin "ssh %h /usr/sbin/imapd" auth implicit; user esr is esr here (THE USE AND ABUSE OF MULTIDROP MAILBOXES) . (multidrop) ETRN ODMR . . (envelope) . . ( fetchmail .. 6.4.X MD5 fetchmail 6.4.16+ . 5.0.8 (--) .. Message-ID . .. .) -- X-Original-To Delivered-To . : (Bcc) . << >> . (Header versus Envelope addresses) ( << >> envelope address RFC822 To/Cc -- Bcc ). << >> . fetchmail . MTA sendmail MTA 'by/for' Received . MTA . fetchmail -E "Received" . SMTP / . ( ) 'X-Envelope-To' . fetchmail -E . ( ) . Postfix . X-Original-To: . Qmail Postfix 'Delivered-To' . Qmail . -Q . . (ISP) . fetchmail To/Cc ( Bcc - ) -- . To: . fetchmail To/Cc ! fetchmail fetchmail . . (Bcc) Bcc ( fetchmail X-Envelope-To ). fetchmail X-Envelope-To . Bcc : (1) (2) (X-Original-To Delivered-To X-Envelope-To) . (Good Ways To Use Multidrop Mailboxes) fetchmail . 'esr' () "fetchmail-friends" (alias) . 'fetchmail-friends' 'esr' .fetchmailrc 'to esr fetchmail-friends here' . 'fetchmail-friends' SMTP . . 'esr' fetchmail-friends . "me-too" ( -oXm sendmail OXm) . . . 'X-Fetchmail-Warning' fetchmail . ( ) fetchmail . (Bad Ways To Abuse Multidrop Mailboxes) fetchmail (daemon) . . fetchmail fetchmail ( root) . (Bcc) . fetchmail POP IMAP ( ). ETRN ODMR fetchmail SMTP ( ). UUCP . fetchmail . . (Speeding Up Multidrop Checking) fetchmail (host part) DNS . "to ... here" . . 'aka' DNS . aka DNS ( MX - ) 'no dns' DNS aka . (Duplicate suppression on multidrop) fetchmail sieve maildrop Courier ( reformail -D) (MDA) ( fetchmail fetchmail ). (SOCKS) socks4/5 . fetchmail socks fetchmail - SOCKS : SOCKS SOCKS_CONF. SOCKS fetchmail SOCKS_CONF=/dev/null ( - - ): env SOCKS_CONF=/dev/null fetchmail (EXIT CODES) fetchmail . fetchmail : 0 ( -c ). 1 . ( .) << >> ( cron) POSIX : || [ $? -eq 1 ] fetchmail . . #C8 FAQ . 2 . -- << >> . fetchmail /etc/services . 3 . APOP . fetchmail . 4 . 5 fetchmail (pre- post-connect) . 6 . 7 . fetchmail (timeout) . 8 . fetchmail . 9 "lock busy" . ! . "3" ( ). qpopper "lock busy" "lock" . 10 fetchmail SMTP . 11 DNS. Fetchmail DNS . 12 BSMTP . 13 ( --fetchlimit ). 14 (Server busy). 23 . . 24 - 26, 28, 29 . fetchmail 0 . . (FILES) ~/.fetchmailrc, $HOME/.fetchmailrc, $HOME_ETC/.fetchmailrc, $FETCHMAILHOME/fetchmailrc ( ) ~/.fetchids, $HOME/.fetchids, $HOME_ETC/.fetchids, $FETCHMAILHOME/.fetchids (UID) . ( ) ~/.fetchmail.pid, $HOME/.fetchmail.pid, $HOME_ETC/.fetchmail.pid, $FETCHMAILHOME/fetchmail.pid ( pidfile PID pidfile ) ( root). ( ) ~/.netrc, $HOME/.netrc, $HOME_ETC/.netrc FTP ( ) . ( ) /var/run/fetchmail.pid (pidfile) ( root ). /etc/fetchmail.pid (pidfile) ( root /var/run). (ENVIRONMENT) Fetchmail . fetchmail OpenSSL . fetchmail . FETCHMAILHOME fetchmail $FETCHMAILHOME/fetchmailrc ( ) $FETCHMAILHOME/.fetchids ( ) $FETCHMAILHOME/fetchmail.pid ( ) . .netrc FETCHMAILHOME ( $HOME_ETC) . FETCHMAILUSER ( ) . LOGNAME USER ( UID ) . getpwuid(3) ( ). FETCHMAIL_DISABLE_CBC_IV_COUNTERMEASURE ( ..): fetchmail SSL CBC IV ( SSL_OP_DONT_INSERT_EMPTY_FRAGMENTS). . NEWS fetchmail-SA-2012-01.txt . fetchmail ( .. ) .. . FETCHMAIL_POP3_FORCE_RETR ( ..): ( ) fetchmail POP3 TOP RETR . TOP . FETCHMAIL_INCLUDE_DEFAULT_X509_CA_CERTS ( ..): fetchmail X.509 (CA) SSL/TLS --sslcertfile --sslcertpath . . . FETCHMAIL_WOLFSSL_DEBUG ( ..): fetchmail wolfSSL wolfSSL --enable-debug wolfSSL . stderr . HOME ( ..): . HOME . HOME_ETC ( .. ): HOME_ETC fetchmail $HOME fetchmail .fetchmailrc .fetchids .fetchmail.pid .netrc $HOME_ETC $HOME ( HOME passwd). HOME_ETC FETCHMAILHOME FETCHMAILHOME HOME_ETC . SOCKS_CONF ( SOCKS ) socks . /dev/null SOCKS . SSL_CERT_DIR ( OpenSSL 3.0 ): OpenSSL ( ) SSL_CTX_set_default_verify_paths(3) openssl . OpenSSL . --sslcertpath . SSL_CERT_FILE ( OpenSSL 3.0 ): OpenSSL ( base64 PEM ) SSL_CTX_set_default_verify_paths(3) openssl . OpenSSL . --sslcertfile . TZ LC_XXX . (SIGNALS) fetchmail root SIGUSR1 . SIGHUP 6.3.X fetchmail . fetchmail root SIGUSR1 ( SIGHUP ). fetchmail fetchmail . (BUGS, LIMITATIONS, AND KNOWN PROBLEMS) NEWS fetchmail . Fetchmail "@" "demonstr@ti on". UID --keep 6.X.Y . Fetchmail . user@server . DNS checkalias . MX POP3 IMAP . MX . mda plugin . MDA fetchmail . (zombie) . MDA . --interface IPv6 IPv6 . RFC822 @ . . fetchmail . TCP/IP . / (packet sniffer) . FreeBSD --interface IP () (promiscuous mode) () . ssh(1) . %F %T mda . '_' . fetchmail set-uid MDA . fetchmail root mda %F %T . Fetchmail SMTP . ~/.fetchmailrc . syslog . fetchmail ioctl . -f - ( stdin) plugin . 'principal' Kerberos IV V. . . . BSMTP . fetchmail-devel . (FAQ) fetchmail ( HTML) fetchmail . (AUTHOR) Fetchmail Matthias Andree Rob Funk Sunil Shetye ( ) Rob MacGregor ( ) . Eric S. Raymond . . popclient Carl Harris . Matthias Andree R. Hannes Beinert Hector Garcia . (SEE ALSO) README, README.SSL, README.SSL-SERVER, The Fetchmail FAQ , mutt(1), elm(1), mail(1), sendmail(8), popd(8), imapd(8), netrc(5), fetchmail , ( ) ; maildrop (APPLICABLE STANDARDS) fetchmail . SMTP/ESMTP: RFC 821, RFC 2821, RFC 1869, RFC 1652, RFC 1870, RFC 1983, RFC 1985, RFC 2554. mail: RFC 822, RFC 2822, RFC 1123, RFC 1892, RFC 1894. POP2: RFC 937 POP3: RFC 1081, RFC 1225, RFC 1460, RFC 1725, RFC 1734, RFC 1939, RFC 1957, RFC 2195, RFC 2449. APOP: RFC 1939. RPOP: RFC 1081, RFC 1225. IMAP2/IMAP2BIS: RFC 1176, RFC 1732. IMAP4/IMAP4rev1: RFC 1730, RFC 1731, RFC 1732, RFC 2060, RFC 2061, RFC 2195, RFC 2177, RFC 2683. ETRN: RFC 1985. ODMR/ATRN: RFC 2645. OTP: RFC 1938. LMTP: RFC 2033. GSSAPI: RFC 1508, RFC 1734, Generic Security Service Application Program Interface (GSSAPI)/Kerberos/Simple Authentication and Security Layer (SASL) Service Names . TLS: RFC 2595. fetchmail 6.6.7 2025-10-10 FETCHMAIL(1)