FETCHMAIL(1) fetchmail reference manual FETCHMAIL(1) (NAME) fetchmail - POP IMAP ETRN ODMR (SYNOPSIS) fetchmail [...] [_...] fetchmailconf (DESCRIPTION) fetchmail () () . mutt(1) elm(1) Mail(1) . fetchmail (Poll) . fetchmail : POP2 ( ) POP3 IMAP2bis IMAP4 IMAP4rev1. ESMTP ETRN ODMR . ( RFC .) fetchmail TCP/IP ( SLIP PPP) (MTA) SMTP sendmail . (DEPRECATION AND CRYPTOGRAPHIC SECURITY WARNINGS) MD4 MD5 SHA1 . . IETF RFC MD4 MD5 SHA1 fetchmail ODMR POP3 APOP . TLS ( IMAP4) ( POP3) STARTTLS . fetchmail NEWS fetchmail . (SUPPORT, TROUBLESHOOTING) (Verbosity) fetchmail . : env LC_ALL=C fetchmail -V -v --nodetach --nosyslog ( fetchmail .) env LC_ALL=C fetchmail -vvv --nodetach --nosyslog ( fetchmail .) : G3# fetchmail . ( ) LC_ALL=C . . . (QUICKSTART) . SMTP maildrop dovecot-lda . . ! . .fetchmailrc POP3 : poll mailserver.example.org proto POP3 uidl user joe.sixpack keep ssl : mailserver.example.org . joe.sixpack . keep . ssl . POP3 IMAP "proto POP3 uidl" "proto IMAP" . mda : mda "/usr/bin/maildrop -d %T" . ~/.fetchmailrc : chmod 0600 ~/.fetchmailrc . fetchmail . : fetchmail -v --fetchlimit 2 POP3 UIDL "keep" uidl keep fetchmail . TLS (SSL) (TLS (SSL) QUICKSTART) fetchmail README.SSL . --ssl --sslproto tls1.2+ fetchmail IETF (RFC-8314 RFC-8996 RFC-8997) . 6.6.0 fetchmail TLS STARTTLS SMTP --smtphost . (CONCEPTS) fetchmail POP IMAP ( ETRN ODMR) : (singledrop) (multidrop). (singledrop): fetchmail ( ) . fetchmail . fetchmail fetchmailrc . (multidrop): fetchmail . fetchmail << >> . fetchmail (MTA) . POP IMAP . (ISP) . fetchmail () . Bcc . fetchmail / (Wildcard) . ETRN ODMR: SMTP . . fetchmail SMTP (localhost) TCP/IP . fetchmail SMTP . MTA ( sendmail(8) exim(8) postfix(8) ). MDA ( ) MTA . ( .forward) MTA . fetchmail MDA ( --mda ) SMTP . fetchmailconf fetchmailrc . X Tk ( ) . fetchmail Novice () . Expert () fetchmail . 'Autoprobe' . (PREFACE ON THIS MANUAL) Fetchmail . (Locale) fetchmail : env LC_ALL=C fetchmail # env LANG=en fetchmail # . . (GENERAL OPERATION) fetchmail ~/.fetchmailrc ( fetchmailconf ). ~/.fetchmailrc (Override) . (Query) . 'poll' ~/.fetchmailrc idle ( ). fetchmail -- (EXIT CODES) . fetchmail . .fetchmailrc . .fetchmailrc . . (General Options) -? | --help . -V | --version fetchmail . . fetchmail . C . . -c | --check ( ). ( ). ETRN ODMR . (False positive) . IMAP POP2 POP3 . -s | --silent . / ( ). --verbose . -v | --verbose (Verbose). fetchmail . --silent . (-v -v) . --nosoftbounce ( 6.3.10 : set no softbounce 6.3.10) (Hard bounce). "no softbounce" . --softbounce ( 6.3.10 : set softbounce 6.3.10) (Soft bounce). . fetchmail fetchmail hard bounce . (Disposal Options) -a | --all | ( 6.3.3) --fetchall (: fetchall 3.0) () . . POP3 RETR TOP . POP2 --all ( ) ETRN ODMR . -a --all fetchall --fetchall 6.3.3 . -k | --keep (: keep) . . keep . ETRN ODMR . POP3 --uidl uidl . -K | --nokeep (: nokeep) . . .fetchmailrc keep . ETRN ODMR . --moveto (: moveto) IMAP (Flush) IMAP . [Gmail]/Trash . IMAP . --proto imap IMAP . --keep . -F | --flush (: flush) POP3/IMAP. . () . : fetchmail fetchmail . ( IMAP2) . . POP3 'uidl' . : '-k' fetchmail . --limitflush POP3/IMAP 6.3.0. . --limit . ETRN ODMR . (Protocol and Query Options) -p | --proto | --protocol (: proto[col]) . AUTO . proto : AUTO IMAP POP3 POP2 ( ). POP2 (POP2) ( ). POP3 (POP3). APOP POP3 MD5. (MitM) . RPOP POP3 RPOP. KPOP POP3 Kerberos V4 . SDPS POP3 SDPS Demon Internet. IMAP IMAP2bis IMAP4 IMAP4rev1 ( fetchmail ). ETRN ESMTP ETRN. ODMR On- Demand Mail Relay ESMTP. ( ) ETRN ODMR. ETRN ESMTP ( BSD sendmail 8.8.0 ) SMTP . ODMR ODMR ETRN DNS . -U | --uidl (: uidl) UIDL ( POP3 ). <<>> (UIDL "unique ID listing" RFC1939 ). 'keep' . syslog . fetchmail . . : --idfile. --idle ( 6.3.3) (: idle 6.0.0) IDLE ( IMAP ). idle (Poll) ! idle --idle 6.3.3 . IDLE fetchmail IMAP . Fetchmail IDLE 6.4.22 6.5.3 ( 616e8c70 f91923b5 ) #69. --forceidle ( 6.5.0) (: forceidle 6.5.0) IDLE . . --idletimeout ( 6.5.0) (: idletimeout 6.5.0) ( ) IDLE ( ) . : (= ). -P | --service (: service) 6.3.0. service . - . R12 FAQ --ssl . --port . TLS STARTTLS TLS ( TLS ) --ssl ssl rc . --port (: port) --service . : . --principal (: principal) principal . POP3 IMAP Kerberos 4 Kerberos 5 GSSAPI . . -t | --timeout (: timeout) timeout . fetchmail . fetchmail TCP . fetchmail . fetchmail -V . fetchmail . . fetchmail 6.3.10 SMTP RFC-5321 SMTP/LMTP . . fetchmail ( ) ( ) MTA MTA "OK" fetchmail . --plugin (: plugin) plugin TCP . ssh . $PATH "%h" "%p" ( ). Fetchmail . --plugout (: plugout) plugin SMTP . -r | --folder (: folder[s]) ( ) . . POP3 ETRN ODMR . --tracepolls (: tracepolls) fetchmail 'polling account %s' 'folder %s' Received %s ( ) ( Received ). . 6.3.4 . --ssl (: ssl) SSL SSL ( SSL-wrapped RFC-8314 TLS ). --sslproto ! README.SSL fetchmail . fetchmail POP3 IMAP STLS STARTTLS SSL . --sslproto . SSL . . IMAP SSL POP3 . /etc/services --service . --nossl (: nossl) ssl defaults rc ( --nossl ). STARTTLS --sslproto . --sslcert (: sslcert) . SSL . . SSL . ( ). ( ) . --sslkey . : CommonName --user . --sslkey (: sslkey) SSL . SSL . . SSL . . . --sslcert . --sslproto (: sslproto : v6.4.0) fetchmail . SSL/TLS STARTTLS ( --ssl ) ( SSL TLS ). TLS -- --sslcertck SSL . --sslproto . 'tls1.2+' 'auto' (+) . TLS (OpenSSL AWS-LC wolfSSL) . ! 'auto' ( TLS1.2+). 6.4.0 6.5.0. TLS. TLSv1.2 . '', STARTTLS. --ssl 'auto' . 'SSL23' 'auto' . . 'TLS' 'auto' . OpenSSL. 'TLS1' TLSv1. TLSv1.1 . TLS1+ . 'TLS1+' 6.4.0. TLSv1.0 . 'TLS1.1' 6.4.0. TLS v1.1. 'TLS1.1+' 6.4.0. TLS. TLSv1.1 . 'TLS1.2' 6.4.0. TLS v1.2. 'TLS1.2+' 6.4.0. TLS. TLSv1.2 . fetchmail v6.5.x . 'TLS1.3' 6.4.0. TLS v1.3. 'TLS1.3+' 6.4.0. TLS. TLSv1.3 . 'auto' . : '' ( ) 'auto' ( TLS) . --sslcertck (: sslcertck v6.4.0) --sslcertck fetchmail SSL/TLS SSL TLS ( ) . ( sslcertfile sslcertpath ). fetchmail sslfingerprint . --nosslcertck (: no sslcertck v6.4.X) --sslcertck . fetchmail . --sslfingerprint . --sslcertfile (: sslcertfile v6.3.17) fetchmail . . --sslcertpath --sslcertfile --sslcertpath . CA PEM . SSL FETCHMAIL_INCLUDE_DEFAULT_X509_CA_CERTS . --sslcertpath (: sslcertpath) fetchmail . OpenSSL . OpenSSL - c_rehash . OpenSSL c_rehash . --sslcertfile . FETCHMAIL_INCLUDE_DEFAULT_X509_CA_CERTS . --sslcommonname (: sslcommonname v6.3.9) . SSL . (CommonName) fetchmail . fetchmail . CommonName "Server CommonName mismatch" . --sslfingerprint [{}] (: sslfingerprint) (Fingerprint) . fetchmail SSL . fetchmail sslcertck . . EVP_MD : {MD5}00:01:...:0F. SSL . SHA256. {algo} fetchmail 6.4 MD5 . --nosslcertck . cert.pem : openssl x509 -in cert.pem -noout -sha256 -fingerprint : x509(1ssl). (Delivery Control Options) -S | --smtphost (: smtp[host]) ( 6.6.0 fetchmail TLS STARTTLS SMTP ) ( 6.5.6 fetchmail IP RFC-5321 IPv4 IPv6 ) ( ). . 'localhost' . (/) "smtp" . ( /) LMTP ( Cyrus IMAP ). : --smtphost server1,server2/2525,server3,/var/imap/socket/lmtp ODMR fetchmail ODMR SMTP LMTP . SMTP (/) : /25 /587 /smtp /465 /smtps smtp ( /etc/services ) fetchmail . : /notls STARTTLS . localhost . /starttls Extended Hello (EHLO) STARTTLS --sslcertck . . /tls TLS --sslcertck . . /notls /tls /starttls: TLS ( localhost ). STARTTLS ( --nosslcertck). /tlsproto=PROTO --sslproto PROTO . /notls . /servername=NAME X.509 NAME Server Name Indication (SNI) . /notls . : getaddrinfo() . : . : --smtphost dnsname.example.org/25/starttls/tlsproto=tls1.3/servername=commonname.example.com dnsname.example.org STARTTLS TLS v1.3 X.509 commonname.example.com . --esmtpname ( 6.5.7 : esmtpname 5.9.9) SMTP AUTH SMTP . FETCHMAILUSER LOGNAME USER . --esmtppassword ( 6.5.7 : esmtppassword 5.9.9) SMTP AUTH SMTP . rc .netrc . --fetchdomains (: fetchdomains) ETRN ODMR . FQDN fetchmail . -D | --smtpaddress (: smtpaddress) RCPT TO SMTP . SMTP SMTP/LMTP 'localhost' . --smtpname (: smtpname) RCPT TO SMTP . . -Z | --antispam (: antispam) SMTP (Spam-block) . 1- . -m | --mda (: mda) fetchmail SMTP LMTP (MDA LDA) . MDA maildrop MTA sendmail fetchmail . fetchmail (Root) MDA : FETCHMAILUSER LOGNAME USER . . MDA : "/usr/sbin/sendmail -i -f %F -- %T" "/usr/bin/deliver" "/usr/bin/maildrop -d %T". %T (From) %F . %F %T (') ! fetchmail . MDA To/Cc/Bcc ( "sendmail -i -t" "qmail-inject") . --lmtp (: lmtp) LMTP . smtphost . --bsmtp (: bsmtp) BSMTP. SMTP SMTP . '-' . --bad-header {reject|accept} (: bad-header v6.3.15) fetchmail ( reject accept). (Resource Limit Control Options) -l | --limit (: limit) (Octet) << >> . . --limitflush . -w | --warnings (: warnings) . . -b | --batchlimit (: batchlimit) SMTP ( ). -B | --fetchlimit (: fetchlimit) (Poll). . --fetchsizelimit (: fetchsizelimit) . . . --fastuidl (: fastuidl) UID . UID . 'n' . POP3 . -e | --expunge (: expunge) . POP3 POP2 IMAP EXPUNGE N . (Authentication Options) -u | --user | --username (: user[name]) . fetchmail . -I | --interface (: interface) IPv4 . FreeBSD . : interface/iii.iii.iii.iii[/mmm.mmm.mmm.mmm] -M | --monitor (: monitor) TCP/IP. . --auth (: auth[enticate]) . : any password kerberos_v5 kerberos ( kerberos_v4) gssapi cram-md5 otp ntlm msn ( POP3) external ( IMAP) implicit ( ssh). any . GSSAPI RFC-2743 : Generic Security Service Application Program Interface (GSSAPI) Service Names . (Miscellaneous Options) -f | --fetchmailrc ~/.fetchmailrc. "-" . 0700 . -i | --idfile (: idfile) .fetchids UID . --pidfile (: pidfile v6.3.4) PID . -n | --norewrite (: no rewrite) RFC-822 (To, From, Cc, Bcc, Reply-To). -E | --envelope (: envelope ) ( 'X-Envelope-To' 'Delivered-To'). -Q | --qvirtual (: qvirtual ) ( qmail ). --configdump ~/.fetchmailrc . -y | --yydebug ( ). (Removed Options) -T | --netsec 6.3.0 inet6_apps . (USER AUTHENTICATION AND ENCRYPTION) ETRN . fetchmail ftp(1) . . fetchmail . -u -- . -u . : fetchmail -u jsmith mailgrunt fetchmail . fetchmail . ~/.fetchmailrc . netrc (Using netrc files) fetchmail ~/.fetchmailrc ~/.netrc . .netrc: machine hermes.example.org login joe password topsecret netrc ftp(1) fetchmail : machine name . login name . password string . default machine (fetchmail ). account string fetchmail . macdef macro_name fetchmail . (SSL) (TLS) (Secure Socket Layers (SSL) and Transport Layer Security (TLS)) SSL TLS . POP3 IMAP STARTTLS ( STLS) SSL/TLS . --ssl ( --ssl --sslproto --sslcertck). TLS SSL fetchmail STARTTLS . TLS SSL --sslcertck STARTTLS . STARTTLS --sslproto auto --sslproto '' . --sslcertck : . --sslcertck fetchmail . SSL: dsniff . CA SSH . POP3 (POP3 VARIANTS) POP3 ( RFC1081 RFC1225) .rhosts RPOP . RFC1460 . RFC1460 APOP . fetchmail MD5 . APOP . RETR TOP (RETR or TOP) fetchmail TOP . "fetchall" "keep" "uidl" RETR . (ALTERNATE AUTHENTICATION FORMS/METHODS) fetchmail Kerberos Kerberos Kerberos . POP3 IMAP GSSAPI fetchmail GSSAPI RFC1731 RFC1734 . IMAP PREAUTH fetchmail ( imapd ssh). TLS1 IMAP AUTH=EXTERNAL fetchmail . POP3 RFC1938 fetchmail . RPA Compuserve NTLM IMAP . ESMTP AUTH (ESMTP AUTH) fetchmail ESMTP RFC 4952 . CRAM-MD5 PLAIN LOGIN . 'esmtpname' 'esmtppassword' . (DAEMON MODE) (Introducing the daemon mode) fetchmail (Sleep) . (Starting the daemon mode) --daemon -d fetchmail ( ) . : fetchmail -d 900 . 'set daemon ' rc . fetchmail . (Awakening the background daemon) fetchmail SIGUSR1 . (Terminating the background daemon) -q --quit (Kill). (Useful options for daemon mode) -L --logfile (: set logfile) . . --syslog (: set syslog) syslog(3) . --nosyslog syslog . -N --nodetach ( init runit). ~/.fetchmailrc . (ADMINISTRATIVE OPTIONS) --postmaster (: set postmaster) . --nobounce "set no bouncemail" . --invisible (: set invisible) fetchmail Received . --showdots (: set showdots) . --tracepolls Received . (RETRIEVAL FAILURE MODES) fetchmail . SMTP . MDA . MDA ( maildrop sendmail postfix exim) . MDA . fetchmail . : POP2 ( / ) POP3 . IMAP \Seen . ETRN ODMR fetchmail SMTP . (SPAM FILTERING) SMTP . MAIL FROM DATA MTA : sendmail 571 RFC2821 550 exim 501 postfix 554 Zmailer 500 . fetchmail 'antispam' . spambounce . SMTP/ESMTP (SMTP/ESMTP ERROR HANDLING) fetchmail ( --softbounce ): 452 ( ) . 552 ( ) . 553 ( ) . --softbounce . (THE RUN CONTROL FILE) fetchmail .fetchmailrc ( fetchmailconf). . ~/.fetchmailrc 0700 . (Run Control Syntax) '#' . - . : ("..."). 'poll' 'skip' . 'server' 'poll' . 'and' 'with' 'has' 'wants' 'options' . ':' ';' ',' . Poll Skip (Poll versus Skip) 'poll' fetchmail . 'skip' fetchmail . (KEYWORD/OPTION SUMMARY) . . '-' . 's' 'm' . : Keyword Opt Mode Function ------------------------------------------------------------------------- set daemon -d . set postmaster (: fetchmail "postmaster" ). set bouncemail (). set no bouncemail ( postmaster). set no spambounce (). set spambounce . set no softbounce . set softbounce (). set logfile -L . . set pidfile -p PID ( ). set idfile -i UID . set syslog syslog(3). set no syslog syslog(3) (). set properties fetchmail ( ). : Keyword Opt Mode Function ------------------------------------------------------------------ via DNS poll. proto[col] -p ( ): POP2 POP3 IMAP APOP KPOP. local[domains] m () . port TCP/IP ( service ). service -P TCP/IP. auth[enticate] ( 'any'). timeout -t ( ). envelope -E m . no envelope m . qvirtual -Q m Qmail . aka m DNS . interface -I () IP . monitor -M IP . plugin . plugout . dns m DNS (). no dns m DNS . checkalias m IP . no checkalias m (). uidl -U POP3 UIDL (). no uidl POP3 UIDL (). interval N N . tracepolls Received. principal Kerberos ( IMAP ). esmtpname RFC2554 ESMTP. esmtppassword RFC2554 ESMTP. bad-header : reject () accept. idletimeout IDLE ( ) --idle . : Keyword Opt Mode Function --------------------------------------------------------------------- user[name] -u . . is . to . pass[word] . ssl SSL. sslcert SSL . sslcertck . no sslcertck . sslcertfile CA. sslcertpath c_rehash CA. sslcommonname (CommonName) . sslfingerprint MD5. sslkey SSL . sslproto SSL/TLS . folder -r . smtphost -S () SMTP . fetchdomains m . smtpaddress -D RCPT TO . smtpname RCPT TO . antispam -Z SMTP . mda -m MDA . bsmtp BSMTP . preconnect . postconnect . keep -k ( POP3 uidl ). flush -F (). limitflush . fetchall -a . rewrite (). stripcr Carriage Return . forcecr Carriage Return . pass8bits BODY=8BITMIME ESMTP. dropstatus Status X-Mozilla-Status . dropdelivered Delivered-To . mimedecode quoted-printable MIME. idle Idle ( IMAP). forceidle Idle ( IMAP ). no keep -K (). no flush (). no fetchall (). no rewrite . no stripcr (). no forcecr (). no pass8bits BODY=8BITMIME ESMTP (). no dropstatus Status (). no dropdelivered Delivered-To (). no mimedecode quoted-printable MIME (). no idle Idle ( IMAP). limit -l . warnings -w . batchlimit -b . fetchlimit -B . fetchsizelimit . fastuidl ( POP3). expunge -e (Expunge) ( IMAP POP3). properties fetchmail ( ). ( user username) . .fetchmailrc 'envelope' . (Keywords Not Corresponding To Option Switches) 'folder' 'smtphost' . : 'via' 'interval' 'aka' 'is' 'to' 'dns'/'no dns' 'checkalias'/'no checkalias' 'password' 'preconnect' 'postconnect' 'localdomains' 'stripcr'/'no stripcr' 'forcecr'/'no forcecr' 'pass8bits'/'no pass8bits' 'dropstatus/no dropstatus' 'dropdelivered/no dropdelivered' 'mimedecode/no mimedecode' 'no idle' 'no envelope'. 'via' . DNS . 'interval' ( N ). (Singledrop versus Multidrop options) . 'is' 'to' () ( =) . '*' . 6.3.5 . Received To Cc Bcc DNS . ( ) fetchmail ( ) Received To Cc Bcc . fetchmail (Bounce). 'dns' ( ) DNS . 'checkalias' DNS IP MTA . 'aka' DNS DNS . 'localdomains' fetchmail MDA . 'password' . 'preconnect' ( ssh). . 'postconnect' . 'forcecr' CRLF . 'stripcr' (CR) ( MDA SMTP ). 'pass8bits' BODY=8BITMIME ESMTP 7bit . 'dropstatus' Status X-Mozilla-Status . 'dropdelivered' Delivered-To ( ). 'mimedecode' quoted-printable MIME . 'idle' IDLE IMAP RFC2177 . 'properties' . (Miscellaneous Run Control Options) 'here' 'there' 'user eric there is esr here'. 'protocol' : auto ( AUTO) pop2 ( POP2) pop3 ( POP3) sdps ( SDPS) imap ( IMAP) apop ( APOP) kpop ( KPOP) : 'any' 'password' 'kerberos' 'kerberos_v4' 'kerberos_v5' 'gssapi' 'cram-md5' 'otp' 'msn' ( POP3) 'ntlm' 'implicit' 'external' ( IMAP). 'set logfile' 'set daemon' 'set postmaster' 'set syslog' . FETCHMAIL (DEBUGGING FETCHMAIL) Fetchmail (Fetchmail crashing) fetchmail "" ( ) . " " (Segmentation fault SIGSEGV segfault) . . . . Sig11 . ("stack backtrace") . (Core Dumps) Fetchmail (Enabling fetchmail core dumps) fetchmail (core dump) . backtrace core : . fetchmail (strip) . : file `which fetchmail` . core . bash "ulimit -Sc unlimited" . . fetchmail core -d0 -v --nosyslog -N . GDB backtrace full . RFC 822 (INTERACTION WITH RFC 822) fetchmail : Return-Path: Resent-Sender: Sender: Resent-From: From: Reply-To: Apparently-From: . 'envelope' . Resent-To: Resent-Cc: Resent-Bcc: To: Cc: Bcc: Apparently-To: . (CONFIGURATION EXAMPLES) $HOME/.netrc . : poll SERVERNAME protocol PROTOCOL username NAME password PASSWORD : poll pop.provider.net protocol pop3 username "jsmith" password "secret1" : poll pop.provider.net proto pop3 user "jsmith" password "secret1" : poll pop.provider.net proto pop3 user "jsmith" pass "secret1" poll other.provider.net proto pop2 user "John.Smith" pass "My^Hat" : defaults proto pop3 user "jsmith" poll pop.provider.net pass "secret1" poll mail.provider.net user "jjsmith" there has password "secret2" : poll pop.provider.net proto pop3 port 3111 user "jsmith" with pass "secret1" is "smith" here user jones with pass "secret2" is "jjones" here keep : poll pop.provider.net: user maildrop with pass secret1 to golux 'hurkle'='happy' snark here : poll pop.provider.net localdomains loonytoons.org toons.org envelope X-Envelope-To user maildrop with pass secret1 to * here ssh plugin: poll mailhost.net with proto imap: plugin "ssh %h /usr/sbin/imapd" auth implicit; user esr is esr here (THE USE AND ABUSE OF MULTIDROP MAILBOXES) . ETRN ODMR . . . (Header versus Envelope addresses) ( To/Cc RFC822) ( Bcc ). << >> . fetchmail Received ( sendmail). 'X-Original-To' 'Delivered-To' 'X-Envelope-To'. -E 'envelope' . Bcc : (1) (2) ( X-Original- To Delivered-To X-Envelope-To) . (Good Ways To Use Multidrop Mailboxes) . (Bad Ways To Abuse Multidrop Mailboxes) fetchmail . ( root) Bcc . . (Speeding Up Multidrop Checking) 'aka' 'no dns' DNS . (Duplicate suppression on multidrop) fetchmail sieve reformail maildrop -D . (SOCKS) socks4/5 . SOCKS SOCKS_CONF=/dev/null : env SOCKS_CONF=/dev/null fetchmail (EXIT CODES) fetchmail : 0 ( -c ). 1 . 2 ( ). 3 ( ). 4 . 5 fetchmail / . 6 . 7 . 8 ( fetchmail ). 9 "lock busy" . 10 SMTP . 11 DNS . 12 BSMTP . 13 ( --fetchlimit) . 14 (Server busy). 23 . 24 - 26, 28, 29 . (FILES) ~/.fetchmailrc, $HOME/.fetchmailrc, $HOME_ETC/.fetchmailrc, $FETCHMAILHOME/fetchmailrc ( ). ~/.fetchids, $HOME/.fetchids, $HOME_ETC/.fetchids, $FETCHMAILHOME/.fetchids UID . ~/.fetchmail.pid, $HOME/.fetchmail.pid, $HOME_ETC/.fetchmail.pid, $FETCHMAILHOME/fetchmail.pid (PID file) . ~/.netrc, $HOME/.netrc, $HOME_ETC/.netrc FTP . /var/run/fetchmail.pid . /etc/fetchmail.pid /var/run. (ENVIRONMENT) fetchmail : FETCHMAILHOME fetchmailrc .fetchids fetchmail.pid . FETCHMAILUSER . FETCHMAIL_DISABLE_CBC_IV_COUNTERMEASURE SSL CBC IV . FETCHMAIL_POP3_FORCE_RETR RETR TOP POP3. FETCHMAIL_INCLUDE_DEFAULT_X509_CA_CERTS CA SSL/TLS. FETCHMAIL_WOLFSSL_DEBUG wolfSSL. HOME . HOME_ETC HOME . SOCKS_CONF SOCKS. SSL_CERT_DIR OpenSSL. SSL_CERT_FILE OpenSSL. (SIGNALS) fetchmail SIGUSR1 . SIGUSR1 . (BUGS, LIMITATIONS, AND KNOWN PROBLEMS) NEWS fetchmail . fetchmail "@" . user@server . mda plugin . --interface IPv6 . RFC822 . ssh(1) SSL/TLS . %F %T MDA . fetchmail localhost . . : fetchmail-devel list FAQ HTML : fetchmail FAQ . (AUTHORS) Fetchmail Matthias Andree Rob Funk Sunil Shetye ( ) Rob MacGregor ( ) . : Eric S. Raymond . . popclient : Carl Harris . Matthias Andree R. Hannes Beinert Hector Garcia . (SEE ALSO) README, README.SSL, README.SSL-SERVER, The Fetchmail FAQ , mutt(1), elm(1), mail(1), sendmail(8), popd(8), imapd(8), netrc(5), fetchmail , ( ) ; maildrop (APPLICABLE STANDARDS) fetchmail : SMTP/ESMTP: RFC 821, RFC 2821, RFC 1869, RFC 1652, RFC 1870, RFC 1983, RFC 1985, RFC 2554. mail: RFC 822, RFC 2822, RFC 1123, RFC 1892, RFC 1894. POP2: RFC 937 POP3: RFC 1081, RFC 1225, RFC 1460, RFC 1725, RFC 1734, RFC 1939, RFC 1957, RFC 2195, RFC 2449. APOP: RFC 1939. RPOP: RFC 1081, RFC 1225. IMAP2/IMAP2BIS: RFC 1176, RFC 1732. IMAP4/IMAP4rev1: RFC 1730, RFC 1731, RFC 1732, RFC 2060, RFC 2061, RFC 2195, RFC 2177, RFC 2683. ETRN: RFC 1985. ODMR/ATRN: RFC 2645. OTP: RFC 1938. LMTP: RFC 2033. GSSAPI: RFC 1508, RFC 1734, Generic Security Service Application Program Interface (GSSAPI) Service Names . TLS: RFC 2595. fetchmail 6.6.7 2025-10-10 FETCHMAIL(1)