dictionary(5) File Formats Manual dictionary(5) (NAME) dictionary - RADIUS FreeRADIUS (DESCRIPTION) RADIUS /etc/raddb/dictionary . dictionary /usr/share/freeradius . RADIUS . RADIUS . . RADIUS RADIUS . FreeRADIUS . /usr/share . RADIUS . /etc/raddb/dictionary . . (FORMAT) ('#') . : ATTRIBUTE name oid type [flags] RADIUS. name . <>. (VSA) <>. . oid . () <<256>> . << >> <<1.2>>. . type : string UTF-8 ( RFC <> ) octets ( RFC <> ) ipaddr IPv4 date ( ) integer ipv6addr IPv6 ipv6prefix IPv6 ifid (hex:hex:hex:hex) integer64 type : ether MAC abinary Ascend byte short signed ( ) tlv -- ( ) ipv4prefix IPv4 RFC 6572 () . . . : array . concat . encrypt=# . has_tag RFC 2868 . secret . virtual . <> DHCP DHCP . <> . . <> . <<1>> RFC2865 User-Password . <<2>> RFC2868 Tunnel-Password . <<3>> Ascend Ascend-Send-Secret . <> () RFC2868 . . RFC2868 . <> . . <> . () . RADIUS . . VALUE attribute-name value-name number integer. attribute-name ATTRIBUTE . value-name RFC2865 . number . RADIUS . VENDOR vendor-name number [format=...] (VSA) vendor-name number. : http://www.iana.org/enterprise-numbers.txt <> () / <> <> . <> . VSA USR <> VSA Lucent <> VSA Starent <> . type ( ) . length ( ) . . BEGIN-VENDOR vendor-name (Vendor-Specific). ATTRIBUTE <> . ATTRIBUTE . VSA <> RFC 6929 <> . <> <> . <> <> . END-VENDOR vendor-name BEGIN- VENDOR . <> . $INCLUDE filename filename. filename . BEGIN-TLV name . <> . END-TLV name . <> . (FILES) /etc/raddb/dictionary, /usr/share/freeradius/dictionary.* (SEE ALSO) radiusd(8), RFC2865, RFC2866, RFC2868, RFC6929 05 Jan 2025 dictionary(5)