DICTD(8) DICTD(8) (NAME) dictd - (SYNOPSIS) dictd [] (DESCRIPTION) dictd (DICT) / TCP . dictd (root) . dictd dictd nobody nobody nogroup ( ) . inetd(8) . ( .) . dictd (index) - (7-bit ASCII) . . "00-database-allchars" dictd "00-database-utf8" utf8 "00-database-8bit-new" (locale) - . (BACKGROUND) <> . webster ( ) (thesaurus) . webster . . . . Jargon WordNet MICRA ( ) Free Online Dictionary of Computing . ( DICT RFC .) ( FOLDOC ). webster webster . DICT . ( ) ( ) ( ). DICT (hooks) . dictd(8) DICT . (Bret Martin) ( ) . (OPTIONS) -V --version . --license . -h --help . -v --verbose -dverbose ( ). -c file --config file . /etc/dict/dictd.conf defs.h (DICTD_CONFIG_FILE). -p port --port port port (Global Settings Specification) (override) . -i --inetd / inetd. inetd . --fast-start . --pp prog m4 cpp. examples/dictd_complex.conf . . --depth length depth (Global Settings Specification) . --delay seconds delay (Global Settings Specification) . --facility facility syslog_facility (Global Settings Specification) . -f --force . ( -p .) --limit children limit (Global Settings Specification) . --listen-to host listen_to (Global Settings Specification) . --address-family family address_family (Global Settings Specification) . --locale locale locale (Global Settings Specification) . -s syslog (Global Settings Specification) . -L file --logfile file log_file (Global Settings Specification) . --pid-file file pid_file (Global Settings Specification) . -m minutes --mark minutes timestamp (Global Settings Specification) . --default-strategy strategy default_strategy (Global Settings Specification) . --without-strategy strat1,strat2,... without_strategy (Global Settings Specification) . --add-strategy strategy_name:description add_strategy (Global Settings Specification) . --fast-start fast_start (Global Settings Specification) . --without-mmap without_mmap (Global Settings Specification) . --stdin2stdout --inetd (stdin) (stdout) . . -l option --log option log_option (Global Settings Specification) . -d option debug_option (Global Settings Specification) . (CONFIGURATION FILE) /etc/dict/dictd.conf -c ( ) . dictd (SIGHUP) dictd . . (Access Section) (Database Section) (User Section) . . (Syntax) : access allow deny group database data index filter prefilter postfilter name include user authonly site. . . _ - . * . . \" \\ \n \ . # . (Global Settings Section) global { } dictd (log file) syslog (locale) . : examples/dictd4.conf . (Access Section) access { } . . : examples/dictd3.conf . (Database Section) database string { } (string) ( wn web1913). ( . dict -d .) : examples/dictd*.conf . : dictd . database_virtual string { } . string ( en-ru fren). : examples/dictd_virtual.conf examples/dictd_complex.conf . database_plugin string { } . string . : examples/dictd_plugin_dbi.conf examples/dictd_complex.conf . database_mime string { mime } dictd dictd 1.10.0 OPTION MIME ( RFC-2229 ). OPTION MIME DICT MIME ( ) . string . : DEFINE . MATCH, SHOW DB, SHOW STRAT, SHOW INFO, SHOW SERVER HELP . : examples/dictd_mime.conf . database_exit '*' . '*' . 'examples/dictd_virtual.conf' . : . (User Section) user string string (shared secret) . AUTH (hashed) . ( ) . . . ( ). (Access Specification) (Access Section) (Database Section) . . allow deny authonly (*) . () . 10.0.0.* *.edu . IP IP (netmask) . 10.0.0.0:10.0.0.255 10.0.0.0/24 10.0.0.* IP . . . --debug auth . . . : allow string IP ( Access) ( Database) . "allow" "allow" . deny string IP ( Access) ( Database) . DNS IP . IP . authonly string Access . IP . DEFINE MATCH SHOW DB . AUTH . user string Database . AUTH . (Global Settings Specification) : port string_or_number ( 2628). RFC DICT 2628 defs.h (DICT_DEFAULT_SERVICE). site string (site information file) SHOW SERVER . : examples/dictd4.conf . site_no_banner boolean SHOW SERVER dictd . . site_no_uptime boolean SHOW SERVER (uptime) dictd (forks) . . site_no_dblist boolean SHOW SERVER (headwords) . . delay number ( ) (idle) . . 0 ( ) defs.h (DICT_DEFAULT_DELAY). : delay limit_time . ( dictd.conf ) . : RFC DICT . depth number listen(2) . . ( BSD) () . 10 defs.h (DICT_QUEUE_DEPTH). limit_childs number . . () ( ) . dict . defs.h (DICT_DAEMON_LIMIT_CHILDS). limit number limit_childs. . limit_matches number MATCH . . . limit_definitions number DEFINE . . . limit_time number ( ) . ( ) defs.h (DICT_DEFAULT_LIMIT_TIME). : limit_time delay . ( dictd.conf ) . : RFC DICT . limit_queries number (MATCH DEFINE SHOW DB ) . . defs.h (DICT_DEFAULT_LIMIT_QUERIES). timestamp number (timestamp) ( ). ( -s -L .) log_option option . -s -L ( --debug nodetach). dictd . : dictd -s --log stats --log found --log notfound . . server . . connect . stats . command . . client CLIENT . found . notfound . timestamp syslog . . host . auth . min . ( syslog) . . all . none . : I . . E . C CLIENT. D . M . N . T . A . connect host . CLIENT . debug_option string . . . -d . verbose -v --verbose. . scan . parse (parser) . search (character folding) . init . port . lev (Levenshtein). auth . nodetach . . nofork (fork) . . nodetach (core dump) . alt altcompare index.c. locale string (locale) . "C" . dictfmt ( ) . - UTF-8 . locale utf8 utf-8 UTF-8 . ASCII7 UTF-8 dictd RFC 2229 . : utf-8 - --locale dictd . dictd utf-8 - . add_strategy strategy_name description strategy_name description. . strategy_name description . default_strategy string MATCH. 'lev' . . default_strategy (Database specification) . disable_strategy string . . . disable_strategy (Database specification) . listen_to host IP bind . * dictd . dictd . address_family family 4 IPv4 () 6 IPv6 . syslog string syslog(3). syslog_facility string (facility) syslog . -s syslog . SYSLOG_NAMES syslog.conf(5) . ( ): auth authpriv cron daemon ftp kern lpr mail news syslog user uucp local0 local1 local2 local3 local4 local5 local6 local7. log_file string . strftime(3) . ".%Y%m%d" . : dictd . pid_file string (pid) dictd . /var/run/dictd.pid . fast_start dictd ( ) . . without_mmap mmap(2) . . (Database Specification) : data string . '.' '/' $datadir/ . . Makefile configure --datadir=.../. . index string (index) . "data" . index_suffix string 'suffix' ( ) . 'dictfmt_index2suffix' . "dictfmt_index2suffix --help" . "data" . index_word string 'word' ( ) . 'dictfmt_index2word' . "dictfmt_index2word --help" . "data" . prefilter string (prefilter) . . LZ77 zlib . postfilter string (postfilter) . . . filter string . . ( html) . name string ( "1913 Webster's"). @ . "@00-database-short" defs.h (DICT_SHORT_ENTRY_NAME). info string . @ . "@00-database-info" defs.h (DICT_INFO_ENTRY_NAME). invisible DEFINE MATCH SHOW INFO SHOW SERVER SHOW DB . . '*' '!' . : ( ) MIME ( database_virtual database_mime ). disable_strategy string . () . examples/dictd_complex.conf . default_strategy string '.' . lev word . (Virtual Database Specification) : database_list string . . name string . . info string . . invisible . . disable_strategy string . . (Plugin Specification) plugin string . data string . name string . . info string . . invisible . . disable_strategy string . . default_strategy string . . MIME (Mime Specification) dbname_nomime string OPTION MIME . dbname_mime string OPTION MIME . MIME . --mime-header dictfmt(1) . name string . . info string . . invisible . . disable_strategy string . . default_strategy string . . include string "string" ( ) . include . (DETERMINATION OF ACCESS LEVEL) . ( "allow *" ). IP . : allow 10.42.* authonly *.edu deny * 10.42 edu.* . 10.42 AUTH . edu.* ( ) AUTH . AUTH . . : user u1 deny *.com user u2 allow * u1 com.* . u2 com.* . "user u2" "allow *" . : IP . DNS . IP . ( : .) (SEARCH ALGORITHMS) DICT . . . . exact . . lev ( ). . <<>> . . prefix . . nprefix prefix . prefix . : 800#100#app 800 100 "app" . DICT ( ) . : nprefix "*" ( ) . : ( ) . re POSIX 1003.2. egrep(1) . ( [[:alnum:]] [[:alpha:]] [[:digit:]] [[:xdigit:]] ) * + ? ^ $ () | . "(foo|bar)" "foo" "bar" . ( ). : . . regexp (). | + ? . . (back reference) . . : ^\(...\).*\1$ . DICT ( -- ). : (backtracking) . soundex (Soundex) . . . substring . -- (Boyer-Moore- Horspool) . . suffix . -- . index_suffix . word . index_word . first . last . index_suffix . (DATABASE FORMAT) dictd . : (flat text) (index). ( ) Tab (headword) . (base 64) - IA5 RFC 1421 ( ) RFC 1522 ( base64 MIME) . Tab ( ) . ( ) . dictd : 00-database-info SHOW INFO . 00-database-short SHOW DB . dictfmt -s . 00-database-url URL . dictfmt -u . dictd . 00-database-utf8 UTF-8 . dictfmt --utf8 . 00-database-8bit-new - ( UTF-8) . dictfmt --locale . gzip(1) ( ) dictzip(1) ( ) . . gzip . gzip(1) . dictzip(1) gzip(1) . . dictzip(1) gzip(1) zcat(1) . (: dictzip znew(1) . dictzip(1) .) (SIGNALS) SIGHUP dictd . SIGUSR1 dictd (unload). dictd ( ) . SIGHUP . mmap(2) dictd . SIGUSR1 dictd SIGHUP . (COPYING) dictd dictzip (faith@dict.org) (GNU GPL) . . (zlib regex libmaa) GPL -- . (BUGS) . . (WARNINGS) ( 're' 'regexp') ERE BRE dictd . 're' 'regexp' utf8 dictd . (FILES) /etc/dict/dictd.conf dictd /usr/bin/dictd dictd /var/run/dictd.pid (pid) dictd /usr/share dictd ( index. dict[.dz].) (SEE ALSO) examples/dictd*.conf, dictfmt(1), dict(1), dictzip(1), gunzip(1), zcat(1), webster(1), RFC 2229 29 March 2002 DICTD(8)