dhcrelay(8) System Manager's Manual dhcrelay(8) (NAME) dhcrelay - (DHCP) (SYNOPSIS) dhcrelay [ -4 ] [ -dqaD ] [ -p port | -rp relay-port ] [ -c count ] [ -A length ] [ -pf pid-file ] [ --no-pid ] [ -m append | replace | forward | discard ] [ -i interface0 [ ... -i interfaceN ] ] [ -iu interface0 [ ... -iu interfaceN ] ] [ -id interface0 [ ... -id interfaceN ] ] [ -U interface ] [ -g ipaddr ] server0 [ ...serverN ] dhcrelay -6 [ -dqI ] [ -p port | -rp relay-port ] [ -c count ] [ -pf pid-file ] [ --no-pid ] [ -s subscriber-id ] -l lower0 [ ... -l lowerN ] -u upper0 [ ... -u upperN ] (DESCRIPTION) DHCP (ISC) dhcrelay DHCP BOOTP DHCP DHCP . DHCPv4/BOOTP DHCPv6 . (OPERATION) DHCP DHCPv4 DHCPv6 <<>> (upstream) . (downstream) . (OPTIONS) : -6 dhcrelay DHCPv6. -4 . -4 dhcrelay DHCPv4/BOOTP. . -6 . DHCPv4/BOOTP: DHCPv4 DHCP/BOOTP . DHCPv4 DHCPv6: -c count (hop count). dhcrelay count . . -d dhcrelay (foreground). dhcrelay inittab System V . -p port port. . DHCPv4/BOOTP DHCPv6 . -rp . -rp relay-port ( ) relay-port (RAI) DHCPv4 relay-source-port DHCPv6. (./configure --enable-relay-port) LPF BPF . -q (Quiet mode). . -pf pid-file PID . --no-pid PID. PID . DHCPv4: -a (agent option field) . . : (Circuit ID) (Remote ID). . . -A length DHCPv4/BOOTP. MTU . -D (Relay Agent Information) . . -g ipaddr IP (giaddr) ipaddr . ( ) ( ) giaddr . -i ifname DHCPv4/BOOTP ifname. -i . dhcrelay (non-broadcast) . -iu ifname (upstream) : . -iu . -i -id . -id ifname (downstream) : . -id . -i -iu . -m append|replace|forward|discard DHCPv4 . giaddr DHCP . giaddr : (append) (replace) (forward) (discard). -U ifname (link selection) RFC 3527 . RFC IP : (giaddr) (). . dhcrelay ( -a ) . ( giaddr ). ( giaddr ). giaddr ifname . . DHCP -i . . -a . -m replace -m discard -U . giaddr . DHCPv6: -I Interface-ID DHCPv6. . -I dhcrelay . -s subscriber-id subscriber-id . subscriber-id . -l [address%]ifname[#index] <<>> (lower) DHCPv6 : . DHCPv6 -l . ifname . address% dhcrelay - (non-link-local) . #index . -u [address%]ifname <<>> (upper) DHCPv6 : . DHCPv6 -u . ifname . address% All_DHCP_Relay_Agents_and_Servers DHCPv6 . . (SEE ALSO) dhclient(8), dhcpd(8), RFC3315, RFC2132, RFC2131. (BUGS) (loop) (hop count) . (loopback) . (AUTHORS) dhcrelay(8) Internet Systems Consortium Ted Lemon Vixie Enterprises . Internet Systems Consortium : https://www.isc.org dhcrelay(8)