.\" dhcrelay.8 .\" .\" Copyright (C) 2004-2022 Internet Systems Consortium, Inc. ("ISC") .\" Copyright (c) 1997-2003 by Internet Software Consortium .\" .\" This Source Code Form is subject to the terms of the Mozilla Public .\" License, v. 2.0. If a copy of the MPL was not distributed with this .\" file, You can obtain one at http://mozilla.org/MPL/2.0 .\" .\" THE SOFTWARE IS PROVIDED "AS IS" AND ISC DISCLAIMS ALL WARRANTIES .\" WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF .\" MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL ISC BE LIABLE FOR .\" ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES .\" WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN .\" ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT .\" OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. .\" .\" Internet Systems Consortium, Inc. .\" PO Box 360 .\" Newmarket, NH 03857 USA .\" .\" https://www.isc.org .\" .\" This software has been written for Internet Systems Consortium .\" by Ted Lemon in cooperation with Vixie Enterprises. .\" .\" Support and other services are available for ISC products - see .\" https://www.isc.org for more information or to learn more about ISC. .\" .\" $Id: dhcrelay.8,v 1.20 2012/05/14 23:17:43 sar Exp $ .\" .TH dhcrelay 8 .SH "نام (NAME)" dhcrelay \- عامل رله پروتکل پیکربندی پویای میزبان (DHCP) .SH "خلاصه دستور (SYNOPSIS)" .B dhcrelay [ .B -4 ] [ .B -dqaD ] [ .B -p .I port | .B -rp .I relay-port ] [ .B -c .I count ] [ .B -A .I length ] [ .B -pf .I pid-file ] [ .B --no-pid ] [ .B -m .I append | .I replace | .I forward | .I discard ] [ .B -i .I interface0 [ .B ... .B -i .I interfaceN ] ] [ .B -iu .I interface0 [ .B ... .B -iu .I interfaceN ] ] [ .B -id .I interface0 [ .B ... .B -id .I interfaceN ] ] [ .B -U .I interface ] [ .B -g .I ipaddr ] .I server0 [ .I ...serverN ] .PP .B dhcrelay -6 [ .B -dqI ] [ .B -p .I port | .B -rp .I relay-port ] [ .B -c .I count ] [ .B -pf .I pid-file ] [ .B --no-pid ] [ .B -s .I subscriber-id ] .B -l .I lower0 [ .B ... .B -l .I lowerN ] .B -u .I upper0 [ .B ... .B -u .I upperN ] .SH "توضیحات (DESCRIPTION)" عامل رله DHCP کنسرسیوم سامانه‌های اینترنتی (ISC)، یعنی .BR dhcrelay ، ابزاری برای رله و بازپخش درخواست‌های DHCP و BOOTP از یک زیرشبکه که هیچ کارگزار DHCP مستقیماً به آن متصل نیست، به یک یا چند کارگزار DHCP در سایر زیرشبکه‌ها فراهم می‌کند. این ابزار از هر دو پروتکل DHCPv4/BOOTP و DHCPv6 پشتیبانی می‌کند. .SH "نحوه عملکرد (OPERATION)" .PP عامل رله DHCP روی یک یا چند رابط شبکه به پرس‌وجوهای DHCPv4 یا DHCPv6 ارسال‌شده از سوی کلاینت‌ها یا سایر عامل‌های رله گوش می‌دهد، و آن‌ها را مطابق مواردی که در خط فرمان مشخص شده است به کارگزاران یا عامل‌های رله «بالادستی» (upstream) منتقل می‌کند. هنگامی که پاسخی از بالادست دریافت می‌شود، به صورت مالتی‌کست یا یونیکست به سمت پایین‌دست (downstream) و به مبدا درخواست اصلی بازگردانده می‌شود. .SH "گزینه‌ها (OPTIONS)" .PP \fIگزینه‌های انتخاب پروتکل:\fR .TP -6 اجرای .B dhcrelay به عنوان یک عامل رله DHCPv6. این گزینه با گزینه .B \-4 ناسازگار است. .TP -4 اجرای .B dhcrelay به عنوان یک عامل رله DHCPv4/BOOTP. این حالت پیش‌فرض عملکرد است، بنابراین ذکر این آرگومان ضروری نیست، اما ممکن است برای شفافیت بیشتر مشخص شود. این گزینه با گزینه .B \-6 ناسازگار است. .PP \fIتعیین کارگزاران DHCPv4/BOOTP:\fR .PP در حالت DHCPv4، باید فهرستی از یک یا چند نشانی کارگزار در خط فرمان مشخص شود تا پرس‌وجوهای DHCP/BOOTP به آن‌ها رله شوند. .PP \fIگزینه‌های مشترک برای هر دو حالت DHCPv4 و DHCPv6:\fR .TP -c \fIcount\fR حداکثر تعداد جهش (hop count). هنگام هدایت بسته‌ها، .B dhcrelay بسته‌هایی را که تعداد جهش آن‌ها به .I count رسیده باشد دور می‌اندازد. مقدار پیش‌فرض ۱۰ و حداکثر مقدار مجاز ۲۵۵ است. .TP -d اجبار .B dhcrelay به اجرا در پیش‌زمینه (foreground). این گزینه هنگام اجرای .B dhcrelay تحت یک دیباگر، یا اجرا خارج از inittab در سیستم‌های System V مفید است. .TP -p \fIport\fR گوش دادن و ارسال روی پورت .IR port . این گزینه بیشتر برای مقاصد اشکال‌زدایی مفید است. پورت پیش‌فرض برای DHCPv4/BOOTP پورت ۶۷ و برای DHCPv6 پورت ۵۴۷ است. این گزینه با .B \-rp ناسازگار است. .TP -rp \fIrelay-port\fR پورت مبدا جایگزین برای پیام‌های بالادستی (به سمت کارگزار) همراه با زیرگزینه relay-port در فیلد اطلاعات عامل رله (RAI) برای DHCPv4 یا گزینه relay-source-port در DHCPv6. پشتیبانی از پورت رله تنها در صورتی فعال است که برنامه با .RB ( ./configure\ \-\-enable\-relay\-port ) کامپایل شده باشد و نیازمند دسترسی به لایه پیوند LPF یا BPF است. .TP -q حالت بی‌صدا (Quiet mode). از چاپ تنظیمات پیکربندی شبکه در زمان راه‌اندازی جلوگیری می‌کند. .TP -pf \fIpid-file\fR مسیر فایل PID جایگزین. .TP --no-pid گزینه‌ای برای غیرفعال کردن نوشتن فایل PID. به‌طور پیش‌فرض این برنامه یک فایل PID می‌نویسد. .PP \fIگزینه‌های مختص حالت DHCPv4:\fR .TP -a افزودن فیلد گزینه عامل (agent option field) به هر درخواست پیش از ارسال آن به کارگزار. فیلدهای گزینه عامل در پاسخ‌های ارسالی از کارگزاران به کلاینت‌ها، پیش از ارسال مجدد این پاسخ‌ها به کلاینت حذف خواهند شد. فیلد گزینه عامل شامل دو زیرگزینه خواهد بود: زیرگزینه شناسه مدار (Circuit ID) و زیرگزینه شناسه دوردست (Remote ID). در حال حاضر، شناسه مدار نام قابل چاپ رابط شبکه‌ای خواهد بود که درخواست کلاینت روی آن دریافت شده است. کلاینت از گنجاندن زیرگزینه شناسه دوردست نیز پشتیبانی می‌کند، اما این مورد به‌طور پیش‌فرض استفاده نمی‌شود. .TP -A \fIlength\fR تعیین حداکثر اندازه بسته برای ارسال به یک کارگزار DHCPv4/BOOTP. این کار ممکن است به منظور فراهم کردن فضای کافی جهت افزودن گزینه‌های عامل رله، در عین حفظ اندازه در محدوده MTU اترنت انجام گیرد. .TP -D دور انداختن بسته‌های دریافتی از کارگزاران بالادستی در صورتی که حاوی گزینه‌های اطلاعات عامل رله (Relay Agent Information) باشند و نشان دهند که در پاسخ به پرس‌وجویی ارسال شده‌اند که از طریق یک عامل رله دیگر آمده است. اگر این گزینه مشخص نشود، این‌گونه بسته‌ها در هر صورت رله خواهند شد. .TP -g \fIipaddr\fR هنگامی که بسته‌ای به کلاینت بازگردانده می‌شود، نشانی IP دروازه (giaddr) را با نشانی داده‌شده در .I ipaddr جایگزین می‌کند. این گزینه می‌تواند به عنوان یک راهکار موقت برای کلاینت‌های معیوب (مانند گراب سولاریس ۱۱) استفاده شود که به جای روتر اعلام‌شده (گزینه ۳)، از giaddr برای تنظیم مسیر پیش‌فرض خود استفاده می‌کنند. .TP -i \fIifname\fR گوش دادن به ترافیک DHCPv4/BOOTP روی رابط شبکه .IR ifname . با استفاده از چند گزینه .B \-i می‌توان چندین رابط شبکه را مشخص کرد. اگر هیچ رابطی در خط فرمان مشخص نشود، .B dhcrelay تمام رابط‌های شبکه را شناسایی کرده، رابط‌های غیرپخشی (non-broadcast) را در صورت امکان حذف می‌کند، و تلاش می‌نماید روی همه آن‌ها گوش دهد. .TP -iu \fIifname\fR یک رابط شبکه بالادستی (upstream) را مشخص می‌کند: رابطی که پاسخ‌ها از کارگزاران و سایر عامل‌های رله از آن پذیرفته خواهند شد. با استفاده از چند گزینه .B \-iu می‌توان چندین رابط شبکه را مشخص کرد. این آرگومان برای استفاده به همراه یک یا چند آرگومان .B \-i یا .B \-id در نظر گرفته شده است. .TP -id \fIifname\fR یک رابط شبکه پایین‌دستی (downstream) را مشخص می‌کند: رابطی که درخواست‌ها از کلاینت‌ها و سایر عامل‌های رله از آن پذیرفته خواهند شد. با استفاده از چند گزینه .B \-id می‌توان چندین رابط را مشخص کرد. این آرگومان برای استفاده به همراه یک یا چند آرگومان .B \-i یا .B \-iu در نظر گرفته شده است. .TP -m \fIappend\fR|\fIreplace\fR|\fIforward\fR|\fIdiscard\fR نحوه مدیریت بسته‌های ورودی DHCPv4 را که از قبل حاوی گزینه‌های عامل رله هستند کنترل می‌کند. اگر در سرآیند چنین بسته‌ای .I giaddr تنظیم نشده باشد، استاندارد DHCP ایجاب می‌کند که بسته دور انداخته شود. با این حال، اگر .I giaddr تنظیم شده باشد، عامل رله می‌تواند به چهار روش با این وضعیت برخورد کند: می‌تواند مجموعه گزینه‌های رله خود را به بسته الحاق کند .RB ( append ) و فیلد گزینه ارائه‌شده را دست‌نخورده باقی بگذارد؛ فیلد گزینه عامل موجود را جایگزین نماید .RB ( replace )؛ بسته را بدون تغییر هدایت کند .RB ( forward )؛ یا آن را دور بیندازد .RB ( discard ). .TP -U \fIifname\fR افزودن زیرگزینه انتخاب پیوند (link selection) منطبق با RFC 3527 را برای کلاینت‌هایی که مستقیماً به رله متصل هستند فعال می‌کند. این RFC به رله اجازه می‌دهد تا دو نشانی IP مختلف را مشخص کند: یکی برای کارگزار جهت استفاده در ارتباط با رله (giaddr) و دیگری برای انتخاب زیرشبکه کلاینت (زیرگزینه). این ویژگی زمانی که کارگزار قادر به ارسال بسته‌ها به رله از طریق نشانی استفاده‌شده برای زیرشبکه نیست، می‌تواند مفید باشد. .PP در صورت فعال بودن، .B dhcrelay یک گزینه عامل (مطابق با گزینه .B \-a در بالا) شامل زیرگزینه انتخاب پیوند را به بسته هدایت‌شده اضافه می‌کند. این کار تنها برای بسته‌های دریافتی از کلاینت‌هایی انجام می‌شود که مستقیماً به رله متصل هستند (یعنی مقدار giaddr صفر است). نشانی استفاده‌شده در زیرگزینه، نشانی همان پیوندی خواهد بود که بسته ورودی روی آن دریافت شده است (که در غیر این صورت برای giaddr استفاده می‌شد). مقدار giaddr روی نشانی رابط .I ifname تنظیم خواهد شد. .PP تنها یک رابط باید به این شیوه مشخص شود. در حال حاضر فعال‌سازی این گزینه روی یک رابط باعث می‌شود رله تمام ترافیک DHCP را مشابه گزینه .B \-i پردازش کند؛ در آینده ممکن است این دو مورد را به‌طور کامل‌تری از هم تفکیک کنیم. .PP این گزینه به‌طور پیش‌فرض غیرفعال است. توجه داشته باشید که فعال کردن این گزینه، گزینه .B \-a را نیز به‌طور خودکار فعال می‌کند. .PP به خاطر داشته باشید که استفاده از گزینه‌هایی مانند .B \-m replace یا .B \-m discard روی رله‌های بالادست رله‌ای که از .B \-U استفاده می‌کند می‌تواند مشکلاتی ایجاد نماید. رله بالادست گزینه اولیه عامل شامل انتخاب پیوند را پاک می‌کند در حالی که مقدار تغییریافته giaddr را بر جای می‌گذارد و این امر موجب هدایت نادرست و سرگردانی بسته‌ها می‌شود. .PP \fIگزینه‌های مختص حالت DHCPv6:\fR .TP -I استفاده اجباری از گزینه Interface-ID در DHCPv6. این گزینه هنگام استفاده از دو یا چند رابط پایین‌دستی به‌طور خودکار ارسال می‌شود تا میان آن‌ها تمایز قائل شود. گزینه .B \-I باعث می‌شود .B dhcrelay این گزینه را حتی در صورت وجود تنها یک رابط پایین‌دستی نیز ارسال کند. .TP -s \fIsubscriber-id\fR افزودن گزینه‌ای با .I subscriber-id مشخص‌شده به داخل بسته. این ویژگی بیشتر برای آزمایش است تا استفاده در محیط عملیاتی، چرا که برای تمام کلاینت‌ها همان .I subscriber-id یکسان را در بسته درج می‌کند. .TP -l [\fIaddress%\fR]\fIifname\fR[\fI#index\fR] رابط شبکه «پایین‌دستی» (lower) را برای حالت رله DHCPv6 مشخص می‌کند: رابطی که پرس‌وجوها از کلاینت‌ها یا سایر عامل‌های رله روی آن دریافت خواهند شد. هنگام اجرا در حالت DHCPv6 حداقل باید یک گزینه .B \-l در خط فرمان گنجانده شود. نام رابط .I ifname یک پارامتر اجباری است. نشانی پیوند را می‌توان با .I address% مشخص کرد؛ در صورت عدم تعیین، .B dhcrelay از نخستین نشانی غیر پیوند-محلی (non-link-local) پیکربندی‌شده روی رابط استفاده خواهد کرد. پارامتر اختیاری .I #index شاخص رابط را مشخص می‌کند. .TP -u [\fIaddress%\fR]\fIifname\fR رابط شبکه «بالادستی» (upper) را برای حالت رله DHCPv6 مشخص می‌کند: رابطی که پرس‌وجوهای کلاینت‌ها و سایر عامل‌های رله باید به آن هدایت شوند. هنگام اجرا در حالت DHCPv6 حداقل باید یک گزینه .B \-u در خط فرمان گنجانده شود. نام رابط .I ifname یک پارامتر اجباری است. نشانی یونیکست یا مالتی‌کست مقصد را می‌توان با .I address% مشخص نمود؛ در صورت عدم تعیین، عامل رله بسته را به نشانی مالتی‌کست .I All_DHCP_Relay_Agents_and_Servers در DHCPv6 ارسال خواهد کرد. .PP امکان تعیین یک رابط یکسان با نشانی‌های مختلف به دفعات وجود دارد، و حتی در صورتی که سیستم پشتیبانی کند، می‌توان از یک رابط به عنوان هر دو رابط بالادستی و پایین‌دستی استفاده نمود. .SH "همچنین ببینید (SEE ALSO)" .BR dhclient (8), .BR dhcpd (8), RFC3315, RFC2132, RFC2131. .SH "اشکالات (BUGS)" .PP استفاده از یک رابط یکسان در هر دو سمت بالادستی و پایین‌دستی ممکن است باعث ایجاد حلقه (loop) شود، بنابراین هنگام اجرا به این شیوه، حداکثر تعداد جهش (hop count) باید روی یک مقدار کم تنظیم گردد. .PP رابط لوپ‌بک (loopback) هنوز به عنوان یک رابط معتبر شناخته نمی‌شود. .SH "نویسندگان (AUTHORS)" .B dhcrelay(8) .PP این نرم‌افزار برای Internet Systems Consortium توسط Ted Lemon و با همکاری Vixie Enterprises نوشته شده است. .PP برای کسب اطلاعات بیشتر درباره Internet Systems Consortium، به نشانی زیر مراجعه کنید: .B https://www.isc.org