dhcpd.conf(5) File Formats Manual dhcpd.conf(5) (NAME) dhcpd.conf - dhcpd (DESCRIPTION) dhcpd.conf dhcpd DHCP (ISC) . dhcpd.conf (ASCII) . - dhcpd . (Tab) . . () ( ) . # . . -- . ( ) ( dhcpd ) ( 220.177.244.7). . . shared-network subnet . range subnet . () host . group . DHCP subnet dhcpd . subnet . IP . . subnet shared-network . shared-network subnet ( subnet ) . DHCP <<>> (stateless) ( ) (stateful) . . host group . . () host ( ) class pool subnet shared-network IP . (lexical scope) . . dhcpd host host fixed-address IP . fixed-address . (EXAMPLES) dhcpd.conf : global parameters... subnet 204.254.239.0 netmask 255.255.255.224 { subnet-specific parameters... range 204.254.239.10 204.254.239.30; } subnet 204.254.239.32 netmask 255.255.255.224 { subnet-specific parameters... range 204.254.239.42 204.254.239.62; } subnet 204.254.239.64 netmask 255.255.255.224 { subnet-specific parameters... range 204.254.239.74 204.254.239.94; } group { group-specific parameters... host zappo.test.isc.org { host-specific parameters... } host beppo.test.isc.org { host-specific parameters... } host harpo.test.isc.org { host-specific parameters... } } . ( ) . : option domain-name "isc.org"; option domain-name-servers ns1.isc.org, ns2.isc.org; IP . IP ( ) . () . : option routers 204.254.239.1; . -- . IP . group -- zappo beppo harpo -- . test.isc.org : option domain-name "test.isc.org"; . DHCP : max-lease-time 120; default-lease-time 120; option . option DHCP option DHCP ( dhcpd ) DHCP ( server-name filename). (host-specific parameters) . hostname ( filename) ( next-server) . . NCD X-Terminal . . host : group { filename "Xncd19r"; next-server ncd-booter; host ncd1 { hardware ethernet 0:c0:c3:49:2b:57; } host ncd4 { hardware ethernet 0:c0:c3:80:fc:32; } host ncd8 { hardware ethernet 0:c0:c3:22:46:81; } } group { filename "Xncd19c"; next-server ncd-booter; host ncd2 { hardware ethernet 0:c0:c3:88:2d:81; } host ncd3 { hardware ethernet 0:c0:c3:00:14:11; } } group { filename "XncdHMX"; next-server ncd-booter; host ncd1 { hardware ethernet 0:c0:c3:11:90:23; } host ncd4 { hardware ethernet 0:c0:c3:91:a7:8; } host ncd8 { hardware ethernet 0:c0:c3:cc:a:8f; } } (ADDRESS POOLS) pool pool6 . DHCP DHCP . DHCP . pool : subnet 10.0.0.0 netmask 255.255.255.0 { option routers 10.0.0.254; # Unknown clients get this pool. pool { option domain-name-servers bogus.example.com; max-lease-time 300; range 10.0.0.200 10.0.0.253; allow unknown-clients; } # Known clients get this pool. pool { option domain-name-servers ns1.example.com, ns2.example.com; max-lease-time 28800; range 10.0.0.5 10.0.0.199; deny unknown-clients; } } -- (shared networks) pool . . allow deny . (permit list) . (deny list) . . pool6 pool . subnet6 . range6 prefix6 . range6 NA TA prefix6 pool6 . (DYNAMIC ADDRESS ALLOCATION) INIT DHCPDISCOVER . DHCPREQUEST -- DHCPREQUEST DHCPNAK DHCPACK . DHCPACK . DHCPNAK . (authoritative) DHCPNAK . host . host fixed-address IP DHCP . host . DHCPREQUEST DHCPNAK . DHCP ( DHCPDISCOVER ) IP IP . . -- DHCPDISCOVER . . pool ( range pool ). . . . . . . DHCP IP (hash table) . DHCP IP . ISC DHCP DHCP IP ISC DHCP . IP (IP ADDRESS CONFLICT PREVENTION) DHCP IP . ICMP ( ICMP Echo request) IP . ICMP . range DHCP -- DHCP (failover peer) . ICMP DHCP -- IP DHCP . (abandoned) . abandon-lease-time . DHCP IP IP DHCP IP (reclaim) . IP ICMP . ICMP . DHCP IP IP . DHCPDISCOVER IP . DHCP (DHCP FAILOVER) ISC DHCP DHCP (failover) draft- ietf-dhc-failover-12.txt . . ISC DHCP . DHCP ( ) . IP . . (down) ( ) . PARTNER-DOWN . omshell (1) (leases file) PARTNER-DOWN . "my state" : failover peer name state { my state partner-down;. peer state state at date; } "my state" . PARTNER-DOWN . : PARTNER-DOWN ** PARTNER-DOWN IP . PARTNER-DOWN . (primary) (secondary) . . . (FAILOVER STARTUP) . DHCP . . . . . MCLT MCLT . . partner-down . DHCP . . MCLT DHCP . (CONFIGURING FAILOVER) (failover) (peer declaration) (pool declaration) . . . . : pool { failover peer "foo"; pool specific parameters }; . . (include) . . . dhcpd.conf (primary) : failover peer "foo" { primary; address anthrax.rc.example.com; port 519; peer address trantor.rc.example.com; peer port 520; max-response-delay 60; max-unacked-updates 10; mclt 3600; split 128; load balance max seconds 3; } include "/etc/dhcpd.master"; : primary secondary [ primary | secondary ]; (primary) (secondary) DHCP FAILOVER . address address address; address IP DNS DHCP . . peer address peer address address; peer address IP DNS . port port port-number; port TCP . IANA . peer port peer port port-number; peer port TCP . IANA . max-response-delay max-response-delay seconds; max-response-delay DHCP . . . max-unacked-updates max-unacked-updates count; max-unacked-updates DHCP BNDACK BNDUPD . . . mclt mclt seconds; mclt Maximum Client Lead Time . . (lease) . PARTNER-DOWN IP . . . split split bits; split (load balancing) . DHCP DHCP (hash) . . (set) . . split . split . ( ) . . hba hba colon-separated-hex-list; hba (cutoff) (bitmap) . . hba: hba ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff:ff: 00:00:00:00:00:00:00:00:00:00:00:00:00:00:00:00; split 128; . split : hba aa:aa:aa:aa:aa:aa:aa:aa:aa:aa:aa:aa:aa:aa:aa:aa: aa:aa:aa:aa:aa:aa:aa:aa:aa:aa:aa:aa:aa:aa:aa:aa; hba 55:55:55:55:55:55:55:55:55:55:55:55:55:55:55:55: 55:55:55:55:55:55:55:55:55:55:55:55:55:55:55:55; (0xa 0x5 ) . . split hba . hba split . load balance max seconds load balance max seconds seconds; . DHCPDISCOVER DHCPREQUEST secs -- . . . . DHCPDISCOVER DHCPREQUEST . auto-partner-down auto-partner-down seconds; (communications-interrupted ) . partner-down . STOS+MCLT () ( ). . partner-down communications- interrupted DHCP . (" "). auto-partner-down ( ) partner-down . (Failover pool balance). max-lease-misbalance percentage; max-lease-ownership percentage; min-balance seconds; max-balance seconds; DHCP . -- . . 'free' 'backup' . ' ' (free state leases) . 'free' 'backup' ' ' . 'free' 'backup' . / . ' ' . . 'lts' "Leases To Send" ( ) . free backup . backup free . : / . . lts ( ). max-lease- misbalance . : lts (free+backup) max-lease- misbalance ( "" ). ( ). free backup . ( ). min-balance max-balance . . lts '' ('panic') POOLREQ . lts max-lease-misbalance . . -- ( split hba ) -- . lts lts max-lease-ownership . -- / ( ) . 'MAC Address Affinity' : DHCP Client Identifier . (affinity) 'expired' 'released' 'free' . free backup . lts max-lease-ownership . lts . . max-lease-misbalance . ( ). max-lease-ownership () . min-balance max-balance ( ). ( ) ( lts ). max-lease- ownership max- lease-misbalance . max-lease-ownership max-lease-misbalance . min-balance max-balance (2^32)-1 ( time_t ) ( ). (CLIENT CLASSING) . match . (lease) . DHCPv6 4.3.0 . DHCPv4 (billing classes) . (matching expression) : class "ras-clients" { match if substring (option dhcp-client-identifier, 1, 3) = "RAS"; } . . . . ( ) . (in-scope) : class "ras-clients" { } (SUBCLASSES) (subclasses) . . . : class "allocation-class-1" { match pick-first-value (option dhcp-client-identifier, hardware); } class "allocation-class-2" { match pick-first-value (option dhcp-client-identifier, hardware); } subclass "allocation-class-1" 1:8:0:2b:4c:39:ad; subclass "allocation-class-2" 1:8:0:2b:a9:cc:e3; subclass "allocation-class-1" 1:0:0:c4:aa:29:44; subnet 10.0.0.0 netmask 255.255.255.0 { pool { allow members of "allocation-class-1"; range 10.0.0.11 10.0.0.50; } pool { allow members of "allocation-class-2"; range 10.0.0.51 10.0.0.100; } } . . . (scope) . . . : subclass "allocation-class-2" 1:08:00:2b:a1:11:31 { option root-path "samsara:/var/diskless/alphapc"; filename "/tftpboot/netbsd.alphapc-diskless"; } . vendor-class-identifier vendor-encapsulated-options . VENDOR ENCAPSULATED OPTIONS dhcp-options(5) . (PER-CLASS LIMITS ON DYNAMIC ADDRESS ALLOCATION) . . DHCPRELEASE. : class "limited-1" { lease limit 4; } . (SPAWNING CLASSES) (spawning class) . . . ISP IP IP . (head-end) (relay) DHCP Relay Agent Information . circuit ID remote ID . : class "customer" { spawn with option agent.circuit-id; lease limit 4; } circuit ID . circuit ID . circuit ID dhcpd.leases . . . MATCH MATCH IF SPAWN WITH (COMBINING MATCH, MATCH IF AND SPAWN WITH) . match if spawn with match if match . : class "jr-cable-modems" { match if option dhcp-vendor-identifier = "jrcm"; spawn with option agent.circuit-id; lease limit 4; } class "dv-dsl-modems" { match if option dhcp-vendor-identifier = "dvdsl"; spawn with option agent.circuit-id; lease limit 16; } spawn with . (DYNAMIC DNS UPDATES) DHCP (DNS) . . RFC 2136 DNS RFC 2136 DHCP . DNS . (interim) DDNS (standard) RFC DHCP-DNS DHCID . ad-hoc . DHCP DNS . standard . DNS interim . ddns-update-style . (THE DNS UPDATE SCHEME) (interim) (standard) IETF . RFC . RFC : RFC 4701 (updated by RF5494) RFC 4702 RFC 4703 : draft-ietf-dnsext-dhcid-rr-??.txt draft-ietf-dhc-fqdn-option-??.txt draft-ietf-dhc-ddns-resolution-??.txt DHCID RR TXT RR . TXT DHCID RR ( MD5 SHA2 ). DHCP A PTR . FQDN A . . allow client-updates; ignore client-updates; . . (FQDN) FQDN FQDN PTR . "radish.org" "jschmoe" . "example.org" . DHCP FQDN FQDN "jschmoe.radish.org." . A . DHCP A PTR IP jschmoe.radish.org . DHCP IP A DNS "radish.org" . . : 1. fqdn ( ) 2. hostname ( ) 3. ( ). ddns-hostname . use-host-decl-names ( ) . . A PTR . fqdn "jschmoe" "jschmoe.radish.org". ignore client-updates; DHCP FQDN . deny client-updates; . DHCP DNS A A . : DHCP SHA DHCP ( RFC 4701 4702 ). A DHCID (hashid) . . A DHCP A DHCID A DHCID hashid . A PTR . ( ) . DHCP DNS . . DNS DNS DNS . DHCP ( ) . DHCP DNS . DNS . (interim) RFC . RFC DHCID RR TXT . ddns-resolution DHCP DHCID RR PTR interim . RFC DHCID RR PTR . (DDNS IN DUAL STACK ENVIRONMENTS) 5.2 RFC 4703 DDNS (dual stack) IPv4 IPv6 IPv4 DUID 6.1 RFC 4361 dhcp-client-identifier . DUID IPv4 IPv6 IPv4 IPv6 DUID . FQDN . IPv4 . ISC DHCP ( 4.4.0) DDNS << >> Dual Stack Mixed Mode ( DSMM) . DSMM . DHCP (IPv4 v6) ddns-update-style ( interim standard) <<>> ddns-update-style <<>> . (TXT DHCID) DHCID RR . . DSMM DSMM IPv4 A PTR DHCID DSMM IPv6 AAAA PTR DHCID . DSMM DSMM DNS . . DSMM . DSMM update-conflict-detection ddns-dual-stack-mixed-mode true . (PROTECTING DNS ENTRIES FOR STATIC CLIENTS) . DNS (forward) DHCID RR . DNS DHCID RR . DNS (overwrite) . DHCID RR DHCID RR . ddns-guard-id-must-match . DSMM . . DSMM : ddns-other-guard-is-dynamic. DSMM DHCID RR DNS FQDN . interim DHCID RR DHCID FQDN DNS FQDN . . . (DYNAMIC DNS UPDATE SECURITY) DNS DHCP . TSIG (shared secret key). . DHCP DHCP DHCP . DNS (zone) DHCP . sneedville.edu 10.10.17.0/24 . TSIG ( A PTR ) ISC BIND : key DHCP_UPDATER { algorithm HMAC-MD5.SIG-ALG.REG.INT; secret pRP5FapFoJ95JEL06sv4PQ==; }; zone "example.org" { type master; file "example.org.db"; allow-update { key DHCP_UPDATER; }; }; zone "17.10.10.in-addr.arpa" { type master; file "10.10.17.db"; allow-update { key DHCP_UPDATER; }; }; DHCP . dhcpd.conf : key DHCP_UPDATER { algorithm HMAC-MD5.SIG-ALG.REG.INT; secret pRP5FapFoJ95JEL06sv4PQ==; }; zone EXAMPLE.ORG. { primary 127.0.0.1; key DHCP_UPDATER; } zone 17.127.10.in-addr.arpa. { primary 127.0.0.1; key DHCP_UPDATER; } primary IP (name server) . primary primary6 secondary secondary6 . primary6 IPv6 . . DDNS . (authority) SOA "example.org." "17.10.10.in-addr.arpa." . "foo.example.org" SOA "foo.example.org." . DHCP "." . "." DHCP . DHCP DNS (quotes) . . ISC BIND 9 dnssec-keygen . dnssec-keygen BIND 9 : dnssec-keygen -a HMAC-MD5 -b 128 -n USER DHCP_UPDATER (secret) DNS . DHCP : HMAC-MD5 HMAC-SHA1 HMAC-SHA224 HMAC-SHA256 HMAC-SHA384 HMAC-SHA512 (logging) DNS DNS . : logging { channel update_debug { file "/var/log/update-debug.log"; severity debug 3; print-category yes; print-severity yes; print-time yes; }; channel security_info { file "/var/log/named-auth.info"; severity info; print-category yes; print-severity yes; print-time yes; }; category update { update_debug; }; category security { security_info; }; }; /var/log/named- auth.info /var/log/update-debug.log . ISC BIND . : (REFERENCE: EVENTS) (lease) . (commit) (release) (expiry) . on . : (REFERENCE: DECLARATIONS) include include "filename"; include include . shared-network shared-network name { [ parameters ] [ declarations ] } shared-network DHCP IP . shared-network . shared-network () . . . Name . () . ( ) . subnet subnet subnet-number netmask netmask { [ parameters ] [ declarations ] } subnet dhcpd IP . . range . subnet-number IP . netmask IP (subnet mask) . IP . netmask subnet-mask subnet-mask subnet . subnet6 subnet6 subnet6-number { [ parameters ] [ declarations ] } subnet6 dhcpd IPv6 subnet6 . . subnet6-number IPv6 ip6-address/bits . range range [ dynamic-bootp ] low-address [ high-address]; range . range IP . IP range . DHCP BOOTP dynamic-bootp . high-address . range6 range6 low-address high-address; range6 subnet6-number; range6 subnet6-number temporary; range6 address temporary; IPv6 ( subnet6) range6 . range6 IPv6 range6 CIDR ip6-address/bits . IP range6 subnet6 range6 . temporary ( ) (RFC 4941) . IA_TA . Release Confirm . IPv6 fixed-address6 IPv6 range6 . prefix6 prefix6 low-address high-address / bits; prefix6 range6 (Prefix Delegation - RFC 3633) . bits low-address high-address . IPv6 fixed-prefix6 () prefix6 . (global) (shared-network scope) . host host hostname { [ parameters ] [ declarations ] } host DHCP DHCP BOOTP . DHCPv6 . DHCP BOOTP v4 () fixed-address host . fixed-address6 v6 . . host . host . host fixed-address ( ) . host fixed-address . host ... fixed-address . hostname . hostname hostname . Host DHCP BOOTP dhcp-client-identifier host host dhcp-client-identifier hardware host (MAC) . BOOTP dhcp-client-identifier BOOTP . DHCPv6 host-identifier option host . dhcp-client-identifier host-identifier option DHCPv6. host-name . host-name dhcp-client-identifier . group group { [ parameters ] [ declarations ] } group . . : ALLOW DENY (REFERENCE: ALLOW AND DENY) allow deny DHCP . allow deny . (pool) . (scope) . ignore deny () . ALLOW DENY IGNORE (ALLOW DENY AND IGNORE IN SCOPE) allow deny . unknown-clients allow unknown-clients; deny unknown-clients; ignore unknown-clients; unknown-clients dhcpd . (allow) . (host declaration) . (deprecated) . deny unknown- clients; << ALLOW DENY >> . bootp allow bootp; deny bootp; ignore bootp; bootp dhcpd bootp . Bootp (allow) . booting allow booting; deny booting; ignore booting; booting dhcpd . . (allow) DHCP . duplicates allow duplicates; deny duplicates; << DHCP>> (DHCP Client Identifier) MAC . MAC MAC - . - . duplicates DHCP MAC MAC UID . DHCP . (allow) . declines allow declines; deny declines; ignore declines; DHCPDECLINE DHCP . DHCPDECLINE (abandon) . (buggy) DHCPDECLINE DHCP . . (thrashing) DNS DHCP DHCP . declines DHCP DHCPDECLINE . deny ignore DHCP DHCPDECLINE . declines DHCPv4 . IPv6 DHCPv6 . IPv6 : ) : DUID DHCP REQUEST DUID . ) . . . . DUID . DUID . DUID . : "Best match for DUID is an abandoned address, This may be a result of multiple clients attempting to use this DUID" DUID . client-updates allow client-updates; deny client-updates; client-updates DHCP A . << DNS>> (THE DNS UPDATE SCHEME) . leasequery allow leasequery; deny leasequery; leasequery DHCP DHCPLEASEQUERY . DHCPLEASEQUERY . . ALLOW DENY (ALLOW AND DENY WITHIN POOL DECLARATIONS) allow deny DHCPDISCOVER DHCPREQUEST - ( ) . DHCPNAK . . DHCPACK . (pool) . . . DHCPREQUEST . DHCP (permit lists) allow deny . DHCPDISCOVER << >> (ADDRESS ALLOCATION) . allow deny : known-clients; ( ) . . unknown-clients; ( ) . members of "class"; . dynamic bootp clients; bootp . authenticated clients; DHCP . . unauthenticated clients; DHCP . . all clients; . (renumber) . after time; . . + min-lease-time . min- lease-time min-lease-time . time (epoch) UTC : 4 2007/08/24 09:14:32 : 4 2007/08/24 11:14:32 -7200 : (REFERENCE: PARAMETERS) abandon-lease-time abandon-lease-time time; time ( ) IPv4 . . ( ) . . (global scope) . (ping check) . 0x7FFFFFFF - 1 0x7FFFFFFF . adaptive-lease-time-threshold adaptive-lease-time-threshold percentage; (pool) percentage DHCP min-lease-time . () . . . . always-broadcast always-broadcast flag; DHCP BOOTP DHCP BOOTP (broadcast bit) BOOTP . DHCP BOOTP DHCP . 'on' DHCP (host) . . DHCP OpenTransport ISC DHCP . always-reply-rfc1048 always-reply-rfc1048 flag; BOOTP RFC1048 RFC1048 . BOOTREQUEST "(non-rfc1048)" . rfc1048 always-reply-rfc1048 DHCP (vendor options) RFC-1048 . . authoritative authoritative; not authoritative; DHCP (authoritative) . DHCP DHCPNAK DHCP . DHCP (authoritative) authoritative; DHCP DHCPNAK . IP . authoritative; . DHCP (per-network-segment) . - shared-network subnet shared-network . . DHCPINFORM . DHCPINFORM . boot-unknown-clients boot-unknown-clients flag; boot-unknown-clients false off host () IP . true on IP allow deny pool . check-secs-byte-order check-secs-byte-order flag; check-secs-byte-order DHCPv4 secs . (network byte order) . secs ( ) (swap) . . failover . ( --enable-secs-byteorder ). db-time-format db-time-format [ default | local ] ; DHCP . . default UTC local (seconds-since-epoch) . dhcpd.leases(5) . ddns-hostname ddns-hostname name; name (hostname) A PTR . ddns-hostname . ddns-domainname ddns-domainname name; name (FQDN) . ddns-dual-stack-mixed-mode ddns-dual-stack-mixed-mode flag; ddns-dual-stack-mixed-mode Dual Stack Mixed Mode DDNS . (off) update-conflict-detection . ddns-guard-id-must-match ddns-guard-id-must-match flag; ddns-guard-id-must-match DHCID RR DNS DNS DHCID RR . . DNS DNS DHCID RR . (on) update-conflict-detection . ddns-local-address4 ddns-local-address6 ddns-local-address4 address; ddns-local-address6 address; address IPv4 IPv6 DDNS . ddns-other-guard-is-dynamic ddns-other-guard-is-dynamic flag; ddns-other-guard-is-dynamic DSMM DHCID RR DNS . DNS . (off) ddns- dual-stack-mixed-mode . ddns-rev-domainname ddns-rev-domainname name; name PTR IP . "in-addr.arpa." (override) . IP IP (dotted quad notation) - IP 10.17.92.74 IP 74.92.17.10 . IP PTR 10.17.92.74.in-addr.arpa. . ddns-update-style ddns-update-style style; style standard interim none . ddns-update-style - dhcpd.conf IP DNS . none . ddns-updates ddns-updates flag; ddns-updates DNS . off . ddns-updates (on) . DNS ddns-update-style none . default-lease-time default-lease-time time; time . DHCPv4 DHCPv6 ( DHCPv6 "valid lifetime" ). . delayed-ack max-ack-delay delayed-ack count; max-ack-delay microseconds; count 2^16-1 0 . 28 ( SO_SNDBUF 576 ). DHCPv4 (database commit) . ( fsync() ) . RFC2131 << >> . DHCPv4 << >> ( select() ) . microseconds fsync fsync . 0 2^32-1 , (/ ) . delayed-ack './configure --disable-delayed-ack' . delayed-ack DHCPv4-over-DHCPv6 4to6 delayed-ack 0 . dhcp-cache-threshold dhcp-cache-threshold percentage; dhcp-cache-threshold 0 100 . 25 ( ) . ( ) . IPv4 IPv6 (pool) IPv6 NA TA PD . . dhcp-cache-threshold DHCP . ( ) CLTT ( Client Last Transmission Time) IPv4: IPv6: . . : 1. dhcp-cache-threshold 2. 3. dhcp-cache-threshold 4. : a. DNS DNS b. ( IPv4) c. ( IPv4) d. - . ( IPv4) on-commit . (relay agent) . . do-forward-updates do-forward-updates flag; do-forward-updates DHCP A DHCP . DNS . (forward updates) . DHCP A PTR FQDN fqdn PTR . DHCP client- updates . dont-use-fsync dont-use-fsync flag; dont-use-fsync DHCP fsync() . false fsync() . fsync() . . . dynamic-bootp-lease-cutoff dynamic-bootp-lease-cutoff date; dynamic-bootp-lease-cutoff BOOTP . BOOTP dhcpd BOOTP . () BOOTP . Date BOOTP . : W YYYY/MM/DD HH:MM:SS W () () . YYYY . MM . DD . HH . MM SS . (UTC) . dynamic-bootp-lease-length dynamic-bootp-lease-length length; dynamic-bootp-lease-length BOOTP . BOOTP DHCP . length . BOOTP length BOOTP . . echo-client-id echo-client-id flag; echo-client-id RFC 6842 . echo-client-id true on DHCP DISCOVER REQUEST ( ) RFC 6842 (DHCP ACK NAK) . . . filename filename "filename"; filename . filename . fixed-address fixed-address address [, address ... ]; fixed-address IP . host . . fixed-address host fixed-address . address fixed-address IP IP . fixed-address6 fixed-address6 ip6-address ; fixed-address6 IPv6 . host . fixed-prefix6 fixed-prefix6 low-address / bits; fixed-prefix6 IPv6 . host fixed-prefix6 host . low-address bits . . host fixed-address6 . fixed-address6 . : . . get-lease-hostnames get-lease-hostnames flag; get-lease-hostnames dhcpd IP (lease pool) DHCP hostname . flag true . flag false . hardware hardware hardware-type hardware-address; BOOTP hardware host . hardware-type . ethernet token-ring fddi ( ) . hardware-address () ( 0 ff) . hardware DHCP . host-identifier option host-identifier option option-name option-data; host-identifier v6relopt number option-name option-data; DHCPv6 host . option-name option-data . option-data . v6relopts . v6relay . 0 (no-op) . ( ) . ignore-client-uids ignore-client-uids flag; ignore-client-uids true on UID . false off UID . infinite-is-reserved infinite-is-reserved flag; ISC DHCP <<>> ('reserved') . << >> (RESERVED LEASES) . flag (on) (0xffffffff) . off () . lease-file-name lease-file-name name; Name name DHCP . DBDIR/dhcpd.leases . (outer scope) . . : 1. lease-file-name . 2. -lf. 3. PATH_DHCPD_DB. dhcpv6-lease-file-name dhcpv6-lease-file-name name; name DHCP DHCPv6 . DBDIR/dhcpd6.leases . . . : 1. dhcpv6-lease-file-name . 2. -lf. 3. PATH_DHCPD6_DB. lease-id-format lease-id-format format; format octal hex . . octal () . hex () . lease-id-format server-duid uid ( DHCPv4) IAID_DUID ( DHCPv6). . limit-addrs-per-ia limit-addrs-per-ia number; DHCPv6 IAADDR IA . number . IP . . local-port local-port port; DHCP UDP port DHCP . local-address local-address address; DHCP DHCP address . DHCP (all-ones IP address) (unicast) DHCP . : USE_SOCKETS #define . USE_SOCKETS : Listening on Socket/eth0 DHCP ()bind . local-address6 bind-local-address6 local-address6 address; bind-local-address6 flag; local-address6 DHCP IPv6 address IPv6 . bind-local-address6 true on address (bind) . address bind-local-address6 (global scope) . log-facility log-facility facility; DHCP dhcpd.conf (log facility) . DHCP daemon . auth authpriv cron daemon ftp kern lpr mail mark news ntp security syslog user uucp local0 local7 . . syslog.conf DHCP . : local7.debug /var/log/dhcpd.log syslog.conf -- syslog.conf . syslog ( /var/log/messages /usr/adm/messages ) SIGHUP syslogd . newsyslog logrotate . log-facility dhcpd.conf dhcpd.conf . README (: README ). DHCP . log-threshold-high log-threshold-low log-threshold-high percentage; log-threshold-low percentage; log-threshold-low log-threshold-high (pool) . . 0 . . . . . (acknowledge) . (shared subnets) (2^64)-1 . : "Threshold logging disabled for shared subnet of ranges: " . max-lease-time max-lease-time time; Time ( ) (lease) . . BOOTP . min-lease-time min-lease-time time; Time ( ) . max- lease-time . min-secs min-secs seconds; Seconds DHCP . . DHCP . DHCP . . . next-server next-server server-name; next-server ( filename) . Server-name IP . omapi-port omapi-port port; omapi-port DHCP OMAPI . OMAPI DHCP . one-lease-per-client one-lease-per-client flag; DHCPREQUEST . DHCPREQUEST DHCPREQUEST - . . persist-eui-64-leases persist-eui-64-leases flag; EUI-64 . DUID . EUI-64 use-eui-64 . (global scope) . pid-file-name pid-file-name name; Name (PID) DHCP . DHCP . RUNDIR/dhcpd.pid . lease-file-name . : 1. pid-file-name . 2. -lf. 3. PATH_DHCPD_PID. dhcpv6-pid-file-name dhcpv6-pid-file-name name; Name pid DHCPv6 . DBDIR/dhcpd6.pid . pid-file-name . : 1. dhcpv6-pid-file-name . 2. -lf. 3. PATH_DHCPD6_PID. ping-check ping-check flag; DHCP IP ICMP Echo ( ping) . ICMP Echo . (abandoned) . abandon-lease-time ( ) . IP DHCP abandon-lease-time IP (reclaim) . ping check DHCPDISCOVER . ping- timeout . ping-check - false . ping-cltt-secs ping-cltt-secs seconds; : 1. . 2. DISCOVER . 3. ( ). 4. : a. ( CLTT 0 ). b. . c. ping-cltt-secs CLTT . d. . ping-cltt-secs CLTT . . ping-timeout ping-timeout seconds; DHCP true ping-check ICMP echo ( ping) ping-timeout DHCP ICMP Echo . (timeout) ICMP Echo . . ping-timeout . ( ping-timeout-ms ) ping-timeout-ms ping-timeout-ms milliseconds; . ping-timeout . . preferred-lifetime preferred-lifetime seconds; IPv6 <<>> (valid) <<>> (preferred) . . (advisory) ( TCP ). / . prefix-length-mode prefix-length-mode mode; RFC 3633 DHCPv6 IA_PD Prefix IA_PD . <> . . RFC << () >> . prefix-length-mode prefix- length . mode ignore prefer exact minimum maximum : 1. ignore - . . 2. prefer - . . . 3. exact - . . 4. minimum - . ( ) . . 60/ 56/ 64/ 64/ . 5. maximum - . ( ) . . 60/ 56/ 64/ 56/ . << >> . A B C : subnet 3000::/64 { # pool A pool6 { : } # pool B pool6 { : } # pool C pool6 { : } } A B C . prefer minimum maximum . . A . release-on-roam release-on-roam flag; dhcpd DHCPv6 ( IAID+DUID) (roam) : "Client: roamed to new network, releasing lease:
" . release-on-roam ( ) . IAID IA . (global) . remote-port remote-port port; DHCP DHCP UDP port DHCP . UDP DHCP local-port . DHCP 127.0.0.1 DHCP remote-port . . server-identifier server-identifier hostname; server-identifier DHCP (DHCP Server Identifier) . IP DHCP . server-identifier - . IP . server-identifier IP . (alias) IP DHCP IP . dhcp-server-identifier server-identifier . server-id-check server-id-check flag; server-id-check failover dhcp-server-identifier DHCP REQUEST . . . failover . server- identifier IP . (global) (subnet) . . (broadcast) failover . - . . . <<>> . . server-duid server-duid LLT [ hardware-type timestamp hardware-address ] ; server-duid EN enterprise-number enterprise-identifier ; server-duid LL [ hardware-type hardware-address ] ; server-duid DUID . LLT ( ) EN ( enterprise) LL ( ) . LLT LL DUID . DUID . EN enterprise number ( ) enterprise-identifier ( ) . server-duid (lease file) server-duid dhcp6.server-id . server-duid LLT . server-name server-name name ; server-name . Name . dhcpv6-set-tee-times dhcpv6-set-tee-times flag; dhcpv6-set-tee-times T1 T2 RFC 3315 ( .) . T1 T2 dhcp-renewal-time dhcp-rebinding- time . . dhcpv6-set-tee-times . . RFC 3315 : T1 0.5 (preferred lifetime) . <<>> 0xFFFFFFFF T1 0xFFFFFFFF . T2 0.8 . <<>> 0xFFFFFFFF T2 0xFFFFFFFF . . T1 = T2 = 4 rebind . . dhcpv6-set- tee-times . RFC . . site-option-space site-option-space name ; site-option-space (site- local) . vendor-option-space . DHCP . (embedded) DHCP . (ad hoc) DHCP . site-option-space ( dhcp-eval (5) ) . stash-agent-options stash-agent-options flag; stash-agent-options true DHCPREQUEST SELECTING DHCPREQUEST RENEWING . DHCPREQUEST RENEWING unicast . update-conflict-detection update-conflict-detection flag; update-conflict-detection true DHCID (multiple-client, one-name) . false (binding) . true (global scope) . update-optimization update-optimization flag; update-optimization false DNS . DNS DHCP DNS . . true DHCP . update-static-leases update-static-leases flag; update-static-leases DHCP DNS IP fixed-address fixed-address6 - . DHCP . DHCP . DHCPv4 DHCPv6 standard interim . . use-eui-64 use-eui-64 flag; ( EUI_64 includes/site.h ) use-eui-64 DUID EUI-64 ( EUI-64) . DUID DUID . IPv6 EUI-64 RFC 2373 host client-id . range6 EUI-64 (/64) . . : subnet6 fc00:e4::/64 { use-eui-64 true; range6 fc00:e4::/64; } (pool) EUI-64 . EUI-64 DUID EUI-64 DUID EUI-64 . (host) DUID DUID ( DUID EUI-64) (fixed-prefix6 fixed-address6) . EUI-64 <> ( ) . DUID ( EUI-64) EUI-64 . EUI-64 . no addresses available . EUI-64 DUID EUI-64 solicit/renew IA_NA EUI-64 : Solicit - ia EUI-64 rapid commit Request - <> ia Renew/Rebind - ia ia EUI-64 EUI-64 persist-eui-64-leases . use-host-decl-names use-host-decl-names flag; use-host-decl-names true (host declaration) (hostname) . group { use-host-decl-names on; host joe { hardware ethernet 08:00:2b:4c:29:32; fixed-address joe.example.com; } } : host joe { hardware ethernet 08:00:2b:4c:29:32; fixed-address joe.example.com; option host-name "joe"; } use-host-decl-names DNS (forward DNS) . DNS . option host-name . DHCP host-name DHCP . IP DNS . . use-lease-addr-for-default-route use-lease-addr-for-default-route flag; use-lease-addr-for-default- route true routers ( ) IP . Win95 IP ARP proxy ARP . DHCP . vendor-option-space vendor-option-space string; vendor-option-space (vendor options) . dhcp-options(5) VENDOR ENCAPSULATED OPTIONS . (SETTING PARAMETER VALUES USING EXPRESSIONS) DHCP . . dhcp-eval(5) . : my-parameter = expression ; : ddns-hostname = binary-to-ascii (16, 8, "-", substring (hardware, 1, 6)); (RESERVED LEASES) . host fixed-address host << >> DNS failover << on>> . range <> () ( ) . ACTIVE . failover FREE BACKUP - - . <<>> . . . OMAPI <> ( ) <> . <> <> . : OPTION (REFERENCE: OPTION STATEMENTS) DHCP dhcp-options(5) . : (REFERENCE: EXPRESSIONS) DHCP dhcp-eval(5) . (SEE ALSO) dhcpd(8), dhcpd.leases(5), dhcp-options(5), dhcp-eval(5), RFC2132, RFC2131. (AUTHORS) dhcpd.conf(5) ISC . Internet Systems Consortium https://www.isc.org . dhcpd.conf(5)