DHCPCD(8) System Manager's Manual DHCPCD(8) (NAME) dhcpcd - DHCP (SYNOPSIS) dhcpcd [-146ABbDdEGgHJKLMNPpqTV] [-C, --nohook hook] [-c, --script script] [-e, --env value] [-F, --fqdn FQDN] [-f, --config file] [-h, --hostname hostname] [-I, --clientid clientid] [-i, --vendorclassid vendorclassid] [-j, --logfile logfile] [-l, --leasetime seconds] [-m, --metric metric] [-O, --nooption option] [-o, --option option] [-Q, --require option] [-r, --request address] [-S, --static value] [-s, --inform address[/cidr[/broadcast_address]]] [--inform6] [-t, --timeout seconds] [-u, --userclass class] [-v, --vendor code, value] [-W, --whitelist address[/cidr]] [-w] [--waitip=[4 | 6]] [-y, --reboot seconds] [-X, --blacklist address[/cidr]] [-Z, --denyinterfaces pattern] [-z, --allowinterfaces pattern] [--inactive] [--configure] [--noconfigure] [interface] [...] dhcpcd -n, --rebind [interface] dhcpcd -k, --release [interface] dhcpcd -U, --dumplease [interface] dhcpcd --version dhcpcd -x, --exit [interface] (DESCRIPTION) dhcpcd DHCP RFC 2131 . dhcpcd ( IP ) DHCP interface . dhcpcd DNS resolvconf(8) /etc/resolv.conf . (null) localhost force_hostname YES TRUE 1 dhcpcd DHCP . dhcpcd . DHCP . (carrier) dhcpcd . -b, --background -w, --waitip . dhcpcd BOOTP RFC 951 . dhcpcd IPv6 (Router Solicitor) RFC 4861 RFC 6106 . dhcpcd IPv6 AutoConf RFC 4941 . dhcpcd . dhcpcd DHCPv6 RFC 3315 . dhcpcd DHCPv6 IPv6 . << >> (Identity Association) << >> (Non-temporary Address) . (Local Link configuration) dhcpcd IPv4LL ( ZeroConf APIPA) (probe) . DHCP . IPv4LL dhcpcd 0 . ARP IPv4LL . -L, --noipv4ll . (Multiple interfaces) dhcpcd dhcpcd . dhcpcd (Manager mode) . dhcpcd-ui dhcpcd . dhcpcd dhcpcd . -w, --waitip . ( ) -k - -N - -n -x . -M, --manager . (carrier) DHCP / IPv4LL (metric) . dhcpcd . . TAP (bridge) FireWire . --allowinterfaces interface /etc/dhcpcd.conf . (Hooking into events) dhcpcd /usr/lib/dhcpcd/dhcpcd-run-hooks -c, --script . /usr/lib/dhcpcd/dhcpcd-hooks (lexical order) . 01-test 20-resolv.conf 30-hostname . -C, --nohook . dhcpcd-run-hooks(8) . dhcpcd . /usr/share/dhcpcd/hooks /usr/lib/dhcpcd/dhcpcd-hooks . 29-lookup-hostname dhcpcd IP DNS . (Fine tuning) dhcpcd : -b, --background . (carrier) . -c, --script script script /usr/lib/dhcpcd/dhcpcd-run-hooks. -D, --duid [ll | lt | uuid | value] DHCP ( DUID). DUID-LLT ( + ) DUID-LL ( ) . /var/lib/dhcpcd/duid DUID . ll lt uuid value 00:11:22:33 . IAID -I, --clientid . DUID /var/lib/dhcpcd/duid . . -d, --debug stderr syslog. -E, --lastlease dhcpcd . --lastleaseextend . ARP dhcpcd . 3.7 RFC 2131 . -e, --env value value dhcpcd-run-hooks(8). -e force_hostname=YES . -g, --reconfigure dhcpcd IP dhcpcd-run-hooks(8) . PPP VPN / DNS dhcpcd . dhcpcd - rebind . -F, --fqdn fqdn DHCP DNS FQDN . fqdn disable none ptr both. dhcpcd DNS . dhcpcd FQDN RFC 1035 . -f, --config file /etc/dhcpcd.conf. dhcpcd . -h, --hostname hostname hostname DHCP DNS . hostname . hostname FQDN ( . ) . -I, --clientid clientid clientid. 01:02:03 . clientid dhcpcd clientid . -i, --vendorclassid vendorclassid vendorclassid DHCPv4. dhcpcd-::: : dhcpcd-5.5.6:NetBSD-6.99.5:i386:i386 . DHCP vendorclassid . vendorclassid MSFT . -j, --logfile logfile logfile . dhcpcd syslog(3) . dhcpcd SIGUSR2 logfile . -k, --release [interface] dhcpcd interface interface -p, --persistent . interface . dhcpcd . -l, --leasetime seconds seconds . -1 . dhcpcd DHCP . -M, --manager dhcpcd . << >> . -m, --metric metric . dhcpcd 1000 + if_nametoindex(3) . IPv4LL (roaming). -n, --rebind [interface] dhcpcd interface (rebind) . interface . dhcpcd . -N, --renew [interface] dhcpcd interface (renew) . interface . dhcpcd . -n, --rebind dhcpcd . -o, --option option option DHCP /usr/lib/dhcpcd/dhcpcd-run-hooks. -p, --persistent dhcpcd interface . NFS SSH . . -r, --request address address DHCP DISCOVER. DHCP . address interface . -s, --inform address[/cidr[/broadcast_address]] -r, --request DISCOVER/REQUEST DHCP INFORM . DHCP address . cidr . dhcpcd . dhcpcd . dhcpcd DHCP IPv4LL . --inform6 << >> (Information Request) DHCPv6 . DHCPv6 . IPv6 . dhcpcd IPv6RA DHCPv6 . -S, --static value value DHCP . ip_address dhcpcd . DNS : dhcpcd -S ip_address=192.168.0.10/24 \ -S routers=192.168.0.1 \ -S domain_name_servers=192.168.0.1 \ eth0 DHCPv6 . -e, --env . -t, --timeout seconds seconds . -1 - --oneshot dhcpcd . 0 seconds dhcpcd . -u, --userclass class DHCPv4 class . DHCP DHCP . -v, --vendor code,value (vendor option) . code . code . : 01 IP: dhcpcd -v 01,192.168.0.2 eth0 02 : dhcpcd -v 02,01:02:03:04:05 eth0 03 IP : dhcpcd -v 03,\"192.168.0.2\" eth0 hello world: dhcpcd -v ,"hello world" eth0 --version . dhcpcd . -w . . --waitip=[4 | 6] . 4 IPv4 . 6 IPv6 . dhcpcd . dhcpcd . -x, --exit [interface] dhcpcd interface . interface . -p, --persistent dhcpcd.conf(5) . dhcpcd . -y, --reboot seconds reboot discover . reboot (fallback) discover. IPv4LL reboot . . 0 dhcpcd reboot discover . DHCPv6 reboot . (Restricting behaviour) dhcpcd . DHCP . . dhcpcd dhcpcd . . -1, --oneshot . -w, --waitip () . -4, --ipv4only IPv4. -6, --ipv6only IPv6. -A, --noarp ARP. IPv4LL . -B, --nobackground . (debugger) (network manager) . -C, --nohook script . .sh . DNS dhcpcd : dhcpcd -C resolv.conf eth0 -G, --nogateway (default routes). -H, --xidhwaddr DHCP xid . -J, --broadcast DHCP (broadcast) . FireWire InfiniBand . dhcpcd . -K, --nolink (carrier status). dhcpcd . -L, --noipv4ll IPv4LL ( APIPA Bonjour ZeroConf). -O, --nooption option option DHCP . -P, --printpidfile pidfile dhcpcd . -Q, --require option option DHCP . dhcpcd DHCP BOOTP -Q dhcp_message_type . -q, --quiet dhcpcd . . syslog(3) . -T, --test DHCP /usr/lib/dhcpcd/dhcpcd-run-hooks TEST DHCP . . rapid_commit TEST . INFORM dhcpcd . -U, --dumplease [interface] (dump) interface . interface . -4 -6 . (pipe) - . . -V, --variables dhcpcd-run-hooks(8). new_ old_ - . DHCP . -W, --whitelist address[/cidr] address[/cidr]. -W, --whitelist - -X, --blacklist . -X, --blacklist address[/cidr] address[/cidr]. -Z, --denyinterfaces pattern pattern fnmatch(3) . -z, --allowinterfaces pattern pattern fnmatch(3) . -Z, --denyinterfaces . --inactive . dhcpcd dhcpcd . --configure dhcpcd . if_configured=true . --noconfigure dhcpcd . --script dhcpcd . -T, --test (one-shot) if_configured=false . --nodev /dev. (3RDPARTY LINK MANAGEMENT) PPP VPN . dhcpcd STATIC INFORM dhcpcd . ( PPP) . INFORM dhcpcd INFORM (unicast) STATIC . (NOTES) dhcpcd IPv4 (BPF) BSD (LPF) . dhcpcd dhcpcd (rebind) dhcpcd . DHCP ClientID . dhcpcd DHCP clientid dhcpcd . DUID ClientID /var/lib/dhcpcd/duid . (FILES) /etc/dhcpcd.conf dhcpcd. . /usr/lib/dhcpcd/dhcpcd-run-hooks Bourne . /usr/lib/dhcpcd/dev /dev . /usr/lib/dhcpcd/dhcpcd-hooks Bourne . -C, --nohook . /var/lib/dhcpcd/duid DUID . /var/lib/dhcpcd/secret . /var/lib/dhcpcd/interface-ssid.lease DHCP . mtime . /var/lib/dhcpcd/interface-ssid.lease6 DHCPv6 . mtime . /var/lib/dhcpcd/rdm_monotonic (monotonic counter) replay . /run/dhcpcd/pid (PID) dhcpcd . /run/dhcpcd/interface.pid (PID) dhcpcd interface . /run/dhcpcd/sock (manager daemon). /run/dhcpcd/interface.sock . (SEE ALSO) fnmatch(3), if_nametoindex(3), dhcpcd.conf(5), resolv.conf(5), dhcpcd-run-hooks(8), resolvconf(8) (STANDARDS) RFC 951, RFC 1534, RFC 2104, RFC 2131, RFC 2132, RFC 2563, RFC 2855, RFC 3004, RFC 3118, RFC 3203, RFC 3315, RFC 3361, RFC 3633, RFC 3396, RFC 3397, RFC 3442, RFC 3495, RFC 3925, RFC 3927, RFC 4039, RFC 4075, RFC 4242, RFC 4361, RFC 4390, RFC 4702, RFC 4074, RFC 4861, RFC 4833, RFC 4941, RFC 5227, RFC 5942, RFC 5969, RFC 6106, RFC 6334, RFC 6355, RFC 6603, RFC 6704, RFC 7217, RFC 7550, RFC 7844. (AUTHORS) Roy Marples (BUGS) https://roy.marples.name/projects/dhcpcd . Linux 6.12.107+deb13-amd64 July 5, 2026 Linux 6.12.107+deb13-amd64