connman.conf(5) File Formats Manual connman.conf(5) (NAME) main.conf - ConnMan (SYNOPSIS) /etc/connman/main.conf (DESCRIPTION) main.conf ConnMan . ConnMan . --config= connman(8) . (FILE FORMAT) () - . '#' () . '[' ']' . - . : [General] . InputRequestTimeout=secs (timeout) . . (passphrase) . . BrowserLaunchTimeout=secs . . (portal pages) . . BackgroundScanning=true | false . true . (backoff) . D-Bus . . . BackgroundScanning false ConnMan D-Bus . UseGatewaysAsTimeservers=true| false (gateways) (timeservers) . false . FallbackTimeservers=server[,...] "," . NTP UseGatewaysAsTimeservers = false . (FQDN) IPv4 IPv6 . FallbackNameservers=server[,...] (nameservers) "," . . DefaultAutoConnectTechnologies=technology[,...] "," . ethernet,wifi,cellular . . DefaultEnabledTechnologies=technology[,...] "," . ethernet . DefaultFavoriteTechnologies=technology[,...] "," . ethernet . . AlwaysConnectedTechnologies=technology[,...] PreferredTechnologies (AutoConnect = true). . PreferredTechnologies=technology[,...] "," . . 'ready' 'ready' (default route) 'online' . NetworkInterfaceBlacklist=interface[,...] "," . connman . vmnet,vboxnet,virbr,ifb,ve-,vb-,ham,veth . AllowHostnameUpdates=true | false connman (hostname) . DHCP hostname . true . AllowDomainnameUpdates=true | false connman (domainname) . DHCP domainname . true . SingleConnectedTechnology=true | false . PreferredTechnologies . 'online' 'ready' . . . VPN . false . TetheringTechnologies=technology[,...] (tethering) ",". wifi,bluetooth,gadget . . "ethernet" . DHCP . . . . PersistentTetheringMode=true | false . false . Enable6to4=true | false Anycast 6to4 . 6to4 . RFC6343 . false ( . RFC6343 ). VendorClassID=string DHCP ( Vendor Class ID) . DHCP MAC . EnableOnlineCheck=true | false HTTP GET . READY ConnMan HTTP GET (end-to-end) . ONLINE . false READY . true . : EnableOnlineCheck OnlineCheckMode one-shot none . OnlineCheckMode=mode HTTP ("") EnableOnlineCheck . mode none one-shot continuous. mode one-shot . none HTTP . (manager) "ready" "online" . one-shot (one-shot) HTTP . "online" . OnlineCheckIntervalStyle OnlineCheckInitialInterval OnlineCheckMaxInterval . continuous HTTP . "one-shot" "online" . OnlineCheckIntervalStyle OnlineCheckMaxInterval . OnlineCheckIntervalStyle OnlineCheckInitialInterval OnlineCheckMaxInterval . OnlineCheckFailuresThreshold "ready" "Error" "online-check-failed" . . OnlineCheckSuccessesThreshold "Error" "online" . OnlineCheckIPv4URL=url,OnlineCheckIPv6URL=url ( IPv4 IPv6) . README . http://ipv4.connman.net/online/status.html http://ipv6.connman.net/online/status.html . OnlineCheckConnectTimeout=secs[.milliseconds] ( 12.3) TCP OnlineCheckIPv4URL OnlineCheckIPv6URL ( ). OnlineCheckConnectTimeout . ('0') . OnlineCheckInitialInterval=interval,OnlineCheckMaxInterval=interval . README . . OnlineCheckIntervalStyle=fibonacci | geometric HTTP "ready" "online". "geometric" "fibonacci" "geometric" . "geometric" (OnlineCheckInitialInterval OnlineCheckMaxInterval ). ( ) . "fibonacci" . . "fibonacci" "geometric" ( "geometric" ) "geometric" . EnableOnlineToReadyTransition=true | false EnableOnlineCheck HTTP GET . false ONLINE HTTP GET DISCONNECT . true HTTP GET . READY . false . : EnableOnlineToReadyTransition OnlineCheckMode continuous none . OnlineCheckFailuresThreshold=failures OnlineCheckMode "continuous" HTTP "ready" "online" "" (failed) . . / OnlineCheckIntervalStyle OnlineCheckInitialInterval OnlineCheckMaxInterval . . OnlineCheckSuccessesThreshold=successes OnlineCheckMode "continuous" HTTP "ready" "online" "" "online" . . / OnlineCheckIntervalStyle OnlineCheckInitialInterval OnlineCheckMaxInterval . . AutoConnectRoamingServices=true | false . . false . AddressConflictDetection=true | false IPv4 RFC5227. ConnMan ARP IPv4 . (static) IPv4LL ( RFC3927). DHCP ConnMan DHCP DECLINE IPv4LL . false . Localtime=string localtime. /etc/localtime . RegdomFollowsTimezone=true | false (regdomain) . true ISO3166 /usr/share/zoneinfo/zone1970.tab regdom . false . ResolvConf=string resolv.conf. . /run/connman/resolv.conf ( /run/connman ) /etc/resolv.conf . resolv.conf /dev/null . (EXAMPLES) . [General] AllowHostnameUpdates = false AllowDomainnameUpdates = false TetheringTechnologies = ethernet,wifi,bluetooth,gadget (SEE ALSO) connman(8) 2015-10-15 connman.conf(5)